Web Services Overview

Web Services Overview Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Purolator International provides a SOAP Online web service interface for customers who wish to write their own software to interact with Purolator’s Online Shipping System.

Purolator support staff provides an Account with one or more users, and (typically) one Shipper Account to represent each facility the customer will be shipping from.

The exact process for creating an application to interact with the web service will differ significantly between programming languages, but the process for some languages can be summarized by:

  1. Use a tool to generate a proxy/wrapper/client class from the Online WSDL file. This class will typically have a set of objects representing web service methods, the associated Request and Response objects, and data objects used to create Requests and Responses.

    The Purolator International Web Service WSDL can be found at Online http://support.pclusa.com/PurolatorOLS/WebServices/ShippingServices.asmx?WSDL .

    Typically, this will need to be completed once and only updated if our web service changes, but for some languages/frameworks this may need to be completed once each time the application starts.

  2. Determine which web service method needs to be executed.

  3. Use the proxy class to create the Request object.

  4. Populate the Request object with the relevant data.

  5. Pass the Request object to the proxy class to execute the web service method.

  6. Handle the Response returned from calling the proxy class as appropriate. For example:

    • If Response.Status is 2 (Error) then fix the problems in the request and resubmit.

      See Return Codes for information about each error message.

    • If Response.Status is 0 (Success) and the request LabelType specified was ZPL or ZPLIMAGES, then send the ZPL code to the Zebra printer.

  7. Closeout any outstanding orders which are being shipped. This typically occurs at the end of a day, but multiple closeouts can occur within one day and a closeout may cover multiple days.

    Closing out a collection of orders:

    • Finalizes them in the OLS database and prevents future modification.
    • Consolidates rates for all orders with the same order information (including the exact destination address, ship method, and other shipping options).
    • May create required documentation for customs.

Since sample (working) source code is often the most helpful way to demonstrate using an API (at least to a programmer) we have created a few sample applications: .NET ( Online C#, Online VB.NET) / Java (TBD)

Walkthru Pages
Courier | LTL
Create Order | Create LTL Order
Create Incomplete Order | Create Incomplete LTL Order
Closeout | Closeout LTL

Send Feedback on this topic to WorldPak.


How To

How To Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Courier

Courier includes shipping individual parcels using Purolator Courier, Canada Post, or UPS; for shipping pallets or containers see the LTL section.

There are two basic workflows for creating courier orders:

  • Create an order after all order information is available and the packages are ready to ship. Create the shipment with AddOrder(OrderRequest). See walkthrough.
  • Create an order after the consignee and item information is known, but before packages have been created. Create the shipment with AddOrder(OrderRequest) and update the shipment with package information AddPackage(AddPackageRequest), or add items using AddItem(AddItemRequest). See walkthrough.

The ResponsePackage objects returned in an OrderResponse, AddPackageResponse, or LabelResponse may contain Package label information stored as ZPL byte code in the ZPLCode field, or encoded as a Online Base64 encoded PNG image in the LabelImage field depending on the LabelType specified in the related request.

When all orders are ready to be shipped, submit a Closeout(CloseoutRequest) to finalize processing. This may create documentation for customs or for the driver. See walkthrough.

Except for adding packages and items, order information cannot be changed with web services. If an order is incorrect a customer can change it manually on the Online website, or by voiding the order/package with VoidOrders(OrderListRequest) or VoidPackages(PackageListRequest).

LTL

A Online LTL (Less Than Truckload) shipment can consist of one or more pallets or containers being shipped to a consignee. "Packages" are optional and represent containers instead of parcels; if any containers are included, then a label can be printed for each container.

Consolidation combines one or more orders (with the same exact address and with the same assessorials) into a single shipment for billing purposes. There are two options for creating orders and consolidating them into LTL shipments depending on whether you have a single order, or multiple orders:

  • Create a single consolidated LTL shipment with AddLTLOrder(LTLOrderRequest).

  • Create each LTL order with AddOrder(OrderRequest).

    Consolidate orders with AddConsolidatedLTLShipment(LTLShipmentRequest).

Both AddOrder(OrderRequest) and AddLTLOrder(LTLOrderRequest) can return container labels in the ResponsePackage objects; AddLTLOrder(LTLOrderRequest) can also return pallet labels in LTLPalletResponse objects. Label information is stored as ZPL byte code in the ZPLCode field, or encoded as a Online Base64 encoded PNG image in the LabelImage field depending on the LabelType specified in the related request.

When all orders are ready to be shipped, submit a CloseoutWithLTL(CloseoutRequestLTL) to finalize processing. An LTL closeout may include Courier packages as well as consolidated LTL shipments. A closeout may create documentation for customs or for the driver. See walkthrough.

Except for adding packages and items, order information cannot be changed with web services. If an order is incorrect a customer can change it manually on the Online website, or by voiding the order/package with VoidOrders(OrderListRequest) or VoidPackages(PackageListRequest).


Create Courier Order

Create Courier Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

This walkthrough is for creating a courier (Purolator, Canada Post, UPS) order using AddOrder(OrderRequest); if you are creating an LTL order then see the LTL walkthrough. This walkthrough assumes that Purolator is handling customs; if you are using a different customs broker then ignore code related to Item data.

  1. Create and populate an OrderRequest object.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

OrderRequest orderRequest = new OrderRequest
{
    Credentials = credentials,
    ShipFromAddress = new Address
    {
        Company    = "My Company",
        Add1       = "290 Spagnoli Road",
        City       = "Melville",
        StateProv  = "NY",
        PostalCode = "11747",
        Country    = "US",
    },
    ShipToAddress = new Address
    {
        Name       = "Test Customer Name",
        Add1       = "560 Kings Road",
        City       = "Sydney",
        StateProv  = "NS",
        PostalCode = "B1S1B8",
        Country    = "CA"
    },
    OrderNumber    = "Order-13544364",
    ShipMethod     = "AIR",     // Invalid for Postal Code B1S1B8
    LabelType      = "ZPLIMAGES",
    ShipDate       = DateTime.Today,
    Packages = new List<RequestPackage>
    {
        new RequestPackage { PackageID = "PKG-13544364-01", WeightUOM = "LB", Weight = 10.0m, }
    }.ToArray(),
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            SKU         = "x35135",
            CustomsDesc = "Documents",
            Quantity    = 2,
            TotalValue  = 10,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    }.ToArray()
};
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

OrderRequest orderRequest = new OrderRequest
{
    Credentials = credentials,
    ShipFromAddress = new Address
    {
        Company    = "My Company",
        Add1       = "290 Spagnoli Road",
        City       = "Melville",
        StateProv  = "NY",
        PostalCode = "11747",
        Country    = "US",
    },
    ShipToAddress = new Address
    {
        Name       = "Test Customer Name",
        Add1       = "560 Kings Road",
        City       = "Sydney",
        StateProv  = "NS",
        PostalCode = "B1S1B8",
        Country    = "CA"
    },
    OrderNumber    = "Order-13544364",
    ShipMethod     = "AIR",     // Invalid for Postal Code B1S1B8
    LabelType      = "ZPLIMAGES",
    ShipDate       = DateTime.Today,
    Packages = new List<RequestPackage>
    {
        new RequestPackage { PackageID = "PKG-13544364-01", WeightUOM = "LB", Weight = 10.0m, }
    }.ToArray(),
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            SKU         = "x35135",
            CustomsDesc = "Documents",
            Quantity    = 2,
            TotalValue  = 10,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    }.ToArray()
};
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim orderRequest As OrderRequest = New OrderRequest With {
    .Credentials = credentials,
    .ShipFromAddress = New Address With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "Order-13544364",
    .ShipMethod = "AIR",     ' Invalid for Postal Code B1S1B8
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364-01", .WeightUOM = "LB", .Weight = 10.0}
    },
    .Items = {
        New RequestItem With {
            .SKU = "x35135",
            .CustomsDesc = "Documents",
            .Quantity = 2,
            .TotalValue = 10,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim orderRequest As OrderRequest = New OrderRequest With {
    .Credentials = credentials,
    .ShipFromAddress = New Address With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "Order-13544364",
    .ShipMethod = "AIR",     ' Invalid for Postal Code B1S1B8
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364-01", .WeightUOM = "LB", .Weight = 10.0}
    },
    .Items = {
        New RequestItem With {
            .SKU = "x35135",
            .CustomsDesc = "Documents",
            .Quantity = 2,
            .TotalValue = 10,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
  2. Submit request.  If the response indicates any errors, then fix and resubmit the request.
    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
OrderResponse orderResponse = client.AddOrder(orderRequest);

if (orderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return orderResponse;
            case 81: // Air service not available.
                orderRequest.ShipMethod = "GROUND";
                break;
            case 82: // Ground service not available.
                orderRequest.ShipMethod = "AIR";
                break;
            // Fix other errors....
        }
    }

    orderResponse = client.AddOrder(orderRequest);
    if (orderResponse.Status == (int)SeverityEnum.Error)
        return orderResponse;
}
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
OrderResponse orderResponse = client.AddOrder(orderRequest);

if (orderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return orderResponse;
            case 81: // Air service not available.
                orderRequest.ShipMethod = "GROUND";
                break;
            case 82: // Ground service not available.
                orderRequest.ShipMethod = "AIR";
                break;
            // Fix other errors....
        }
    }

    orderResponse = client.AddOrder(orderRequest);
    if (orderResponse.Status == (int)SeverityEnum.Error)
        return orderResponse;
}
    Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim orderResponse As OrderResponse = client.AddOrder(orderRequest)

If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1	'Invalid Credentials
                Console.Write("Invalid Credentials")
                Return orderResponse
            Case 81	'Air service not available.
                orderRequest.ShipMethod = "GROUND"
            Case 82	'Ground service not available.
                orderRequest.ShipMethod = "AIR"
        ' Fix other errors....
        End Select
    Next

    orderResponse = client.AddOrder(orderRequest)
    If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return orderResponse
    End If
End If
    Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim orderResponse As OrderResponse = client.AddOrder(orderRequest)

If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1	'Invalid Credentials
                Console.Write("Invalid Credentials")
                Return orderResponse
            Case 81	'Air service not available.
                orderRequest.ShipMethod = "GROUND"
            Case 82	'Ground service not available.
                orderRequest.ShipMethod = "AIR"
        ' Fix other errors....
        End Select
    Next

    orderResponse = client.AddOrder(orderRequest)
    If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return orderResponse
    End If
End If
  3.
                            Print and apply the label for each package.  See ZPL page
                            for more information.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    foreach (ResponsePackage package in orderResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    foreach (ResponsePackage package in orderResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    For Each package As ResponsePackage In orderResponse.Packages
    ' This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
    For Each package As ResponsePackage In orderResponse.Packages
    ' This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
  4.
                            When all orders have the correct labels attached and are ready to ship, create a Closeout to complete processing.  See the
                            Closeout page for more information.


Create Incomplete Courier Order

Create Incomplete Courier Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

This walkthrough is for creating a courier (Purolator, Canada Post, UPS) order using AddOrder(OrderRequest); if you are creating an LTL order then see the LTL walkthrough. This walkthrough assumes that Purolator is handling customs; if you are using a different customs broker then ignore code related to Item data.

  1. Create an order with AddOrder(OrderRequest).

    If Purolator is handling customs for the account, then customs information for at least one item is required, otherwise the item information is ignored.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

OrderRequest orderRequest = new OrderRequest
{
    Credentials = credentials,
    ShipFromAddress = new Address
    {
        Company    = "My Company",
        Add1       = "290 Spagnoli Road",
        City       = "Melville",
        StateProv  = "NY",
        PostalCode = "11747",
        Country    = "US",
    },
    ShipToAddress = new Address
    {
        Name       = "Test Customer Name",
        Add1       = "560 Kings Road",
        City       = "Sydney",
        StateProv  = "NS",
        PostalCode = "B1S1B8",
        Country    = "CA"
    },
    OrderNumber    = "Order-13544364-2",
    ShipMethod     = "Pony Express",  // Invalid
    LabelType      = "ZPLIMAGES",
    ShipDate       = DateTime.Today,
    // Package data not yet available.
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            SKU         = "x35135",
            CustomsDesc = "Documents",
            Quantity    = 2,
            TotalValue  = 10,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    }.ToArray()
};
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

OrderRequest orderRequest = new OrderRequest
{
    Credentials = credentials,
    ShipFromAddress = new Address
    {
        Company    = "My Company",
        Add1       = "290 Spagnoli Road",
        City       = "Melville",
        StateProv  = "NY",
        PostalCode = "11747",
        Country    = "US",
    },
    ShipToAddress = new Address
    {
        Name       = "Test Customer Name",
        Add1       = "560 Kings Road",
        City       = "Sydney",
        StateProv  = "NS",
        PostalCode = "B1S1B8",
        Country    = "CA"
    },
    OrderNumber    = "Order-13544364-2",
    ShipMethod     = "Pony Express",  // Invalid
    LabelType      = "ZPLIMAGES",
    ShipDate       = DateTime.Today,
    // Package data not yet available.
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            SKU         = "x35135",
            CustomsDesc = "Documents",
            Quantity    = 2,
            TotalValue  = 10,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    }.ToArray()
};
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim orderRequest As OrderRequest = New OrderRequest With {
    .Credentials = credentials,
    .ShipFromAddress = New Address With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "Order-13544364-2",
    .ShipMethod = "Pony Express",
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364-01", .WeightUOM = "LB", .Weight = 10.0}
    },
    .Items = {
        New RequestItem With {
            .SKU = "x35135",
            .CustomsDesc = "Documents",
            .Quantity = 2,
            .TotalValue = 10,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
' Ship method is invalid.
' Package data not available.
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim orderRequest As OrderRequest = New OrderRequest With {
    .Credentials = credentials,
    .ShipFromAddress = New Address With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "Order-13544364-2",
    .ShipMethod = "Pony Express",
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364-01", .WeightUOM = "LB", .Weight = 10.0}
    },
    .Items = {
        New RequestItem With {
            .SKU = "x35135",
            .CustomsDesc = "Documents",
            .Quantity = 2,
            .TotalValue = 10,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
' Ship method is invalid.
' Package data not available.
  2. If the response indicated an error, fix the information and repeat step 1.
    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
OrderResponse orderResponse = client.AddOrder(orderRequest);

if (orderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 3: // Invalid Ship Method.
                orderRequest.ShipMethod = "Ground";
                break;
            // Fix other errors....
        }
    }

    orderResponse = client.AddOrder(orderRequest);
    if (orderResponse.Status == (int)SeverityEnum.Error)
        return;
}
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
OrderResponse orderResponse = client.AddOrder(orderRequest);

if (orderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 3: // Invalid Ship Method.
                orderRequest.ShipMethod = "Ground";
                break;
            // Fix other errors....
        }
    }

    orderResponse = client.AddOrder(orderRequest);
    if (orderResponse.Status == (int)SeverityEnum.Error)
        return;
}
    Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim orderResponse As OrderResponse = client.AddOrder(orderRequest)

If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1    ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 3    ' Invalid Ship Method.
                orderRequest.ShipMethod = "Ground"
            ' Fix other errors....
        End Select
    Next

    orderResponse = client.AddOrder(orderRequest)
    If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
End If
    Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim orderResponse As OrderResponse = client.AddOrder(orderRequest)

If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1    ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 3    ' Invalid Ship Method.
                orderRequest.ShipMethod = "Ground"
            ' Fix other errors....
        End Select
    Next

    orderResponse = client.AddOrder(orderRequest)
    If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
End If
  3.
                            When complete information for a package (a customer generated unique PackageID, weight, dimensions(optional)) is determined, use an
                            AddPackage(AddPackageRequest)
                            request to update the order and then print and attach the label to the package.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    AddPackageRequest addPackageRequest = new AddPackageRequest
{
    Credentials = credentials,
    OrderNumber = "Order-13544364-2",
    Packages = new List<RequestPackage>
    {
        // The PackageIDs should be unique.
        new RequestPackage { PackageID = "PKG-13544364", WeightUOM = "LB", Weight = 10.0m, },
        new RequestPackage { PackageID = "PKG-13544364", WeightUOM = "LB", Weight = 2.34m, },
    }.ToArray(),
    LabelType = "ZPLIMAGES",
};

client = new ShippingServicesSoapClient("PurolatorWebService");
AddPackageResponse addPackageResponse = client.AddPackage(addPackageRequest);

if (addPackageResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in addPackageResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 80: // Duplicate Package Numbers
                for (int index = 0; index < addPackageRequest.Packages.Length; index++)
                    addPackageRequest.Packages[index].PackageID += "-" + (index + 1);
                break;
            // Fix other errors....
        }
    }

    addPackageResponse = client.AddPackage(addPackageRequest);
    if (addPackageResponse.Status == (int)SeverityEnum.Error)
        return;
}
    AddPackageRequest addPackageRequest = new AddPackageRequest
{
    Credentials = credentials,
    OrderNumber = "Order-13544364-2",
    Packages = new List<RequestPackage>
    {
        // The PackageIDs should be unique.
        new RequestPackage { PackageID = "PKG-13544364", WeightUOM = "LB", Weight = 10.0m, },
        new RequestPackage { PackageID = "PKG-13544364", WeightUOM = "LB", Weight = 2.34m, },
    }.ToArray(),
    LabelType = "ZPLIMAGES",
};

client = new ShippingServicesSoapClient("PurolatorWebService");
AddPackageResponse addPackageResponse = client.AddPackage(addPackageRequest);

if (addPackageResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in addPackageResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 80: // Duplicate Package Numbers
                for (int index = 0; index < addPackageRequest.Packages.Length; index++)
                    addPackageRequest.Packages[index].PackageID += "-" + (index + 1);
                break;
            // Fix other errors....
        }
    }

    addPackageResponse = client.AddPackage(addPackageRequest);
    if (addPackageResponse.Status == (int)SeverityEnum.Error)
        return;
}
    Dim addPackageRequest As AddPackageRequest = New AddPackageRequest With {
    .Credentials = credentials,
    .OrderNumber = "Order-13544364-2",
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364", .WeightUOM = "LB", .Weight = 10.0},
        New RequestPackage With {.PackageID = "PKG-13544364", .WeightUOM = "LB", .Weight = 2.34}
    },
    .LabelType = "ZPLIMAGES"
}

client = New ShippingServicesSoapClient("PurolatorWebService")
Dim addPackageResponse As AddPackageResponse = client.AddPackage(addPackageRequest)

If addPackageResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In addPackageResponse.Messages
        Select Case message.Number
            Case 1    ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 80    ' Duplicate Package Numbers
                For index As Integer = 0 To addPackageRequest.Packages.Length - 1
                    addPackageRequest.Packages(index).PackageID += "-" & (index + 1)
                Next

                addPackageResponse = client.AddPackage(addPackageRequest)
                If addPackageResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
        End Select
        ' Fix other errors....
    Next
End If
    Dim addPackageRequest As AddPackageRequest = New AddPackageRequest With {
    .Credentials = credentials,
    .OrderNumber = "Order-13544364-2",
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364", .WeightUOM = "LB", .Weight = 10.0},
        New RequestPackage With {.PackageID = "PKG-13544364", .WeightUOM = "LB", .Weight = 2.34}
    },
    .LabelType = "ZPLIMAGES"
}

client = New ShippingServicesSoapClient("PurolatorWebService")
Dim addPackageResponse As AddPackageResponse = client.AddPackage(addPackageRequest)

If addPackageResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In addPackageResponse.Messages
        Select Case message.Number
            Case 1    ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 80    ' Duplicate Package Numbers
                For index As Integer = 0 To addPackageRequest.Packages.Length - 1
                    addPackageRequest.Packages(index).PackageID += "-" & (index + 1)
                Next

                addPackageResponse = client.AddPackage(addPackageRequest)
                If addPackageResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
        End Select
        ' Fix other errors....
    Next
End If
  4.
                            If any additional customs item information needs to be added,
                            AddItem(AddItemRequest)
                            can be used to add item information.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    AddItemRequest addItemRequest = new AddItemRequest
{
    Credentials = credentials,
    OrderNumber = "Order-13544364-2",
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            //SKU       = "x35135", // SKU is required.
            CustomsDesc = "Documents",
            Quantity    = 3,
            TotalValue  = 2.35m,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        },
    }.ToArray()
};

client = new ShippingServicesSoapClient("PurolatorWebService");
AddItemResponse addItemResponse = client.AddItem(addItemRequest);

if (addItemResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in addItemResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 60: // SKU is required.
                foreach (RequestItem requestItem in addItemRequest.Items.Where(item => string.IsNullOrEmpty(item.SKU)))
                    if (requestItem.CustomsDesc == "Documents")
                        requestItem.SKU = "x35135";
                break;
            // Fix other errors....
        }
    }

    addItemResponse = client.AddItem(addItemRequest);
    if (addItemResponse.Status == (int)SeverityEnum.Error)
        return;
}
    AddItemRequest addItemRequest = new AddItemRequest
{
    Credentials = credentials,
    OrderNumber = "Order-13544364-2",
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            //SKU       = "x35135", // SKU is required.
            CustomsDesc = "Documents",
            Quantity    = 3,
            TotalValue  = 2.35m,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        },
    }.ToArray()
};

client = new ShippingServicesSoapClient("PurolatorWebService");
AddItemResponse addItemResponse = client.AddItem(addItemRequest);

if (addItemResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in addItemResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 60: // SKU is required.
                foreach (RequestItem requestItem in addItemRequest.Items.Where(item => string.IsNullOrEmpty(item.SKU)))
                    if (requestItem.CustomsDesc == "Documents")
                        requestItem.SKU = "x35135";
                break;
            // Fix other errors....
        }
    }

    addItemResponse = client.AddItem(addItemRequest);
    if (addItemResponse.Status == (int)SeverityEnum.Error)
        return;
}
    Dim addItemRequest As AddItemRequest = New AddItemRequest() With {
    .Credentials = credentials,
    .OrderNumber = "Order-13544364-2",
    .Items = {
        New RequestItem With {
            .CustomsDesc = "Documents",
            .Quantity = 3,
            .TotalValue = 2.35,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}

client = New ShippingServicesSoapClient("PurolatorWebService")
Dim addItemResponse As AddItemResponse = client.AddItem(addItemRequest)

If addItemResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In addItemResponse.Messages
        Select Case message.Number
            Case 1    'Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 60    'SKU is required.
                For Each requestItem As RequestItem In addItemRequest.Items
                    If String.IsNullOrEmpty(requestItem.SKU) And requestItem.CustomsDesc = "Documents" Then
                        requestItem.SKU = "x35135"
                    End If
                Next
        ' Fix other errors....
        End Select
    Next
End If
    Dim addItemRequest As AddItemRequest = New AddItemRequest() With {
    .Credentials = credentials,
    .OrderNumber = "Order-13544364-2",
    .Items = {
        New RequestItem With {
            .CustomsDesc = "Documents",
            .Quantity = 3,
            .TotalValue = 2.35,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}

client = New ShippingServicesSoapClient("PurolatorWebService")
Dim addItemResponse As AddItemResponse = client.AddItem(addItemRequest)

If addItemResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In addItemResponse.Messages
        Select Case message.Number
            Case 1    'Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 60    'SKU is required.
                For Each requestItem As RequestItem In addItemRequest.Items
                    If String.IsNullOrEmpty(requestItem.SKU) And requestItem.CustomsDesc = "Documents" Then
                        requestItem.SKU = "x35135"
                    End If
                Next
        ' Fix other errors....
        End Select
    Next
End If
  5.
                            Print and apply the label for each package.  See ZPL page
                            for more information.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    foreach (ResponsePackage package in addPackageResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    foreach (ResponsePackage package in addPackageResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    For Each package As ResponsePackage In addPackageResponse.Packages
    'This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
    For Each package As ResponsePackage In addPackageResponse.Packages
    'This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
  6.
                            When all orders have the correct labels attached and are ready to ship, create a Closeout to complete processing.  See the
                            Closeout page for more information.


Closeout

Closeout Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

For a package to be included in a close out, its entire order must be valid, and a label must have been created for the package. The software does not have the ability to determine if a label was physically printed, but it counts if the label has been displayed on the web site or if any request returned a response with the ZPL code for or image of the label.

It is important that each package included in a close out has actually been shipped since this may generate customs documentation or trigger other procedures which enable the package to be shipped without incident. It is also important to not include packages which haven’t actually shipped since you will be billed for packages which are closed out.

  1. Create a Closeout(CloseoutRequest)

    • ParsNumber is required for PARS customers.

    • PackIDType must specify either Pin or PackageID.

    • PackageIDs must contain either a list of Purolator generated Pins (from the barcode section of the label) or the PackageIDs/Package Numbers for each included package depending on the value of PackIDType.

  2. Save any Documents returned in the close out (if successful) response.

  3. Save updated rates for the closed out packages if needed.

Example using PackageID

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

string[] addedPackageIDs = orderResponse.Packages.Select(pkg => pkg.PackageID).ToArray();

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequest closeoutRequest = new CloseoutRequest
{
    Credentials = credentials,
    PackageIDs  = addedPackageIDs,
    PackIDType  = "PackageID",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponse closeoutResponse = client.Closeout(closeoutRequest);
if (closeoutResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponse = client.Closeout(closeoutRequest);
    if (closeoutResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

string[] addedPackageIDs = orderResponse.Packages.Select(pkg => pkg.PackageID).ToArray();

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequest closeoutRequest = new CloseoutRequest
{
    Credentials = credentials,
    PackageIDs  = addedPackageIDs,
    PackIDType  = "PackageID",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponse closeoutResponse = client.Closeout(closeoutRequest);
if (closeoutResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponse = client.Closeout(closeoutRequest);
    if (closeoutResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim addedPackageIDs As List(Of String) = New List(Of String)
For Each pkg As ResponsePackage In orderResponse.Packages
    addedPackageIDs.Add(pkg.PackageID)
Next

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim closeoutRequest As CloseoutRequest = New CloseoutRequest With {
    .Credentials = credentials,
    .PackageIDs = addedPackageIDs.ToArray(),
    .PackIDType = "PackageID"
}
'closeoutRequest.ParsNumber = "12-14799638"	' Only used by PARS customers.

Dim closeoutResponse As CloseoutResponse = client.Closeout(closeoutRequest)
If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1 ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71	' No packages.
            Case 79	' No packages.
                Return
            Case 87	' PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "PackageID"
            Case 88	' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponse = client.Closeout(closeoutRequest)
    If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
End If

' Handle any closeoutResponse.Documents
Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim addedPackageIDs As List(Of String) = New List(Of String)
For Each pkg As ResponsePackage In orderResponse.Packages
    addedPackageIDs.Add(pkg.PackageID)
Next

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim closeoutRequest As CloseoutRequest = New CloseoutRequest With {
    .Credentials = credentials,
    .PackageIDs = addedPackageIDs.ToArray(),
    .PackIDType = "PackageID"
}
'closeoutRequest.ParsNumber = "12-14799638"	' Only used by PARS customers.

Dim closeoutResponse As CloseoutResponse = client.Closeout(closeoutRequest)
If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1 ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71	' No packages.
            Case 79	' No packages.
                Return
            Case 87	' PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "PackageID"
            Case 88	' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponse = client.Closeout(closeoutRequest)
    If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
End If

' Handle any closeoutResponse.Documents
Example using Pin
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

string[] trackingNumbers = orderResponse.Packages.Select(pkg => pkg.TrackingNumber).ToArray();

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequest closeoutRequest = new CloseoutRequest
{
    Credentials = credentials,
    PackageIDs  = trackingNumbers,
    PackIDType  = "Pin",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponse closeoutResponse = client.Closeout(closeoutRequest);
if (closeoutResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "Pin";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponse = client.Closeout(closeoutRequest);
    if (closeoutResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

string[] trackingNumbers = orderResponse.Packages.Select(pkg => pkg.TrackingNumber).ToArray();

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequest closeoutRequest = new CloseoutRequest
{
    Credentials = credentials,
    PackageIDs  = trackingNumbers,
    PackIDType  = "Pin",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponse closeoutResponse = client.Closeout(closeoutRequest);
if (closeoutResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "Pin";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponse = client.Closeout(closeoutRequest);
    if (closeoutResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim trackingNumbers As List(Of String) = New List(Of String)
For Each pkg As ResponsePackage In orderResponse.Packages
    trackingNumbers.Add(pkg.TrackingNumber)
Next

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim closeoutRequest As CloseoutRequest = New CloseoutRequest With {
    .Credentials = credentials,
    .PackageIDs = trackingNumbers.ToArray(),
    .PackIDType = "Pin"
}
'closeoutRequest.ParsNumber = "12-14799638"	' Only used by PARS customers.

Dim closeoutResponse As CloseoutResponse = client.Closeout(closeoutRequest)
If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1	' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71	' No packages.
            Case 79	' No packages.
                Return
            Case 87	' PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "Pin"
            Case 88	' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponse = client.Closeout(closeoutRequest)
    If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
End If

' Handle any closeoutResponse.Documents
Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim trackingNumbers As List(Of String) = New List(Of String)
For Each pkg As ResponsePackage In orderResponse.Packages
    trackingNumbers.Add(pkg.TrackingNumber)
Next

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim closeoutRequest As CloseoutRequest = New CloseoutRequest With {
    .Credentials = credentials,
    .PackageIDs = trackingNumbers.ToArray(),
    .PackIDType = "Pin"
}
'closeoutRequest.ParsNumber = "12-14799638"	' Only used by PARS customers.

Dim closeoutResponse As CloseoutResponse = client.Closeout(closeoutRequest)
If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1	' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71	' No packages.
            Case 79	' No packages.
                Return
            Case 87	' PackIDType should be Pin or PackageID.
                closeoutRequest.PackIDType = "Pin"
            Case 88	' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponse = client.Closeout(closeoutRequest)
    If closeoutResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then Return
End If

' Handle any closeoutResponse.Documents


ZPL

ZPL Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Online ZPL is a Online Zebra printer specific printer control language we can use to send commands to the printer in raw ZPL byte code (i.e. not as documents or PNG images) to store label images and print labels.

Caution note Caution

ZPL printers from UPS are configured to be incompatible with retail/Purolator Zebra printers so you cannot use the same printer for UPS package labels and Purolator package labels.

Retail Zebra (and ZPL compatible) printers should be completely compatible.

The printer driver model for Vista and later prevents raw text from being sent directly to the printer without calling the Win32 API. The .NET sample applications includes sample code to demonstrate sending ZPL encoded text to the printers: Online C#, Online VB.NET

Storing the image contents before printing labels allows the software to just send the ZPL commands for the labels (with a reference to any stored image and greatly reduces the size of the ZPL needed to print each label. Some Zebra printers will store the images in flash memory, but smaller ones need to be initialized each time the printer is turned on so it is advisable to initialize the printer when your application starts.

If the images have been stored in the ZPL printer's memory then set the LabelType to ZPL. If the images have not been stored in the printer's memory then use ZPLIMAGES instead.

We recommended that the encoded images be retrieved from the web service when the application starts (instead of being hard coded into the application) in case they are updated. The current (uncompressed) image text (from GetZPLInitializationImages(CredentialInfo)) is currently about 120 KB.

  • Sample Code

    • RawDataPrinterHelper class
    • Save image contents to the printer’s memory
    • Print the ZPL labels when creating a valid new shipment
    • Print a single ZPL label
  • Sample ZPL Encoded Barcode
  • Sample ZPL Encoded Label
  • Sample ZPL Encoded Image
Sample Code

This is a helper class to help send ZPL encoded commands directly to the ZPL printer using the Win32 API.

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
// See http://support.microsoft.com/kb/322091
public class RawDataPrinterHelper
{
    [StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]
    public struct DOCINFO
    {
        [MarshalAs(UnmanagedType.LPWStr)] public string pDocName;
        [MarshalAs(UnmanagedType.LPWStr)] public string pOutputFile;
        [MarshalAs(UnmanagedType.LPWStr)] public string pDataType;
    }

    [DllImport("winspool.Drv", EntryPoint = "OpenPrinterW", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool OpenPrinter(string src, ref IntPtr hPrinter, IntPtr pd);
    [DllImport("winspool.Drv", EntryPoint = "ClosePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool ClosePrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "StartDocPrinterW", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool StartDocPrinter(IntPtr hPrinter, Int32 level, ref DOCINFO pDI);
    [DllImport("winspool.Drv", EntryPoint = "EndDocPrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool EndDocPrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "StartPagePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool StartPagePrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "EndPagePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool EndPagePrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "WritePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool WritePrinter(IntPtr hPrinter, IntPtr pBytes, Int32 dwCount, ref Int32 dwWritten);

    public static void SendStringToPrinter(string printerName, string text)
    {
        IntPtr pBytes = Marshal.StringToCoTaskMemAnsi(text);
        Int32 dwCount = text.Length;

        SendBytesToPrinter(printerName, pBytes, dwCount);
        Marshal.FreeCoTaskMem(pBytes);
    }

    public static void SendBytesToPrinter(string printerName, IntPtr byteCount, Int32 dwCount)
    {
        IntPtr  hPrinter  = default(IntPtr);
        DOCINFO di        = default(DOCINFO);
        Int32   dwWritten = default(Int32);

        di.pDocName  = "ZPL";
        di.pDataType = "RAW";

        if (OpenPrinter(printerName.Normalize(), ref hPrinter, (IntPtr)0))
        {
            if (StartDocPrinter(hPrinter, 1, ref di))
            {
                if (StartPagePrinter(hPrinter))
                {
                    WritePrinter(hPrinter, byteCount, dwCount, ref dwWritten);
                    EndPagePrinter(hPrinter);
                }
                EndDocPrinter(hPrinter);
            }
            ClosePrinter(hPrinter);
        }
    }
}
// See http://support.microsoft.com/kb/322091
public class RawDataPrinterHelper
{
    [StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]
    public struct DOCINFO
    {
        [MarshalAs(UnmanagedType.LPWStr)] public string pDocName;
        [MarshalAs(UnmanagedType.LPWStr)] public string pOutputFile;
        [MarshalAs(UnmanagedType.LPWStr)] public string pDataType;
    }

    [DllImport("winspool.Drv", EntryPoint = "OpenPrinterW", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool OpenPrinter(string src, ref IntPtr hPrinter, IntPtr pd);
    [DllImport("winspool.Drv", EntryPoint = "ClosePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool ClosePrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "StartDocPrinterW", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool StartDocPrinter(IntPtr hPrinter, Int32 level, ref DOCINFO pDI);
    [DllImport("winspool.Drv", EntryPoint = "EndDocPrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool EndDocPrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "StartPagePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool StartPagePrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "EndPagePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool EndPagePrinter(IntPtr hPrinter);
    [DllImport("winspool.Drv", EntryPoint = "WritePrinter", SetLastError = true, CharSet = CharSet.Unicode, ExactSpelling = true, CallingConvention = CallingConvention.StdCall)]
    private static extern bool WritePrinter(IntPtr hPrinter, IntPtr pBytes, Int32 dwCount, ref Int32 dwWritten);

    public static void SendStringToPrinter(string printerName, string text)
    {
        IntPtr pBytes = Marshal.StringToCoTaskMemAnsi(text);
        Int32 dwCount = text.Length;

        SendBytesToPrinter(printerName, pBytes, dwCount);
        Marshal.FreeCoTaskMem(pBytes);
    }

    public static void SendBytesToPrinter(string printerName, IntPtr byteCount, Int32 dwCount)
    {
        IntPtr  hPrinter  = default(IntPtr);
        DOCINFO di        = default(DOCINFO);
        Int32   dwWritten = default(Int32);

        di.pDocName  = "ZPL";
        di.pDataType = "RAW";

        if (OpenPrinter(printerName.Normalize(), ref hPrinter, (IntPtr)0))
        {
            if (StartDocPrinter(hPrinter, 1, ref di))
            {
                if (StartPagePrinter(hPrinter))
                {
                    WritePrinter(hPrinter, byteCount, dwCount, ref dwWritten);
                    EndPagePrinter(hPrinter);
                }
                EndDocPrinter(hPrinter);
            }
            ClosePrinter(hPrinter);
        }
    }
}
              ' See http://support.microsoft.com/kb/322090
  Public Class RawDataPrinterHelper

      <StructLayout(LayoutKind.Sequential, CharSet:=CharSet.Ansi)> _
      Public Structure DOCINFO
          Dim pDocName As String
          Dim pOutputFile As String
          Dim pDataType As String
      End Structure

      <DllImport("winspool.drv", EntryPoint:="OpenPrinterA", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function OpenPrinter(ByVal pPrinterName As String, ByRef phPrinter As IntPtr, ByVal pDefault As Integer) As Long
      End Function
      <DllImport("winspool.drv", EntryPoint:="ClosePrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function ClosePrinter(ByVal hPrinter As IntPtr) As Long
      End Function
      <DllImport("winspool.drv", EntryPoint:="StartDocPrinterA", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function StartDocPrinter(ByVal hPrinter As IntPtr, ByVal Level As Integer, ByRef pDocInfo As DOCINFO) As Long
      End Function
      <DllImport("winspool.drv", EntryPoint:="EndDocPrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function EndDocPrinter(ByVal hPrinter As IntPtr) As Long
      End Function
      <DllImport("winspool.drv", EntryPoint:="StartPagePrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function StartPagePrinter(ByVal hPrinter As IntPtr) As Long
      End Function
      <DllImport("winspool.drv", EntryPoint:="EndPagePrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function EndPagePrinter(ByVal hPrinter As IntPtr) As Long
      End Function
      <DllImport("winspool.drv", EntryPoint:="WritePrinter", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
      Public Shared Function WritePrinter(ByVal hPrinter As IntPtr, ByVal data() As Byte, ByVal buf As Integer, ByRef pcWritten As Integer) As Long
      End Function

      Public Shared Sub SendStringToPrinter(ByVal printerName As String, ByVal text As String)
          SendBytesToPrinter(printerName, ASCII.GetBytes(text))
      End Sub

      Public Shared Sub SendBytesToPrinter(ByVal printerName As String, ByVal byteData() As Byte)
          Dim hPrinter As IntPtr = New IntPtr(0)
          Dim dwError As Integer = 0
          Dim di As DOCINFO = New DOCINFO
          Dim dwWritten As Integer = 0

          di.pDocName = "My VB RAW Document"
          di.pDataType = "RAW"

          If OpenPrinter(printerName.Normalize(), hPrinter, IntPtr.Zero) Then
              If StartDocPrinter(hPrinter, 1, di) Then
                  If StartPagePrinter(hPrinter) Then
                      WritePrinter(hPrinter, byteData, byteData.Length, dwWritten)
                      EndPagePrinter(hPrinter)
                  End If
                  EndDocPrinter(hPrinter)
              End If
              ClosePrinter(hPrinter)
          End If
      End Sub
  End Class
            ' See http://support.microsoft.com/kb/322090
Public Class RawDataPrinterHelper

    <StructLayout(LayoutKind.Sequential, CharSet:=CharSet.Ansi)> _
    Public Structure DOCINFO
        Dim pDocName As String
        Dim pOutputFile As String
        Dim pDataType As String
    End Structure

    <DllImport("winspool.drv", EntryPoint:="OpenPrinterA", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function OpenPrinter(ByVal pPrinterName As String, ByRef phPrinter As IntPtr, ByVal pDefault As Integer) As Long
    End Function
    <DllImport("winspool.drv", EntryPoint:="ClosePrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function ClosePrinter(ByVal hPrinter As IntPtr) As Long
    End Function
    <DllImport("winspool.drv", EntryPoint:="StartDocPrinterA", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function StartDocPrinter(ByVal hPrinter As IntPtr, ByVal Level As Integer, ByRef pDocInfo As DOCINFO) As Long
    End Function
    <DllImport("winspool.drv", EntryPoint:="EndDocPrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function EndDocPrinter(ByVal hPrinter As IntPtr) As Long
    End Function
    <DllImport("winspool.drv", EntryPoint:="StartPagePrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function StartPagePrinter(ByVal hPrinter As IntPtr) As Long
    End Function
    <DllImport("winspool.drv", EntryPoint:="EndPagePrinter", SetLastError:=True, CharSet:=CharSet.Auto, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function EndPagePrinter(ByVal hPrinter As IntPtr) As Long
    End Function
    <DllImport("winspool.drv", EntryPoint:="WritePrinter", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function WritePrinter(ByVal hPrinter As IntPtr, ByVal data() As Byte, ByVal buf As Integer, ByRef pcWritten As Integer) As Long
    End Function

    Public Shared Sub SendStringToPrinter(ByVal printerName As String, ByVal text As String)
        SendBytesToPrinter(printerName, ASCII.GetBytes(text))
    End Sub

    Public Shared Sub SendBytesToPrinter(ByVal printerName As String, ByVal byteData() As Byte)
        Dim hPrinter As IntPtr = New IntPtr(0)
        Dim dwError As Integer = 0
        Dim di As DOCINFO = New DOCINFO
        Dim dwWritten As Integer = 0

        di.pDocName = "My VB RAW Document"
        di.pDataType = "RAW"

        If OpenPrinter(printerName.Normalize(), hPrinter, IntPtr.Zero) Then
            If StartDocPrinter(hPrinter, 1, di) Then
                If StartPagePrinter(hPrinter) Then
                    WritePrinter(hPrinter, byteData, byteData.Length, dwWritten)
                    EndPagePrinter(hPrinter)
                End If
                EndDocPrinter(hPrinter)
            End If
            ClosePrinter(hPrinter)
        End If
    End Sub
End Class
Save image contents to the printer’s memory
  1.
                                    Make a GetZPLInitializationImages(CredentialInfo)
                                    request to get the ZPL encoded images.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
ZPLInitializationResponse response = client.GetZPLInitializationImages(credentials);
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
ZPLInitializationResponse response = client.GetZPLInitializationImages(credentials);
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim response As ZPLInitializationResponse = client.GetZPLInitializationImages(credentials)
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim response As ZPLInitializationResponse = client.GetZPLInitializationImages(credentials)
  2. Send the response ZPLCode to the ZPL printer as raw text.
    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    if (response.Status != (int)SeverityEnum.Error)
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.ZPLCode);
    if (response.Status != (int)SeverityEnum.Error)
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.ZPLCode);
    If response.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.ZPLCode)
End If
    If response.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.ZPLCode)
End If
Print the ZPL labels when creating a valid new shipment
  1. Create an OrderRequest object with the shipment data and the LabelType set to ZPL (if image contents have already been saved to the printer’s memory) or ZPLIMAGES.
    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

OrderRequest orderRequest = new OrderRequest
{
    Credentials = credentials,
    ShipFromAddress = new Address
    {
        Company    = "My Company",
        Add1       = "290 Spagnoli Road",
        City       = "Melville",
        StateProv  = "NY",
        PostalCode = "11747",
        Country    = "US",
    },
    ShipToAddress = new Address
    {
        Name       = "Test Customer Name",
        Add1       = "560 Kings Road",
        City       = "Sydney",
        StateProv  = "NS",
        PostalCode = "B1S1B8",
        Country    = "CA"
    },
    OrderNumber    = "Order-13544364",
    ShipMethod     = "AIR",     // Invalid for Postal Code B1S1B8
    LabelType      = "ZPLIMAGES",
    ShipDate       = DateTime.Today,
    Packages = new List<RequestPackage>
    {
        new RequestPackage { PackageID = "PKG-13544364-01", WeightUOM = "LB", Weight = 10.0m, }
    }.ToArray(),
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            SKU         = "x35135",
            CustomsDesc = "Documents",
            Quantity    = 2,
            TotalValue  = 10,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    }.ToArray()
};
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

OrderRequest orderRequest = new OrderRequest
{
    Credentials = credentials,
    ShipFromAddress = new Address
    {
        Company    = "My Company",
        Add1       = "290 Spagnoli Road",
        City       = "Melville",
        StateProv  = "NY",
        PostalCode = "11747",
        Country    = "US",
    },
    ShipToAddress = new Address
    {
        Name       = "Test Customer Name",
        Add1       = "560 Kings Road",
        City       = "Sydney",
        StateProv  = "NS",
        PostalCode = "B1S1B8",
        Country    = "CA"
    },
    OrderNumber    = "Order-13544364",
    ShipMethod     = "AIR",     // Invalid for Postal Code B1S1B8
    LabelType      = "ZPLIMAGES",
    ShipDate       = DateTime.Today,
    Packages = new List<RequestPackage>
    {
        new RequestPackage { PackageID = "PKG-13544364-01", WeightUOM = "LB", Weight = 10.0m, }
    }.ToArray(),
    Items = new List<RequestItem>
    {
        new RequestItem
        {
            SKU         = "x35135",
            CustomsDesc = "Documents",
            Quantity    = 2,
            TotalValue  = 10,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    }.ToArray()
};
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim orderRequest As OrderRequest = New OrderRequest With {
    .Credentials = credentials,
    .ShipFromAddress = New Address With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "Order-13544364",
    .ShipMethod = "AIR",     ' Invalid for Postal Code B1S1B8
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364-01", .WeightUOM = "LB", .Weight = 10.0}
    },
    .Items = {
        New RequestItem With {
            .SKU = "x35135",
            .CustomsDesc = "Documents",
            .Quantity = 2,
            .TotalValue = 10,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim orderRequest As OrderRequest = New OrderRequest With {
    .Credentials = credentials,
    .ShipFromAddress = New Address With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "Order-13544364",
    .ShipMethod = "AIR",     ' Invalid for Postal Code B1S1B8
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .Packages = {
        New RequestPackage With {.PackageID = "PKG-13544364-01", .WeightUOM = "LB", .Weight = 10.0}
    },
    .Items = {
        New RequestItem With {
            .SKU = "x35135",
            .CustomsDesc = "Documents",
            .Quantity = 2,
            .TotalValue = 10,
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
  2.
                                    If the Status
                                    is Error (2), then the order data needs to be fixed and resubmitted.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
OrderResponse orderResponse = client.AddOrder(orderRequest);

if (orderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return orderResponse;
            case 81: // Air service not available.
                orderRequest.ShipMethod = "GROUND";
                break;
            case 82: // Ground service not available.
                orderRequest.ShipMethod = "AIR";
                break;
            // Fix other errors....
        }
    }

    orderResponse = client.AddOrder(orderRequest);
    if (orderResponse.Status == (int)SeverityEnum.Error)
        return orderResponse;
}
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
OrderResponse orderResponse = client.AddOrder(orderRequest);

if (orderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in orderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return orderResponse;
            case 81: // Air service not available.
                orderRequest.ShipMethod = "GROUND";
                break;
            case 82: // Ground service not available.
                orderRequest.ShipMethod = "AIR";
                break;
            // Fix other errors....
        }
    }

    orderResponse = client.AddOrder(orderRequest);
    if (orderResponse.Status == (int)SeverityEnum.Error)
        return orderResponse;
}
    Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim orderResponse As OrderResponse = client.AddOrder(orderRequest)

If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1	'Invalid Credentials
                Console.Write("Invalid Credentials")
                Return orderResponse
            Case 81	'Air service not available.
                orderRequest.ShipMethod = "GROUND"
            Case 82	'Ground service not available.
                orderRequest.ShipMethod = "AIR"
        ' Fix other errors....
        End Select
    Next

    orderResponse = client.AddOrder(orderRequest)
    If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return orderResponse
    End If
End If
    Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim orderResponse As OrderResponse = client.AddOrder(orderRequest)

If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In orderResponse.Messages
        Select Case message.Number
            Case 1	'Invalid Credentials
                Console.Write("Invalid Credentials")
                Return orderResponse
            Case 81	'Air service not available.
                orderRequest.ShipMethod = "GROUND"
            Case 82	'Ground service not available.
                orderRequest.ShipMethod = "AIR"
        ' Fix other errors....
        End Select
    Next

    orderResponse = client.AddOrder(orderRequest)
    If orderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return orderResponse
    End If
End If
  3.
                                    Otherwise send each ZPLCode
                                    in the response.Packages collection to the ZPL printer as raw text.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    foreach (ResponsePackage package in orderResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    foreach (ResponsePackage package in orderResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    For Each package As ResponsePackage In orderResponse.Packages
    ' This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
    For Each package As ResponsePackage In orderResponse.Packages
    ' This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
Print a single ZPL label
  1.
                                    Make a GetLabel(LabelRequest)
                                    request with the LabelType set to ZPL,

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

LabelRequest labelRequest = new LabelRequest
{
    Credentials = credentials,
    LabelType   = "ZPL",  // or ZPLIMAGES
    OrderNumber = "Order-13544364",
    PackageID   = "PKG-13544364-01"
    // We could have provided the package.TrackingNumber returned from an AddOrder response package instead of using PackageID.
};

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
LabelResponse response = client.GetLabel(labelRequest);
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

LabelRequest labelRequest = new LabelRequest
{
    Credentials = credentials,
    LabelType   = "ZPL",  // or ZPLIMAGES
    OrderNumber = "Order-13544364",
    PackageID   = "PKG-13544364-01"
    // We could have provided the package.TrackingNumber returned from an AddOrder response package instead of using PackageID.
};

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
LabelResponse response = client.GetLabel(labelRequest);
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim labelRequest As LabelRequest = New LabelRequest With {
    .Credentials = credentials,
    .LabelType = "ZPL",
    .PackageID = "PKG-13544364-01"
}
'We could have provided the package.TrackingNumber returned from an AddOrder response package instead of using PackageID.

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim response As LabelResponse = client.GetLabel(labelRequest)
    Dim credentials As CredentialInfo = New CredentialInfo With {.UserName = "User", .Password = "****", .ClientID = "0000000"}

Dim labelRequest As LabelRequest = New LabelRequest With {
    .Credentials = credentials,
    .LabelType = "ZPL",
    .PackageID = "PKG-13544364-01"
}
'We could have provided the package.TrackingNumber returned from an AddOrder response package instead of using PackageID.

Dim client As ShippingServicesSoapClient = New ShippingServicesSoapClient("PurolatorWebService")
Dim response As LabelResponse = client.GetLabel(labelRequest)
  2.
                                    If the Status
                                    is Error (2), then the package was not found or the request was invalid.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    if (response.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in response.Messages.Where(msg => msg.Severity == (int)SeverityEnum.Error))
        Console.WriteLine(message.Message);
    return;
}
    if (response.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in response.Messages.Where(msg => msg.Severity == (int)SeverityEnum.Error))
        Console.WriteLine(message.Message);
    return;
}
    If response.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In response.Messages
        If message.Severity = DirectCast(SeverityEnum.FatalError, Integer) Then
            Console.WriteLine(message.Message)
        End If
    Next
    Return
End If
    If response.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In response.Messages
        If message.Severity = DirectCast(SeverityEnum.FatalError, Integer) Then
            Console.WriteLine(message.Message)
        End If
    Next
    Return
End If
  3.
                                    Otherwise send the ZPLCode
                                    to the ZPL printer as raw text.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.Package.ZPLCode);

    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.Package.ZPLCode);
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.Package.ZPLCode)

    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, response.Package.ZPLCode)
Sample ZPL Encoded Barcode
This is ZPL code for a bar code:
View Colorized Copy to Clipboard Print
^XA^PR5,5^LH25,0^FO55,600^BY3^BCN,250,N,N,N,N^FD>;0830351221208070000100331000000000^FS^XZ
^XA^PR5,5^LH25,0^FO55,600^BY3^BCN,250,N,N,N,N^FD>;0830351221208070000100331000000000^FS^XZ
Sample ZPL Encoded Label
This is ZPL code for a label:
View Colorized Copy to Clipboard Print
^XA^PR5,5^LH25,0^FO5,30^XGR:PCLLOGO.GRF,1,1^FS^FO8,93^GB18,120,23^FS^FO12,107^A0B,20,23^FR^FDFROM/DE^FS^FO43,90^A0N,22,23^FDThe Lighthouse Group, LLC Shipping^FS^FO43,114^A0N,22,23^FD123 Shipping Street^FS^FO43,138^A0N,22,23^FDSuite 1001^FS^FO43,162^A0N,22,23^FDNew York, New York 10020^FS^FO43,186^A0N,22,23^FD(703) 123-4567^FS^FO40,207^GB65,25,25^FS^FO40,211^A0N,22,25^FB65,,,C^FR^FDRef:^FS^FO110,211^A0N,22,23^FDMyRef007^FS^FO8,264^GB18,80,23^FS^FO12,283^A0B,20,23^FR^FDTO/A^FS^FO43,260^A0N,28,29^FDMontreal Canadiens^FS^FO43,294^A0N,28,29^FD1275 St. Antoine Street West^FS^FO43,328^A0N,28,29^FDSuite 99^FS^FO41,362^A0N,33,35^FDMONTREAL, QC H3C5L2^FS^FO43,401^A0N,28,29^FD(514) 790-2525^FS^FO4,473^GB102,26,26^FS^FO4,477^A0N,25,27^FB102,,,C^FR^FDNOTE:^FS^FO111,476^A0N,28,29^FDComment noted.^FS^FO625,420^A0N,117,125^FDE3^FS^FO4,523^GB102,26,26^FS^FO0,527^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,557^A0N,25,29^FB162,,,C^FD5/12/2010^FS^FO334,523^GB131,26,26^FS^FO336,527^A0N,25,27^FB131,,,C^FR^FDPIECES^FS^FO305,557^A0N,25,29^FB191,,,C^FD1 of/de 2^FS^FO569,523^GB225,26,26^FS^FO569,527^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,557^A0N,25,29^FB225,,,C^FD75.00 lb^FS^FO0,655^A0B,20,24^FDSD: 3/1/2010^FS^FO55,600^BY3^BCN,250,N,N,N,N^FD>;0830351221208070000100331000060000^FS^FO0,865^A0N,33,43^FB800,,,C^FDPUROLATOR PIN: LHG000010033^FS^FO0,855^A0B,20,24^FDLHG000010033^FS^FO5,890^XGR:SATURDAY.GRF,1,1^FS^FO413,910^A0N,117,125^FDYUL^FS^FO663,910^A0N,61,64^FD07Y^FS^FO5,1035^XGR:DANGER.GRF,1,1^FS^FO30,1200^A0N,22,23^FDFully Regulated as per Shipper's Declaration^FS^FO450,1035^XGR:HEAVY.GRF,1,1^FS^FO400,90^A0N,22,23^FDIf undeliverable, use re-delivery^FS^FO400,114^A0N,22,23^FDlabel to route to: / Si non livrable,^FS^FO400,138^A0N,22,23^FDutilisez l'auto-collant de nouvelle^FS^FO400,162^A0N,22,23^FH^FDlivraison pour l'exp_82dier _85:^FS^FO450,186^A0N,22,23^FDPurolator USA^FS^FO450,210^A0N,22,23^FD1151 Martin Grove Road^FS^FO450,234^A0N,22,23^FDEtobicoke, ON^FS^XZ
^XA^PR5,5^LH25,0^FO5,30^XGR:PCLLOGO.GRF,1,1^FS^FO8,93^GB18,120,23^FS^FO12,107^A0B,20,23^FR^FDFROM/DE^FS^FO43,90^A0N,22,23^FDThe Lighthouse Group, LLC Shipping^FS^FO43,114^A0N,22,23^FD123 Shipping Street^FS^FO43,138^A0N,22,23^FDSuite 1001^FS^FO43,162^A0N,22,23^FDNew York, New York 10020^FS^FO43,186^A0N,22,23^FD(703) 123-4567^FS^FO40,207^GB65,25,25^FS^FO40,211^A0N,22,25^FB65,,,C^FR^FDRef:^FS^FO110,211^A0N,22,23^FDMyRef007^FS^FO8,264^GB18,80,23^FS^FO12,283^A0B,20,23^FR^FDTO/A^FS^FO43,260^A0N,28,29^FDMontreal Canadiens^FS^FO43,294^A0N,28,29^FD1275 St. Antoine Street West^FS^FO43,328^A0N,28,29^FDSuite 99^FS^FO41,362^A0N,33,35^FDMONTREAL, QC H3C5L2^FS^FO43,401^A0N,28,29^FD(514) 790-2525^FS^FO4,473^GB102,26,26^FS^FO4,477^A0N,25,27^FB102,,,C^FR^FDNOTE:^FS^FO111,476^A0N,28,29^FDComment noted.^FS^FO625,420^A0N,117,125^FDE3^FS^FO4,523^GB102,26,26^FS^FO0,527^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,557^A0N,25,29^FB162,,,C^FD5/12/2010^FS^FO334,523^GB131,26,26^FS^FO336,527^A0N,25,27^FB131,,,C^FR^FDPIECES^FS^FO305,557^A0N,25,29^FB191,,,C^FD1 of/de 2^FS^FO569,523^GB225,26,26^FS^FO569,527^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,557^A0N,25,29^FB225,,,C^FD75.00 lb^FS^FO0,655^A0B,20,24^FDSD: 3/1/2010^FS^FO55,600^BY3^BCN,250,N,N,N,N^FD>;0830351221208070000100331000060000^FS^FO0,865^A0N,33,43^FB800,,,C^FDPUROLATOR PIN: LHG000010033^FS^FO0,855^A0B,20,24^FDLHG000010033^FS^FO5,890^XGR:SATURDAY.GRF,1,1^FS^FO413,910^A0N,117,125^FDYUL^FS^FO663,910^A0N,61,64^FD07Y^FS^FO5,1035^XGR:DANGER.GRF,1,1^FS^FO30,1200^A0N,22,23^FDFully Regulated as per Shipper's Declaration^FS^FO450,1035^XGR:HEAVY.GRF,1,1^FS^FO400,90^A0N,22,23^FDIf undeliverable, use re-delivery^FS^FO400,114^A0N,22,23^FDlabel to route to: / Si non livrable,^FS^FO400,138^A0N,22,23^FDutilisez l'auto-collant de nouvelle^FS^FO400,162^A0N,22,23^FH^FDlivraison pour l'exp_82dier _85:^FS^FO450,186^A0N,22,23^FDPurolator USA^FS^FO450,210^A0N,22,23^FD1151 Martin Grove Road^FS^FO450,234^A0N,22,23^FDEtobicoke, ON^FS^XZ
The label was based on the following information:
FROM/DE | TO/A
The Lighthouse Group, LLC Shipping | Montreal Canadiens
WorldPak User | Wayne Gretzky
123 Shipping Street | 1275 St. Antoine Street West
Suite 1001 | Suite 99
New York, New York 10020 | MONTREAL, QC H3C5L2
703 123-4567 | (514) 790-2525
NOTE | Comment noted.
Sort code | E3
DATE | 5/12/2010
PIECES | 1 of/de 2
WEIGHT/POIDS | 75.00 lb
SD | 3/1/2010
PIN | LHG000010033
AirportCode | YUL
 | Fully regulated, Saturday delivery
Sample ZPL Encoded Image
This is ZPL code for a single image (the Purolator logo):
View Colorized Copy to Clipboard Print
~DGR:PCLLOGO,02295,045,000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
000000000001E07FFFF003FFFC0000000000000000000000000000000000000000000000000000000000000000
00000000000FE07FFFE003FFFFF000000000000000000000000000000000000000000000000000000000000000
00000000001FC0FFFFE007FFFFFE00000000000000000000000000000000000000000000000000000000000000
00000000003FC0FFFFC007FFFFFF00000000000000000000000000000000000000000000000000000000000000
00000000007F81FFFFC00FFFFFFF80000000000000000000000000003FE000000000007FC00000000000000000
0000000000FF81FFFF800FFFFFFF80000000000000000000000000007FE00000000000FF800000000000000000
0000000000FF03FFFF801FFFFFFFC000000000000000000000000000FFC00000000001FF800000000000000000
0000000000FF03FFFF001FFC3FFFC000000000000000000000000001FFC00000000003FF000000000000000000
0000000001FE07FFFF003FF803FFC000000000000000000000000003FF800000000007FF000000000000000000
0000000001FE07FFFF003FF801FFC000000000000000000000000003FF800000000007FF000000000000000000
0000000003FC07FFFE007FF001FFC000000000000000000000000003FF00000000000FFE000000000000000000
0000000003FC0FFFFE007FF001FFC000000000000000000000000007FF00000000000FFE000000000000000000
0000000007F80FFFFC00FFE001FF8000000000000000000000000007FE00000000000FFC000000000000000000
0000000007F81FFFFC00FFE001FF83FF801FFC07FC0FC001FFF0000FFE000FFFE003FFFFF0001FFF0000FF81F8
000000000FF81FFFF800FFC003FF87FF001FF807FC3FC00FFFFC000FFC00FFFFF003FFFFF0007FFFC000FF87F8
000000000FF03FFFF801FFC003FF07FF003FF80FF8FF803FFFFE001FFC03FFFFF807FFFFE003FFFFE001FF0FF0
000000001FF03FFFF001FF8007FF0FFE003FF00FF9FF807FFFFF001FF807FFFFFC07FFFFE007FFFFF001FF3FF0
000000001FE07FFFF003FF8007FF0FFE007FF01FFBFF01FFFFFF003FF807FFFFFC0FFFFFC01FFFFFF003FF7FE0
000000003FE07FFFE003FF000FFE0FFC007FE01FFFFF03FFFFFF003FF80FFFFFFC0FFFFFC03FFFFFF803FFFFE0
000000003FC0FFFFE007FF001FFC1FFC00FFE03FFFFE07FFFFFF807FF00FFCFFFC0FFFFF807FFFFFF807FFFFC0
000000007FC0FFFFC007FE003FFC1FF800FFC03FFFFE0FFE07FF807FF01F003FFC01FFE000FFF07FF807FFFFC0
000000007F81FFFFC00FFE00FFF83FF801FFC03FFFFC1FFC07FF80FFE018001FFC01FFC001FFC07FF807FFFF80
000000007F81FFFF800FFE07FFF03FF001FFC07FFF803FF803FF80FFE000001FFC01FF8003FF803FF80FFFF000
00000000FF03FFFF801FFFFFFFE07FF003FF807FFC007FF003FF81FFC000001FFC03FF8007FF003FF80FFF8000
00000000FF03FFFF801FFFFFFFC07FE003FF80FFF800FFE003FF81FFC000001FF803FF800FFE003FF81FFF0000
00000001FE03FFFF003FFFFFFF80FFE007FF00FFF001FFC007FF01FF800003FFF807FF001FFC003FF01FFE0000
00000001FE07FFFF003FFFFFFE00FFE007FF01FFE001FF8007FF03FF8000FFFFF807FF001FF8007FF03FFC0000
3FFFFF03FE07FFFE007FFFFFFC01FFC00FFE01FFC003FF8007FF03FF0007FFFFF007FE003FF8007FF03FF80000
7FFFFF03FC0FFFFE007FFFFFF001FFC00FFE03FF8007FF000FFE07FF001FFFFFF00FFE007FF0007FF07FF00000
7FFFFE07FC0FFFFC007FFFFF8003FF800FFC03FF8007FF000FFE07FE007FFFFFE00FFC007FF000FFE07FF00000
3FFFFE07F81FFFFC00FFFFE00003FF801FFC07FF000FFE000FFE0FFE01FFFFFFE01FFC00FFE000FFE0FFE00000
1FFFFC0FF81FFFF800FFC0000007FF001FF807FF000FFE001FFC0FFC03FFFDFFC01FF800FFE001FFC0FFE00000
0FFFFC0FF03FFFF801FFC0000007FF003FF80FFE001FFC001FFC1FFC07FF81FFC03FF800FFC001FFC1FFC00000
07FFF81FF03FFFF001FF80000007FE003FF00FFE001FFC003FF81FFC0FFE01FF803FF001FFC003FF81FFC00000
03FFF81FE07FFFF003FF8000000FFE007FF01FFC001FF8007FF03FF81FF803FF807FF001FFC003FF81FF800000
01FFF01FE07FFFE003FF0000000FFC007FE01FFC003FF8007FF03FF83FF003FF007FE001FF8007FF03FF800000
00FFF03FC0FFFFE007FF0000001FFC00FFE01FF8003FF800FFE07FF07FF007FF00FFE003FF800FFE03FF000000
007FE03FC0FFFFC007FE0000001FFC01FFE03FF8003FF801FFC07FF07FE007FE00FFE003FF800FFE07FF000000
003FE07F80FFFFC00FFE0000001FFC01FFC03FF0003FF801FFC0FFE0FFE00FFE00FFC003FF801FFC07FE000000
001FE07F81FFFFC00FFE0000003FFC07FFC07FF0003FF807FF80FFE0FFC01FFE01FFE003FF803FF80FFE000000
000FC0FF01FFFF801FFC0000003FFE1FFF807FE0003FF80FFF00FFC0FFE03FFC01FFE003FF80FFF00FFC000000
0007C0FF03FFFF801FFC0000003FFFFFFF80FFE0003FFC3FFE01FFC1FFE0FFFC01FFFF03FFC1FFE01FFC000000
000381FF03FFFF003FF80000003FFFFFFF00FFC0003FFFFFFC01FF81FFFFFFF803FFFF03FFFFFFC01FF8000000
000181FE07FFFF003FF80000003FFFFFFF01FFC0003FFFFFF003FF81FFFFFFF803FFFE03FFFFFF803FF8000000
000003FE07FFFE003FF00000003FFFFFFE01FF80003FFFFFE003FF01FFFFFFF003FFFE01FFFFFE003FF8000000
000003FC0FFFFE007FE00000003FFFF3FE03FF80001FFFFFC007FF01FFFFFFF003FFFC01FFFFFC007FF0000000
000007FC0FFFFC007FE00000003FFFC7FE03FF00000FFFFF0007FE00FFFF3FE001FFFC00FFFFF0007FE0000000
000007F81FFFF000FF800000001FFF07FC07FE000007FFFC000FFC007FFC3FE000FFF8007FFFC000FFC0000000
00000FF81FFFC000FC000000000FFC0FFC07F0000001FFC0000FC0003FE07FE0007FF0001FFE0000FE00000000
000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:PCLLOGO,02295,045,000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
000000000001E07FFFF003FFFC0000000000000000000000000000000000000000000000000000000000000000
00000000000FE07FFFE003FFFFF000000000000000000000000000000000000000000000000000000000000000
00000000001FC0FFFFE007FFFFFE00000000000000000000000000000000000000000000000000000000000000
00000000003FC0FFFFC007FFFFFF00000000000000000000000000000000000000000000000000000000000000
00000000007F81FFFFC00FFFFFFF80000000000000000000000000003FE000000000007FC00000000000000000
0000000000FF81FFFF800FFFFFFF80000000000000000000000000007FE00000000000FF800000000000000000
0000000000FF03FFFF801FFFFFFFC000000000000000000000000000FFC00000000001FF800000000000000000
0000000000FF03FFFF001FFC3FFFC000000000000000000000000001FFC00000000003FF000000000000000000
0000000001FE07FFFF003FF803FFC000000000000000000000000003FF800000000007FF000000000000000000
0000000001FE07FFFF003FF801FFC000000000000000000000000003FF800000000007FF000000000000000000
0000000003FC07FFFE007FF001FFC000000000000000000000000003FF00000000000FFE000000000000000000
0000000003FC0FFFFE007FF001FFC000000000000000000000000007FF00000000000FFE000000000000000000
0000000007F80FFFFC00FFE001FF8000000000000000000000000007FE00000000000FFC000000000000000000
0000000007F81FFFFC00FFE001FF83FF801FFC07FC0FC001FFF0000FFE000FFFE003FFFFF0001FFF0000FF81F8
000000000FF81FFFF800FFC003FF87FF001FF807FC3FC00FFFFC000FFC00FFFFF003FFFFF0007FFFC000FF87F8
000000000FF03FFFF801FFC003FF07FF003FF80FF8FF803FFFFE001FFC03FFFFF807FFFFE003FFFFE001FF0FF0
000000001FF03FFFF001FF8007FF0FFE003FF00FF9FF807FFFFF001FF807FFFFFC07FFFFE007FFFFF001FF3FF0
000000001FE07FFFF003FF8007FF0FFE007FF01FFBFF01FFFFFF003FF807FFFFFC0FFFFFC01FFFFFF003FF7FE0
000000003FE07FFFE003FF000FFE0FFC007FE01FFFFF03FFFFFF003FF80FFFFFFC0FFFFFC03FFFFFF803FFFFE0
000000003FC0FFFFE007FF001FFC1FFC00FFE03FFFFE07FFFFFF807FF00FFCFFFC0FFFFF807FFFFFF807FFFFC0
000000007FC0FFFFC007FE003FFC1FF800FFC03FFFFE0FFE07FF807FF01F003FFC01FFE000FFF07FF807FFFFC0
000000007F81FFFFC00FFE00FFF83FF801FFC03FFFFC1FFC07FF80FFE018001FFC01FFC001FFC07FF807FFFF80
000000007F81FFFF800FFE07FFF03FF001FFC07FFF803FF803FF80FFE000001FFC01FF8003FF803FF80FFFF000
00000000FF03FFFF801FFFFFFFE07FF003FF807FFC007FF003FF81FFC000001FFC03FF8007FF003FF80FFF8000
00000000FF03FFFF801FFFFFFFC07FE003FF80FFF800FFE003FF81FFC000001FF803FF800FFE003FF81FFF0000
00000001FE03FFFF003FFFFFFF80FFE007FF00FFF001FFC007FF01FF800003FFF807FF001FFC003FF01FFE0000
00000001FE07FFFF003FFFFFFE00FFE007FF01FFE001FF8007FF03FF8000FFFFF807FF001FF8007FF03FFC0000
3FFFFF03FE07FFFE007FFFFFFC01FFC00FFE01FFC003FF8007FF03FF0007FFFFF007FE003FF8007FF03FF80000
7FFFFF03FC0FFFFE007FFFFFF001FFC00FFE03FF8007FF000FFE07FF001FFFFFF00FFE007FF0007FF07FF00000
7FFFFE07FC0FFFFC007FFFFF8003FF800FFC03FF8007FF000FFE07FE007FFFFFE00FFC007FF000FFE07FF00000
3FFFFE07F81FFFFC00FFFFE00003FF801FFC07FF000FFE000FFE0FFE01FFFFFFE01FFC00FFE000FFE0FFE00000
1FFFFC0FF81FFFF800FFC0000007FF001FF807FF000FFE001FFC0FFC03FFFDFFC01FF800FFE001FFC0FFE00000
0FFFFC0FF03FFFF801FFC0000007FF003FF80FFE001FFC001FFC1FFC07FF81FFC03FF800FFC001FFC1FFC00000
07FFF81FF03FFFF001FF80000007FE003FF00FFE001FFC003FF81FFC0FFE01FF803FF001FFC003FF81FFC00000
03FFF81FE07FFFF003FF8000000FFE007FF01FFC001FF8007FF03FF81FF803FF807FF001FFC003FF81FF800000
01FFF01FE07FFFE003FF0000000FFC007FE01FFC003FF8007FF03FF83FF003FF007FE001FF8007FF03FF800000
00FFF03FC0FFFFE007FF0000001FFC00FFE01FF8003FF800FFE07FF07FF007FF00FFE003FF800FFE03FF000000
007FE03FC0FFFFC007FE0000001FFC01FFE03FF8003FF801FFC07FF07FE007FE00FFE003FF800FFE07FF000000
003FE07F80FFFFC00FFE0000001FFC01FFC03FF0003FF801FFC0FFE0FFE00FFE00FFC003FF801FFC07FE000000
001FE07F81FFFFC00FFE0000003FFC07FFC07FF0003FF807FF80FFE0FFC01FFE01FFE003FF803FF80FFE000000
000FC0FF01FFFF801FFC0000003FFE1FFF807FE0003FF80FFF00FFC0FFE03FFC01FFE003FF80FFF00FFC000000
0007C0FF03FFFF801FFC0000003FFFFFFF80FFE0003FFC3FFE01FFC1FFE0FFFC01FFFF03FFC1FFE01FFC000000
000381FF03FFFF003FF80000003FFFFFFF00FFC0003FFFFFFC01FF81FFFFFFF803FFFF03FFFFFFC01FF8000000
000181FE07FFFF003FF80000003FFFFFFF01FFC0003FFFFFF003FF81FFFFFFF803FFFE03FFFFFF803FF8000000
000003FE07FFFE003FF00000003FFFFFFE01FF80003FFFFFE003FF01FFFFFFF003FFFE01FFFFFE003FF8000000
000003FC0FFFFE007FE00000003FFFF3FE03FF80001FFFFFC007FF01FFFFFFF003FFFC01FFFFFC007FF0000000
000007FC0FFFFC007FE00000003FFFC7FE03FF00000FFFFF0007FE00FFFF3FE001FFFC00FFFFF0007FE0000000
000007F81FFFF000FF800000001FFF07FC07FE000007FFFC000FFC007FFC3FE000FFF8007FFFC000FFC0000000
00000FF81FFFC000FC000000000FFC0FFC07F0000001FFC0000FC0003FE07FE0007FF0001FFE0000FE00000000
000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000


Create LTL Order

Create LTL Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

This walkthrough is for LTL orders; if you are creating an courier (not Purolator, Canada Post, or UPS) order then see the courier walkthrough. This walkthrough assumes that Purolator is handling customs; if you are using a different customs broker then ignore code related to Item data.

  1. Create and populate an OrderRequest object.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

LTLOrderRequest ltlOrderRequest = new LTLOrderRequest
{
    Credentials     = credentials,
    ShipFromAddress = new Address
    {
        Company     = "My Company",
        Add1        = "290 Spagnoli Road",
        City        = "Melville",
        StateProv   = "NY",
        PostalCode  = "11747",
        Country     = "US",
    },
    ShipToAddress   = new Address
    {
        Name        = "Test Customer Name",
        Add1        = "560 Kings Road",
        City        = "Sydney",
        StateProv   = "NS",
        PostalCode  = "B1S1B8",
        Country     = "CA"
    },
    OrderNumber     = "LTLOrder-LSA5281",
    LabelType       = "ZPLIMAGES",
    ShipDate        = DateTime.Today,
    SpecialServices = new[] { "SATURDAY" }, // invalid for LTL
    GrossWeight     = 25 + 1 * palletWeight,
    Pallets         = new [] { new LTLPalletRequest { PalletNumber = "LSA5281" } },
    Items           = new []
    {
        new RequestItem
        {
            SKU         = "L61832",
            CustomsDesc = "Ladder",
            Quantity    = 1,
            TotalValue  = (decimal)89.98,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    },
};
    CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

LTLOrderRequest ltlOrderRequest = new LTLOrderRequest
{
    Credentials     = credentials,
    ShipFromAddress = new Address
    {
        Company     = "My Company",
        Add1        = "290 Spagnoli Road",
        City        = "Melville",
        StateProv   = "NY",
        PostalCode  = "11747",
        Country     = "US",
    },
    ShipToAddress   = new Address
    {
        Name        = "Test Customer Name",
        Add1        = "560 Kings Road",
        City        = "Sydney",
        StateProv   = "NS",
        PostalCode  = "B1S1B8",
        Country     = "CA"
    },
    OrderNumber     = "LTLOrder-LSA5281",
    LabelType       = "ZPLIMAGES",
    ShipDate        = DateTime.Today,
    SpecialServices = new[] { "SATURDAY" }, // invalid for LTL
    GrossWeight     = 25 + 1 * palletWeight,
    Pallets         = new [] { new LTLPalletRequest { PalletNumber = "LSA5281" } },
    Items           = new []
    {
        new RequestItem
        {
            SKU         = "L61832",
            CustomsDesc = "Ladder",
            Quantity    = 1,
            TotalValue  = (decimal)89.98,
            Currency    = "CAD",
            CountryOfOrigin = "United States",
        }
    },
};
    Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim ltlOrderRequest As New LTLOrderRequest() With {
    .Credentials = credentials,
    .ShipFromAddress = New Address() With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address() With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "LTLOrder-LSA5281",
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .SpecialServices = New String() {"SATURDAY"},
    .GrossWeight = 25 + 1 * palletWeight,
    .Pallets = {
        New LTLPalletRequest() With {.PalletNumber = "LSA5281"}
    },
    .Items = {
        New RequestItem() With {
            .SKU = "L61832",
            .CustomsDesc = "Ladder",
            .Quantity = 1,
            .TotalValue = CDec(89.98),
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
    Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim ltlOrderRequest As New LTLOrderRequest() With {
    .Credentials = credentials,
    .ShipFromAddress = New Address() With {
        .Company = "My Company",
        .Add1 = "290 Spagnoli Road",
        .City = "Melville",
        .StateProv = "NY",
        .PostalCode = "11747",
        .Country = "US"
    },
    .ShipToAddress = New Address() With {
        .Name = "Test Customer Name",
        .Add1 = "560 Kings Road",
        .City = "Sydney",
        .StateProv = "NS",
        .PostalCode = "B1S1B8",
        .Country = "CA"
    },
    .OrderNumber = "LTLOrder-LSA5281",
    .LabelType = "ZPLIMAGES",
    .ShipDate = DateTime.Today,
    .SpecialServices = New String() {"SATURDAY"},
    .GrossWeight = 25 + 1 * palletWeight,
    .Pallets = {
        New LTLPalletRequest() With {.PalletNumber = "LSA5281"}
    },
    .Items = {
        New RequestItem() With {
            .SKU = "L61832",
            .CustomsDesc = "Ladder",
            .Quantity = 1,
            .TotalValue = CDec(89.98),
            .Currency = "CAD",
            .CountryOfOrigin = "United States"
        }
    }
}
  2. Submit request.  If the response indicates any errors, then fix and resubmit the request.
    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
LTLOrderResponse ltlOrderResponse = client.AddLTLOrder(ltlOrderRequest);

if (ltlOrderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in ltlOrderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return ltlOrderResponse;
            case 3:  // Ship Method not valid - the postal code may be invalid
                return ltlOrderResponse;
            case 35: // LTL shipments must be end of day.
                ltlOrderRequest.SpecialServices = null;
                break;
            // Fix other errors....
        }
    }

    ltlOrderResponse = client.AddLTLOrder(ltlOrderRequest);
    if (ltlOrderResponse.Status == (int)SeverityEnum.Error)
        return ltlOrderResponse;
}
    ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
LTLOrderResponse ltlOrderResponse = client.AddLTLOrder(ltlOrderRequest);

if (ltlOrderResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in ltlOrderResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return ltlOrderResponse;
            case 3:  // Ship Method not valid - the postal code may be invalid
                return ltlOrderResponse;
            case 35: // LTL shipments must be end of day.
                ltlOrderRequest.SpecialServices = null;
                break;
            // Fix other errors....
        }
    }

    ltlOrderResponse = client.AddLTLOrder(ltlOrderRequest);
    if (ltlOrderResponse.Status == (int)SeverityEnum.Error)
        return ltlOrderResponse;
}
    Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlOrderResponse As LTLOrderResponse = client.AddLTLOrder(ltlOrderRequest)

If ltlOrderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In ltlOrderResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return ltlOrderResponse
            Case 3  ' Ship Method not valid - the postal code may be invalid
                Return ltlOrderResponse
            Case 35 ' LTL shipments must be end of day.
                ltlOrderRequest.SpecialServices = Nothing
                Exit Select
                ' Fix other errors....
        End Select
    Next

    ltlOrderResponse = client.AddLTLOrder(ltlOrderRequest)
    If ltlOrderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return ltlOrderResponse
    End If
End If
    Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlOrderResponse As LTLOrderResponse = client.AddLTLOrder(ltlOrderRequest)

If ltlOrderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In ltlOrderResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return ltlOrderResponse
            Case 3  ' Ship Method not valid - the postal code may be invalid
                Return ltlOrderResponse
            Case 35 ' LTL shipments must be end of day.
                ltlOrderRequest.SpecialServices = Nothing
                Exit Select
                ' Fix other errors....
        End Select
    Next

    ltlOrderResponse = client.AddLTLOrder(ltlOrderRequest)
    If ltlOrderResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return ltlOrderResponse
    End If
End If
  3.
                            Print and apply the label for each package.  See ZPL page
                            for more information.

    C#
    VB
    C++
    F#
    View Colorized Copy to Clipboard Print
    foreach (ResponsePackage package in ltlOrderResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    foreach (ResponsePackage package in ltlOrderResponse.Packages)
{
    // This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode);
}
    For Each package As ResponsePackage In ltlOrderResponse.Packages
    ' This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
    For Each package As ResponsePackage In ltlOrderResponse.Packages
    ' This method sends raw ZPL data to the printer using Windows API.
    RawDataPrinterHelper.SendStringToPrinter(zplPrinterName, package.ZPLCode)
Next
  4.
                            When all orders have the correct labels attached and are ready to ship, create a Closeout to complete processing.  See the
                            Closeout page for more information.


Create Incomplete LTL Order

Create Incomplete LTL Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

This walkthrough is for LTL orders; if you are creating an courier (not Purolator, Canada Post, or UPS) order then see the courier walkthrough. This walkthrough assumes that Purolator is handling customs; if you are using a different customs broker then ignore code related to Item data.

Add incomplete LTL shipments

  1. Create an order with AddLTLOrder(LTLOrderRequest).

    Customs Item information is required if Purolator is handling customs for the account.

  2. If the response indicated an error, fix the information and repeat step 1.

  3. When complete information for a package (a customer generated unique PackageID, weight, dimensions(optional)) is determined, use an AddPackage(AddPackageRequest) request to update the order and then print and attach the label to the package.

  4. If any additional customs item information needs to be added, AddItem(AddItemRequest) can be used to add item information.

  5. When the labels have been printed and applied to all packages, they can be added to the next Closeout.


Closeout LTL

Closeout LTL Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

For a package to be included in a close out, its entire order must be valid, and a label must have been created for the package. The software does not have the ability to determine if a label was physically printed, but it counts if the label has been displayed on the web site or if any request returned a response with the ZPL code for or image of the label.

It is important that each package included in a close out has actually been shipped since this may generate customs documentation or trigger other procedures which enable the package to be shipped without incident. It is also important to not include packages which haven’t actually shipped since you will be billed for packages which are closed out.

  1. Create a Closeout(CloseoutRequest)

    • ParsNumber is required for PARS customers.

    • PackIDType must specify either Pin or PackageID.

    • PackageIDs must contain either a list of Purolator generated Pins (from the barcode section of the label) or the PackageIDs/Package Numbers for each included package depending on the value of PackIDType.

  2. Save any Documents returned in the close out (if successful) response.

  3. Save updated rates for the closed out packages if needed.

Example using LTLNumbers

C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequestLTL ltlCloseoutRequest = new CloseoutRequestLTL
{
    Credentials   = credentials,
    ShipDate      = DateTime.Today,
    LTLNumberType = "LTLNumber",   // Could also be ProNumber
    LTLNumbers    = ltlNumbers,
    PackIDType    = "PackageID",
    PackageIDs    = nonLTLPackageIDs,
    //SkidCount   = ltlOrderResponse.Pallets.Count(),
    //ParsNumber  = "12-14799638", // Only used by PARS customers.
};

CloseoutResponseLTL closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in closeoutResponseLTLResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
    if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequestLTL ltlCloseoutRequest = new CloseoutRequestLTL
{
    Credentials   = credentials,
    ShipDate      = DateTime.Today,
    LTLNumberType = "LTLNumber",   // Could also be ProNumber
    LTLNumbers    = ltlNumbers,
    PackIDType    = "PackageID",
    PackageIDs    = nonLTLPackageIDs,
    //SkidCount   = ltlOrderResponse.Pallets.Count(),
    //ParsNumber  = "12-14799638", // Only used by PARS customers.
};

CloseoutResponseLTL closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in closeoutResponseLTLResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
    if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlCloseoutRequest As New CloseoutRequestLTL() With {
    .Credentials = credentials,
    .ShipDate = DateTime.Today,
    .LTLNumberType = "LTLNumber",  ' Could also be ProNumber
    .LTLNumbers = ltlNumbers,
    .PackIDType = "PackageID",
    .PackageIDs = nonLTLPackageIDs
    '.SkidCount = ltlOrderResponse.Pallets.Count(),
    '.ParsNumber = "12-14799638", ' Only used by PARS customers.
}

Dim closeoutResponseLTLResponse As CloseoutResponseLTL = client.CloseoutWithLTL(ltlCloseoutRequest)
If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In closeoutResponseLTLResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71, 79 ' No packages.
                Return
            Case 87 ' PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID"
                Exit Select
            Case 88 ' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest)
    If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return
    End If
End If

' Handle any closeoutResponse.Documents
Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlCloseoutRequest As New CloseoutRequestLTL() With {
    .Credentials = credentials,
    .ShipDate = DateTime.Today,
    .LTLNumberType = "LTLNumber",  ' Could also be ProNumber
    .LTLNumbers = ltlNumbers,
    .PackIDType = "PackageID",
    .PackageIDs = nonLTLPackageIDs
    '.SkidCount = ltlOrderResponse.Pallets.Count(),
    '.ParsNumber = "12-14799638", ' Only used by PARS customers.
}

Dim closeoutResponseLTLResponse As CloseoutResponseLTL = client.CloseoutWithLTL(ltlCloseoutRequest)
If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In closeoutResponseLTLResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71, 79 ' No packages.
                Return
            Case 87 ' PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID"
                Exit Select
            Case 88 ' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest)
    If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return
    End If
End If

' Handle any closeoutResponse.Documents
Example using ProNumbers
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequestLTL ltlCloseoutRequest = new CloseoutRequestLTL
{
    Credentials   = credentials,
    ShipDate      = DateTime.Today,
    LTLNumberType = "PRONUMBER",
    LTLNumbers    = proNumbers,
    PackageIDs    = nonLTLPins,
    PackIDType    = "Pin",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponseLTL closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in closeoutResponseLTLResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
    if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequestLTL ltlCloseoutRequest = new CloseoutRequestLTL
{
    Credentials   = credentials,
    ShipDate      = DateTime.Today,
    LTLNumberType = "PRONUMBER",
    LTLNumbers    = proNumbers,
    PackageIDs    = nonLTLPins,
    PackIDType    = "Pin",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponseLTL closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in closeoutResponseLTLResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
    if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlCloseoutRequest As New CloseoutRequestLTL() With {
    .Credentials = credentials,
    .ShipDate = DateTime.Today,
    .LTLNumberType = "PRONUMBER",
    .LTLNumbers = proNumbers,
    .PackageIDs = nonLTLPins,
    .PackIDType = "Pin"
    '.ParsNumber = "12-14799638", ' Only used by PARS customers.
}

Dim closeoutResponseLTLResponse As CloseoutResponseLTL = client.CloseoutWithLTL(ltlCloseoutRequest)
If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In closeoutResponseLTLResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71, 79 ' No packages.
                Return
            Case 87 ' PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID"
                Exit Select
            Case 88 ' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest)
    If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return
    End If
End If

' Handle any closeoutResponse.Documents
Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlCloseoutRequest As New CloseoutRequestLTL() With {
    .Credentials = credentials,
    .ShipDate = DateTime.Today,
    .LTLNumberType = "PRONUMBER",
    .LTLNumbers = proNumbers,
    .PackageIDs = nonLTLPins,
    .PackIDType = "Pin"
    '.ParsNumber = "12-14799638", ' Only used by PARS customers.
}

Dim closeoutResponseLTLResponse As CloseoutResponseLTL = client.CloseoutWithLTL(ltlCloseoutRequest)
If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In closeoutResponseLTLResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71, 79 ' No packages.
                Return
            Case 87 ' PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID"
                Exit Select
            Case 88 ' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest)
    If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return
    End If
End If

' Handle any closeoutResponse.Documents
Example using LtlShipmentNumber
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequestLTL ltlCloseoutRequest = new CloseoutRequestLTL
{
    Credentials   = credentials,
    ShipDate      = DateTime.Today,
    LTLNumberType = "LTLNUMBER",
    LTLNumbers    = new[] { ltlShipmentNumber },
    PackageIDs    = new string[0],
    PackIDType    = "Pin",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponseLTL closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in closeoutResponseLTLResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
    if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
CredentialInfo credentials = new CredentialInfo { UserName = "User", Password = "****", ClientID = "0000000" };

ShippingServicesSoapClient client = new ShippingServicesSoapClient("PurolatorWebService");
CloseoutRequestLTL ltlCloseoutRequest = new CloseoutRequestLTL
{
    Credentials   = credentials,
    ShipDate      = DateTime.Today,
    LTLNumberType = "LTLNUMBER",
    LTLNumbers    = new[] { ltlShipmentNumber },
    PackageIDs    = new string[0],
    PackIDType    = "Pin",
    //ParsNumber = "12-14799638", // Only used by PARS customers.
};

CloseoutResponseLTL closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
{
    foreach (ResponseMessage message in closeoutResponseLTLResponse.Messages)
    {
        switch (message.Number)
        {
            case 1:  // Invalid Credentials
                Console.Write("Invalid Credentials");
                return;
            case 71: // No packages.
            case 79: // No packages.
                return;
            case 87: // PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID";
                break;
            case 88: // Package(s) not found, or is not available for closeout.
                // This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                return;
        }
    }

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest);
    if (closeoutResponseLTLResponse.Status == (int)SeverityEnum.Error)
        return;
}

// Handle any closeoutResponse.Documents
Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlCloseoutRequest As New CloseoutRequestLTL() With {
    .Credentials = credentials,
    .ShipDate = DateTime.Today,
    .LTLNumberType = "LTLNUMBER",
    .LTLNumbers = New String() {ltlShipmentNumber},
    .PackageIDs = New String() {},
    .PackIDType = "Pin"
}
'ParsNumber = "12-14799638", ' Only used by PARS customers.

Dim closeoutResponseLTLResponse As CloseoutResponseLTL = client.CloseoutWithLTL(ltlCloseoutRequest)
If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In closeoutResponseLTLResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71, 79 ' No packages.
                Return
            Case 87 ' PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID"
                Exit Select
            Case 88 ' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest)
    If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return
    End If
End If

' Handle any closeoutResponse.Documents
Dim credentials As New CredentialInfo() With { .UserName = "User", .Password = "****", .ClientID = "0000000" }

Dim client As New ShippingServicesSoapClient("PurolatorWebService")
Dim ltlCloseoutRequest As New CloseoutRequestLTL() With {
    .Credentials = credentials,
    .ShipDate = DateTime.Today,
    .LTLNumberType = "LTLNUMBER",
    .LTLNumbers = New String() {ltlShipmentNumber},
    .PackageIDs = New String() {},
    .PackIDType = "Pin"
}
'ParsNumber = "12-14799638", ' Only used by PARS customers.

Dim closeoutResponseLTLResponse As CloseoutResponseLTL = client.CloseoutWithLTL(ltlCloseoutRequest)
If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
    For Each message As ResponseMessage In closeoutResponseLTLResponse.Messages
        Select Case message.Number
            Case 1  ' Invalid Credentials
                Console.Write("Invalid Credentials")
                Return
            Case 71, 79 ' No packages.
                Return
            Case 87 ' PackIDType should be Pin or PackageID.
                ltlCloseoutRequest.PackIDType = "PackageID"
                Exit Select
            Case 88 ' Package(s) not found, or is not available for closeout.
                ' This can happen if the label isn't printed, if the package is voided, if the package isn't verified, ...
                Return
        End Select
    Next

    closeoutResponseLTLResponse = client.CloseoutWithLTL(ltlCloseoutRequest)
    If closeoutResponseLTLResponse.Status = DirectCast(SeverityEnum.FatalError, Integer) Then
        Return
    End If
End If

' Handle any closeoutResponse.Documents


FAQ

FAQ Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Frequently Asked Questions

  • What is a WSDL file?
  • What can I do via the web services?
  • How do I use a WSDL file?
  • What type of label is returned when an order is created?
  • How does the closeout work?
  • Can I void a package/order and reuse the PackageID/OrderNumber?
  • I can create a request, but I get back an "Invalid credentials" error message even though I used the correct user name and password!
  • What is the Purolator web service URL?
  • How do I test the web service?
  • How can I see what I sent via the web service?
  • Where can I get the most recent version of this help file?

Q: What is a WSDL file?

A: A WSDL file is an XML file which defines how the web service behaves and allows tools to generate code to interact with the web service. See: Online WSDL

Q: How do I use a WSDL file?

A: You use a tool to create code you can use to interact with the web service.

Q: What can I do via the web services?

A: You can estimate shipping, create/update an order, get encoded label data, void packages/orders, and close out shipped packages.

Q: What type of label is returned when an order is created?

A: GetLabel, AddOrder, and AddLTLOrder offer the following LabelType options:

None: No label is generated. The order will still be modifiable.

Image: A PNG image is created and encoded as a Online Base64 string.

ZPL/ZPLIMAGES: A ZPL encoded label will be returned. More Info

Q: How does the closeout work?

A: A closeout marks packages from one or more shipments as being ready to ship. If Purolator is handling customs for a customer then documentation will be printed for the items the packages contain. After the closeout is completed the shipments and packages are no longer modifiable or voidable.

Q: Can I void a package/order and reuse the PackageID/OrderNumber?

A: Yes. Both the PackageID and the OrderNumber must be unique for non-voided packages/orders.

Q: I can create a request, but I get back an "Invalid credentials" error message even though I used the same user name and password I use when logging into the web site! Why isn’t it working?

A: A valid CredentialInfo must also contain a ClientID for the facility you want to ship from.

Q: What is the Purolator web service URL?

A: Use the Sandbox URL during testing, and the Production URL when you want to ship live packages. Use the URL below for connecting to the web service; you may need to append "?WSDL" when creating a proxy class.

Sandbox: http://support.pclusa.com/Sandbox/WebServices/ShippingServices.asmx

Production: http://www.purolatorshipping.com/WebServices/ShippingServices.asmx

Q: How do I test the web service?

A: That depends on what problem you are trying to troubleshoot.

As a general rule, you should start with GetZPLInitializationImages(CredentialInfo) when trying to test a connection since that should give you the same result is the same for each customer.

Document (at least) the XML request you sent to the web service, and the response you received. soapUI can be very useful.

Q: How can I see what I sent via the web service?

A: The response you receive will contain the original request (except for CredentialInfo) in the Request field.

If the request was malformed, then you may receive an exception message. In this case you could install packet capture software such as Online Wireshark or Online EtherDetect to keep track of the actual network traffic your software is sending to our web service. soapUI can also be useful.

Q: Where can I get the most recent version of this help file?

A: You should be able to download it (and other files) from the Online Download page.


Example Requests and Responses

Example Requests and Responses Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Sample Request section contains a sample SOAP request message which consists of a SOAP header and a SOAP body, and the related response from the server.

Sample Request and Response

This example of a request Online SOAP header was created with soapUI, the layout generated by another framework may be significantly different.

The Content-Length will be the length of the SOAP envelope portion of the request. Your User-Agent string will likely be different, but it is ignored by the server.

View Colorized Copy to Clipboard Print
POST http://support.pclusa.com/PurolatorOLS/WebServices/ShippingServices.asmx HTTP/1.1
  Accept-Encoding: gzip,deflate
  Content-Type: application/soap+xml;charset=UTF-8;action="http://PurolatorServices.com/GetOrderStatus"
  User-Agent: Jakarta Commons-HttpClient/3.1
  Host: support.pclusa.com
  Content-Length: 497

POST http://support.pclusa.com/PurolatorOLS/WebServices/ShippingServices.asmx HTTP/1.1
Accept-Encoding: gzip,deflate
Content-Type: application/soap+xml;charset=UTF-8;action="http://PurolatorServices.com/GetOrderStatus"
User-Agent: Jakarta Commons-HttpClient/3.1
Host: support.pclusa.com
Content-Length: 497

This is a typical SOAP envelope portion of a request.

XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:GetOrderStatus>
              <pur:credentials>
                  <pur:UserName>TestUser</pur:UserName>
                  <pur:Password>5VJrtqTa</pur:Password>
                  <pur:ClientID>0000000</pur:ClientID>
              </pur:credentials>
              <pur:orderNumber>Nonexistent Order</pur:orderNumber>
          </pur:GetOrderStatus>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:GetOrderStatus>
            <pur:credentials>
                <pur:UserName>TestUser</pur:UserName>
                <pur:Password>5VJrtqTa</pur:Password>
                <pur:ClientID>0000000</pur:ClientID>
            </pur:credentials>
            <pur:orderNumber>Nonexistent Order</pur:orderNumber>
        </pur:GetOrderStatus>
    </soap:Body>
</soap:Envelope>

This is a SOAP envelope from a typical response from the server.

This response indicates that the order specified in the request does not exist.

XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <GetOrderStatusResponse xmlns="http://PurolatorServices.com/">
           <GetOrderStatusResult>
              <Status>2</Status>
              <Messages>
                 <ResponseMessage>
                    <Number>11</Number>
                    <Severity>2</Severity>
                    <Message>Invalid shipment order number: Nonexistent Order.</Message>
                 </ResponseMessage>
              </Messages>
              <TotalShipping>0</TotalShipping>
           </GetOrderStatusResult>
        </GetOrderStatusResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <GetOrderStatusResponse xmlns="http://PurolatorServices.com/">
         <GetOrderStatusResult>
            <Status>2</Status>
            <Messages>
               <ResponseMessage>
                  <Number>11</Number>
                  <Severity>2</Severity>
                  <Message>Invalid shipment order number: Nonexistent Order.</Message>
               </ResponseMessage>
            </Messages>
            <TotalShipping>0</TotalShipping>
         </GetOrderStatusResult>
      </GetOrderStatusResponse>
   </soap:Body>
</soap:Envelope>
Sample Raw Request and Response

A request with an "empty" body:

XML
View Colorized Copy to Clipboard Print
POST http://support.pclusa.com/PurolatorOLS/WebServices/ShippingServices.asmx HTTP/1.1
  Accept-Encoding: gzip,deflate
  Content-Type: application/soap+xml;charset=UTF-8;action="http://PurolatorServices.com/GetOrderStatus"
  User-Agent: Jakarta Commons-HttpClient/3.1
  Host: support.pclusa.com
  Content-Length: 103

  <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
      <soap:Body/>
  </soap:Envelope>
POST http://support.pclusa.com/PurolatorOLS/WebServices/ShippingServices.asmx HTTP/1.1
Accept-Encoding: gzip,deflate
Content-Type: application/soap+xml;charset=UTF-8;action="http://PurolatorServices.com/GetOrderStatus"
User-Agent: Jakarta Commons-HttpClient/3.1
Host: support.pclusa.com
Content-Length: 103

<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
    <soap:Body/>
</soap:Envelope>

The corresponding response:

View Colorized Copy to Clipboard Print
HTTP/1.1 200 OK
  Cache-Control: private, max-age=0
  Content-Type: application/soap+xml; charset=utf-8
  Server: Microsoft-IIS/7.0
  X-AspNet-Version: 4.0.30319
  X-Powered-By: ASP.NET
  Date: Mon, 30 Jan 2012 16:16:38 GMT
  Content-Length: 561

  <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><GetOrderStatusResponse xmlns="http://PurolatorServices.com/"><GetOrderStatusResult><Status>2</Status><Messages><ResponseMessage><Number>1</Number><Severity>2</Severity><Message>Invalid credentials.</Message></ResponseMessage></Messages><TotalShipping>0</TotalShipping></GetOrderStatusResult></GetOrderStatusResponse></soap:Body></soap:Envelope>
HTTP/1.1 200 OK
Cache-Control: private, max-age=0
Content-Type: application/soap+xml; charset=utf-8
Server: Microsoft-IIS/7.0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Mon, 30 Jan 2012 16:16:38 GMT
Content-Length: 561

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><GetOrderStatusResponse xmlns="http://PurolatorServices.com/"><GetOrderStatusResult><Status>2</Status><Messages><ResponseMessage><Number>1</Number><Severity>2</Severity><Message>Invalid credentials.</Message></ResponseMessage></Messages><TotalShipping>0</TotalShipping></GetOrderStatusResult></GetOrderStatusResponse></soap:Body></soap:Envelope>
See Also

Other Resources

Online SOAP overview


Get Rates

Get Rates Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

GetRates returns a list of rates that include estimated delivery time and estimated rate for air and ground ship methods. If the ship method is set to PuroLetter or PuroPak, and estimated rate will also be included for the requested service. GetRates does not enter the order into the system for shipping.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:GetRates>
           <pur:request>
              <pur:Credentials>
                  <pur:UserName>TestUser</pur:UserName>
                  <pur:Password>5VJrtqTa</pur:Password>
                  <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:OrderNumber>Test-0001</pur:OrderNumber>
              <pur:Ref1>MyRef 001</pur:Ref1>
              <pur:Ref2>Note 001</pur:Ref2>
              <pur:ShipDate>2012-02-05T00:00:00</pur:ShipDate>
              <pur:ShipMethod>GROUND</pur:ShipMethod>
              <pur:SpecialServices>
                 <pur:string>NOTIFYCONSIGNEE</pur:string>
                 <pur:string>OSNR</pur:string>
              </pur:SpecialServices>
              <pur:BillingOption>PREPAID</pur:BillingOption>
              <pur:BillingAccount/>
              <pur:LabelType>NONE</pur:LabelType>
              <pur:ShipFromAddress>
                 <pur:Name></pur:Name>
                 <pur:Company>Simple Earth Hops</pur:Company>
                 <pur:Add1>210 S Lindsey Street</pur:Add1>
                 <pur:Add2></pur:Add2>
                 <pur:City>Dodgeville</pur:City>
                 <pur:StateProv>WI</pur:StateProv>
                 <pur:PostalCode>53533</pur:PostalCode>
                 <pur:Country>US</pur:Country>
                 <pur:Phone></pur:Phone>
                 <pur:Email></pur:Email>
              </pur:ShipFromAddress>
              <pur:ShipToAddress>
                 <pur:Name></pur:Name>
                 <pur:Company>Red Duck Beer</pur:Company>
                 <pur:Add1>101 Sample Street</pur:Add1>
                 <pur:Add2>Suite 202</pur:Add2>
                 <pur:City>Scarborough</pur:City>
                 <pur:StateProv>ON</pur:StateProv>
                 <pur:PostalCode>M1M1M1</pur:PostalCode>
                 <pur:Country>CA</pur:Country>
                 <pur:Phone></pur:Phone>
                 <pur:Email>SampleAddress@Example.com</pur:Email>
              </pur:ShipToAddress>
              <pur:DeclaredValue>23.68</pur:DeclaredValue>
              <pur:Currency>USD</pur:Currency>
              <pur:Packages>
                 <pur:RequestPackage>
                    <pur:PackageID>Pkg-0001a</pur:PackageID>
                    <pur:WeightUOM>LB</pur:WeightUOM>
                    <pur:Weight>2.354</pur:Weight>
                    <pur:DimensionUOM>IN</pur:DimensionUOM>
                    <pur:DimL>10.1</pur:DimL>
                    <pur:DimW>13.2</pur:DimW>
                    <pur:DimH>1.3</pur:DimH>
                 </pur:RequestPackage>
                 <pur:RequestPackage>
                    <pur:PackageID>Pkg-0001b</pur:PackageID>
                    <pur:WeightUOM>LB</pur:WeightUOM>
                    <pur:Weight>4.25</pur:Weight>
                    <pur:DimensionUOM>IN</pur:DimensionUOM>
                    <pur:DimL>0</pur:DimL>
                    <pur:DimW>0</pur:DimW>
                    <pur:DimH>0</pur:DimH>
                 </pur:RequestPackage>
              </pur:Packages>
              <pur:Items>
                 <pur:RequestItem>
                    <pur:SKU>DOC</pur:SKU>
                    <pur:CustomsDesc>Documents</pur:CustomsDesc>
                    <pur:ExtendedDesc>Misc. Documents</pur:ExtendedDesc>
                    <pur:Quantity>201</pur:Quantity>
                    <pur:TotalValue>1.00</pur:TotalValue>
                    <pur:Currency>CAD</pur:Currency>
                    <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                    <pur:HSCode></pur:HSCode>
                    <pur:NAFTAEligible>false</pur:NAFTAEligible>
                    <pur:FDAFood>false</pur:FDAFood>
                    <pur:Textile>false</pur:Textile>
                 </pur:RequestItem>
                 <pur:RequestItem>
                    <pur:SKU>Caps-2161</pur:SKU>
                    <pur:CustomsDesc>Bottle Caps</pur:CustomsDesc>
                    <pur:ExtendedDesc>Stainless Steel Bottle Caps</pur:ExtendedDesc>
                    <pur:Quantity>3000</pur:Quantity>
                    <pur:TotalValue>22.68</pur:TotalValue>
                    <pur:Currency>USD</pur:Currency>
                    <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                    <pur:HSCode>39235010</pur:HSCode>
                    <pur:NAFTAEligible>false</pur:NAFTAEligible>
                    <pur:FDAFood>false</pur:FDAFood>
                    <pur:Textile>false</pur:Textile>
                 </pur:RequestItem>
              </pur:Items>
           </pur:request>
        </pur:GetRates>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:GetRates>
         <pur:request>
            <pur:Credentials>
                <pur:UserName>TestUser</pur:UserName>
                <pur:Password>5VJrtqTa</pur:Password>
                <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:OrderNumber>Test-0001</pur:OrderNumber>
            <pur:Ref1>MyRef 001</pur:Ref1>
            <pur:Ref2>Note 001</pur:Ref2>
            <pur:ShipDate>2012-02-05T00:00:00</pur:ShipDate>
            <pur:ShipMethod>GROUND</pur:ShipMethod>
            <pur:SpecialServices>
               <pur:string>NOTIFYCONSIGNEE</pur:string>
               <pur:string>OSNR</pur:string>
            </pur:SpecialServices>
            <pur:BillingOption>PREPAID</pur:BillingOption>
            <pur:BillingAccount/>
            <pur:LabelType>NONE</pur:LabelType>
            <pur:ShipFromAddress>
               <pur:Name></pur:Name>
               <pur:Company>Simple Earth Hops</pur:Company>
               <pur:Add1>210 S Lindsey Street</pur:Add1>
               <pur:Add2></pur:Add2>
               <pur:City>Dodgeville</pur:City>
               <pur:StateProv>WI</pur:StateProv>
               <pur:PostalCode>53533</pur:PostalCode>
               <pur:Country>US</pur:Country>
               <pur:Phone></pur:Phone>
               <pur:Email></pur:Email>
            </pur:ShipFromAddress>
            <pur:ShipToAddress>
               <pur:Name></pur:Name>
               <pur:Company>Red Duck Beer</pur:Company>
               <pur:Add1>101 Sample Street</pur:Add1>
               <pur:Add2>Suite 202</pur:Add2>
               <pur:City>Scarborough</pur:City>
               <pur:StateProv>ON</pur:StateProv>
               <pur:PostalCode>M1M1M1</pur:PostalCode>
               <pur:Country>CA</pur:Country>
               <pur:Phone></pur:Phone>
               <pur:Email>SampleAddress@Example.com</pur:Email>
            </pur:ShipToAddress>
            <pur:DeclaredValue>23.68</pur:DeclaredValue>
            <pur:Currency>USD</pur:Currency>
            <pur:Packages>
               <pur:RequestPackage>
                  <pur:PackageID>Pkg-0001a</pur:PackageID>
                  <pur:WeightUOM>LB</pur:WeightUOM>
                  <pur:Weight>2.354</pur:Weight>
                  <pur:DimensionUOM>IN</pur:DimensionUOM>
                  <pur:DimL>10.1</pur:DimL>
                  <pur:DimW>13.2</pur:DimW>
                  <pur:DimH>1.3</pur:DimH>
               </pur:RequestPackage>
               <pur:RequestPackage>
                  <pur:PackageID>Pkg-0001b</pur:PackageID>
                  <pur:WeightUOM>LB</pur:WeightUOM>
                  <pur:Weight>4.25</pur:Weight>
                  <pur:DimensionUOM>IN</pur:DimensionUOM>
                  <pur:DimL>0</pur:DimL>
                  <pur:DimW>0</pur:DimW>
                  <pur:DimH>0</pur:DimH>
               </pur:RequestPackage>
            </pur:Packages>
            <pur:Items>
               <pur:RequestItem>
                  <pur:SKU>DOC</pur:SKU>
                  <pur:CustomsDesc>Documents</pur:CustomsDesc>
                  <pur:ExtendedDesc>Misc. Documents</pur:ExtendedDesc>
                  <pur:Quantity>201</pur:Quantity>
                  <pur:TotalValue>1.00</pur:TotalValue>
                  <pur:Currency>CAD</pur:Currency>
                  <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                  <pur:HSCode></pur:HSCode>
                  <pur:NAFTAEligible>false</pur:NAFTAEligible>
                  <pur:FDAFood>false</pur:FDAFood>
                  <pur:Textile>false</pur:Textile>
               </pur:RequestItem>
               <pur:RequestItem>
                  <pur:SKU>Caps-2161</pur:SKU>
                  <pur:CustomsDesc>Bottle Caps</pur:CustomsDesc>
                  <pur:ExtendedDesc>Stainless Steel Bottle Caps</pur:ExtendedDesc>
                  <pur:Quantity>3000</pur:Quantity>
                  <pur:TotalValue>22.68</pur:TotalValue>
                  <pur:Currency>USD</pur:Currency>
                  <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                  <pur:HSCode>39235010</pur:HSCode>
                  <pur:NAFTAEligible>false</pur:NAFTAEligible>
                  <pur:FDAFood>false</pur:FDAFood>
                  <pur:Textile>false</pur:Textile>
               </pur:RequestItem>
            </pur:Items>
         </pur:request>
      </pur:GetRates>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <GetRatesResponse xmlns="http://PurolatorServices.com/">
           <GetRatesResult>
              <Status>0</Status>
              <Request>
                 <OrderNumber>Test-0001</OrderNumber>
                 <Ref1>MyRef 001</Ref1>
                 <Ref2>Note 001</Ref2>
                 <ShipDate>2012-02-05T00:00:00</ShipDate>
                 <ShipMethod>GROUND</ShipMethod>
                 <SpecialServices>
                    <string>NOTIFYCONSIGNEE</string>
                    <string>OSNR</string>
                 </SpecialServices>
                 <BillingOption>PREPAID</BillingOption>
                 <BillingAccount/>
                 <LabelType>NONE</LabelType>
                 <ShipFromAddress>
                    <Name/>
                    <Company>Simple Earth Hops</Company>
                    <Add1>210 S Lindsey Street</Add1>
                    <Add2/>
                    <City>Dodgeville</City>
                    <StateProv>WI</StateProv>
                    <PostalCode>53533</PostalCode>
                    <Country>US</Country>
                    <Phone/>
                    <Email/>
                 </ShipFromAddress>
                 <ShipToAddress>
                    <Name/>
                    <Company>Red Duck Beer</Company>
                    <Add1>101 Sample Street</Add1>
                    <Add2>Suite 202</Add2>
                    <City>Scarborough</City>
                    <StateProv>ON</StateProv>
                    <PostalCode>M1M1M1</PostalCode>
                    <Country>CA</Country>
                    <Phone/>
                    <Email>SampleAddress@Example.com</Email>
                 </ShipToAddress>
                 <DeclaredValue>23.68</DeclaredValue>
                 <Currency>USD</Currency>
                 <Packages>
                    <RequestPackage>
                       <PackageID>Pkg-0001a</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>2.354</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>10.1</DimL>
                       <DimW>13.2</DimW>
                       <DimH>1.3</DimH>
                    </RequestPackage>
                    <RequestPackage>
                       <PackageID>Pkg-0001b</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>4.25</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>0</DimL>
                       <DimW>0</DimW>
                       <DimH>0</DimH>
                    </RequestPackage>
                 </Packages>
                 <Items>
                    <RequestItem>
                       <SKU>DOC</SKU>
                       <CustomsDesc>Documents</CustomsDesc>
                       <ExtendedDesc>Misc. Documents</ExtendedDesc>
                       <Quantity>201</Quantity>
                       <TotalValue>1.00</TotalValue>
                       <Currency>CAD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode/>
                       <NAFTAEligible>false</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>false</Textile>
                    </RequestItem>
                    <RequestItem>
                       <SKU>Caps-2161</SKU>
                       <CustomsDesc>Bottle Caps</CustomsDesc>
                       <ExtendedDesc>Stainless Steel Bottle Caps</ExtendedDesc>
                       <Quantity>3000</Quantity>
                       <TotalValue>22.68</TotalValue>
                       <Currency>USD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode>39235010</HSCode>
                       <NAFTAEligible>false</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>false</Textile>
                    </RequestItem>
                 </Items>
              </Request>
              <Packages/>
              <TotalShipping>0</TotalShipping>
              <Rates>
                 <Rate>
                    <ShipMethod>GROUND</ShipMethod>
                    <EstimatedDeliveryDate>2012-02-07T00:00:00</EstimatedDeliveryDate>
                    <EstimatedRate>4.58</EstimatedRate>
                 </Rate>
              </Rates>
           </GetRatesResult>
        </GetRatesResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <GetRatesResponse xmlns="http://PurolatorServices.com/">
         <GetRatesResult>
            <Status>0</Status>
            <Request>
               <OrderNumber>Test-0001</OrderNumber>
               <Ref1>MyRef 001</Ref1>
               <Ref2>Note 001</Ref2>
               <ShipDate>2012-02-05T00:00:00</ShipDate>
               <ShipMethod>GROUND</ShipMethod>
               <SpecialServices>
                  <string>NOTIFYCONSIGNEE</string>
                  <string>OSNR</string>
               </SpecialServices>
               <BillingOption>PREPAID</BillingOption>
               <BillingAccount/>
               <LabelType>NONE</LabelType>
               <ShipFromAddress>
                  <Name/>
                  <Company>Simple Earth Hops</Company>
                  <Add1>210 S Lindsey Street</Add1>
                  <Add2/>
                  <City>Dodgeville</City>
                  <StateProv>WI</StateProv>
                  <PostalCode>53533</PostalCode>
                  <Country>US</Country>
                  <Phone/>
                  <Email/>
               </ShipFromAddress>
               <ShipToAddress>
                  <Name/>
                  <Company>Red Duck Beer</Company>
                  <Add1>101 Sample Street</Add1>
                  <Add2>Suite 202</Add2>
                  <City>Scarborough</City>
                  <StateProv>ON</StateProv>
                  <PostalCode>M1M1M1</PostalCode>
                  <Country>CA</Country>
                  <Phone/>
                  <Email>SampleAddress@Example.com</Email>
               </ShipToAddress>
               <DeclaredValue>23.68</DeclaredValue>
               <Currency>USD</Currency>
               <Packages>
                  <RequestPackage>
                     <PackageID>Pkg-0001a</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>2.354</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>10.1</DimL>
                     <DimW>13.2</DimW>
                     <DimH>1.3</DimH>
                  </RequestPackage>
                  <RequestPackage>
                     <PackageID>Pkg-0001b</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>4.25</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>0</DimL>
                     <DimW>0</DimW>
                     <DimH>0</DimH>
                  </RequestPackage>
               </Packages>
               <Items>
                  <RequestItem>
                     <SKU>DOC</SKU>
                     <CustomsDesc>Documents</CustomsDesc>
                     <ExtendedDesc>Misc. Documents</ExtendedDesc>
                     <Quantity>201</Quantity>
                     <TotalValue>1.00</TotalValue>
                     <Currency>CAD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode/>
                     <NAFTAEligible>false</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>false</Textile>
                  </RequestItem>
                  <RequestItem>
                     <SKU>Caps-2161</SKU>
                     <CustomsDesc>Bottle Caps</CustomsDesc>
                     <ExtendedDesc>Stainless Steel Bottle Caps</ExtendedDesc>
                     <Quantity>3000</Quantity>
                     <TotalValue>22.68</TotalValue>
                     <Currency>USD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode>39235010</HSCode>
                     <NAFTAEligible>false</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>false</Textile>
                  </RequestItem>
               </Items>
            </Request>
            <Packages/>
            <TotalShipping>0</TotalShipping>
            <Rates>
               <Rate>
                  <ShipMethod>GROUND</ShipMethod>
                  <EstimatedDeliveryDate>2012-02-07T00:00:00</EstimatedDeliveryDate>
                  <EstimatedRate>4.58</EstimatedRate>
               </Rate>
            </Rates>
         </GetRatesResult>
      </GetRatesResponse>
   </soap:Body>
</soap:Envelope>


Add Order

Add Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets the service availability, estimated rate, pin numbers and labels for each package.

AddOrder determines if the specified service is avaialble for the order and returns an estimated rate and a pin number and label for each package. AddOrder enters the order into the system for shipping.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:AddOrder>
              <pur:request>
              <pur:Credentials>
                  <pur:UserName>TestUser</pur:UserName>
                  <pur:Password>5VJrtqTa</pur:Password>
                  <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:OrderNumber>Test-0001</pur:OrderNumber>
              <pur:Ref1>MyRef 001</pur:Ref1>
              <pur:Ref2>Note 001</pur:Ref2>
              <pur:ShipDate>2012-08-09T00:00:00</pur:ShipDate>
              <pur:ShipMethod>GROUND</pur:ShipMethod>
              <pur:SpecialServices>
                  <pur:string>NOTIFYCONSIGNEE</pur:string>
                  <pur:string>OSNR</pur:string>
              </pur:SpecialServices>
              <pur:BillingOption>PREPAID</pur:BillingOption>
              <pur:LabelType>NONE</pur:LabelType>
              <pur:ShipFromAddress>
                 <pur:Name></pur:Name>
                 <pur:Company>Simple Earth Hops</pur:Company>
                 <pur:Add1>210 S Lindsey Street</pur:Add1>
                 <pur:Add2></pur:Add2>
                 <pur:City>Dodgeville</pur:City>
                 <pur:StateProv>WI</pur:StateProv>
                 <pur:PostalCode>53533</pur:PostalCode>
                 <pur:Country>US</pur:Country>
                 <pur:Phone></pur:Phone>
                 <pur:Email></pur:Email>
              </pur:ShipFromAddress>
              <pur:ShipToAddress>
                  <pur:Name></pur:Name>
                  <pur:Company>Red Duck Beer</pur:Company>
                  <pur:Add1>101 Sample Street</pur:Add1>
                  <pur:Add2>Suite 202</pur:Add2>
                  <pur:City>Scarborough</pur:City>
                  <pur:StateProv>ON</pur:StateProv>
                  <pur:PostalCode>M1M1M1</pur:PostalCode>
                  <pur:Country>CA</pur:Country>
                  <pur:Phone></pur:Phone>
                  <pur:Email>SampleAddress@Example.com</pur:Email>
              </pur:ShipToAddress>
              <pur:DeclaredValue>23.68</pur:DeclaredValue>
              <pur:Currency>USD</pur:Currency>
              <pur:Packages>
                  <pur:RequestPackage>
                      <pur:PackageID>Pkg-0001a</pur:PackageID>
                      <pur:WeightUOM>LB</pur:WeightUOM>
                      <pur:Weight>2.354</pur:Weight>
                      <pur:DimensionUOM>IN</pur:DimensionUOM>
                      <pur:DimL>10.1</pur:DimL>
                      <pur:DimW>13.2</pur:DimW>
                      <pur:DimH>1.3</pur:DimH>
                  </pur:RequestPackage>
                  <pur:RequestPackage>
                      <pur:PackageID>Pkg-0001b</pur:PackageID>
                      <pur:WeightUOM>LB</pur:WeightUOM>
                      <pur:Weight>4.25</pur:Weight>
                      <pur:DimensionUOM>IN</pur:DimensionUOM>
                      <pur:DimL>0</pur:DimL>
                      <pur:DimW>0</pur:DimW>
                      <pur:DimH>0</pur:DimH>
                  </pur:RequestPackage>
              </pur:Packages>
              <pur:Items>
                  <pur:RequestItem>
                      <pur:SKU>DOC</pur:SKU>
                      <pur:CustomsDesc>Documents</pur:CustomsDesc>
                      <pur:ExtendedDesc>Misc. Documents</pur:ExtendedDesc>
                      <pur:Quantity>201</pur:Quantity>
                      <pur:TotalValue>1.00</pur:TotalValue>
                      <pur:Currency>CAD</pur:Currency>
                      <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                      <pur:HSCode></pur:HSCode>
                      <pur:NAFTAEligible>false</pur:NAFTAEligible>
                      <pur:FDAFood>false</pur:FDAFood>
                      <pur:Textile>false</pur:Textile>
                  </pur:RequestItem>
                  <pur:RequestItem>
                      <pur:SKU>Caps-2161</pur:SKU>
                      <pur:CustomsDesc>Bottle Caps</pur:CustomsDesc>
                      <pur:ExtendedDesc>Stainless Steel Bottle Caps</pur:ExtendedDesc>
                      <pur:Quantity>3000</pur:Quantity>
                      <pur:TotalValue>22.68</pur:TotalValue>
                      <pur:Currency>USD</pur:Currency>
                      <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                      <pur:HSCode>39235010</pur:HSCode>
                      <pur:NAFTAEligible>false</pur:NAFTAEligible>
                      <pur:FDAFood>false</pur:FDAFood>
                      <pur:Textile>false</pur:Textile>
                  </pur:RequestItem>
              </pur:Items>
           </pur:request>
        </pur:AddOrder>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:AddOrder>
            <pur:request>
            <pur:Credentials>
                <pur:UserName>TestUser</pur:UserName>
                <pur:Password>5VJrtqTa</pur:Password>
                <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:OrderNumber>Test-0001</pur:OrderNumber>
            <pur:Ref1>MyRef 001</pur:Ref1>
            <pur:Ref2>Note 001</pur:Ref2>
            <pur:ShipDate>2012-08-09T00:00:00</pur:ShipDate>
            <pur:ShipMethod>GROUND</pur:ShipMethod>
            <pur:SpecialServices>
                <pur:string>NOTIFYCONSIGNEE</pur:string>
                <pur:string>OSNR</pur:string>
            </pur:SpecialServices>
            <pur:BillingOption>PREPAID</pur:BillingOption>
            <pur:LabelType>NONE</pur:LabelType>
            <pur:ShipFromAddress>
               <pur:Name></pur:Name>
               <pur:Company>Simple Earth Hops</pur:Company>
               <pur:Add1>210 S Lindsey Street</pur:Add1>
               <pur:Add2></pur:Add2>
               <pur:City>Dodgeville</pur:City>
               <pur:StateProv>WI</pur:StateProv>
               <pur:PostalCode>53533</pur:PostalCode>
               <pur:Country>US</pur:Country>
               <pur:Phone></pur:Phone>
               <pur:Email></pur:Email>
            </pur:ShipFromAddress>
            <pur:ShipToAddress>
                <pur:Name></pur:Name>
                <pur:Company>Red Duck Beer</pur:Company>
                <pur:Add1>101 Sample Street</pur:Add1>
                <pur:Add2>Suite 202</pur:Add2>
                <pur:City>Scarborough</pur:City>
                <pur:StateProv>ON</pur:StateProv>
                <pur:PostalCode>M1M1M1</pur:PostalCode>
                <pur:Country>CA</pur:Country>
                <pur:Phone></pur:Phone>
                <pur:Email>SampleAddress@Example.com</pur:Email>
            </pur:ShipToAddress>
            <pur:DeclaredValue>23.68</pur:DeclaredValue>
            <pur:Currency>USD</pur:Currency>
            <pur:Packages>
                <pur:RequestPackage>
                    <pur:PackageID>Pkg-0001a</pur:PackageID>
                    <pur:WeightUOM>LB</pur:WeightUOM>
                    <pur:Weight>2.354</pur:Weight>
                    <pur:DimensionUOM>IN</pur:DimensionUOM>
                    <pur:DimL>10.1</pur:DimL>
                    <pur:DimW>13.2</pur:DimW>
                    <pur:DimH>1.3</pur:DimH>
                </pur:RequestPackage>
                <pur:RequestPackage>
                    <pur:PackageID>Pkg-0001b</pur:PackageID>
                    <pur:WeightUOM>LB</pur:WeightUOM>
                    <pur:Weight>4.25</pur:Weight>
                    <pur:DimensionUOM>IN</pur:DimensionUOM>
                    <pur:DimL>0</pur:DimL>
                    <pur:DimW>0</pur:DimW>
                    <pur:DimH>0</pur:DimH>
                </pur:RequestPackage>
            </pur:Packages>
            <pur:Items>
                <pur:RequestItem>
                    <pur:SKU>DOC</pur:SKU>
                    <pur:CustomsDesc>Documents</pur:CustomsDesc>
                    <pur:ExtendedDesc>Misc. Documents</pur:ExtendedDesc>
                    <pur:Quantity>201</pur:Quantity>
                    <pur:TotalValue>1.00</pur:TotalValue>
                    <pur:Currency>CAD</pur:Currency>
                    <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                    <pur:HSCode></pur:HSCode>
                    <pur:NAFTAEligible>false</pur:NAFTAEligible>
                    <pur:FDAFood>false</pur:FDAFood>
                    <pur:Textile>false</pur:Textile>
                </pur:RequestItem>
                <pur:RequestItem>
                    <pur:SKU>Caps-2161</pur:SKU>
                    <pur:CustomsDesc>Bottle Caps</pur:CustomsDesc>
                    <pur:ExtendedDesc>Stainless Steel Bottle Caps</pur:ExtendedDesc>
                    <pur:Quantity>3000</pur:Quantity>
                    <pur:TotalValue>22.68</pur:TotalValue>
                    <pur:Currency>USD</pur:Currency>
                    <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                    <pur:HSCode>39235010</pur:HSCode>
                    <pur:NAFTAEligible>false</pur:NAFTAEligible>
                    <pur:FDAFood>false</pur:FDAFood>
                    <pur:Textile>false</pur:Textile>
                </pur:RequestItem>
            </pur:Items>
         </pur:request>
      </pur:AddOrder>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <AddOrderResponse xmlns="http://PurolatorServices.com/">
           <AddOrderResult>
              <Status>0</Status>
              <Request>
                 <OrderNumber>Test-0001</OrderNumber>
                 <Ref1>MyRef 001</Ref1>
                 <Ref2>Note 001</Ref2>
                 <ShipDate>2012-08-09T00:00:00</ShipDate>
                 <ShipMethod>GROUND</ShipMethod>
                 <SpecialServices>
                    <string>NOTIFYCONSIGNEE</string>
                    <string>OSNR</string>
                 </SpecialServices>
                 <BillingOption>PREPAID</BillingOption>
                 <BillingAccount/>
                 <LabelType>NONE</LabelType>
                 <ShipFromAddress>
                    <Name/>
                    <Company>Simple Earth Hops</Company>
                    <Add1>210 S Lindsey Street</Add1>
                    <Add2/>
                    <City>Dodgeville</City>
                    <StateProv>WI</StateProv>
                    <PostalCode>53533</PostalCode>
                    <Country>US</Country>
                    <Phone/>
                    <Email/>
                 </ShipFromAddress>
                 <ShipToAddress>
                    <Name/>
                    <Company>Red Duck Beer</Company>
                    <Add1>101 Sample Street</Add1>
                    <Add2>Suite 202</Add2>
                    <City>Scarborough</City>
                    <StateProv>ON</StateProv>
                    <PostalCode>M1M1M1</PostalCode>
                    <Country>CA</Country>
                    <Phone/>
                    <Email>SampleAddress@Example.com</Email>
                 </ShipToAddress>
                 <DeclaredValue>23.68</DeclaredValue>
                 <Currency>USD</Currency>
                 <Packages>
                    <RequestPackage>
                       <PackageID>Pkg-0001a</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>2.354</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>10.1</DimL>
                       <DimW>13.2</DimW>
                       <DimH>1.3</DimH>
                    </RequestPackage>
                    <RequestPackage>
                       <PackageID>Pkg-0001b</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>4.25</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>0</DimL>
                       <DimW>0</DimW>
                       <DimH>0</DimH>
                    </RequestPackage>
                 </Packages>
                 <Items>
                    <RequestItem>
                       <SKU>DOC</SKU>
                       <CustomsDesc>Documents</CustomsDesc>
                       <ExtendedDesc>Misc. Documents</ExtendedDesc>
                       <Quantity>201</Quantity>
                       <TotalValue>1.00</TotalValue>
                       <Currency>CAD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode/>
                       <NAFTAEligible>false</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>false</Textile>
                    </RequestItem>
                    <RequestItem>
                       <SKU>Caps-2161</SKU>
                       <CustomsDesc>Bottle Caps</CustomsDesc>
                       <ExtendedDesc>Stainless Steel Bottle Caps</ExtendedDesc>
                       <Quantity>3000</Quantity>
                       <TotalValue>22.68</TotalValue>
                       <Currency>USD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode>39235010</HSCode>
                       <NAFTAEligible>false</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>false</Textile>
                    </RequestItem>
                 </Items>
              </Request>
              <Packages>
                 <ResponsePackage>
                    <PackageID>Pkg-0001a</PackageID>
                    <TrackingNumber>TST000006569</TrackingNumber>
                    <ShippingCharge>1.64680</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode/>
                 </ResponsePackage>
                 <ResponsePackage>
                    <PackageID>Pkg-0001b</PackageID>
                    <TrackingNumber>TST000006577</TrackingNumber>
                    <ShippingCharge>2.97320</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode/>
                 </ResponsePackage>
              </Packages>
              <TotalShipping>4.62</TotalShipping>
              <Rates/>
           </AddOrderResult>
        </AddOrderResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <AddOrderResponse xmlns="http://PurolatorServices.com/">
         <AddOrderResult>
            <Status>0</Status>
            <Request>
               <OrderNumber>Test-0001</OrderNumber>
               <Ref1>MyRef 001</Ref1>
               <Ref2>Note 001</Ref2>
               <ShipDate>2012-08-09T00:00:00</ShipDate>
               <ShipMethod>GROUND</ShipMethod>
               <SpecialServices>
                  <string>NOTIFYCONSIGNEE</string>
                  <string>OSNR</string>
               </SpecialServices>
               <BillingOption>PREPAID</BillingOption>
               <BillingAccount/>
               <LabelType>NONE</LabelType>
               <ShipFromAddress>
                  <Name/>
                  <Company>Simple Earth Hops</Company>
                  <Add1>210 S Lindsey Street</Add1>
                  <Add2/>
                  <City>Dodgeville</City>
                  <StateProv>WI</StateProv>
                  <PostalCode>53533</PostalCode>
                  <Country>US</Country>
                  <Phone/>
                  <Email/>
               </ShipFromAddress>
               <ShipToAddress>
                  <Name/>
                  <Company>Red Duck Beer</Company>
                  <Add1>101 Sample Street</Add1>
                  <Add2>Suite 202</Add2>
                  <City>Scarborough</City>
                  <StateProv>ON</StateProv>
                  <PostalCode>M1M1M1</PostalCode>
                  <Country>CA</Country>
                  <Phone/>
                  <Email>SampleAddress@Example.com</Email>
               </ShipToAddress>
               <DeclaredValue>23.68</DeclaredValue>
               <Currency>USD</Currency>
               <Packages>
                  <RequestPackage>
                     <PackageID>Pkg-0001a</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>2.354</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>10.1</DimL>
                     <DimW>13.2</DimW>
                     <DimH>1.3</DimH>
                  </RequestPackage>
                  <RequestPackage>
                     <PackageID>Pkg-0001b</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>4.25</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>0</DimL>
                     <DimW>0</DimW>
                     <DimH>0</DimH>
                  </RequestPackage>
               </Packages>
               <Items>
                  <RequestItem>
                     <SKU>DOC</SKU>
                     <CustomsDesc>Documents</CustomsDesc>
                     <ExtendedDesc>Misc. Documents</ExtendedDesc>
                     <Quantity>201</Quantity>
                     <TotalValue>1.00</TotalValue>
                     <Currency>CAD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode/>
                     <NAFTAEligible>false</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>false</Textile>
                  </RequestItem>
                  <RequestItem>
                     <SKU>Caps-2161</SKU>
                     <CustomsDesc>Bottle Caps</CustomsDesc>
                     <ExtendedDesc>Stainless Steel Bottle Caps</ExtendedDesc>
                     <Quantity>3000</Quantity>
                     <TotalValue>22.68</TotalValue>
                     <Currency>USD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode>39235010</HSCode>
                     <NAFTAEligible>false</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>false</Textile>
                  </RequestItem>
               </Items>
            </Request>
            <Packages>
               <ResponsePackage>
                  <PackageID>Pkg-0001a</PackageID>
                  <TrackingNumber>TST000006569</TrackingNumber>
                  <ShippingCharge>1.64680</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode/>
               </ResponsePackage>
               <ResponsePackage>
                  <PackageID>Pkg-0001b</PackageID>
                  <TrackingNumber>TST000006577</TrackingNumber>
                  <ShippingCharge>2.97320</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode/>
               </ResponsePackage>
            </Packages>
            <TotalShipping>4.62</TotalShipping>
            <Rates/>
         </AddOrderResult>
      </AddOrderResponse>
   </soap:Body>
</soap:Envelope>


Add LTL Order

Add LTL Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds an LTL order that will be included on a single LTL Shipment.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:AddLTLOrder>
              <pur:request>
              <pur:Credentials>
                  <pur:UserName>TestUser</pur:UserName>
                  <pur:Password>5VJrtqTa</pur:Password>
                  <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:OrderNumber>LTL-0001</pur:OrderNumber>
              <!--<ProNumber>000000042</ProNumber>-->
              <pur:Ref1>MyRef 001</pur:Ref1>
              <pur:Ref2>Note 001</pur:Ref2>
              <pur:ShipDate>2012-08-09T00:00:00</pur:ShipDate>
              <pur:ShipMethod>GROUND</pur:ShipMethod>
              <pur:SpecialServices>
                  <pur:string>NOTIFYCONSIGNEE</pur:string>
              </pur:SpecialServices>
              <pur:BillingOption>PREPAID</pur:BillingOption>
              <pur:LabelType>NONE</pur:LabelType>
              <pur:ShipFromAddress>
                 <pur:Name></pur:Name>
                 <pur:Company>Simple Earth Hops</pur:Company>
                 <pur:Add1>210 S Lindsey Street</pur:Add1>
                 <pur:Add2></pur:Add2>
                 <pur:City>Dodgeville</pur:City>
                 <pur:StateProv>WI</pur:StateProv>
                 <pur:PostalCode>53533</pur:PostalCode>
                 <pur:Country>US</pur:Country>
                 <pur:Phone></pur:Phone>
                 <pur:Email></pur:Email>
              </pur:ShipFromAddress>
              <pur:ShipToAddress>
                  <pur:Name></pur:Name>
                  <pur:Company>Red Duck Beer</pur:Company>
                  <pur:Add1>101 Sample Street</pur:Add1>
                  <pur:Add2>Suite 202</pur:Add2>
                  <pur:City>Scarborough</pur:City>
                  <pur:StateProv>ON</pur:StateProv>
                  <pur:PostalCode>M1M1M1</pur:PostalCode>
                  <pur:Country>CA</pur:Country>
                  <pur:Phone></pur:Phone>
                  <pur:Email>SampleAddress@Example.com</pur:Email>
              </pur:ShipToAddress>
              <pur:Packages>
                  <pur:RequestPackage>
                      <pur:PackageID>LPkg-0001a</pur:PackageID>
                      <pur:WeightUOM>LB</pur:WeightUOM>
                      <pur:Weight>2.354</pur:Weight>
                      <pur:DimensionUOM>IN</pur:DimensionUOM>
                      <pur:DimL>10.1</pur:DimL>
                      <pur:DimW>13.2</pur:DimW>
                      <pur:DimH>1.3</pur:DimH>
                  </pur:RequestPackage>
                  <pur:RequestPackage>
                      <pur:PackageID>LPkg-0001b</pur:PackageID>
                      <pur:WeightUOM>LB</pur:WeightUOM>
                      <pur:Weight>4.25</pur:Weight>
                      <pur:DimensionUOM>IN</pur:DimensionUOM>
                      <pur:DimL>0</pur:DimL>
                      <pur:DimW>0</pur:DimW>
                      <pur:DimH>0</pur:DimH>
                  </pur:RequestPackage>
              </pur:Packages>
              <pur:Items>
                  <pur:RequestItem>
                      <pur:SKU>DOC</pur:SKU>
                      <pur:CustomsDesc>Documents</pur:CustomsDesc>
                      <pur:ExtendedDesc>Misc. Documents</pur:ExtendedDesc>
                      <pur:Quantity>201</pur:Quantity>
                      <pur:TotalValue>1.00</pur:TotalValue>
                      <pur:Currency>CAD</pur:Currency>
                      <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                      <pur:HSCode></pur:HSCode>
                      <pur:NAFTAEligible>false</pur:NAFTAEligible>
                      <pur:FDAFood>false</pur:FDAFood>
                      <pur:Textile>false</pur:Textile>
                  </pur:RequestItem>
                  <pur:RequestItem>
                      <pur:SKU>Caps-2161</pur:SKU>
                      <pur:CustomsDesc>Bottle Caps</pur:CustomsDesc>
                      <pur:ExtendedDesc>Stainless Steel Bottle Caps</pur:ExtendedDesc>
                      <pur:Quantity>3000</pur:Quantity>
                      <pur:TotalValue>22.68</pur:TotalValue>
                      <pur:Currency>USD</pur:Currency>
                      <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                      <pur:HSCode>39235010</pur:HSCode>
                      <pur:NAFTAEligible>false</pur:NAFTAEligible>
                      <pur:FDAFood>false</pur:FDAFood>
                      <pur:Textile>false</pur:Textile>
                  </pur:RequestItem>
              </pur:Items>
              <pur:GrossWeight>10.0</pur:GrossWeight>
              <pur:Pallets>
                 <pur:LTLPalletRequest>
                    <pur:PalletNumber>1</pur:PalletNumber>
                 </pur:LTLPalletRequest>
              </pur:Pallets>
           </pur:request>
        </pur:AddLTLOrder>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:AddLTLOrder>
            <pur:request>
            <pur:Credentials>
                <pur:UserName>TestUser</pur:UserName>
                <pur:Password>5VJrtqTa</pur:Password>
                <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:OrderNumber>LTL-0001</pur:OrderNumber>
            <!--<ProNumber>000000042</ProNumber>-->
            <pur:Ref1>MyRef 001</pur:Ref1>
            <pur:Ref2>Note 001</pur:Ref2>
            <pur:ShipDate>2012-08-09T00:00:00</pur:ShipDate>
            <pur:ShipMethod>GROUND</pur:ShipMethod>
            <pur:SpecialServices>
                <pur:string>NOTIFYCONSIGNEE</pur:string>
            </pur:SpecialServices>
            <pur:BillingOption>PREPAID</pur:BillingOption>
            <pur:LabelType>NONE</pur:LabelType>
            <pur:ShipFromAddress>
               <pur:Name></pur:Name>
               <pur:Company>Simple Earth Hops</pur:Company>
               <pur:Add1>210 S Lindsey Street</pur:Add1>
               <pur:Add2></pur:Add2>
               <pur:City>Dodgeville</pur:City>
               <pur:StateProv>WI</pur:StateProv>
               <pur:PostalCode>53533</pur:PostalCode>
               <pur:Country>US</pur:Country>
               <pur:Phone></pur:Phone>
               <pur:Email></pur:Email>
            </pur:ShipFromAddress>
            <pur:ShipToAddress>
                <pur:Name></pur:Name>
                <pur:Company>Red Duck Beer</pur:Company>
                <pur:Add1>101 Sample Street</pur:Add1>
                <pur:Add2>Suite 202</pur:Add2>
                <pur:City>Scarborough</pur:City>
                <pur:StateProv>ON</pur:StateProv>
                <pur:PostalCode>M1M1M1</pur:PostalCode>
                <pur:Country>CA</pur:Country>
                <pur:Phone></pur:Phone>
                <pur:Email>SampleAddress@Example.com</pur:Email>
            </pur:ShipToAddress>
            <pur:Packages>
                <pur:RequestPackage>
                    <pur:PackageID>LPkg-0001a</pur:PackageID>
                    <pur:WeightUOM>LB</pur:WeightUOM>
                    <pur:Weight>2.354</pur:Weight>
                    <pur:DimensionUOM>IN</pur:DimensionUOM>
                    <pur:DimL>10.1</pur:DimL>
                    <pur:DimW>13.2</pur:DimW>
                    <pur:DimH>1.3</pur:DimH>
                </pur:RequestPackage>
                <pur:RequestPackage>
                    <pur:PackageID>LPkg-0001b</pur:PackageID>
                    <pur:WeightUOM>LB</pur:WeightUOM>
                    <pur:Weight>4.25</pur:Weight>
                    <pur:DimensionUOM>IN</pur:DimensionUOM>
                    <pur:DimL>0</pur:DimL>
                    <pur:DimW>0</pur:DimW>
                    <pur:DimH>0</pur:DimH>
                </pur:RequestPackage>
            </pur:Packages>
            <pur:Items>
                <pur:RequestItem>
                    <pur:SKU>DOC</pur:SKU>
                    <pur:CustomsDesc>Documents</pur:CustomsDesc>
                    <pur:ExtendedDesc>Misc. Documents</pur:ExtendedDesc>
                    <pur:Quantity>201</pur:Quantity>
                    <pur:TotalValue>1.00</pur:TotalValue>
                    <pur:Currency>CAD</pur:Currency>
                    <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                    <pur:HSCode></pur:HSCode>
                    <pur:NAFTAEligible>false</pur:NAFTAEligible>
                    <pur:FDAFood>false</pur:FDAFood>
                    <pur:Textile>false</pur:Textile>
                </pur:RequestItem>
                <pur:RequestItem>
                    <pur:SKU>Caps-2161</pur:SKU>
                    <pur:CustomsDesc>Bottle Caps</pur:CustomsDesc>
                    <pur:ExtendedDesc>Stainless Steel Bottle Caps</pur:ExtendedDesc>
                    <pur:Quantity>3000</pur:Quantity>
                    <pur:TotalValue>22.68</pur:TotalValue>
                    <pur:Currency>USD</pur:Currency>
                    <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                    <pur:HSCode>39235010</pur:HSCode>
                    <pur:NAFTAEligible>false</pur:NAFTAEligible>
                    <pur:FDAFood>false</pur:FDAFood>
                    <pur:Textile>false</pur:Textile>
                </pur:RequestItem>
            </pur:Items>
            <pur:GrossWeight>10.0</pur:GrossWeight>
            <pur:Pallets>
               <pur:LTLPalletRequest>
                  <pur:PalletNumber>1</pur:PalletNumber>
               </pur:LTLPalletRequest>
            </pur:Pallets>
         </pur:request>
      </pur:AddLTLOrder>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <AddLTLOrderResponse xmlns="http://PurolatorServices.com/">
           <AddLTLOrderResult>
              <Status>0</Status>
              <Request>
                 <OrderNumber>LTL-0001</OrderNumber>
                 <Ref1>MyRef 001</Ref1>
                 <Ref2>Note 001</Ref2>
                 <ShipDate>2012-08-09T00:00:00</ShipDate>
                 <ShipMethod>LTL</ShipMethod>
                 <SpecialServices>
                    <string>NOTIFYCONSIGNEE</string>
                 </SpecialServices>
                 <BillingOption>PREPAID</BillingOption>
                 <BillingAccount/>
                 <LabelType>NONE</LabelType>
                 <ShipFromAddress>
                    <Name/>
                    <Company>Simple Earth Hops</Company>
                    <Add1>210 S Lindsey Street</Add1>
                    <Add2/>
                    <City>Dodgeville</City>
                    <StateProv>WI</StateProv>
                    <PostalCode>53533</PostalCode>
                    <Country>US</Country>
                    <Phone/>
                    <Email/>
                 </ShipFromAddress>
                 <ShipToAddress>
                    <Name/>
                    <Company>Red Duck Beer</Company>
                    <Add1>101 Sample Street</Add1>
                    <Add2>Suite 202</Add2>
                    <City>Scarborough</City>
                    <StateProv>ON</StateProv>
                    <PostalCode>M1M1M1</PostalCode>
                    <Country>CA</Country>
                    <Phone/>
                    <Email>SampleAddress@Example.com</Email>
                 </ShipToAddress>
                 <DeclaredValue>0</DeclaredValue>
                 <Currency>USD</Currency>
                 <Packages>
                    <RequestPackage>
                       <PackageID>LPkg-0001a</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>2.354</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>10.1</DimL>
                       <DimW>13.2</DimW>
                       <DimH>1.3</DimH>
                    </RequestPackage>
                    <RequestPackage>
                       <PackageID>LPkg-0001b</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>4.25</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>0</DimL>
                       <DimW>0</DimW>
                       <DimH>0</DimH>
                    </RequestPackage>
                 </Packages>
                 <Items>
                    <RequestItem>
                       <SKU>DOC</SKU>
                       <CustomsDesc>Documents</CustomsDesc>
                       <ExtendedDesc>Misc. Documents</ExtendedDesc>
                       <Quantity>201</Quantity>
                       <TotalValue>1.00</TotalValue>
                       <Currency>CAD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode/>
                       <NAFTAEligible>false</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>false</Textile>
                    </RequestItem>
                    <RequestItem>
                       <SKU>Caps-2161</SKU>
                       <CustomsDesc>Bottle Caps</CustomsDesc>
                       <ExtendedDesc>Stainless Steel Bottle Caps</ExtendedDesc>
                       <Quantity>3000</Quantity>
                       <TotalValue>22.68</TotalValue>
                       <Currency>USD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode>39235010</HSCode>
                       <NAFTAEligible>false</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>false</Textile>
                    </RequestItem>
                 </Items>
              </Request>
              <Packages>
                 <ResponsePackage>
                    <PackageID>LPkg-0001a</PackageID>
                    <TrackingNumber>LTLTST000000018</TrackingNumber>
                    <ShippingCharge>0</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode/>
                 </ResponsePackage>
                 <ResponsePackage>
                    <PackageID>LPkg-0001b</PackageID>
                    <TrackingNumber>LTLTST000000026</TrackingNumber>
                    <ShippingCharge>0</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode/>
                 </ResponsePackage>
              </Packages>
              <TotalShipping>0</TotalShipping>
              <Rates/>
              <ProNumber>000000059</ProNumber>
              <Pallets>
                 <LTLPalletResponse>
                    <PalletNumber>1</PalletNumber>
                    <TrackingNumber>000000059</TrackingNumber>
                    <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO125,580^BY3^B3N,N,200,N,N^FD000000059^FS^FO0,810^A0N,33,43^FB800,,,C^FDPRO NUMBER: 000000059^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
                 </LTLPalletResponse>
                 <LTLPalletResponse>
                    <PalletNumber>1</PalletNumber>
                    <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD2 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO0,590^A0N,33,43^FDPRO NUMBER: 000000059^FS^FO210,650^BY4^BCN,200,N,N,N,N^FD^FS^FO0,885^A0N,33,43^FB800,,,C^FDPIN NUMBER: ^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
                 </LTLPalletResponse>
              </Pallets>
           </AddLTLOrderResult>
        </AddLTLOrderResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <AddLTLOrderResponse xmlns="http://PurolatorServices.com/">
         <AddLTLOrderResult>
            <Status>0</Status>
            <Request>
               <OrderNumber>LTL-0001</OrderNumber>
               <Ref1>MyRef 001</Ref1>
               <Ref2>Note 001</Ref2>
               <ShipDate>2012-08-09T00:00:00</ShipDate>
               <ShipMethod>LTL</ShipMethod>
               <SpecialServices>
                  <string>NOTIFYCONSIGNEE</string>
               </SpecialServices>
               <BillingOption>PREPAID</BillingOption>
               <BillingAccount/>
               <LabelType>NONE</LabelType>
               <ShipFromAddress>
                  <Name/>
                  <Company>Simple Earth Hops</Company>
                  <Add1>210 S Lindsey Street</Add1>
                  <Add2/>
                  <City>Dodgeville</City>
                  <StateProv>WI</StateProv>
                  <PostalCode>53533</PostalCode>
                  <Country>US</Country>
                  <Phone/>
                  <Email/>
               </ShipFromAddress>
               <ShipToAddress>
                  <Name/>
                  <Company>Red Duck Beer</Company>
                  <Add1>101 Sample Street</Add1>
                  <Add2>Suite 202</Add2>
                  <City>Scarborough</City>
                  <StateProv>ON</StateProv>
                  <PostalCode>M1M1M1</PostalCode>
                  <Country>CA</Country>
                  <Phone/>
                  <Email>SampleAddress@Example.com</Email>
               </ShipToAddress>
               <DeclaredValue>0</DeclaredValue>
               <Currency>USD</Currency>
               <Packages>
                  <RequestPackage>
                     <PackageID>LPkg-0001a</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>2.354</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>10.1</DimL>
                     <DimW>13.2</DimW>
                     <DimH>1.3</DimH>
                  </RequestPackage>
                  <RequestPackage>
                     <PackageID>LPkg-0001b</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>4.25</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>0</DimL>
                     <DimW>0</DimW>
                     <DimH>0</DimH>
                  </RequestPackage>
               </Packages>
               <Items>
                  <RequestItem>
                     <SKU>DOC</SKU>
                     <CustomsDesc>Documents</CustomsDesc>
                     <ExtendedDesc>Misc. Documents</ExtendedDesc>
                     <Quantity>201</Quantity>
                     <TotalValue>1.00</TotalValue>
                     <Currency>CAD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode/>
                     <NAFTAEligible>false</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>false</Textile>
                  </RequestItem>
                  <RequestItem>
                     <SKU>Caps-2161</SKU>
                     <CustomsDesc>Bottle Caps</CustomsDesc>
                     <ExtendedDesc>Stainless Steel Bottle Caps</ExtendedDesc>
                     <Quantity>3000</Quantity>
                     <TotalValue>22.68</TotalValue>
                     <Currency>USD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode>39235010</HSCode>
                     <NAFTAEligible>false</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>false</Textile>
                  </RequestItem>
               </Items>
            </Request>
            <Packages>
               <ResponsePackage>
                  <PackageID>LPkg-0001a</PackageID>
                  <TrackingNumber>LTLTST000000018</TrackingNumber>
                  <ShippingCharge>0</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode/>
               </ResponsePackage>
               <ResponsePackage>
                  <PackageID>LPkg-0001b</PackageID>
                  <TrackingNumber>LTLTST000000026</TrackingNumber>
                  <ShippingCharge>0</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode/>
               </ResponsePackage>
            </Packages>
            <TotalShipping>0</TotalShipping>
            <Rates/>
            <ProNumber>000000059</ProNumber>
            <Pallets>
               <LTLPalletResponse>
                  <PalletNumber>1</PalletNumber>
                  <TrackingNumber>000000059</TrackingNumber>
                  <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO125,580^BY3^B3N,N,200,N,N^FD000000059^FS^FO0,810^A0N,33,43^FB800,,,C^FDPRO NUMBER: 000000059^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
               </LTLPalletResponse>
               <LTLPalletResponse>
                  <PalletNumber>1</PalletNumber>
                  <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD2 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO0,590^A0N,33,43^FDPRO NUMBER: 000000059^FS^FO210,650^BY4^BCN,200,N,N,N,N^FD^FS^FO0,885^A0N,33,43^FB800,,,C^FDPIN NUMBER: ^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
               </LTLPalletResponse>
            </Pallets>
         </AddLTLOrderResult>
      </AddLTLOrderResponse>
   </soap:Body>
</soap:Envelope>


Add Package

Add Package Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds a package to an existing order.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
          <pur:AddPackage>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:OrderNumber>Test-0001</pur:OrderNumber>
                  <pur:LabelType>ZPL</pur:LabelType>
                  <pur:Packages>
                      <pur:RequestPackage>
                          <pur:PackageID>Pkg-0001c</pur:PackageID>
                          <pur:WeightUOM>KG</pur:WeightUOM>
                          <pur:Weight>0.25</pur:Weight>
                          <pur:DimensionUOM>CM</pur:DimensionUOM>
                          <pur:DimL>0.0</pur:DimL>
                          <pur:DimW>0.0</pur:DimW>
                          <pur:DimH>0.0</pur:DimH>
                      </pur:RequestPackage>
                  </pur:Packages>
              </pur:request>
          </pur:AddPackage>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
        <pur:AddPackage>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:OrderNumber>Test-0001</pur:OrderNumber>
                <pur:LabelType>ZPL</pur:LabelType>
                <pur:Packages>
                    <pur:RequestPackage>
                        <pur:PackageID>Pkg-0001c</pur:PackageID>
                        <pur:WeightUOM>KG</pur:WeightUOM>
                        <pur:Weight>0.25</pur:Weight>
                        <pur:DimensionUOM>CM</pur:DimensionUOM>
                        <pur:DimL>0.0</pur:DimL>
                        <pur:DimW>0.0</pur:DimW>
                        <pur:DimH>0.0</pur:DimH>
                    </pur:RequestPackage>
                </pur:Packages>
            </pur:request>
        </pur:AddPackage>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <AddPackageResponse xmlns="http://PurolatorServices.com/">
           <AddPackageResult>
              <Status>0</Status>
              <Request>
                 <OrderNumber>Test-0001</OrderNumber>
                 <LabelType>ZPL</LabelType>
                 <Packages>
                    <RequestPackage>
                       <PackageID>Pkg-0001c</PackageID>
                       <WeightUOM>KG</WeightUOM>
                       <Weight>0.25</Weight>
                       <DimensionUOM>CM</DimensionUOM>
                       <DimL>0.0</DimL>
                       <DimW>0.0</DimW>
                       <DimH>0.0</DimH>
                    </RequestPackage>
                 </Packages>
              </Request>
              <Packages>
                 <ResponsePackage>
                    <PackageID>Pkg-0001c</PackageID>
                    <TrackingNumber>TST000006585</TrackingNumber>
                    <ShippingCharge>0.16861</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode/>
                    <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO8,73^GB18,120,23^FS^FO12,87^A0B,20,23^FR^FDFROM/DE^FS^FO43,70^A0N,22,23^FDSimple Earth Hops^FS^FO43,93^A0N,22,23^FD210 S Lindsey Street^FS^FO43,116^A0N,22,23^FDDodgeville, WI   53533^FS^FO40,187^GB65,25,25^FS^FO40,191^A0N,22,25^FB65,,,C^FR^FDRef:^FS^FO110,191^A0N,22,23^FDMyRef 001^FS^FO8,228^GB18,80,23^FS^FO12,242^A0B,20,23^FR^FDTO/A^FS^FO43,225^A0N,26,27^FDRed Duck Beer^FS^FO43,251^A0N,26,27^FD101 Sample Street^FS^FO43,277^A0N,26,27^FDSuite 202^FS^FO41,303^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO4,413^GB102,26,26^FS^FO4,417^A0N,25,27^FB102,,,C^FR^FDNOTE:^FS^FO111,416^A0N,28,29^FDNote 001^FS^FO0,445^A0N,17,19^FB800,,,C^FDPurolator's published terms and conditions of service apply - see www.purolatorinternational.com.^FS^FO0,463^A0N,17,19^FB800,,,C^FH^FDLes Modalit_82s et conditions de service publi_82es de Purolator s'appliquent -^FS^FO0,481^A0N,17,19^FB800,,,C^FDvoir www.purolatorinternational.com^FS^FO445,120^XGR:OSNR.GRF,1,1^FS^FO625,340^A0N,117,125^FD^FS^FO4,503^GB102,26,26^FS^FO0,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD09 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDPIECES^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 1^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD1.00 lb^FS^FO55,560^BY3^BCN,250,N,N,N,N^FD>;1311311312019200000065850000100000^FS^FO0,820^A0N,33,43^FB800,,,C^FDPUROLATOR PIN: TST000006585^FS^FO540,880^A0N,117,125^FD52^FS^FO450,1150^A0N,22,23^FDSD: 2012/07/30 - OLS 2^FS^FO400,60^A0N,36,36^FDUNDELIVERABLE RETURN^FS^FO440,97^A0N,36,36^FDTO PCL LOGISTICS^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
                 </ResponsePackage>
              </Packages>
              <TotalShipping>4.62</TotalShipping>
           </AddPackageResult>
        </AddPackageResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <AddPackageResponse xmlns="http://PurolatorServices.com/">
         <AddPackageResult>
            <Status>0</Status>
            <Request>
               <OrderNumber>Test-0001</OrderNumber>
               <LabelType>ZPL</LabelType>
               <Packages>
                  <RequestPackage>
                     <PackageID>Pkg-0001c</PackageID>
                     <WeightUOM>KG</WeightUOM>
                     <Weight>0.25</Weight>
                     <DimensionUOM>CM</DimensionUOM>
                     <DimL>0.0</DimL>
                     <DimW>0.0</DimW>
                     <DimH>0.0</DimH>
                  </RequestPackage>
               </Packages>
            </Request>
            <Packages>
               <ResponsePackage>
                  <PackageID>Pkg-0001c</PackageID>
                  <TrackingNumber>TST000006585</TrackingNumber>
                  <ShippingCharge>0.16861</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode/>
                  <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO8,73^GB18,120,23^FS^FO12,87^A0B,20,23^FR^FDFROM/DE^FS^FO43,70^A0N,22,23^FDSimple Earth Hops^FS^FO43,93^A0N,22,23^FD210 S Lindsey Street^FS^FO43,116^A0N,22,23^FDDodgeville, WI   53533^FS^FO40,187^GB65,25,25^FS^FO40,191^A0N,22,25^FB65,,,C^FR^FDRef:^FS^FO110,191^A0N,22,23^FDMyRef 001^FS^FO8,228^GB18,80,23^FS^FO12,242^A0B,20,23^FR^FDTO/A^FS^FO43,225^A0N,26,27^FDRed Duck Beer^FS^FO43,251^A0N,26,27^FD101 Sample Street^FS^FO43,277^A0N,26,27^FDSuite 202^FS^FO41,303^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO4,413^GB102,26,26^FS^FO4,417^A0N,25,27^FB102,,,C^FR^FDNOTE:^FS^FO111,416^A0N,28,29^FDNote 001^FS^FO0,445^A0N,17,19^FB800,,,C^FDPurolator's published terms and conditions of service apply - see www.purolatorinternational.com.^FS^FO0,463^A0N,17,19^FB800,,,C^FH^FDLes Modalit_82s et conditions de service publi_82es de Purolator s'appliquent -^FS^FO0,481^A0N,17,19^FB800,,,C^FDvoir www.purolatorinternational.com^FS^FO445,120^XGR:OSNR.GRF,1,1^FS^FO625,340^A0N,117,125^FD^FS^FO4,503^GB102,26,26^FS^FO0,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD09 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDPIECES^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 1^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD1.00 lb^FS^FO55,560^BY3^BCN,250,N,N,N,N^FD>;1311311312019200000065850000100000^FS^FO0,820^A0N,33,43^FB800,,,C^FDPUROLATOR PIN: TST000006585^FS^FO540,880^A0N,117,125^FD52^FS^FO450,1150^A0N,22,23^FDSD: 2012/07/30 - OLS 2^FS^FO400,60^A0N,36,36^FDUNDELIVERABLE RETURN^FS^FO440,97^A0N,36,36^FDTO PCL LOGISTICS^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
               </ResponsePackage>
            </Packages>
            <TotalShipping>4.62</TotalShipping>
         </AddPackageResult>
      </AddPackageResponse>
   </soap:Body>
</soap:Envelope>


Add Item

Add Item Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds an item to an existing order.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
          <pur:AddItem>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:OrderNumber>Test-0001</pur:OrderNumber>
                  <pur:Items>
                      <pur:RequestItem>
                          <pur:SKU>TShirtMD-1654</pur:SKU>
                          <pur:CustomsDesc>Clothing</pur:CustomsDesc>
                          <pur:ExtendedDesc>TShirt With Logo</pur:ExtendedDesc>
                          <pur:Quantity>1</pur:Quantity>
                          <pur:TotalValue>19.99</pur:TotalValue>
                          <pur:Currency>USD</pur:Currency>
                          <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                          <pur:HSCode/>
                          <pur:NAFTAEligible>true</pur:NAFTAEligible>
                          <pur:FDAFood>false</pur:FDAFood>
                          <pur:Textile>true</pur:Textile>
                      </pur:RequestItem>
              </pur:Items>
           </pur:request>
        </pur:AddItem>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
        <pur:AddItem>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:OrderNumber>Test-0001</pur:OrderNumber>
                <pur:Items>
                    <pur:RequestItem>
                        <pur:SKU>TShirtMD-1654</pur:SKU>
                        <pur:CustomsDesc>Clothing</pur:CustomsDesc>
                        <pur:ExtendedDesc>TShirt With Logo</pur:ExtendedDesc>
                        <pur:Quantity>1</pur:Quantity>
                        <pur:TotalValue>19.99</pur:TotalValue>
                        <pur:Currency>USD</pur:Currency>
                        <pur:CountryOfOrigin>US</pur:CountryOfOrigin>
                        <pur:HSCode/>
                        <pur:NAFTAEligible>true</pur:NAFTAEligible>
                        <pur:FDAFood>false</pur:FDAFood>
                        <pur:Textile>true</pur:Textile>
                    </pur:RequestItem>
            </pur:Items>
         </pur:request>
      </pur:AddItem>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <AddItemResponse xmlns="http://PurolatorServices.com/">
           <AddItemResult>
              <Status>0</Status>
              <Request>
                 <OrderNumber>Test-0001</OrderNumber>
                 <Items>
                    <RequestItem>
                       <SKU>TShirtMD-1654</SKU>
                       <CustomsDesc>Clothing</CustomsDesc>
                       <ExtendedDesc>TShirt With Logo</ExtendedDesc>
                       <Quantity>1</Quantity>
                       <TotalValue>19.99</TotalValue>
                       <Currency>USD</Currency>
                       <CountryOfOrigin>US</CountryOfOrigin>
                       <HSCode/>
                       <NAFTAEligible>true</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>true</Textile>
                    </RequestItem>
                 </Items>
              </Request>
           </AddItemResult>
        </AddItemResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <AddItemResponse xmlns="http://PurolatorServices.com/">
         <AddItemResult>
            <Status>0</Status>
            <Request>
               <OrderNumber>Test-0001</OrderNumber>
               <Items>
                  <RequestItem>
                     <SKU>TShirtMD-1654</SKU>
                     <CustomsDesc>Clothing</CustomsDesc>
                     <ExtendedDesc>TShirt With Logo</ExtendedDesc>
                     <Quantity>1</Quantity>
                     <TotalValue>19.99</TotalValue>
                     <Currency>USD</Currency>
                     <CountryOfOrigin>US</CountryOfOrigin>
                     <HSCode/>
                     <NAFTAEligible>true</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>true</Textile>
                  </RequestItem>
               </Items>
            </Request>
         </AddItemResult>
      </AddItemResponse>
   </soap:Body>
</soap:Envelope>


Update Order

Update Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Updates values in an existing order.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:UpdateOrder>
           <pur:request>
              <pur:Credentials>
                 <pur:UserName>TestUser</pur:UserName>
                 <pur:Password>5VJrtqTa</pur:Password>
                 <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:UpdateOrders>
                 <pur:UpdateOrderInfo>
                    <pur:OrderNumber>Test-0001</pur:OrderNumber>
                    <pur:UpdateType>PONumber</pur:UpdateType>
                    <pur:UpdateValue>PO-216874-1</pur:UpdateValue>
                 </pur:UpdateOrderInfo>
              </pur:UpdateOrders>
           </pur:request>
        </pur:UpdateOrder>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:UpdateOrder>
         <pur:request>
            <pur:Credentials>
               <pur:UserName>TestUser</pur:UserName>
               <pur:Password>5VJrtqTa</pur:Password>
               <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:UpdateOrders>
               <pur:UpdateOrderInfo>
                  <pur:OrderNumber>Test-0001</pur:OrderNumber>
                  <pur:UpdateType>PONumber</pur:UpdateType>
                  <pur:UpdateValue>PO-216874-1</pur:UpdateValue>
               </pur:UpdateOrderInfo>
            </pur:UpdateOrders>
         </pur:request>
      </pur:UpdateOrder>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <UpdateOrderResponse xmlns="http://PurolatorServices.com/">
           <UpdateOrderResult>
              <Status>0</Status>
              <Request>
                 <UpdateOrders>
                    <UpdateOrderInfo>
                       <OrderNumber>Test-0001</OrderNumber>
                       <UpdateType>PONumber</UpdateType>
                       <UpdateValue>PO-216874-1</UpdateValue>
                    </UpdateOrderInfo>
                 </UpdateOrders>
              </Request>
           </UpdateOrderResult>
        </UpdateOrderResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <UpdateOrderResponse xmlns="http://PurolatorServices.com/">
         <UpdateOrderResult>
            <Status>0</Status>
            <Request>
               <UpdateOrders>
                  <UpdateOrderInfo>
                     <OrderNumber>Test-0001</OrderNumber>
                     <UpdateType>PONumber</UpdateType>
                     <UpdateValue>PO-216874-1</UpdateValue>
                  </UpdateOrderInfo>
               </UpdateOrders>
            </Request>
         </UpdateOrderResult>
      </UpdateOrderResponse>
   </soap:Body>
</soap:Envelope>


Get Order Status

Get Order Status Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Finds the order with the specified order number and returns an OrderResponse.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:GetOrderStatus>
              <pur:credentials>
                  <pur:UserName>TestUser</pur:UserName>
                  <pur:Password>5VJrtqTa</pur:Password>
                  <pur:ClientID>0000000</pur:ClientID>
              </pur:credentials>
              <pur:orderNumber>Test-0001</pur:orderNumber>
          </pur:GetOrderStatus>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:GetOrderStatus>
            <pur:credentials>
                <pur:UserName>TestUser</pur:UserName>
                <pur:Password>5VJrtqTa</pur:Password>
                <pur:ClientID>0000000</pur:ClientID>
            </pur:credentials>
            <pur:orderNumber>Test-0001</pur:orderNumber>
        </pur:GetOrderStatus>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <GetOrderStatusResponse xmlns="http://PurolatorServices.com/">
           <GetOrderStatusResult>
              <Status>0</Status>
              <Request>
                 <OrderNumber>Test-0001</OrderNumber>
                 <Ref1>MyRef 001</Ref1>
                 <Ref2>Note 001</Ref2>
                 <ShipDate>2012-08-09T00:00:00</ShipDate>
                 <ShipMethod>GROUND</ShipMethod>
                 <SpecialServices>
                    <string>OSNR</string>
                    <string>NOTIFYCONSIGNEE</string>
                 </SpecialServices>
                 <BillingOption>PREPAID</BillingOption>
                 <BillingAccount/>
                 <LabelType>NONE</LabelType>
                 <ShipFromAddress>
                    <Name/>
                    <Company>Simple Earth Hops</Company>
                    <Add1>210 S Lindsey Street</Add1>
                    <Add2/>
                    <City>Dodgeville</City>
                    <StateProv>WI</StateProv>
                    <PostalCode>53533</PostalCode>
                    <Country>US</Country>
                    <Phone/>
                    <Email/>
                 </ShipFromAddress>
                 <ShipToAddress>
                    <Name/>
                    <Company>Red Duck Beer</Company>
                    <Add1>101 Sample Street</Add1>
                    <Add2>Suite 202</Add2>
                    <City>Scarborough</City>
                    <StateProv>ON</StateProv>
                    <PostalCode>M1M1M1</PostalCode>
                    <Country>CA</Country>
                    <Phone/>
                    <Email>SampleAddress@Example.com</Email>
                 </ShipToAddress>
                 <DeclaredValue>23.6800</DeclaredValue>
                 <Currency>USD</Currency>
                 <Packages>
                    <RequestPackage>
                       <PackageID>Pkg-0001a</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>2.35</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>13.20</DimL>
                       <DimW>10.10</DimW>
                       <DimH>1.30</DimH>
                    </RequestPackage>
                    <RequestPackage>
                       <PackageID>Pkg-0001b</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>4.25</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>0.00</DimL>
                       <DimW>0.00</DimW>
                       <DimH>0.00</DimH>
                    </RequestPackage>
                    <RequestPackage>
                       <PackageID>Pkg-0001c</PackageID>
                       <WeightUOM>LB</WeightUOM>
                       <Weight>0.55</Weight>
                       <DimensionUOM>IN</DimensionUOM>
                       <DimL>0.00</DimL>
                       <DimW>0.00</DimW>
                       <DimH>0.00</DimH>
                    </RequestPackage>
                 </Packages>
                 <Items>
                    <RequestItem>
                       <SKU>TShirtMD-1654</SKU>
                       <CustomsDesc>Clothing</CustomsDesc>
                       <ExtendedDesc>TShirt With Logo</ExtendedDesc>
                       <Quantity>1</Quantity>
                       <TotalValue>19.9900</TotalValue>
                       <Currency>USD</Currency>
                       <CountryOfOrigin>United States</CountryOfOrigin>
                       <HSCode/>
                       <NAFTAEligible>true</NAFTAEligible>
                       <FDAFood>false</FDAFood>
                       <Textile>true</Textile>
                    </RequestItem>
                 </Items>
              </Request>
              <Packages>
                 <ResponsePackage>
                    <PackageID>Pkg-0001a</PackageID>
                    <TrackingNumber>TST000006569</TrackingNumber>
                    <ShippingCharge>1.6468</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode>YYZ</AirportCode>
                 </ResponsePackage>
                 <ResponsePackage>
                    <PackageID>Pkg-0001b</PackageID>
                    <TrackingNumber>TST000006577</TrackingNumber>
                    <ShippingCharge>2.9732</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode>YYZ</AirportCode>
                 </ResponsePackage>
                 <ResponsePackage>
                    <PackageID>Pkg-0001c</PackageID>
                    <TrackingNumber>TST000006585</TrackingNumber>
                    <ShippingCharge>0.1686</ShippingCharge>
                    <Unicode>52</Unicode>
                    <AirportCode>YYZ</AirportCode>
                 </ResponsePackage>
              </Packages>
              <TotalShipping>4.6200</TotalShipping>
           </GetOrderStatusResult>
        </GetOrderStatusResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <GetOrderStatusResponse xmlns="http://PurolatorServices.com/">
         <GetOrderStatusResult>
            <Status>0</Status>
            <Request>
               <OrderNumber>Test-0001</OrderNumber>
               <Ref1>MyRef 001</Ref1>
               <Ref2>Note 001</Ref2>
               <ShipDate>2012-08-09T00:00:00</ShipDate>
               <ShipMethod>GROUND</ShipMethod>
               <SpecialServices>
                  <string>OSNR</string>
                  <string>NOTIFYCONSIGNEE</string>
               </SpecialServices>
               <BillingOption>PREPAID</BillingOption>
               <BillingAccount/>
               <LabelType>NONE</LabelType>
               <ShipFromAddress>
                  <Name/>
                  <Company>Simple Earth Hops</Company>
                  <Add1>210 S Lindsey Street</Add1>
                  <Add2/>
                  <City>Dodgeville</City>
                  <StateProv>WI</StateProv>
                  <PostalCode>53533</PostalCode>
                  <Country>US</Country>
                  <Phone/>
                  <Email/>
               </ShipFromAddress>
               <ShipToAddress>
                  <Name/>
                  <Company>Red Duck Beer</Company>
                  <Add1>101 Sample Street</Add1>
                  <Add2>Suite 202</Add2>
                  <City>Scarborough</City>
                  <StateProv>ON</StateProv>
                  <PostalCode>M1M1M1</PostalCode>
                  <Country>CA</Country>
                  <Phone/>
                  <Email>SampleAddress@Example.com</Email>
               </ShipToAddress>
               <DeclaredValue>23.6800</DeclaredValue>
               <Currency>USD</Currency>
               <Packages>
                  <RequestPackage>
                     <PackageID>Pkg-0001a</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>2.35</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>13.20</DimL>
                     <DimW>10.10</DimW>
                     <DimH>1.30</DimH>
                  </RequestPackage>
                  <RequestPackage>
                     <PackageID>Pkg-0001b</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>4.25</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>0.00</DimL>
                     <DimW>0.00</DimW>
                     <DimH>0.00</DimH>
                  </RequestPackage>
                  <RequestPackage>
                     <PackageID>Pkg-0001c</PackageID>
                     <WeightUOM>LB</WeightUOM>
                     <Weight>0.55</Weight>
                     <DimensionUOM>IN</DimensionUOM>
                     <DimL>0.00</DimL>
                     <DimW>0.00</DimW>
                     <DimH>0.00</DimH>
                  </RequestPackage>
               </Packages>
               <Items>
                  <RequestItem>
                     <SKU>TShirtMD-1654</SKU>
                     <CustomsDesc>Clothing</CustomsDesc>
                     <ExtendedDesc>TShirt With Logo</ExtendedDesc>
                     <Quantity>1</Quantity>
                     <TotalValue>19.9900</TotalValue>
                     <Currency>USD</Currency>
                     <CountryOfOrigin>United States</CountryOfOrigin>
                     <HSCode/>
                     <NAFTAEligible>true</NAFTAEligible>
                     <FDAFood>false</FDAFood>
                     <Textile>true</Textile>
                  </RequestItem>
               </Items>
            </Request>
            <Packages>
               <ResponsePackage>
                  <PackageID>Pkg-0001a</PackageID>
                  <TrackingNumber>TST000006569</TrackingNumber>
                  <ShippingCharge>1.6468</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode>YYZ</AirportCode>
               </ResponsePackage>
               <ResponsePackage>
                  <PackageID>Pkg-0001b</PackageID>
                  <TrackingNumber>TST000006577</TrackingNumber>
                  <ShippingCharge>2.9732</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode>YYZ</AirportCode>
               </ResponsePackage>
               <ResponsePackage>
                  <PackageID>Pkg-0001c</PackageID>
                  <TrackingNumber>TST000006585</TrackingNumber>
                  <ShippingCharge>0.1686</ShippingCharge>
                  <Unicode>52</Unicode>
                  <AirportCode>YYZ</AirportCode>
               </ResponsePackage>
            </Packages>
            <TotalShipping>4.6200</TotalShipping>
         </GetOrderStatusResult>
      </GetOrderStatusResponse>
   </soap:Body>
</soap:Envelope>


Get Label

Get Label Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets a Package label either as ZPL code or as a Base64 encoded image.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:GetLabel>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:OrderNumber/>
                  <pur:PackageID>Pkg-0001a</pur:PackageID>
                  <pur:TrackingNumber/>
                  <pur:LabelType>ZPL</pur:LabelType>
              </pur:request>
          </pur:GetLabel>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:GetLabel>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:OrderNumber/>
                <pur:PackageID>Pkg-0001a</pur:PackageID>
                <pur:TrackingNumber/>
                <pur:LabelType>ZPL</pur:LabelType>
            </pur:request>
        </pur:GetLabel>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <GetLabelResponse xmlns="http://PurolatorServices.com/">
           <GetLabelResult>
              <Status>0</Status>
              <Package>
                 <PackageID>Pkg-0001a</PackageID>
                 <TrackingNumber>TST000006569</TrackingNumber>
                 <ShippingCharge>0</ShippingCharge>
                 <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO8,73^GB18,120,23^FS^FO12,87^A0B,20,23^FR^FDFROM/DE^FS^FO43,70^A0N,22,23^FDSimple Earth Hops^FS^FO43,93^A0N,22,23^FD210 S Lindsey Street^FS^FO43,116^A0N,22,23^FDDodgeville, WI   53533^FS^FO40,187^GB65,25,25^FS^FO40,191^A0N,22,25^FB65,,,C^FR^FDRef:^FS^FO110,191^A0N,22,23^FDMyRef 001^FS^FO8,228^GB18,80,23^FS^FO12,242^A0B,20,23^FR^FDTO/A^FS^FO43,225^A0N,26,27^FDRed Duck Beer^FS^FO43,251^A0N,26,27^FD101 Sample Street^FS^FO43,277^A0N,26,27^FDSuite 202^FS^FO41,303^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO4,413^GB102,26,26^FS^FO4,417^A0N,25,27^FB102,,,C^FR^FDNOTE:^FS^FO111,416^A0N,28,29^FDNote 001^FS^FO0,445^A0N,17,19^FB800,,,C^FDPurolator's published terms and conditions of service apply - see www.purolatorinternational.com.^FS^FO0,463^A0N,17,19^FB800,,,C^FH^FDLes Modalit_82s et conditions de service publi_82es de Purolator s'appliquent -^FS^FO0,481^A0N,17,19^FB800,,,C^FDvoir www.purolatorinternational.com^FS^FO445,120^XGR:OSNR.GRF,1,1^FS^FO625,340^A0N,117,125^FD^FS^FO4,503^GB102,26,26^FS^FO0,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD09 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDPIECES^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 3^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD2.35 lb^FS^FO55,560^BY3^BCN,250,N,N,N,N^FD>;1311311312019200000065690000100000^FS^FO0,820^A0N,33,43^FB800,,,C^FDPUROLATOR PIN: TST000006569^FS^FO540,880^A0N,117,125^FD52^FS^FO450,1150^A0N,22,23^FDSD: 2012/07/30 - OLS 2^FS^FO400,60^A0N,36,36^FDUNDELIVERABLE RETURN^FS^FO440,97^A0N,36,36^FDTO PCL LOGISTICS^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
              </Package>
           </GetLabelResult>
        </GetLabelResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <GetLabelResponse xmlns="http://PurolatorServices.com/">
         <GetLabelResult>
            <Status>0</Status>
            <Package>
               <PackageID>Pkg-0001a</PackageID>
               <TrackingNumber>TST000006569</TrackingNumber>
               <ShippingCharge>0</ShippingCharge>
               <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO8,73^GB18,120,23^FS^FO12,87^A0B,20,23^FR^FDFROM/DE^FS^FO43,70^A0N,22,23^FDSimple Earth Hops^FS^FO43,93^A0N,22,23^FD210 S Lindsey Street^FS^FO43,116^A0N,22,23^FDDodgeville, WI   53533^FS^FO40,187^GB65,25,25^FS^FO40,191^A0N,22,25^FB65,,,C^FR^FDRef:^FS^FO110,191^A0N,22,23^FDMyRef 001^FS^FO8,228^GB18,80,23^FS^FO12,242^A0B,20,23^FR^FDTO/A^FS^FO43,225^A0N,26,27^FDRed Duck Beer^FS^FO43,251^A0N,26,27^FD101 Sample Street^FS^FO43,277^A0N,26,27^FDSuite 202^FS^FO41,303^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO4,413^GB102,26,26^FS^FO4,417^A0N,25,27^FB102,,,C^FR^FDNOTE:^FS^FO111,416^A0N,28,29^FDNote 001^FS^FO0,445^A0N,17,19^FB800,,,C^FDPurolator's published terms and conditions of service apply - see www.purolatorinternational.com.^FS^FO0,463^A0N,17,19^FB800,,,C^FH^FDLes Modalit_82s et conditions de service publi_82es de Purolator s'appliquent -^FS^FO0,481^A0N,17,19^FB800,,,C^FDvoir www.purolatorinternational.com^FS^FO445,120^XGR:OSNR.GRF,1,1^FS^FO625,340^A0N,117,125^FD^FS^FO4,503^GB102,26,26^FS^FO0,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD09 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDPIECES^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 3^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD2.35 lb^FS^FO55,560^BY3^BCN,250,N,N,N,N^FD>;1311311312019200000065690000100000^FS^FO0,820^A0N,33,43^FB800,,,C^FDPUROLATOR PIN: TST000006569^FS^FO540,880^A0N,117,125^FD52^FS^FO450,1150^A0N,22,23^FDSD: 2012/07/30 - OLS 2^FS^FO400,60^A0N,36,36^FDUNDELIVERABLE RETURN^FS^FO440,97^A0N,36,36^FDTO PCL LOGISTICS^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
            </Package>
         </GetLabelResult>
      </GetLabelResponse>
   </soap:Body>
</soap:Envelope>


Get ZPL Initialization Images

Get ZPL Initialization Images Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets ZPL code to load purolator specific images into a ZPL printer.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:GetZPLInitializationImages>
           <pur:request>
              <pur:UserName>TestUser</pur:UserName>
              <pur:Password>5VJrtqTa</pur:Password>
              <pur:ClientID>0000000</pur:ClientID>
           </pur:request>
        </pur:GetZPLInitializationImages>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:GetZPLInitializationImages>
         <pur:request>
            <pur:UserName>TestUser</pur:UserName>
            <pur:Password>5VJrtqTa</pur:Password>
            <pur:ClientID>0000000</pur:ClientID>
         </pur:request>
      </pur:GetZPLInitializationImages>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <GetZPLInitializationImagesResponse xmlns="http://PurolatorServices.com/">
           <GetZPLInitializationImagesResult>
              <Status>0</Status>
              <ZPLCode>~DGR:PCLLOGO,02295,045,000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  000000000001E07FFFF003FFFC0000000000000000000000000000000000000000000000000000000000000000
  00000000000FE07FFFE003FFFFF000000000000000000000000000000000000000000000000000000000000000
  00000000001FC0FFFFE007FFFFFE00000000000000000000000000000000000000000000000000000000000000
  00000000003FC0FFFFC007FFFFFF00000000000000000000000000000000000000000000000000000000000000
  00000000007F81FFFFC00FFFFFFF80000000000000000000000000003FE000000000007FC00000000000000000
  0000000000FF81FFFF800FFFFFFF80000000000000000000000000007FE00000000000FF800000000000000000
  0000000000FF03FFFF801FFFFFFFC000000000000000000000000000FFC00000000001FF800000000000000000
  0000000000FF03FFFF001FFC3FFFC000000000000000000000000001FFC00000000003FF000000000000000000
  0000000001FE07FFFF003FF803FFC000000000000000000000000003FF800000000007FF000000000000000000
  0000000001FE07FFFF003FF801FFC000000000000000000000000003FF800000000007FF000000000000000000
  0000000003FC07FFFE007FF001FFC000000000000000000000000003FF00000000000FFE000000000000000000
  0000000003FC0FFFFE007FF001FFC000000000000000000000000007FF00000000000FFE000000000000000000
  0000000007F80FFFFC00FFE001FF8000000000000000000000000007FE00000000000FFC000000000000000000
  0000000007F81FFFFC00FFE001FF83FF801FFC07FC0FC001FFF0000FFE000FFFE003FFFFF0001FFF0000FF81F8
  000000000FF81FFFF800FFC003FF87FF001FF807FC3FC00FFFFC000FFC00FFFFF003FFFFF0007FFFC000FF87F8
  000000000FF03FFFF801FFC003FF07FF003FF80FF8FF803FFFFE001FFC03FFFFF807FFFFE003FFFFE001FF0FF0
  000000001FF03FFFF001FF8007FF0FFE003FF00FF9FF807FFFFF001FF807FFFFFC07FFFFE007FFFFF001FF3FF0
  000000001FE07FFFF003FF8007FF0FFE007FF01FFBFF01FFFFFF003FF807FFFFFC0FFFFFC01FFFFFF003FF7FE0
  000000003FE07FFFE003FF000FFE0FFC007FE01FFFFF03FFFFFF003FF80FFFFFFC0FFFFFC03FFFFFF803FFFFE0
  000000003FC0FFFFE007FF001FFC1FFC00FFE03FFFFE07FFFFFF807FF00FFCFFFC0FFFFF807FFFFFF807FFFFC0
  000000007FC0FFFFC007FE003FFC1FF800FFC03FFFFE0FFE07FF807FF01F003FFC01FFE000FFF07FF807FFFFC0
  000000007F81FFFFC00FFE00FFF83FF801FFC03FFFFC1FFC07FF80FFE018001FFC01FFC001FFC07FF807FFFF80
  000000007F81FFFF800FFE07FFF03FF001FFC07FFF803FF803FF80FFE000001FFC01FF8003FF803FF80FFFF000
  00000000FF03FFFF801FFFFFFFE07FF003FF807FFC007FF003FF81FFC000001FFC03FF8007FF003FF80FFF8000
  00000000FF03FFFF801FFFFFFFC07FE003FF80FFF800FFE003FF81FFC000001FF803FF800FFE003FF81FFF0000
  00000001FE03FFFF003FFFFFFF80FFE007FF00FFF001FFC007FF01FF800003FFF807FF001FFC003FF01FFE0000
  00000001FE07FFFF003FFFFFFE00FFE007FF01FFE001FF8007FF03FF8000FFFFF807FF001FF8007FF03FFC0000
  3FFFFF03FE07FFFE007FFFFFFC01FFC00FFE01FFC003FF8007FF03FF0007FFFFF007FE003FF8007FF03FF80000
  7FFFFF03FC0FFFFE007FFFFFF001FFC00FFE03FF8007FF000FFE07FF001FFFFFF00FFE007FF0007FF07FF00000
  7FFFFE07FC0FFFFC007FFFFF8003FF800FFC03FF8007FF000FFE07FE007FFFFFE00FFC007FF000FFE07FF00000
  3FFFFE07F81FFFFC00FFFFE00003FF801FFC07FF000FFE000FFE0FFE01FFFFFFE01FFC00FFE000FFE0FFE00000
  1FFFFC0FF81FFFF800FFC0000007FF001FF807FF000FFE001FFC0FFC03FFFDFFC01FF800FFE001FFC0FFE00000
  0FFFFC0FF03FFFF801FFC0000007FF003FF80FFE001FFC001FFC1FFC07FF81FFC03FF800FFC001FFC1FFC00000
  07FFF81FF03FFFF001FF80000007FE003FF00FFE001FFC003FF81FFC0FFE01FF803FF001FFC003FF81FFC00000
  03FFF81FE07FFFF003FF8000000FFE007FF01FFC001FF8007FF03FF81FF803FF807FF001FFC003FF81FF800000
  01FFF01FE07FFFE003FF0000000FFC007FE01FFC003FF8007FF03FF83FF003FF007FE001FF8007FF03FF800000
  00FFF03FC0FFFFE007FF0000001FFC00FFE01FF8003FF800FFE07FF07FF007FF00FFE003FF800FFE03FF000000
  007FE03FC0FFFFC007FE0000001FFC01FFE03FF8003FF801FFC07FF07FE007FE00FFE003FF800FFE07FF000000
  003FE07F80FFFFC00FFE0000001FFC01FFC03FF0003FF801FFC0FFE0FFE00FFE00FFC003FF801FFC07FE000000
  001FE07F81FFFFC00FFE0000003FFC07FFC07FF0003FF807FF80FFE0FFC01FFE01FFE003FF803FF80FFE000000
  000FC0FF01FFFF801FFC0000003FFE1FFF807FE0003FF80FFF00FFC0FFE03FFC01FFE003FF80FFF00FFC000000
  0007C0FF03FFFF801FFC0000003FFFFFFF80FFE0003FFC3FFE01FFC1FFE0FFFC01FFFF03FFC1FFE01FFC000000
  000381FF03FFFF003FF80000003FFFFFFF00FFC0003FFFFFFC01FF81FFFFFFF803FFFF03FFFFFFC01FF8000000
  000181FE07FFFF003FF80000003FFFFFFF01FFC0003FFFFFF003FF81FFFFFFF803FFFE03FFFFFF803FF8000000
  000003FE07FFFE003FF00000003FFFFFFE01FF80003FFFFFE003FF01FFFFFFF003FFFE01FFFFFE003FF8000000
  000003FC0FFFFE007FE00000003FFFF3FE03FF80001FFFFFC007FF01FFFFFFF003FFFC01FFFFFC007FF0000000
  000007FC0FFFFC007FE00000003FFFC7FE03FF00000FFFFF0007FE00FFFF3FE001FFFC00FFFFF0007FE0000000
  000007F81FFFF000FF800000001FFF07FC07FE000007FFFC000FFC007FFC3FE000FFF8007FFFC000FFC0000000
  00000FF81FFFC000FC000000000FFC0FFC07F0000001FFC0000FC0003FE07FE0007FF0001FFE0000FE00000000
  000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:9AM.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
  0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
  000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
  00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
  00000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
  0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
  000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
  000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
  00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
  00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
  0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
  0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
  000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
  000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
  00000000000000000FFFFFFFFFFF0001FFFFFFFFFFFFFFFFFFFFF0000000000000000000000070F800000000000000
  00000000000000003FFFFFFFFFC0000003FFFFFFFFFFFFFFFFFFF8000003E000FE00003F000070F800000000000000
  0000000000000000FFFFFFFFFC000000003FFFFFFFFFFFFFFFFFF8000003F000FF00007F8000F0F800000000000000
  0000000000000001FFFFFFFFE00000000007FFFFFFFFFFFFFFFFFC000007F000FF00007F8000E0F800000000000000
  0000000000000007FFFFFFFF800000000001FFFFFFFFFFFFFFFFFE000007F000FF8000FF8000E0F800000000000000
  000000000000001FFFFFFFFC0000000000007FFFFFFFFFFFFFFFFF000007F800FF8000FF8001C0F800000000000000
  000000000000003FFFFFFFF00000000000001FFFFFFFFFFFFFFFFF00000FF800FFC001FF8001C0F800000000000000
  00000000000000FFFFFFFFE000000000000007FFFFFFFFFFFFFFFF80000FFC00FFC001FF800380F800000000000000
  00000000000001FFFFFFFF8000000000000001FFFFFFFFFFFFFFFF80001E7C00FFE003DF800380F83C000000000000
  00000000000007FFFFFFFF0000000000000000FFFFFFFFFFFFFFFFC0001E7E00FBE003DF800780F9FF800000000000
  0000000000000FFFFFFFFC00000000000000007FFFFFFFFFFFFFFFC0003E7E00FBF0079F800700FFFFC00000000000
  0000000000001FFFFFFFF800000000000000003FFFFFFFFFFFFFFFE0003C3E00F9F0079F800700FFFFC00000000000
  0000000000007FFFFFFFF000000000000000001FFFFFFFFFFFFFFFE0007C3F00F9F00F1F800E00FE0FE00000000000
  000000000000FFFFFFFFE000000007C000000007FFFFFFFFFFFFFFF0007C1F00F8F80F1F800E00FC07E00000000000
  000000000001FFFFFFFFC0000000FFFE00000007FFFFFFFFFFFFFFF000F81F80F8F81F1F801C00F803E00000000000
  000000000003FFFFFFFF80000003FFFF80000003FFFFFFFFFFFFFFF000F81F80F87C1E1F801C00F803E00000000000
  00000000000FFFFFFFFF0000000FFFFFE0000001FFFFFFFFFFFFFFF800F00F80F87C3E1F801C00F803E00000000000
  00000000001FFFFFFFFE0000001FFFFFF0000000FFFFFFFFFFFFFFF801FFFFC0F87E3C1F803800F803E00000000000
  00000000003FFFFFFFFC0000003FFFFFFC000000FFFFFFFFFFFFFFF801FFFFC0F83E7C1F803800F803E00000000000
  00000000007FFFFFFFFC0000007FFFFFFE0000007FFFFFFFFFFFFFF803FFFFE0F83E781F807000F803E00000000000
  0000000000FFFFFFFFF8000000FFFFFFFF0000003FFFFFFFFFFFFFFC03E007E0F81FF81F807000F803E00000000000
  0000000001FFFFFFFFF0000001FFFFFFFF0000003FFFFFFFFFFFFFFC07C007E0F81FF01F80F000F803E00000000000
  0000000003FFFFFFFFF0000003FFFFFFFF8000001FFFFFFFFFFFFFFC07C003F0F80FF01F80E000F803E00000000000
  0000000007FFFFFFFFE0000003FFFFFFFFC000001FFFFFFFFFFFFFFC0F8003F0F80FE01F80E000F803E00000000000
  000000000FFFFFFFFFE0000007FFFFFFFFC000000FFFFFFFFFFFFFFC0F8003F8F807E01F81C000F803E00000000000
  000000001FFFFFFFFFC0000007FFFFFFFFE000000FFFFFFFFFFFFFFC0F8001F8F807C01F81C000F803E00000000000
  000000003FFFFFFFFFC000000FFFFFFFFFE0000007FFFFFFFFFFFFFC1F0001FCF803C01F838000F803E00000000000
  000000007FFFFFFFFF8000000FFFFFFFFFE0000007FFFFFFFFFFFFFC00000000000000000380000000000000000000
  00000000FFFFFFFFFF8000000FFFFFFFFFF0000007FFFFFFFFFFFFFC00000000000000000780000000000000000000
  00000001FFFFFFFFFF8000001FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000700000000000000000000
  00000001FFFFFFFFFF0000001FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000700000000000000000000
  00000003FFFFFFFFFF0000001FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000007FFFFFFFFFF0000003FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000000FFFFFFFFFFF0000003FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000001FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
  0000001FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
  0000003FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
  000000FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF000000000000000000000000000000000000000
  000001FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF000000000000000000000000000000000000000
  000001FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF000000000000000000000000000000000000000
  000003FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFE000000000000000000000000000000000000000
  000003FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFE000000000000000000000000000000000000000
  000007FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFE000000000000000000000000000000000000000
  000007FFFFFFFFFFFF0000001FFFFFFFFFF0000001FFFFFFFFFFFFC000000000000000000000000000000000000000
  00000FFFFFFFFFFFFF0000001FFFFFFFFFE0000001FFFFFFFFFFFFC000000000000000000000000000000000000000
  00000FFFFFFFFFFFFF0000001FFFFFFFFFE0000001FFFFFFFFFFFF8000000000000000000000000000000000000000
  00001FFFFFFFFFFFFF0000001FFFFFFFFFE0000001FFFFFFFFFFFF8000000000000000000000000000000000000000
  00001FFFFFFFFFFFFF8000000FFFFFFFFFC0000001FFFFFFFFFFFF0000000000000000000000000000000000000000
  00001FFFFFFFFFFFFF8000000FFFFFFFFFC0000001FFFFFFFFFFFF0000000000000000000000000000000000000000
  00003FFFFFFFFFFFFF80000007FFFFFFFF80000003FFFFFFFFFFFE0000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFC0000007FFFFFFFF80000003FFFFFFFFFFFE0000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFC0000003FFFFFFFF00000003FFFFFFFFFFFC0000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFE0000001FFFFFFFF00000003FFFFFFFFFFFC0000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFE0000000FFFFFFFE00000003FFFFFFFFFFF80000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFF00000007FFFFFFC00000007FFFFFFFFFFF00000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFF80000003FFFFFF800000007FFFFFFFFFFF00000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFF80000001FFFFFE000000007FFFFFFFFFFE00000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFC00000007FFFF8000000007FFFFFFFFFFC00000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFE00000001FFFE000000000FFFFFFFFFFFC00000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF000000003FE0000000000FFFFFFFFFFF800000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF800000000000000000000FFFFFFFFFFF000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFC00000000000000000001FFFFFFFFFFE000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFE00000000000000000001FFFFFFFFFFC000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFF00000000000000000001FFFFFFFFFFC000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFF80000000000000000003FFFFFFFFFF8000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFE0000000000000000003FFFFFFFFFF0000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFF0000000000000000007FFFFFFFFFE0000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFC000000000000000007FFFFFFFFFC0000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFF000000000000000007FFFFFFFFF80000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFE000000000C000000FFFFFFFFFF00000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFC00000007C000000FFFFFFFFFE00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFC000007F8000001FFFFFFFFFC00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000003FFFFFFFFF800000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000003FFFFFFFFF000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000007FFFFFFFFE000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE0000007FFFFFFFFC000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000FFFFFFFFF0000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFC000001FFFFFFFFE0000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFF8000001FFFFFFFFC0000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFFFFFFFF8000003FFFFFFFF80000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFFFFFFFF0000007FFFFFFFE00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFFFFFFFFFFFFE0000007FFFFFFFC00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFFFFFFFFFFFFC000000FFFFFFFF800000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFFFFFFFFFFFF8000001FFFFFFFE000000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFFFFFFFFFFFF0000003FFFFFFFC000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFFFFFFE0000007FFFFFFF0000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFFFFFFC0000007FFFFFFE0000000000000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFFFFFFFFFFF8000000FFFFFFF80000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFFFF00000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFFE0000003FFFFFFC00000000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFFFFFFFFFFC0000007FFFFFF000000000000000000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFFFFFFFFFF8000000FFFFFFE000000000000000000000000000000000000000000000000000
  0000003FFFFFFFFFFFFFFFFFFFFFE0000001FFFFFF8000000000000000000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFFFFFFFFFC0000003FFFFFE0000000000000000000000000000000000000000000000000000
  0000000FFFFFFFFFFFFFFFFFFFFF00000007FFFFF80000000000000000000000000000000000000000000000000000
  00000007FFFFFFFFFFFFFFFFFFFE0000001FFFFFE00000000000000000000000000000000000000000000000000000
  00000003FFFFFFFFFFFFFFFFFFF80000003FFFFF800000000000000000000000000000000000000000000000000000
  00000001FFFFFFFFFFFFFFFFFFE00000007FFFFE000000000000000000000000000000000000000000000000000000
  000000007FFFFFFFFFFFFFFFFFC0000000FFFFF8000000000000000000000000000000000000000000000000000000
  000000003FFFFFFFFFFFFFFFFF00000003FFFFC0000000000000000000000000000000000000000000000000000000
  000000001FFFFFFFFFFFFFFFF800000007FFFF00000000000000000000000000000000000000000000000000000000
  0000000007FFFFFFFFFFFFFFE00000000FFFF800000000000000000000000000000000000000000000000000000000
  0000000001FFFFFFFFFFFFFF000000003FFFE000000000000000000000000000000000000000000000000000000000
  00000000007FFFFFFFFFFFF8000000007FFF0000000000000000000000000000000000000000000000000000000000
  00000000001FFFFFFFFFFFC000000001FFF80000000000000000000000000000000000000000000000000000000000
  000000000007FFFFFFFFF80000000007FFC00000000000000000000000000000000000000000000000000000000000
  000000000001FFFFFFFF80000000000FFE000000000000000000000000000000000000000000000000000000000000
  0000000000003FFFFFFF80000000003FE0000000000000000000000000000000000000000000000000000000000000
  00000000000007FFFFFF8000000000FFC0000000000000000000000000000000000000000000000000000000000000
  00000000000000FFFFFF8000000003FF00000000000000000000000000000000000000000000000000000000000000
  000000000000000FFFFF800000000FFC00000000000000000000000000000000000000000000000000000000000000
  0000000000000000FFFF800000007FF000000000000000000000000000000000000000000000000000000000000000
  000000000000000001FF80000001FFC000000000000000000000000000000000000000000000000000000000000000
  000000000000000000000000000FFF0000000000000000000000000000000000000000000000000000000000000000
  000000000000000000000000003FFC0000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000003FFE00000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000001FFF800000000000000000000000000000000000000000000000000000000000000000
  000000000000000000000001FFFC000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000003FFFE0000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000007FFFE00000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000007FFE000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000007FC0000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:10AM.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
  0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
  000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
  00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
  00000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
  0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
  000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
  000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
  00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
  00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
  0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
  0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
  000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
  000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000C00000C0000000000000000000000000000
  00000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00001FFE000FF8000000000000000000000000000
  00000000000000003FFFFF00001FFFFFFFFFF007FFFFFFFFFFFFF80007FFF001FFE000000000000000000000000000
  0000000000000000FFFFFC00001FFFFFFFFE00003FFFFFFFFFFFF80003FFF803FFF000000000000000000000000000
  0000000000000001FFFFE000001FFFFFFFF0000007FFFFFFFFFFFC000303FC07E3F800000000000000000000000000
  0000000000000007FFFF8000001FFFFFFF80000000FFFFFFFFFFFE000001FC0FC1F800000000000000000000000000
  000000000000001FFFFC0000001FFFFFFF000000007FFFFFFFFFFF000000FC0FC0FC00000000000000000000000000
  000000000000003FFFF00000001FFFFFFC000000001FFFFFFFFFFF000000FC1F80FC00000000000000000000000000
  00000000000000FFFFC00000001FFFFFF0000000000FFFFFFFFFFF800000FC1F807E00000000000000000000000000
  00000000000001FFFE000000001FFFFFE00000000003FFFFFFFFFF800001F81F807E00000000000000000000000000
  00000000000007FFF8000000001FFFFFC00000000001FFFFFFFFFFC00003F03F807E00000000000000000000000000
  0000000000000FFFC0000000001FFFFF800000000000FFFFFFFFFFC0000FE03F007E00000000000000000000000000
  0000000000001FFF00000000001FFFFF0000000000007FFFFFFFFFE000FF803F007E00000000000000000000000000
  0000000000007FF800000000001FFFFE0000000000003FFFFFFFFFE000FFE03F007E00000000000000000000000000
  000000000000FFE000000000001FFFFC0000000000001FFFFFFFFFF000FFF83F007E00000000000000000000000000
  000000000001FFF000000000001FFFF80000000000000FFFFFFFFFF00003FC3F007E00000000000000000000000000
  000000000003FFF000000000001FFFF000000000000007FFFFFFFFF00000FE3F007E00000000000000000000000000
  00000000000FFFF000000000001FFFF000000780000007FFFFFFFFF800007E1F807E00000000000000000000000000
  00000000001FFFF800001000001FFFE000003FF0000003FFFFFFFFF800007F1F807E00000000000000000000000000
  00000000003FFFF800007000001FFFC000007FFC000001FFFFFFFFF800007F1F807E00000000000000000000000000
  00000000007FFFF80003F000001FFFC00001FFFE000001FFFFFFFFF800007F1F80FC00000000000000000000000000
  0000000000FFFFF8000FF000001FFF800003FFFF000000FFFFFFFFFC00007E0FC0FC00000000000000000000000000
  0000000001FFFFFC007FF000001FFF800003FFFF8000007FFFFFFFFC0000FE0FC1F800000000000000000000000000
  0000000003FFFFFC01FFF000001FFF000007FFFFC000007FFFFFFFFC0201FC07E3F800000000000000000000000000
  0000000007FFFFFC0FFFF000001FFF00000FFFFFC000003FFFFFFFFC03FFFC03FFF000000000000000000000000000
  000000000FFFFFFE3FFFF000001FFE00000FFFFFE000003FFFFFFFFC07FFF001FFE000000000000000000000000000
  000000001FFFFFFFFFFFF000001FFE00001FFFFFE000001FFFFFFFFC03FFE000FF8000000000000000000000000000
  000000003FFFFFFFFFFFF000001FFC00001FFFFFF000001FFFFFFFFC001E00001C0000000000000000000000000000
  000000007FFFFFFFFFFFF000001FFC00003FFFFFF000001FFFFFFFFC00000000000000000000000000000000000000
  00000000FFFFFFFFFFFFF000001FF800003FFFFFF800000FFFFFFFFC00000000000000000000000000000000000000
  00000001FFFFFFFFFFFFF000001FF800007FFFFFF800000FFFFFFFFC00000000000000000000000000000000000000
  00000001FFFFFFFFFFFFF000001FF800007FFFFFF8000007FFFFFFFC00000000000000000000000000000000000000
  00000003FFFFFFFFFFFFF000001FF000007FFFFFFC000007FFFFFFFC00000000000000000000000000000000000000
  00000007FFFFFFFFFFFFF000001FF000007FFFFFFC000007FFFFFFFC00000000000000000000000000000000000000
  0000000FFFFFFFFFFFFFF000001FF00000FFFFFFFC000007FFFFFFFC00000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFF000001FE00000FFFFFFFC000003FFFFFFF800000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFF000001FE00000FFFFFFFE000003FFFFFFF800000000000000000000000000000000000000
  0000003FFFFFFFFFFFFFF000001FE00000FFFFFFFE000003FFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFF000001FE00001FFFFFFFE000001FFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFF000001FC00001FFFFFFFE000001FFFFFFF80000000000000000000030F800000000000000
  000000FFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001FFFFFFF00000000000000000000070F800000000000000
  000001FFFFFFFFFFFFFFF000001FC00001FFFFFFFF000001FFFFFFF00003F000FF00007F8000F0F800000000000000
  000001FFFFFFFFFFFFFFF000001FC00001FFFFFFFF000001FFFFFFF00007F000FF00007F8000E0F800000000000000
  000003FFFFFFFFFFFFFFF000001F800001FFFFFFFF000000FFFFFFE00007F000FF8000FF8000E0F800000000000000
  000003FFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFE00007F800FF8000FF8001E0F800000000000000
  000007FFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFE0000FF800FFC001FF8001C0F800000000000000
  000007FFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFC0000FFC00FFC001FF8003C0F800000000000000
  00000FFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFC0001F7C00FFE003FF800380F800000000000000
  00000FFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFF80001E7C00FBE003DF800380F8FF000000000000
  00001FFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFF80003E7E00FBE007DF800700FBFF800000000000
  00001FFFFFFFFFFFFFFFF000001F800003FFFFFFFF0000007FFFFF00003E3E00F9F0079F800700FFFFC00000000000
  00001FFFFFFFFFFFFFFFF000001F000003FFFFFFFF0000007FFFFF00007C3F00F9F00F9F800F00FF1FE00000000000
  00003FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFE00007C3F00F9F80F1F800E00FC07E00000000000
  00003FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFE0000781F00F8F81F1F801E00FC07E00000000000
  00003FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFC0000F81F80F8FC1E1F801C00F803E00000000000
  00007FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFC0000F81F80F87C3E1F801C00F803E00000000000
  00007FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFF80001FFFFC0F87E3C1F803800F803E00000000000
  00007FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFF00001FFFFC0F83E3C1F803800F803E00000000000
  0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFF00003FFFFE0F83E781F807800F803E00000000000
  0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFE00003FFFFE0F81F781F807000F803E00000000000
  0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFC00007C007E0F81FF01F80F000F803E00000000000
  0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFC00007C007F0F81FF01F80E000F803E00000000000
  0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFF800007C003F0F80FE01F80E000F803E00000000000
  0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFF00000F8003F8F80FE01F81E000F803E00000000000
  0001FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFE00000F8003F8F807C01F81C000F803E00000000000
  0001FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF0000007FFC00001F0001F8F807C01F83C000F803E00000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFC00001F0001FCF803801F838000F803E00000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFF8000000000000000000000380000000000000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFF0000000000000000000000700000000000000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFE0000000000000000000000700000000000000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFC0000000000000000000000F00000000000000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FF80000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FF00000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFF000001F800001FFFFFFFF000000FE00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFF000001F800001FFFFFFFF000000FC00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFF000001F800000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001F000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001F000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001F000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001E000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFF000001FE00000FFFFFFFE000003E000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFF000001FE00000FFFFFFFE000003E000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFF000001FE00000FFFFFFFC000003E000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFF000001FE00000FFFFFFFC000003E000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFF000001FF00000FFFFFFFC000007C000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFF000001FF000007FFFFFFC000007C000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFF000001FF000007FFFFFF8000007C000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFF000001FF800007FFFFFF800000FC000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFF000001FF800003FFFFFF800000F8000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFF000001FF800003FFFFFF800000F8000000000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFF000001FFC00003FFFFFF000001F8000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFF000001FFC00001FFFFFF000001F0000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFF000001FFE00001FFFFFE000003F0000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFF000001FFE00000FFFFFE000003E0000000000000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFF000001FFF00000FFFFFC000007E0000000000000000000000000000000000000000000000
  0000003FFFFFFFFFFFFFF000001FFF000007FFFFC000007E0000000000000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFF000001FFF800007FFFF800000FC0000000000000000000000000000000000000000000000
  0000000FFFFFFFFFFFFFF000001FFF800003FFFF000000FC0000000000000000000000000000000000000000000000
  00000007FFFFFFFFFFFFF000001FFFC00001FFFE000001F80000000000000000000000000000000000000000000000
  00000003FFFFFFFFFFFFF000001FFFC00000FFFC000001F80000000000000000000000000000000000000000000000
  00000001FFFFFFFFFFFFF000001FFFE000007FF8000003F00000000000000000000000000000000000000000000000
  000000007FFFFFFFFFFFF000001FFFF000001FE0000007F00000000000000000000000000000000000000000000000
  000000003FFFFFFFFFFFF000001FFFF000000000000007E00000000000000000000000000000000000000000000000
  000000001FFFFFFFFFFFF000001FFFF80000000000000FC00000000000000000000000000000000000000000000000
  0000000007FFFFFFFFFFF000001FFFFC0000000000001FC00000000000000000000000000000000000000000000000
  0000000001FFFFFFFFFFF000001FFFFE0000000000003F800000000000000000000000000000000000000000000000
  00000000007FFFFFFFFFF000001FFFFF0000000000007F000000000000000000000000000000000000000000000000
  00000000001FFFFFFFFFF000001FFFFF800000000000FE000000000000000000000000000000000000000000000000
  000000000007FFFFFFFFF000001FFFFFC00000000001FE000000000000000000000000000000000000000000000000
  000000000001FFFFFFFFF000001FFFFFE00000000003FC000000000000000000000000000000000000000000000000
  0000000000003FFFFFFFF000001FFFFFE00000000007F8000000000000000000000000000000000000000000000000
  00000000000007FFFFFFF000001FFFFF00000000001FF0000000000000000000000000000000000000000000000000
  00000000000000FFFFFFF000001FFFE000000000003FC0000000000000000000000000000000000000000000000000
  000000000000000FFFFFF000001FFE000000000000FF80000000000000000000000000000000000000000000000000
  0000000000000000FFFFF000001F80000000000003FF00000000000000000000000000000000000000000000000000
  000000000000000001FFFF00003E0000001800000FFC00000000000000000000000000000000000000000000000000
  000000000000000000003FFFFFFE0000000700007FF800000000000000000000000000000000000000000000000000
  00000000000000000000007FFFFE00000001FFFFFFE000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000003FFFFF0000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000000007FFF80000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:SATURDAY.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000007FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFFC000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000
  0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000000
  000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000000
  00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000
  00000000000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000
  0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
  000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000
  000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
  00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
  00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000
  0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
  0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
  000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
  000000000000000003FFFFFFFFFFFFCFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
  00000000000000000FFFFFFFFFFF000003FFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
  00000000000000003FFFFFFFFFE00000003FFFFFFFFFFFFFFFFFF80000000000000001F00000000000000000000000
  0000000000000000FFFFFFFFFF0000000003FFFFFFFFFFFFFFFFFC0000000000000001F80000000000000000000000
  0000000000000001FFFFFFFFF800000000007FFFFFFFFFFFFFE0FE0000000000000001F80000000000000000000000
  0000000000000007FFFFFFFFE000000000001FFFFFFFFFFFFFC0FE0000000000000001F80000000000000000000000
  000000000000001FFFFFFFFF80000000000007FFFFFFFFFFFFC0FF0000000000000001F80000000000000000000000
  000000000000003FFFFFFFFE00000000000001FFFFFFFFFFFFC0FF8000000000000001F80000000000000000000000
  00000000000000FFFFFFFFFC00000000000000FFFFFFFFFFFFC0FF8000000000000001F80000000000000000000000
  00000000000001FFFFFFFFF0000000000000003FFFFFFC01FE0007C000000000000001F80000000000000000000000
  00000000000007FFFFFFFFE0000000000000001FFFFFF0007E0007C000000000000001F80000000000000000000000
  0000000000000FFFFFFFFFC0000000000000001FFFFFE0003E0007E0F807C07C7C07F9F803FF00F801F00000000000
  0000000000001FFFFFFFFF80000000000000003FFFFFE1F03FC0FFE0F807C07CFC1FFDF80FFFC0F801F00000000000
  0000000000007FFFFFFFFF00000000000000003FFFFFF7F81FC0FFF0F807C07FFC3FFFF80FFFE0FC03E00000000000
  000000000000FFFFFFFFFE00000000000000007FFFFFFFF81FC0FFF0F807C07FF87E07F80E07E07C03E00000000000
  000000000001FFFFFFFFFC0000000000000000FFFFFFFFC01FC0FFF8F807C07F087E03F80003F07E07C00000000000
  000000000003FFFFFFFFFC0000000000000001FFFFFFFC001FC0FFF8F807C07E00FC03F80003F07E07C00000000000
  00000000000FFFFFFFFFF800000001FFF00001FFFFFFF0081FC0FFF8F807C07E00FC01F8003FF03E07800000000000
  00000000001FFFFFFFFFF00000000FFFFF0003FFFFFFE0781FC0FFF8F807C07E00F801F801FFF03F0F800000000000
  00000000003FFFFFFFFFF00000003FFFFFC007FFFFFFC0F81FC0FFFCF807C07C00F801F807F3F01F0F000000000000
  00000000007FFFFFFFFFE00000007FFFFFF80FFFFFFF81F81FC0FFFCF807C07C00F801F80FC3F01F9F000000000000
  0000000000FFFFFFFFFFE0000000FFFFFFFE0FFFFFFF81F81FC0FFFCF807C07C00F801F81F03F00F9E000000000000
  0000000001FFFFFFFFFFE0000001FFFFFFFF1FFFFFFF81F01FC0FFFCF807C07C00FC01F83F03F00F9E000000000000
  0000000003FFFFFFFFFFC0000003FFFFFFFFFFFFFFFF81F01FC0FFFCF807C07C00FC01F83E03F007FC000000000000
  0000000007FFFFFFFFFFC0000007FFFFFFFFFFFFFFFF80C01FC07FFCFC0FC07C00FC03F83E07F007FC000000000000
  000000000FFFFFFFFFFFC0000007FFFFFFFFFFFFFFFFC0001FE007FEFC0FC07C007E07F83F0FF003F8000000000000
  000000001FFFFFFFFFFFC0000007FFFFFFFFFFFFFFFFE0081FE003FEFF3FC07C007F0FF83F9FF003F8000000000000
  000000003FFFFFFFFFFF80000007FFFFFFFFFFFFFFFFF03C0FF007FE7FFFC07C003FFFF81FFFF003F0000000000000
  000000007FFFFFFFFFFF8000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE3FF7C07C001FFDF80FF3F001F0000000000000
  00000000FFFFFFFFFFFF8000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE1FC7C07C0007F1F007C1F001E0000000000000
  00000001FFFFFFFFFFFF80000007FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000003E0000000000000
  00000003FFFFFFFFFFFF80000007FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000003C0000000000000
  00000003FFFFFFFFFFFF80000007FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000007C0000000000000
  00000007FFFFFFFFFFFFC0000003FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000F80000000000000
  0000000FFFFFFFFFFFFFC0000003FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000F80000000000000
  0000001FFFFFFFFFFFFFC0000001FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000003F00000000000000
  0000001FFFFFFFFFFFFFC0000001FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000001FE00000000000000
  0000003FFFFFFFFFFFFFC0000000FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000001FC00000000000000
  0000007FFFFFFFFFFFFFE00000007FFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000001F000000000000000
  0000007FFFFFFFFFFFFFE00000003FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFE00000001FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFF00000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFF000000003FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFF800000001FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFFC00000000FFFFFFFFFFFFFFFFFFFFFFFFF000000000000001F00E00000000000000000000
  000007FFFFFFFFFFFFFFFC000000007FFFFFFFFFFFFFFFFFFFFFFFE000000000000001F01F00000000000000000000
  000007FFFFFFFFFFFFFFFE000000001FFFFFFFFFFFFFFFFFFFFFFFE000000000000001F03F80000000000000000000
  00000FFFFFFFFFFFFFFFFF000000000FFFFFFFFFFFFFFFFFFFFFFFC000000000000001F03F80000000000000000000
  00000FFFFFFFFFFFFFFFFF8000000003FFFFFFFFFFFFFFFFFFFFFFC000000000000001F01F00000000000000000000
  00001FFFFFFFFFFFFFFFFF8000000001FFFFFFFFFFFFFFFFFFFFFF8000000000000001F00F00000000000000000000
  00001FFFFFFFFFFFFFFFFFC000000000FFFFFFFFFFFFFF07FFFFE18000000000000001F00000000000000000000000
  00003FFFFFFFFFFFFFFFFFE0000000003FFFFFFFFFFFF800FF83000000000000000001F00000000000000000000000
  00003FFFFFFFFFFFFFFFFFF8000000001FFFFFFFFFFFE0007F800000000000F80003E1F00000000000000000000000
  00003FFFFFFFFFFFFFFFFFFC000000000FFFFFFFFFFFE0403F800000000007FF000FFDF01F00000000000000000000
  00007FFFFFFFFFFFFFFFFFFE0000000003FFFFFFFFFFF3F01F80F807C0001FFF803FFFF01F00000000000000000000
  00007FFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFFFFFF81F81FC0FC0403F0FC03F0FF01F00000000000000000000
  00007FFFFFFFFFFFFFFFFFFF8000000000FFFFFFFFFFFFF01F81FC0E00403E07C07E07F01F00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFE0000000003FFFFFFFFFFF001F81F80C00607C03E0FC03F01F00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFFF8001F81F00C00607C03E0FC03F01F00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFF8000000000FFFFFFFFFF0181F81F00C0060FC03E0F801F01F00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFE0000000003FFFFFFFFC0F81F81E00C0060FFFFE1F801F01F00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFC1F81F81C00C0060FFFFE1F801F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF8000000000FFFFFFFF81F81F81C00C0060FC0001F801F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFE0000000007FFFFFFF81F81F81800C0060FC0001F801F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFF0000000003FFFFFFF81F01F81000C0060FC0000F801F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFC000000001FFFFFFF81E01F81000C00607E0000FC03F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFE000000000FFFFFFFC0001F81000C00607E0000FC03F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFF8000000007FFFFFFC0001F81000C00603F80C07E07F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFC000000003FFFFFFE0180F81000C00601FFFC07F9FF01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFF000000001FFFFFFF87F1FE3001C00E00FFFE03FFDF01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFF800000000FFFFFFFFFFFFFF00FC07E007FF800FF9F01F00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFFE00000000FFFFFFFFFFFFC00000000000780003C0000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFFF000000007FFFFFFFFFFF80000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFFF800000003FFFFFFFFFFF00000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFFFE00000001FFFFFFFFFFE00000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFFFF00000001FFFFFFFFFFC00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFF80000000FFFFFFFFFF800000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000FFFFFFFFFF000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFE00000007FFFFFFFFC000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFF00000007FFFFFFFF8000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFF00000003FFFFFFFF0000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFF80000003FFFFFFFE0000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000003FFFFFFFC0000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000001FFFFFFF00000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFFFFFFFFE0000001FFFFFFE00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFFFFFFFFFFFFFE0000001FFFFFFC00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFFF000000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFFE000000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFF8000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFF0000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFC0000000000000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFF80000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFE00000000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFF800000000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFF000000000000000000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFC000000000000000000000000000000000000000000000000000
  0000003FFFFFFFFFFFFFFFFFFFFFFFFFE0000001FF0000000000000000000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFFFFFFFFFFFFFE0000001FC0000000000000000000000000000000000000000000000000000
  0000000FFFFFFFFFFFFFF9FFFFFFFFFFE0000003FC0000000000000000000000000000000000000000000000000000
  00000007FFFFFFFFFFFFF0FFFFFFFFFFC0000003FC0000000000000000000000000000000000000000000000000000
  00000001FFFFFFFFFFFFF03FFFFFFFFF80000007F80000000000000000000000000000000000000000000000000000
  00000000FFFFFFFFFFFFE00FFFFFFFFF00000007F80000000000000000000000000000000000000000000000000000
  000000007FFFFFFFFFFFC003FFFFFFFE00000007F80000000000000000000000000000000000000000000000000000
  000000001FFFFFFFFFFFC000FFFFFFFC0000000FF00000000000000000000000000000000000000000000000000000
  000000000FFFFFFFFFFF80003FFFFFF00000001FF00000000000000000000000000000000000000000000000000000
  0000000003FFFFFFFFFF000007FFFFC00000001FF00000000000000000000000000000000000000000000000000000
  0000000000FFFFFFFFFF000000FFFE000000003FE00000000000000000000000000000000000000000000000000000
  00000000003FFFFFFFFE0000000000000000007FE00000000000000000000000000000000000000000000000000000
  00000000000FFFFFFFFC000000000000000000FFC00000000000000000000000000000000000000000000000000000
  000000000003FFFFFFF8000000000000000000FF800000000000000000000000000000000000000000000000000000
  000000000000FFFFFFF8000000000000000001FF000000000000000000000000000000000000000000000000000000
  0000000000001FFFFFF0000000000000000003FF000000000000000000000000000000000000000000000000000000
  00000000000003FFFFF800000000000000000FFE000000000000000000000000000000000000000000000000000000
  000000000000003FFFFE00000000000000001FFC000000000000000000000000000000000000000000000000000000
  0000000000000003FFFF00000000000000003FF8000000000000000000000000000000000000000000000000000000
  00000000000000001FFFC000000000000000FFF0000000000000000000000000000000000000000000000000000000
  0000000000000000001FF000000000000001FFE0000000000000000000000000000000000000000000000000000000
  000000000000000000000000000000000007FF80000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000001FFF00000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000007FFE00000000000000000000000000000000000000000000000000000000
  00000000000000000000001C0000000003FFF800000000000000000000000000000000000000000000000000000000
  000000000000000000000007800000003FFFE000000000000000000000000000000000000000000000000000000000
  000000000000000000000000FE000003FFFF8000000000000000000000000000000000000000000000000000000000
  0000000000000000000000001FFFFFFFFFFC0000000000000000000000000000000000000000000000000000000000
  00000000000000000000000003FFFFFFFFE00000000000000000000000000000000000000000000000000000000000
  000000000000000000000000003FFFFFFF000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFC0000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:DANGER.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
  0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
  000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
  00000000000003FFFFFF800FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
  00000000000003FFFFFFF83FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
  00000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
  00000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
  00000000000003E0000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
  00000000000003E00000007FFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
  00000000000003E00000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
  00000000000003E000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
  00000000000003E000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
  00000000000003E0000000007FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
  00000000000003E0000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
  00000000000003E0000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
  00000000000003E0000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
  00000000000003E003FFE00007FFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
  00000000000003E003FFFC0003FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000
  00000000000003E003FFFF0001FFFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
  00000000000003E003FFFF8001FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  00000000000003E003FFFFC000FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  00000000000003E003FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
  00000000000003E003FFFFF0007FFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
  00000000000007E003FFFFF0007FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
  0000000000000FE003FFFFF8003FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
  0000000000001FE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000003C000000000000000000000
  0000000000007FE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFE0007F800000000003C000000000000000000000
  000000000000FFE003FFFFFC001FFFFFFFFFFFFFFFFFFFFFFFFFFFF001FFC00000000003C000000000000000000000
  000000000001FFE003FFFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFF007E0800000000003C000000000000000000000
  000000000003FFE003FFFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFF00F80000000000003C000000000000000000000
  00000000000FFFE003FFFFFE001FC3FFE3FF1FFF1FFE7F0FFFFFF8F80F00001E003C0073C0E0000000000000000000
  00000000001FFFE003FFFFFE001F00F800FC007C07C43C03E3E1E0381E00007F80FF01FFC3F8000000000000000000
  00000000003FFFE003FFFFFE000F187800786078E3C03861E3E1C3781E0001F3C1E783CFC790000000000000000000
  00000000007FFFE003FFFFFF000FFC787870F071F1C1F0F0E3E1C7F81E0001E1E3C3C783C780000000000000000000
  0000000000FFFFE003FFFFFF000FF038F871F871F1C3E1F8E3E1C3FC1E0003C0E381C783C780000000000000000000
  0000000001FFFFE003FFFFFF000F8038F871F86001C7E1F863E1E0FC1E01E3C0E781E703C3E0000000000000000000
  0000000003FFFFE003FFFFFF000E1C38F861F86001C7E1F863E1F07C1E01E3C0F781E703C1F0000000000000000000
  0000000007FFFFE003FFFFFF000E3C38F871F861FFC7E1F8E3E1F83C0F01E3C0E781E703C0F8000000000000000000
  000000000FFFFFE003FFFFFF000C3C38F870F871FFC7F1F0E1E1FE3C0F81E3C1E381C783C038000000000000000000
  000000001FFFFFE003FFFFFF000C3838F870F070FFC7F0F0E1C1FE3C07C1E1E1E3C3C787C038000000000000000000
  000000003FFFFFE003FFFFFF000E0038F878207801C7F861E001CC3C03FFE0F3C1E783EFC678000000000000000000
  000000007FFFFFE003FFFFFF000E0438F87C087C01C7FC03F001C07C00FFE07F80FF01FBC7F0000000000000000000
  00000000FFFFFFE003FFFFFF000FFFFFFFFFF87FFFFFFFFFFFFFFFFC001C000C001800600080000000000000000000
  00000001FFFFFFE003FFFFFF001FFFFFFFFFF8FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000001FFFFFFE003FFFFFE001FFFFFFFFFF0FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000003FFFFFFE003FFFFFE001FFFFFFFFBE0FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000007FFFFFFE003FFFFFE001FFFFFFFF001FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000000FFFFFFFE003FFFFFE001FFFFFFFFC07FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000001FFFFFFFE003FFFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000001FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000003FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  000000FFFFFFFFE003FFFFF8007FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000001FFFFFFFFE003FFFFF8007FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000001FFFFFFFFE003FFFFF000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000003FFFFFFFFE003FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
  000003FFFFFFFFE003FFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
  000007FFFFFFFFE003FFFFC001FFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
  000007FFFFFFFFE003FFFF8003FFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
  00000FFFFFFFFFE003FFFE0003FFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
  00000FFFFFFFFFE003FFF80007FFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
  00001FFFFFFFFFE003FFE0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
  00001FFFFFFFFFE0000000001FFFFFFFC001FFFFFFFFFFC7FFFFFF0000007000000000000000E00000000000000000
  00001FFFFFFFFFE0000000003FFFFFFFC001FFFFFFFFFF87FFFFFF00000071E0000000000000F00000000000000000
  00003FFFFFFFFFE0000000007FFFFFFF8001FFFFFFFFFF87FFFFFE00000071E0000000000000F00000000000000000
  00003FFFFFFFFFE000000000FFFFFFFF8001FFFFFFFFFF87FFFFFE00000070E0000000000000F00000000000000000
  00003FFFFFFFFFE000000000FFFFFFFF8001FFFFFFFFFF87FFFFFC0000007000000000000000F00000000000000000
  00007FFFFFFFFFE000000000FFFFFFFF0001FFC7FFDFE7873FF9FC01800C7000700300300018F018001800C0000000
  00007FFFFFFFFFE0000000007FFFFFFF0001FF00F00701800FC038FFE07FF1E1FC1FC0FE007FF0FF0FFF03FF000000
  00007FFFFFFFFFE0000000007FFFFFFE0001FE10F00C018007C410FFF0FBF1E3CC3CE1E400FBF1EF8FFF07DF000000
  0000FFFFFFFFFFE0000000007FFFFFFE0001FFF870783F83C3FF10F0F0E0F1E3C07071C001E1F0038F878F0F000000
  0000FFFFFFFFFFFFFFFF80003FFFFFFE0001FFF070F87F87C3FC18F071E0F1E3C0F071E001C0F00F8F078E07000000
  0000FFFFFFFFFFFFFFFF80003FFFFFFC0001FF8070F8FF87C3E018F071E071E1F0FFF1F001C0F07F8F079E07000000
  0000FFFFFFFFFFFFFFFF80003FFFFFFC0001FE1C70F8FF87C38318F071E071E0F8FFF0FC03C0F1E38F079E07000000
  0000FFFFFFFFFFFFFFFF80001FFFFFF80001FC3870F8FF87C38F18F071E071E07CF0003E03C0F1C38F079E07000000
  0000FFFFFFFFFFFFFFFF80001FFFFFF80001FC7870F87F87C30F18F071E0F1E01C70001E01E0F3C38F078E07000000
  0001FFFFFFFFFFFFFFFF80000FFFFFF80001FC3870F83F87C30E18F070F0F1E01C78000E01E1F3C78F078F0F0E0000
  0001FFFFFFFFFFFFFFFF80000FFFFFF00001FC0070FC0187C38018F070FBF1E33C3EF39E00F3F1FF8F07879F0F0000
  0001FFFFFFFFFFFFFFFF80000FFFFFF01001FE0470FE0187C38008F0707FF1E3F81FF3FC007EF1FBCF0787F70F0000
  0001FFFFFFFFFFFFFFFF802007FFFFE01001FF1FFFFFC7FFFFE73800001C0000E007807000180060000000C7060000
  0001FFFFFFFFFFFFFFFF802007FFFFE01001FFFFFFFFFFFFFFFE380000000000000000000000000000000007000000
  0001FFFFFFFFFFFFFFFF802007FFFFE03001FFFFFFFFFFFFFFE000000000000000000000000000000000000F000000
  0001FFFFFFFFFFFFFFFF803003FFFFC03001FFFFFFFFFFFFFFC000000000000000000000000000000000041E000000
  0001FFFFFFFFFFFFFFFF803003FFFFC03001FFFFFFFFFFFFFF80000000000000000000000000000000000FFE000000
  0001FFFFFFFFFFFFFFFF803003FFFFC07001FFFFFFFFFFFFFF000000000000000000000000000000000007F8000000
  0001FFFFFFFFFFFFFFFF803801FFFF807001FFFFFFFFFFFFFE00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF803801FFFF807001FFFFFFFFFFFFFC00000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF803801FFFF00F001FFFFFFFFFFFFF800000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF803C00FFFF00F001FFFFFFFFFFFFF000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF803C00FFFF00F001FFFFFFFFFFFFE000000000000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFF803C00FFFE01F001FFFFFFFFFFFFC000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFF803E007FFE01F001FFFFFFFFFFFF0000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFF803E007FFC01F001FFFFFFFFFFFE0000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFF803E007FFC03F001FFFFFFFFFFFC0000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFF803F003FFC03F001FFFFFFFFFFF80000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFF803F003FF803F001FFFFFFFFFFE00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFF803F003FF807F001FFFFFFFFFFC00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFF803F801FF807F001FFFFFFFFFF800000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFF803F801FF00FF001FFFFFFFFFE000000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFF803F801FF00FF001FFFFFFFFFC000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFF803FC00FE00FF001FFFFFFFFF0000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFF803FC00FE01FF001FFFFFFFFE0000000000000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFF803FC00FE01FF001FFFFFFFF80000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFF803FE007C01FF001FFFFFFFF00000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFF803FE007C03FF001FFFFFFFC00000000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFF803FE007C03FF001FFFFFFF000000000000000000000000000000000000000000000000000
  0000007FFFFFFFFFFFFF803FF003807FF001FFFFFFE000000000000000000000000000000000000000000000000000
  0000003FFFFFFFFFFFFF803FF003807FF001FFFFFF8000000000000000000000000000000000000000000000000000
  0000001FFFFFFFFFFFFF803FF003807FF001FFFFFE0000000000000000000000000000000000000000000000000000
  0000000FFFFFFFFFFFFF803FF80100FFF001FFFFF80000000000000000000000000000000000000000000000000000
  00000007FFFFFFFFFFFF803FF80100FFF001FFFFE00000000000000000000000000000000000000000000000000000
  00000003FFFFFFFFFFFF803FF80000FFF001FFFF800000000000000000000000000000000000000000000000000000
  00000001FFFFFFFFFFFF803FFC0001FFF001FFFE000000000000000000000000000000000000000000000000000000
  000000007FFFFFFFFFFF803FFC0001FFF001FFF8000000000000000000000000000000000000000000000000000000
  000000003FFFFFFFFFFF803FFE0003FFF001FFC0000000000000000000000000000000000000000000000000000000
  000000001FFFFFFFFFFF803FFE0003FFF001FF00000000000000000000000000000000000000000000000000000000
  0000000007FFFFFFFFFF803FFE0003FFF001F800000000000000000000000000000000000000000000000000000000
  0000000001FFFFFFFFFF803FFF0007FFF001F000000000000000000000000000000000000000000000000000000000
  00000000007FFFFFFFFF803FFF0007FFF001F000000000000000000000000000000000000000000000000000000000
  00000000001FFFFFFFFF803FFF0007FFF001F000000000000000000000000000000000000000000000000000000000
  000000000007FFFFFFFF803FFF800FFFF001F000000000000000000000000000000000000000000000000000000000
  000000000001FFFFFFFF803FFF800FFFF001F000000000000000000000000000000000000000000000000000000000
  0000000000003FFFFFFF803FFF801FFFE001F000000000000000000000000000000000000000000000000000000000
  00000000000007FFFFFF803FFFC01FFF0001F000000000000000000000000000000000000000000000000000000000
  00000000000000FFFFFF803FFFC01FE00001F000000000000000000000000000000000000000000000000000000000
  000000000000000FFFFF803FFFE03F000001F000000000000000000000000000000000000000000000000000000000
  0000000000000000FFFF803FFFE03F000001F000000000000000000000000000000000000000000000000000000000
  000000000000000001FF807FFFC07F000001F000000000000000000000000000000000000000000000000000000000
  000000000000000000003FFE0001FE0000FFF000000000000000000000000000000000000000000000000000000000
  0000000000000000000007FC0001FE0000FFF000000000000000000000000000000000000000000000000000000000
  0000000000000000000007FC0001FC0000FFF000000000000000000000000000000000000000000000000000000000
  0000000000000000000007FC0000FC00007FF000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:HEAVY.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  0000000000007FFE0000003FFF0FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  0000000000007FFE0000003FFF7FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  0000000000007FFE0000003FFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
  0000000000007FFE0000003FFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
  0000000000007C000000003E000FFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
  0000000000007C000000003E000FFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
  0000000000007C000000003E000FFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
  0000000000007C00000001FE000FFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
  0000000000007C0000000FFE000FFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
  0000000000007C0000003FFE000FFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
  0000000000007C000000FFFE000FFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
  0000000000007C000003FFFE000FFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
  0000000000007C00000FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
  0000000000007C00003FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
  0000000000007C0000FFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
  0000000000007C0003FFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
  0000000000007C000FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF803C000000000000000000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFDFFF803E00001E0000007C0000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFC1FF8003F00001F0000007C0000000000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFE0FF8003F00003F0000007C0000100000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFE0FF8007E00001F0000007C0000F00000000000000000
  0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFE0FF0007E00001E0000007C0001F00000000000000000
  000000000000FC0000000000000FFFFFFFFFFFFFFFFFFFFFFE0FF0107E0000000000007C0001F00000000000000000
  000000000001FC0000000000000FFFFFFFFFFFFFFFFFFFFFFF07F0107E0000000000007C0001F00000000000000000
  000000000003FC0000000000000FFFE07FF01FE3FC79FF1FFF07E000FC07E01E00FC787C7E07FF0000000000000000
  00000000000FFC0000000000000FFF803FC00783FC00FF0FFF07E008FC1FF81F01FEF87DFF07FF8000000000000000
  00000000001FFC0000000000000FFE001F800383FC20FE0FFF87E308FC3FFC1F03FFF87FFF87FF8000000000000000
  00000000003FFC0000000000000FFE0F0FCF83C1F8707E1FFF83C300F87C3C1F07C3F87F8FC1F00000000000000000
  00000000007FFC0000000000000FFC1F07FFC1C1F8707E1FFF83C301F8F81E1F0F81F87E07C1F00000000000000000
  0000000000FFFC0000000000000FFC3F87FF81E0F0707C3FFF83C381F8F81E1F0F80F87E07C1F00000000000000000
  0000000001FFFC0000000000000FF83F87FC01E0F0F83C3FFFC38781F9F01E1F1F00F87C07C1F00000000000000000
  0000000003FFFC001FFFFFFE000FF80007E001F0F0F8387FFFC18781F1FFFE1F1F00F87C07C1F00000000000000000
  0000000007FFFC001FFFFFFE000FF80007C0C1F061FC387FFFC187C3F1FFFE1F1F00F87C07C1F00000000000000000
  000000000FFFFC001FFFFFFE000FF83FFF83C1F061FC187FFFE18FC3F1F8001F1F00F87C07C1F00000000000000000
  000000001FFFFC001FFFFFFE000FF83FFF07C1F863FE10FFFFE10FC3E1F0001F1F00F87C07C1F00000000000000000
  000000003FFFFC001FFFFFFE000FF83FFF07C1F803FE10FFFFE00FC3E0F8001F1F00F87C07C1F00000000000000000
  000000007FFFFC001FFFFFFE000FFC1FFF0F81FC07FE01FFFFE01FE3E0F8001F0F81F87C07C1F00000000000000000
  00000000FFFFFC001FFFFFFE000FFC0FFF0781FC07FF01FFFFF01FE3E0FC001F0F81F87C07C1F00000000000000000
  00000001FFFFFC001FFFFFFE000FFE078F0201FE07FF03FFFFF01FE3C07E1C1F07C3F87C07C0F80000000000000000
  00000001FFFFFC001FFFFFFE000FFF00078001FE0FFF83FFFFF01FF3C03FFE1F07FFF87C07C0FF8000000000000000
  00000003FFFFFC001FFFFFFE000FFF800F80C1FE0FFF87FFFFF83FF3C01FFC1F03FEF87C07C07F8000000000000000
  00000007FFFFFC001FFFFFFE000FFFE07FE1E1FF1FFF87FFFFF83FFB8007F01E00F8F83C03C03F0000000000000000
  0000000FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFF0FFFFFFFFFFC000000000000F8000000000000000000000000
  0000001FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFF0FFFFFFFFFF8000000000000F8000000000000000000000000
  0000001FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFE0FFFFFFFFFF8000000000001F0000000000000000000000000
  0000003FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFE1FFFFFFFFFF8000000000001F0000000000000000000000000
  0000007FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFF83FFFFFFFFFF8000000000607E0000000000000000000000000
  0000007FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFC03FFFFFFFFFF8000000000FFFC0000000000000000000000000
  000000FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFC07FFFFFFFFFF0000000000FFF80000000000000000000000000
  000001FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFC1FFFFFFFFFFF00000000001FE00000000000000000000000000
  000001FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000003FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
  000003FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
  000007FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
  000007FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
  00000FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
  00000FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
  00001FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
  00001FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  00001FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  00003FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
  00003FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
  00003FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFC7FFFFFFFFCF000000000000000001C00000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC3FFFFFFFFDF000000000000000003E00000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0FFFFFFFF9F000000000000000003E00000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF07FFFFFFF1F000000000000000003E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC3FFFFFFF1F000000000000000003E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFE00000000000007FFFFFFF7FFFFFFE1F000000000000000003E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFE00000000000007FFFFFFFFFFFFFFC1F000000000000000003E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFE00000000000007FFFFFFFFFFFFFFC1F000000000000000003E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFE00000000000007FE1C7F81FFC0FF81F003F00780783C703F3E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFE00000000000007FE183E007F003F01F01FFC07C0F87DF8FFBE00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFE00000000000007FE103C003F007E01F03FFE07C0F87FF9FFFE00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFE00000000000007FE00783C3E0FFC01F07C1F07C0F87FF1F0FE00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFE00000000000007FE07707E1E0FFC01F07C0F87C0F87F13E07E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE0007FFFFFFE0FF07E1E0FF801F0F80F87C0F87E03C07E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE0FF07E1E07F001F0F80787C0F87E07C03E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FE0001F01E001F0F807C7C0F87C07C03E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FE0001F80C001F0F807C7C0F87C07C03E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FE07FFFC00001F0F807C7C0F87C07C03E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF0FFFFF00001F0F807C7C0F87C07C03E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF07FFFF82001F0F80F87C0F87C07C03E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF07FFFF82001F0F80F87C0F87C03E07E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF83FFFF83001F07C0F87E1F87C03E07E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF80F3E703001F07E1F03F3F87C03F0FE00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FFC001C006001F03FFE03FFF87C01FFFE00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FFE003E00E001F00FFC01FEF87C00FFBE00000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFC0FF83C0000003F000F80000003E0000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFFE7F80000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFE00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  00001FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFF800000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  00000FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFC000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFF0000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFF80000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFF00000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFC00000000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFF000000000000000000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFE000000000000000000000000000000000000000000000000000
  0000003FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFE0000000000000000000000000000000000000000000000000000
  0000000FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFF80000000000000000000000000000000000000000000000000000
  00000007FFFFFFFFFFFFFFFFFFFFE000FFFFFFFFE00000000000000000000000000000000000000000000000000000
  00000003FFFFFFFFFFFFFFFFFFFFE000FFFFFFFF800000000000000000000000000000000000000000000000000000
  00000001FFFFFFFFFFFFFFFFFFFFE000FFFFFFFE000000000000000000000000000000000000000000000000000000
  000000007FFFFFFFFFFFFFFFFFFFE000FFFFFFF8000000000000000000000000000000000000000000000000000000
  000000003FFFFFFFFFFFFFFFFFFFE000FFFFFFC0000000000000000000000000000000000000000000000000000000
  000000001FFFFFFFFFFFFFFFFFFFE000FFFFFF00000000000000000000000000000000000000000000000000000000
  0000000007FFFFFFFFFFFFFFFFFFE000FFFFF800000000000000000000000000000000000000000000000000000000
  0000000001FFFFFFFFFFFFFFFFFFE000FFFFE000000000000000000000000000000000000000000000000000000000
  00000000007FFFFFFFFFFFFFFFFFE000FFFF0000000000000000000000000000000000000000000000000000000000
  00000000001FFFFFFFFFFFFFFFFFE000FFF80000000000000000000000000000000000000000000000000000000000
  000000000007FFFFFFFFFFFFFFFFE000FFC00000000000000000000000000000000000000000000000000000000000
  000000000001FFFFFFFFFFFFFFFFE000FE000000000000000000000000000000000000000000000000000000000000
  0000000000003FFFFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
  00000000000007FFFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000FFFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
  000000000000000FFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
  0000000000000000FFFFFFFFFFFF8000F8000000000000000000000000000000000000000000000000000000000000
  000000000000000001FFFFFFFFC00000F8000000000000000000000000000000000000000000000000000000000000
  000000000000000000003FFC00000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
  000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
  000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
  000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
  000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:HOLD.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
  0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
  000000000000000000000001C0007FFFFF87FFC3FFFE0FFFE0000000000380003C0000000000000000000000000000
  00000000000000000000000FC0007FFFFF87FFC3FFFC0FFFF80000000007C0003C0000000000000000000000000000
  00000000000000000000003FC0007FFFFF87FFC3FFF87FFFFE0000000007C0003C0000000000000000000000000000
  00000000000000000E0001FFC0007FFFFF87FFC3FFF87FFFFF800000000380003C0000000000000000000000000000
  00000000000000000E000FFFC0007FFFFF87FFC3FFF87FFFFFC00000000000003C0000000000000000000000000000
  00000000000000000E003FFFC0007FFFFF87FFC3FFF87FFFFFF00000000000003C0000000000000000000000000000
  00000000000000000E00FFFFC0007FE01F87E043FFE00F80FE30000F7F0780FE3C38003C0E1EFE0000000000000000
  00000000000000000E03FFFFC0007FC00F87C003FFE00E003E00800FFF8783FE3C78003C0E1FFF0000000000000000
  00000000000000000E0FFFFFC0007F8787878783FFF87C3E1E01800FC7C787C03CF0003C0E1F0F0000000000000000
  00000000000000000E3FFFFFC0007F0FC3870FC3FFF87C3E1E1F800F83C787803DE0003C0E1E078000000000000000
  00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E1FC00F03E78F003FC0003C0E1E078000000000000000
  00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E1FE00F01E78F003FC0003C0E1E078000000000000000
  00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E3FF00F01E78F003FC0003C0E1E078000000000000000
  00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E3FF80F01E78F003DE0003C0E1E078000000000000000
  00000000000000000FFFFFFFC0007F0FC3870FC3FFF87C3F0E3FF80F03C78F803DF0003C1E1E078000000000000000
  00000000000000000FFFFFFFC0007F87C3870783FFF87C3E1E3FFC0F83C787803CF8001E1E1F0F8000000000000000
  00000000000000000FFFFFFFC0007F8387878303FFF87E1C3E3FFE0FC78783E63C7C001FFE1F9F0000000000000000
  00000000000000000FFFFFFFC0007FC00F87C003FFF87F007E3FFF0FFF0781FF3C3C001FFE1FFE0000000000000000
  00000000000000000FFFFFFFC0007FF03F87E0C3FFF87F80FE3FFF0F3E0380FE3C180007CE1EF80000000000000000
  00000000000000000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFF8F0000000000000000001E000000000000000000
  00000000000000000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFF8F0000000000000000001E000000000000000000
  00000000000000000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFCF0000000000000000001E000000000000000000
  0000000000000C000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFCF0000000000000000001E000000000000000000
  0000000000001C000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFEF0000000000000000001E000000000000000000
  0000000000007C000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFEF0000000000000000001E000000000000000000
  000000000000FC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000000000001FC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  000000000003FC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
  00000000000FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  00000000001FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  00000000003FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  00000000007FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000000000FFFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000000001FFFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000000003FFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000000007FFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  000000000FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  000000001FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  000000003FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  000000007FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000000FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000001FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000001FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000003FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  00000007FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000000FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
  0000001FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000001FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000003FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
  0000007FFFFFFC000FFFFFFFC0000000007FFFFFFFFFFFFFFFFFFFF870000000000000000000000000000000000000
  0000007FFFFFFC000FFFFFFFC0000000000FFFFFFFFFFFFFFFFFFFF878000000000000000000000000000000000000
  000000FFFFFFFC000FFFFFFFC00000000001FFFFFFFFFE1FFFFFFFF078000000000000000000000000000000000000
  000001FFFFFFFC000FFFFFFFC000000000007FFFFFFFFE1FFFFFFFF070000000000000000000000000000000000000
  000001FFFFFFFC000FFFFFFFC000000000003FFFFFFFFE1FFFFFFFF000000000000000000000000000000000000000
  000003FFFFFFFC000FFFFFFFC000000000000FFFFFF1FC1FF87FFE200003000007000E000000030000000000000000
  000003FFFFFFFC000FFFFFFFC000000000000FFFFF807803E01F000078F78003FFC07FC1E070F78000000000000000
  000007FFFFFFFC000FFFFFFFC0000000000007FFFF0C3803C30F000078FF8003FFE0FBE1E070FF8000000000000000
  000007FFFFFFFC000FFFFFFFC0000000000003FFFE1E1E1F8787078478FF0003E1E1E0F1E070FF0000000000000000
  00000FFFFFFFFC000FFFFFFFC00001FFE00001FFFE1F1E1F0F870F8478F80003C0F1E0F1E070F00000000000000000
  00000FFFFFFFFC000FFFFFFFC00001FFF80001FFFC001E1F00070F8678F00003C0F3C079E070F00000000000000000
  00001FFFFFFFFC000FFFFFFFC00001FFFE0001FFFC001E1F00070F8678F00003C0F3C079E070F00000000000000000
  00001FFFFFFFFC000FFFFFFFC00001FFFF0000FFFC1FFE1F07FF0F0678F00003C0F3C079E070F00000000000000000
  00001FFFFFFFFC000FFFFFFFC00001FFFF0000FFFC1FFE1F0FFF0F0678F00003C0F3C079E070F00000000000000000
  00003FFFFFFFFC000FFFFFFFC00001FFFF8000FFFE1FFE1F07FF0E0678F00003C0F1E0F1F0F0F00000000000000000
  00003FFFFFFFFC000FFFFFFFC00001FFFF8000FFFE0FFE1F83FF0E0678F00003E1E1E0F0F0F0F00000000000000000
  00003FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFF001E0BC00F0C0678F00003F3E0F1E0FFF0F00000000000000000
  00007FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFF801F01E00F0C0678F00003FFC07FC07FF0F00000000000000000
  00007FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFFE0FF87F83FF81E00000003CF001F003C00000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFFFFFFFFFFFFF81E00000003C00000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFFFFFFFFFFFFF00000000003C00000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF8000FFFFFFFFFFFFFFE00000000003C00000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF8000FFFFFFFFFFFFFFC00000000003C00000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF8001FFFFFFFFFFFFFFC00000000003C00000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF0001FFFFFFFFFFFFFF800000000003800000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FFFE0001FFFFFFFFFFFFFF000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0001FFFE0003FFFFFFFFFFFFFE000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0001FFF80003FFFFFFFFFFFFFC000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0001FFF00007FFFFFFFFFFFFFC000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0001FFC0000FFFFFFFFFFFFFF8000000000000000000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF00000000001FFFFFFFFFFFFFF0000000000C3C380000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF00000000003FFFFFFFFFFFFFE0000000001E3C780000000000000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF00000000007FFFFFFFFFFFFFC0000000003E3C780000100200000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0000000000FFFFFFFFFFFFFF80000000001E3C780000F01E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFFFFFFF0000000000003C780000F01E00000000000000000000
  0001FFFFFFFFFFFFFFFFFFFFFF0000000007FFFFFFFFFFFFFE0000000000003C780000F01E00000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0000000007FFFFFFFFFFFFFC3F9E0F01F81E3C780FC1FF7FE0FE0000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0000000007FFFFFFFFFFFFF8FF9E0F07FE1E3C783FF1FF7FE3FF0000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0000000003FFFFFFFFFFFFF1F11E0F0F0E1E3C787870F01E07878000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FF0003FFFFFFFFFFFFE3E01E0F0E0F1E3C787078F01E07838000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFF0001FF0001FFFFFFFFFFFFC3C01E0F1E0F1E3C78F078F01E07838000000000000000
  00007FFFFFFFFFFFFFFFFFFFFF0001FF8000FFFFFFFFFFFF03C01E0F1FFF1E3C78FFF8F01E0FFF8000000000000000
  00007FFFFFFFFFFFFFFFFFFFFF0001FF8000FFFFFFFFFFFE03C01E0F1FFF1E3C78FFF8F01E0FFF8000000000000000
  00007FFFFFFFFFFFFFFFFFFFFF0001FFC0007FFFFFFFFFFC03C01E0F1E001E3C78F000F01E0F000000000000000000
  00003FFFFFFFFFFFFFFFFFFFFF0001FFC0007FFFFFFFFFF803C01E0F1E001E3C78F000F01E07800000000000000000
  00003FFFFFFFFFFFFFFFFFFFFF0001FFE0003FFFFFFFFFE003E01F0F0F001E3C787800F01E07800000000000000000
  00001FFFFFFFFFFFFFFFFFFFFF0001FFE0001FFFFFFFFFC001F18F9F0F861E3C787C30781F03E18000000000000000
  00001FFFFFFFFFFFFFFFFFFFFF0001FFF0001FFFFFFFFF8000FF8FFF07FF1E3C783FF87F0FE1FF8000000000000000
  00000FFFFFFFFFFFFFFFFFFFFF0001FFF0000FFFFFFFFE00003F87E701FC1E3C380FE03F07E0FF0000000000000000
  00000FFFFFFFFFFFFFFFFFFFFF0001FFF8000FFFFFFFFC000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFF0001FFF80007FFFFFFF0000000000000000000000000000000000000000000000000
  000007FFFFFFFFFFFFFFFFFFFF0001FFFC0003FFFFFFE0000000000000000000000000000000000000000000000000
  000003FFFFFFFFFFFFFFFFFFFF0001FFFE0003FFFFFF80000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFF0001FFFE0001FFFFFF00000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFF0001FFFF0000FFFFFC00000000000000000000000000000000000000000000000000
  000000FFFFFFFFFFFFFFFFFFFF0001FFFF0000FFFFF000000000000000000000000000000000000000000000000000
  0000007FFFFFFFFFFFFFFFFFFF0001FFFF80007FFFE000000000000000000000000000000000000000000000000000
  0000003FFFFFFFFFFFFFFFFFFF0001FFFF80007FFF8000000000000000000000000000000000000000000000000000
  0000001FFFFFFFFFFFFFFFFFFF0001FFFFC0003FFE0000000000000000000000000000000000000000000000000000
  0000000FFFFFFFFFFFFFFFFFFF0001FFFFC0001FF80000000000000000000000000000000000000000000000000000
  00000007FFFFFFFFFFFFFFFFFF0001FFFFE0001FE00000000000000000000000000000000000000000000000000000
  00000003FFFFFFFFFFFFFFFFFF0001FFFFE0000F800000000000000000000000000000000000000000000000000000
  00000001FFFFFFFFFFFFFFFFFF0001FFFFF0000E000000000000000000000000000000000000000000000000000000
  000000007FFFFFFFFFFFFFFFFF0001FFFFF00004000000000000000000000000000000000000000000000000000000
  000000003FFFFFFFFFFFFFFFFF0001FFFFF8007E000000000000000000000000000000000000000000000000000000
  000000001FFFFFFFFFFFFFFFFFFFFFFFFFF81FFF000000000000000000000000000000000000000000000000000000
  0000000007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000000000000000
  0000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000000000000000
  00000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000000000000000000
  00000000001FFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000000000000000
  000000000007FFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000000000000000
  000000000001FFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000
  0000000000003FFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000
  00000000000007FFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000000000000000
  00000000000000FFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000000
  000000000000000FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000000
  0000000000000000FFFFFFFFFFFF800000000000000000000000000000000000000000000000000000000000000000
  000000000000000001FFFFFFFFC0000000000000000000000000000000000000000000000000000000000000000000
  000000000000000000003FFC0000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  ~DGR:OSNR.GRF,08225,047,
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
  00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
  0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
  000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
  0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
  000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
  000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
  00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
  0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
  000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
  00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
  00000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
  0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
  000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
  000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
  00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
  00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
  0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
  0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
  000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
  000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
  00000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
  00000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
  0000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
  0000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000
  0000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
  000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  000000000000000003FFFFFFFFFFFFF001FFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
  0000000000000000003FFFFFFFFFFF00003FFFFF003FFFFFFFFF0000003FFFFFFC0000000000000000000000000000
  00000000000000000007FFFFFFFFFC000007FFFF001FFFFFFFFF0000007FFFFFFFC000000000000000000000000000
  00000000000000000001FFFFFFFFF0000001FFFF000FFFFFFFFF0000007FFFFFFFF000000000000000000000000000
  000000000000000000007FFFFFFFC0000000FFFF0007FFFFFFFF0000007FFFFFFFFC00000000000000000000000000
  000000000000000000003FFFFFFF800000007FFF0003FFFFFFFF003E007FFFFFFFFF00000000000000000000000000
  000000000000000000000FFFFFFF000000007FFF0001FFFFFFFF003E007FFFFFFFFF80000000000000000000000000
  0000000000000000000007FFFFFE000000007FFF0001FFFFFFFF003E007FFFFFFFFFC0000000000000000000000000
  0000000000000000000003FFFFFC00000000FFFF0000FFFFFFFF003E007FFFFFFFFFE0000000000000000000000000
  0000000000000000000001FFFFFC0001FC01FFFF00007FFFFFFF003E007FFFFFFFFFE0000000000000000000000000
  000000000000003FFC0000FFFFF80007FF81FFFF00003FFFFFFF003E007FFE007FFFF0000000000000000000000000
  00000000000001FFFF00007FFFF8000FFFE3FFFF00001FFFFFFF003E007FFE000FFFF0000000000000000000000000
  00000000000003FFFFC0003FFFF8001FFFFFFFFF00000FFFFFFF003E007FFE0007FFF8000000000000000000000000
  0000000000000FFFFFE0001FFFF0003FFFFFFFFF00000FFFFFFF003E007FFE0003FFF8000000000000000000000000
  0000000000001FFFFFF0001FFFF0003FFFFFFFFF000007FFFFFF003E007FFE0001FFF8000000000000000000000000
  0000000000003FFFFFF8000FFFF0003FFFFFFFFF000003FFFFFF003E007FFE0001FFF8000000000000000000000000
  0000000000003FFFFFFC000FFFF0003FFFFFFFFF000001FFFFFF003E007FFE0000FFF8000000000000000000000000
  0000000000007FFFFFFC0007FFF0003FFFFFFFFF000000FFFFFF003E007FFE0000FFF8000000000000000000000000
  000000000000FFFFFFFE0007FFF0001FFFFFFFFF0000007FFFFF003E007FFE0000FFFC000000000000000000000000
  000000000000FFFFFFFF0003FFF0001FFFFFFFFF0000007FFFFF003E007FFE0000FFF8000000000000000000000000
  000000000001FFFFFFFF0003FFF8000FFFFFFFFF0010003FFFFF003E007FFE0000FFF8000000000000000000000000
  000000000001FFFFFFFF0001FFF80007FFFFFFFF0010001FFFFF003E007FFE0000FFF8000000000000000000000000
  000000000001FFFFFFFF8001FFF80003FFFFFFFF0018000FFFFF003E007FFE0000FFF8000000000000000000000000
  000000010003FFFFFFFF8001FFFC0001FFFFFFFF001C0007FFFF003E007FFE0000FFF8000000000000000000000000
  000000010003FFFFFFFF8000FFFC0000FFFFFFFF001E0007FFFF003E007FFE0001FFF8000000000000000000000000
  000000030003FFFFFFFFC000FFFE00007FFFFFFF001E0003FFFF003E007FFE0001FFF0000000000000000000000000
  000000060003FFFFFFFFC000FFFF00001FFFFFFF001F0001FFFF003E007FFE0003FFF0000000000000000000000000
  0000000E0003FFFFFFFFC000FFFF80000FFFFFFF001F8000FFFF003E007FFE0007FFF0000000000000000000000000
  0000001E0007FFFFFFFFC000FFFFC00007FFFFFF001FC0007FFF003E007FFE0007FFE0000000000000000000000000
  0000001E0007FFFFFFFFC000FFFFE00003FFFFFF001FC0003FFF003E007FFE001FFFE0000000000000000000000000
  0000003E0007FFFFFFFFC0007FFFF00000FFFFFF001FE0003FFF003E007FFE007FFFC0000000000000000000000000
  0000007E0007FFFFFFFFC0007FFFF800007FFFFF001FF0001FFF003E007FFE07FFFF80000000000000000000000000
  0000007E0007FFFFFFFFC0007FFFFC00003FFFFF001FF8000FFF003E007FFFFFFFFF00000000000000000000000000
  000000FE0007FFFFFFFFC0007FFFFE00001FFFFF001FF80007FF003E007FFFFFFFFE00000000000000000000000000
  000001FE0007FFFFFFFFC0007FFFFF80000FFFFF001FFC0007FF003E007FFFFFFFFC00000000000000000000000000
  000001FE0007FFFFFFFFC0007FFFFFC00007FFFF001FFE0003FF003E007FFFFFFFF800000000000000000000000000
  000003FE0007FFFFFFFFC000FFFFFFF00003FFFF001FFF0001FF003E007FFFFFFFF000000000000000000000000000
  000003FE0007FFFFFFFFC000FFFFFFF80001FFFF001FFF8000FF003E007FFFFFFFE000000000000000000000000000
  000007FE0007FFFFFFFFC000FFFFFFFC0000FFFF001FFF80007F003E007FFFFFFFE000000000000000000000000000
  000007FE0003FFFFFFFFC000FFFFFFFF00007FFF001FFFC0007F003E007FFFFFFFF000000000000000000000000000
  00000FFF0003FFFFFFFFC000FFFFFFFF80007FFF001FFFE0003F003E007FFE03FFF000000000000000000000000000
  00000FFF0003FFFFFFFFC000FFFFFFFFC0003FFF001FFFF0001F003E007FFE01FFF800000000000000000000000000
  00001FFF0003FFFFFFFF8000FFFFFFFFE0003FFF001FFFF8000F003E007FFE00FFF800000000000000000000000000
  00001FFF0003FFFFFFFF8001FFFFFFFFF0001FFF001FFFF8000F003E007FFE00FFFC00000000000000000000000000
  00001FFF0001FFFFFFFF8001FFFFFFFFF0001FFF001FFFFC0007003E007FFE007FFE00000000000000000000000000
  00003FFF8001FFFFFFFF0001FFFFFFFFF8001FFF001FFFFE0003003E007FFE007FFE00000000000000000000000000
  00003FFF8001FFFFFFFF0003FFFFFFFFF8001FFF001FFFFF0001003E007FFE003FFF00000000000000000000000000
  00003FFF8000FFFFFFFF0003FFFFFFFFFC000FFF001FFFFF8000003E007FFE003FFF00000000000000000000000000
  00007FFFC000FFFFFFFE0003FFFFFFFFFC000FFF001FFFFFC000003E007FFE001FFF80000000000000000000000000
  00007FFFC0007FFFFFFE0007FFFFFFFFFC000FFF001FFFFFC000003E007FFE001FFF80000000000000000000000000
  00007FFFE0003FFFFFFC0007FFFFFFFFFC000FFF001FFFFFE000003E007FFE000FFFC0000000000000000000000000
  0000FFFFE0003FFFFFF8000FFFFFFFFFFC000FFF001FFFFFF000003E007FFE000FFFC0000000000000000000000000
  0000FFFFF0001FFFFFF8000FFFFFFFFFFC001FFF001FFFFFF800003E007FFE000FFFE0000000000000000000000000
  0000FFFFF8000FFFFFF0001FFFFFFFFFF8001FFF001FFFFFFC00003E007FFE0007FFF0000000000000000000000000
  0000FFFFF80007FFFFE0003FFFFCFFFFF8001FFF001FFFFFFC00003E007FFE0007FFF0000000000000000000000000
  0000FFFFFC0003FFFF80003FFFF87FFFF0001FFF001FFFFFFE00003E007FFE0003FFF8000000000000000000000000
  0000FFFFFE0000FFFE00007FFFF01FFFE0003FFF001FFFFFFF00003E007FFE0003FFF8000000000000000000000000
  0001FFFFFF00001FF80000FFFFF007FF80003FFF001FFFFFFF80003E007FFE0001FFFC000000000000000000000000
  0001FFFFFF800000000001FFFFE0007C00007FFF001FFFFFFFC0003E007FFE0001FFFC000000000000000000000000
  0001FFFFFFC00000000003FFFFC000000000FFFF001FFFFFFFE0003E007FFE0000FFFE000000000000000000000000
  0001FFFFFFE00000000007FFFFC000000001FFFF001FFFFFFFF0003E007FFE0000FFFE000000000000000000000000
  0001FFFFFFF0000000001FFFFFC000000003FFFF001FFFFFFFF0003E007FFE00007FFF000000000000000000000000
  0001FFFFFFF8000000003FFFFFE000000007FFFF001FFFFFFFE0003E007FFE00007FFF800000000000000000000000
  0001FFFFFFFE00000000FFFFFFF80000000FFFFF001FFFFFFFC0003E007FFE00003FFF800000000000000000000000
  0001FFFFFFFF80000001FFFFFFFE0000003FFFFF001FFFFFFF80003E007FFE00003FFFC00000000000000000000000
  0001FFFFFFFFE000000FFFFFFFFF800000FFFFFF001FFFFFFF00003E007FFE00001FFF000000000000000000000000
  0001FFFFFFFFFE00007FFFFFFFFFF00007FFFFFF803FFFFFFE00003E003FFC00001FC0000000000000000000000000
  0000FFFFFFFFFFF01FFFFFFFFFFFFFC0FFFFFFFFFFFFFFFFFC003FFE00000000000800000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8001FFE00000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000FFE00000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE00007FC00000000000000000000000000000000000000
  0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000000
  00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000
  00007FFFE3FFFFCFFFFFFFFFFFFFFFF9FFFFFFFFFFFFFFFE018000000C0300000009800000C0480000000000000000
  00007FFFCBFFFFCFFFFFFFFFFFFFFFF9FFFFFFFFFFFFFFFC0180080008000000000900000000498000000000000000
  00003FFFCFCE9E4E75F9D9D3AE77F3C9FFFFFFFFFFFFFFF803C41C3028C302418A090C4160C3C9C622500000000000
  00003FFFC7244C8931F4C4898C932491FFFFFFFFFFFFFFE0024CCCC9E98D8332CE083679B366CD8D32780000000000
  00001FFFF304E9C837F84C9C99934099FFFFFFFFFFFFFFC0026CC8CD898D8331C80836711B6C4D9DB2600000000000
  00001FFFF93CE9C9F7F64C9CB9D84799FFFFFFFFFFFFFF8007ECC88D88CC0336C80830311B0C4D9832600000000000
  00000FFFF93CECC9F7E44C99B998E799FFFFFFFFFFFFFE00042CC8CD886C0336C80830599B0CCD8832600000000000
  00000FFFC384EC0C37F04183BC3CE0C1FFFFFFFFFFFFFC000C37CE7989C783E7C8081ECDF1E7C8EF3E600000000000
  000007FFFFFFFFFFFFFFCF9FFFFFFFFFFFFFFFFFFFFFF0000000000000000300000000010000000000000000000000
  000007FFFFFFFFFFFFFFCF9FFFFFFFFFFFFFFFFFFFFFE0000000000000000300000000010000000000000000000000
  000003FFFFFFFFFFFFFFDF9FFFFFFFFFFFFFFFFFFFFF80000000000000000200000000010000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000
  000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000000
  000000FFFCFFFFFFFFFFFFFFFFFFFFFFFE7FFFDFFFF000000000001800000000000000000000000180000000000000
  0000007FFEFFFFFE7FFFFFFFFE7FFFFFFF7FFFDFFFE000000000000000000800000000000000000000000000000000
  0000003FC4C1838426421F070C3E31C1BB611C1FFF800000000001D9F3E39E89EE07C79F83DE3EC99CF00000000000
  0000001F9CC899E66644CF32667C64993366699FFE0000000000031B3320C88999066CD9833266CDB1900000000000
  0000000FCC9C9986664C0F32727CC099336E09DFF80000000000019B1233C8899F066CD8833FC6CD99F00000000000
  00000007E49C9926664CFF32767CE799336E79DFE0000000000180DB1236C88998066CD8833046CD8D800000000000
  00000003E4C89926644E7F33267CE799936E689F80000000000000DB3236CCD998066CD883386EDD8D800000000000
  00000001CEE0B99730CF1F3B8F3EF1C18B6F0C5E0000000000000188F2224E6907040308820E366918700000000000
  000000007FFDFFFFFFFFFFFFFFFFFFF9FFFFFFF8000000000000000030000000000000000000060000000000000000
  000000003FC1FFFFFFFFFFFFFFFFFFF9FFFFFFC00000000000000001E0000000000000000000060000000000000000
  000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000000000
  0000000007FFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000000000000000
  0000000001FFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000
  00000000007FFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000000000000000
  00000000001FFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000000000000000
  000000000007FFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000000000000000
  000000000001FFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000
  0000000000003FFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000
  00000000000007FFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000000000000000
  00000000000000FFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000000
  000000000000000FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000000
  0000000000000000FFFFFFFFFFFF800000000000000000000000000000000000000000000000000000000000000000
  000000000000000001FFFFFFFFC0000000000000000000000000000000000000000000000000000000000000000000
  000000000000000000003FFC0000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
  0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</ZPLCode>
           </GetZPLInitializationImagesResult>
        </GetZPLInitializationImagesResponse>
     </soap:Body>
  </soap:Envelope>
            <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <GetZPLInitializationImagesResponse xmlns="http://PurolatorServices.com/">
         <GetZPLInitializationImagesResult>
            <Status>0</Status>
            <ZPLCode>~DGR:PCLLOGO,02295,045,000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
000000000001E07FFFF003FFFC0000000000000000000000000000000000000000000000000000000000000000
00000000000FE07FFFE003FFFFF000000000000000000000000000000000000000000000000000000000000000
00000000001FC0FFFFE007FFFFFE00000000000000000000000000000000000000000000000000000000000000
00000000003FC0FFFFC007FFFFFF00000000000000000000000000000000000000000000000000000000000000
00000000007F81FFFFC00FFFFFFF80000000000000000000000000003FE000000000007FC00000000000000000
0000000000FF81FFFF800FFFFFFF80000000000000000000000000007FE00000000000FF800000000000000000
0000000000FF03FFFF801FFFFFFFC000000000000000000000000000FFC00000000001FF800000000000000000
0000000000FF03FFFF001FFC3FFFC000000000000000000000000001FFC00000000003FF000000000000000000
0000000001FE07FFFF003FF803FFC000000000000000000000000003FF800000000007FF000000000000000000
0000000001FE07FFFF003FF801FFC000000000000000000000000003FF800000000007FF000000000000000000
0000000003FC07FFFE007FF001FFC000000000000000000000000003FF00000000000FFE000000000000000000
0000000003FC0FFFFE007FF001FFC000000000000000000000000007FF00000000000FFE000000000000000000
0000000007F80FFFFC00FFE001FF8000000000000000000000000007FE00000000000FFC000000000000000000
0000000007F81FFFFC00FFE001FF83FF801FFC07FC0FC001FFF0000FFE000FFFE003FFFFF0001FFF0000FF81F8
000000000FF81FFFF800FFC003FF87FF001FF807FC3FC00FFFFC000FFC00FFFFF003FFFFF0007FFFC000FF87F8
000000000FF03FFFF801FFC003FF07FF003FF80FF8FF803FFFFE001FFC03FFFFF807FFFFE003FFFFE001FF0FF0
000000001FF03FFFF001FF8007FF0FFE003FF00FF9FF807FFFFF001FF807FFFFFC07FFFFE007FFFFF001FF3FF0
000000001FE07FFFF003FF8007FF0FFE007FF01FFBFF01FFFFFF003FF807FFFFFC0FFFFFC01FFFFFF003FF7FE0
000000003FE07FFFE003FF000FFE0FFC007FE01FFFFF03FFFFFF003FF80FFFFFFC0FFFFFC03FFFFFF803FFFFE0
000000003FC0FFFFE007FF001FFC1FFC00FFE03FFFFE07FFFFFF807FF00FFCFFFC0FFFFF807FFFFFF807FFFFC0
000000007FC0FFFFC007FE003FFC1FF800FFC03FFFFE0FFE07FF807FF01F003FFC01FFE000FFF07FF807FFFFC0
000000007F81FFFFC00FFE00FFF83FF801FFC03FFFFC1FFC07FF80FFE018001FFC01FFC001FFC07FF807FFFF80
000000007F81FFFF800FFE07FFF03FF001FFC07FFF803FF803FF80FFE000001FFC01FF8003FF803FF80FFFF000
00000000FF03FFFF801FFFFFFFE07FF003FF807FFC007FF003FF81FFC000001FFC03FF8007FF003FF80FFF8000
00000000FF03FFFF801FFFFFFFC07FE003FF80FFF800FFE003FF81FFC000001FF803FF800FFE003FF81FFF0000
00000001FE03FFFF003FFFFFFF80FFE007FF00FFF001FFC007FF01FF800003FFF807FF001FFC003FF01FFE0000
00000001FE07FFFF003FFFFFFE00FFE007FF01FFE001FF8007FF03FF8000FFFFF807FF001FF8007FF03FFC0000
3FFFFF03FE07FFFE007FFFFFFC01FFC00FFE01FFC003FF8007FF03FF0007FFFFF007FE003FF8007FF03FF80000
7FFFFF03FC0FFFFE007FFFFFF001FFC00FFE03FF8007FF000FFE07FF001FFFFFF00FFE007FF0007FF07FF00000
7FFFFE07FC0FFFFC007FFFFF8003FF800FFC03FF8007FF000FFE07FE007FFFFFE00FFC007FF000FFE07FF00000
3FFFFE07F81FFFFC00FFFFE00003FF801FFC07FF000FFE000FFE0FFE01FFFFFFE01FFC00FFE000FFE0FFE00000
1FFFFC0FF81FFFF800FFC0000007FF001FF807FF000FFE001FFC0FFC03FFFDFFC01FF800FFE001FFC0FFE00000
0FFFFC0FF03FFFF801FFC0000007FF003FF80FFE001FFC001FFC1FFC07FF81FFC03FF800FFC001FFC1FFC00000
07FFF81FF03FFFF001FF80000007FE003FF00FFE001FFC003FF81FFC0FFE01FF803FF001FFC003FF81FFC00000
03FFF81FE07FFFF003FF8000000FFE007FF01FFC001FF8007FF03FF81FF803FF807FF001FFC003FF81FF800000
01FFF01FE07FFFE003FF0000000FFC007FE01FFC003FF8007FF03FF83FF003FF007FE001FF8007FF03FF800000
00FFF03FC0FFFFE007FF0000001FFC00FFE01FF8003FF800FFE07FF07FF007FF00FFE003FF800FFE03FF000000
007FE03FC0FFFFC007FE0000001FFC01FFE03FF8003FF801FFC07FF07FE007FE00FFE003FF800FFE07FF000000
003FE07F80FFFFC00FFE0000001FFC01FFC03FF0003FF801FFC0FFE0FFE00FFE00FFC003FF801FFC07FE000000
001FE07F81FFFFC00FFE0000003FFC07FFC07FF0003FF807FF80FFE0FFC01FFE01FFE003FF803FF80FFE000000
000FC0FF01FFFF801FFC0000003FFE1FFF807FE0003FF80FFF00FFC0FFE03FFC01FFE003FF80FFF00FFC000000
0007C0FF03FFFF801FFC0000003FFFFFFF80FFE0003FFC3FFE01FFC1FFE0FFFC01FFFF03FFC1FFE01FFC000000
000381FF03FFFF003FF80000003FFFFFFF00FFC0003FFFFFFC01FF81FFFFFFF803FFFF03FFFFFFC01FF8000000
000181FE07FFFF003FF80000003FFFFFFF01FFC0003FFFFFF003FF81FFFFFFF803FFFE03FFFFFF803FF8000000
000003FE07FFFE003FF00000003FFFFFFE01FF80003FFFFFE003FF01FFFFFFF003FFFE01FFFFFE003FF8000000
000003FC0FFFFE007FE00000003FFFF3FE03FF80001FFFFFC007FF01FFFFFFF003FFFC01FFFFFC007FF0000000
000007FC0FFFFC007FE00000003FFFC7FE03FF00000FFFFF0007FE00FFFF3FE001FFFC00FFFFF0007FE0000000
000007F81FFFF000FF800000001FFF07FC07FE000007FFFC000FFC007FFC3FE000FFF8007FFFC000FFC0000000
00000FF81FFFC000FC000000000FFC0FFC07F0000001FFC0000FC0003FE07FE0007FF0001FFE0000FE00000000
000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:9AM.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
00000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
00000000000000000FFFFFFFFFFF0001FFFFFFFFFFFFFFFFFFFFF0000000000000000000000070F800000000000000
00000000000000003FFFFFFFFFC0000003FFFFFFFFFFFFFFFFFFF8000003E000FE00003F000070F800000000000000
0000000000000000FFFFFFFFFC000000003FFFFFFFFFFFFFFFFFF8000003F000FF00007F8000F0F800000000000000
0000000000000001FFFFFFFFE00000000007FFFFFFFFFFFFFFFFFC000007F000FF00007F8000E0F800000000000000
0000000000000007FFFFFFFF800000000001FFFFFFFFFFFFFFFFFE000007F000FF8000FF8000E0F800000000000000
000000000000001FFFFFFFFC0000000000007FFFFFFFFFFFFFFFFF000007F800FF8000FF8001C0F800000000000000
000000000000003FFFFFFFF00000000000001FFFFFFFFFFFFFFFFF00000FF800FFC001FF8001C0F800000000000000
00000000000000FFFFFFFFE000000000000007FFFFFFFFFFFFFFFF80000FFC00FFC001FF800380F800000000000000
00000000000001FFFFFFFF8000000000000001FFFFFFFFFFFFFFFF80001E7C00FFE003DF800380F83C000000000000
00000000000007FFFFFFFF0000000000000000FFFFFFFFFFFFFFFFC0001E7E00FBE003DF800780F9FF800000000000
0000000000000FFFFFFFFC00000000000000007FFFFFFFFFFFFFFFC0003E7E00FBF0079F800700FFFFC00000000000
0000000000001FFFFFFFF800000000000000003FFFFFFFFFFFFFFFE0003C3E00F9F0079F800700FFFFC00000000000
0000000000007FFFFFFFF000000000000000001FFFFFFFFFFFFFFFE0007C3F00F9F00F1F800E00FE0FE00000000000
000000000000FFFFFFFFE000000007C000000007FFFFFFFFFFFFFFF0007C1F00F8F80F1F800E00FC07E00000000000
000000000001FFFFFFFFC0000000FFFE00000007FFFFFFFFFFFFFFF000F81F80F8F81F1F801C00F803E00000000000
000000000003FFFFFFFF80000003FFFF80000003FFFFFFFFFFFFFFF000F81F80F87C1E1F801C00F803E00000000000
00000000000FFFFFFFFF0000000FFFFFE0000001FFFFFFFFFFFFFFF800F00F80F87C3E1F801C00F803E00000000000
00000000001FFFFFFFFE0000001FFFFFF0000000FFFFFFFFFFFFFFF801FFFFC0F87E3C1F803800F803E00000000000
00000000003FFFFFFFFC0000003FFFFFFC000000FFFFFFFFFFFFFFF801FFFFC0F83E7C1F803800F803E00000000000
00000000007FFFFFFFFC0000007FFFFFFE0000007FFFFFFFFFFFFFF803FFFFE0F83E781F807000F803E00000000000
0000000000FFFFFFFFF8000000FFFFFFFF0000003FFFFFFFFFFFFFFC03E007E0F81FF81F807000F803E00000000000
0000000001FFFFFFFFF0000001FFFFFFFF0000003FFFFFFFFFFFFFFC07C007E0F81FF01F80F000F803E00000000000
0000000003FFFFFFFFF0000003FFFFFFFF8000001FFFFFFFFFFFFFFC07C003F0F80FF01F80E000F803E00000000000
0000000007FFFFFFFFE0000003FFFFFFFFC000001FFFFFFFFFFFFFFC0F8003F0F80FE01F80E000F803E00000000000
000000000FFFFFFFFFE0000007FFFFFFFFC000000FFFFFFFFFFFFFFC0F8003F8F807E01F81C000F803E00000000000
000000001FFFFFFFFFC0000007FFFFFFFFE000000FFFFFFFFFFFFFFC0F8001F8F807C01F81C000F803E00000000000
000000003FFFFFFFFFC000000FFFFFFFFFE0000007FFFFFFFFFFFFFC1F0001FCF803C01F838000F803E00000000000
000000007FFFFFFFFF8000000FFFFFFFFFE0000007FFFFFFFFFFFFFC00000000000000000380000000000000000000
00000000FFFFFFFFFF8000000FFFFFFFFFF0000007FFFFFFFFFFFFFC00000000000000000780000000000000000000
00000001FFFFFFFFFF8000001FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000700000000000000000000
00000001FFFFFFFFFF0000001FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000700000000000000000000
00000003FFFFFFFFFF0000001FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000000000000000000000000
00000007FFFFFFFFFF0000003FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000000000000000000000000
0000000FFFFFFFFFFF0000003FFFFFFFFFF0000003FFFFFFFFFFFFFC00000000000000000000000000000000000000
0000001FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
0000001FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
0000003FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
0000007FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
0000007FFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF800000000000000000000000000000000000000
000000FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF000000000000000000000000000000000000000
000001FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF000000000000000000000000000000000000000
000001FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFF000000000000000000000000000000000000000
000003FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFE000000000000000000000000000000000000000
000003FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFE000000000000000000000000000000000000000
000007FFFFFFFFFFFE0000003FFFFFFFFFF0000001FFFFFFFFFFFFE000000000000000000000000000000000000000
000007FFFFFFFFFFFF0000001FFFFFFFFFF0000001FFFFFFFFFFFFC000000000000000000000000000000000000000
00000FFFFFFFFFFFFF0000001FFFFFFFFFE0000001FFFFFFFFFFFFC000000000000000000000000000000000000000
00000FFFFFFFFFFFFF0000001FFFFFFFFFE0000001FFFFFFFFFFFF8000000000000000000000000000000000000000
00001FFFFFFFFFFFFF0000001FFFFFFFFFE0000001FFFFFFFFFFFF8000000000000000000000000000000000000000
00001FFFFFFFFFFFFF8000000FFFFFFFFFC0000001FFFFFFFFFFFF0000000000000000000000000000000000000000
00001FFFFFFFFFFFFF8000000FFFFFFFFFC0000001FFFFFFFFFFFF0000000000000000000000000000000000000000
00003FFFFFFFFFFFFF80000007FFFFFFFF80000003FFFFFFFFFFFE0000000000000000000000000000000000000000
00003FFFFFFFFFFFFFC0000007FFFFFFFF80000003FFFFFFFFFFFE0000000000000000000000000000000000000000
00003FFFFFFFFFFFFFC0000003FFFFFFFF00000003FFFFFFFFFFFC0000000000000000000000000000000000000000
00007FFFFFFFFFFFFFE0000001FFFFFFFF00000003FFFFFFFFFFFC0000000000000000000000000000000000000000
00007FFFFFFFFFFFFFE0000000FFFFFFFE00000003FFFFFFFFFFF80000000000000000000000000000000000000000
00007FFFFFFFFFFFFFF00000007FFFFFFC00000007FFFFFFFFFFF00000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFF80000003FFFFFF800000007FFFFFFFFFFF00000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFF80000001FFFFFE000000007FFFFFFFFFFE00000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFC00000007FFFF8000000007FFFFFFFFFFC00000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFE00000001FFFE000000000FFFFFFFFFFFC00000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF000000003FE0000000000FFFFFFFFFFF800000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF800000000000000000000FFFFFFFFFFF000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFC00000000000000000001FFFFFFFFFFE000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFE00000000000000000001FFFFFFFFFFC000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFF00000000000000000001FFFFFFFFFFC000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFF80000000000000000003FFFFFFFFFF8000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFE0000000000000000003FFFFFFFFFF0000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFF0000000000000000007FFFFFFFFFE0000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFC000000000000000007FFFFFFFFFC0000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFF000000000000000007FFFFFFFFF80000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFE000000000C000000FFFFFFFFFF00000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFC00000007C000000FFFFFFFFFE00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFC000007F8000001FFFFFFFFFC00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000003FFFFFFFFF800000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000003FFFFFFFFF000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000007FFFFFFFFE000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE0000007FFFFFFFFC000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000FFFFFFFFF0000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFC000001FFFFFFFFE0000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFF8000001FFFFFFFFC0000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFFFFFFFFFFFFF8000003FFFFFFFF80000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFFFFFFFFFFFFF0000007FFFFFFFE00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFFFFFFFFFFFFE0000007FFFFFFFC00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFFFFFFFFFFFFC000000FFFFFFFF800000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFFFFFFFFFFFF8000001FFFFFFFE000000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFFFFFFFFFFFF0000003FFFFFFFC000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFFFFFFE0000007FFFFFFF0000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFFFFFFC0000007FFFFFFE0000000000000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFFFFFFFFFFF8000000FFFFFFF80000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFFFF00000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFFE0000003FFFFFFC00000000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFFFFFFFFFFFC0000007FFFFFF000000000000000000000000000000000000000000000000000
0000007FFFFFFFFFFFFFFFFFFFFFF8000000FFFFFFE000000000000000000000000000000000000000000000000000
0000003FFFFFFFFFFFFFFFFFFFFFE0000001FFFFFF8000000000000000000000000000000000000000000000000000
0000001FFFFFFFFFFFFFFFFFFFFFC0000003FFFFFE0000000000000000000000000000000000000000000000000000
0000000FFFFFFFFFFFFFFFFFFFFF00000007FFFFF80000000000000000000000000000000000000000000000000000
00000007FFFFFFFFFFFFFFFFFFFE0000001FFFFFE00000000000000000000000000000000000000000000000000000
00000003FFFFFFFFFFFFFFFFFFF80000003FFFFF800000000000000000000000000000000000000000000000000000
00000001FFFFFFFFFFFFFFFFFFE00000007FFFFE000000000000000000000000000000000000000000000000000000
000000007FFFFFFFFFFFFFFFFFC0000000FFFFF8000000000000000000000000000000000000000000000000000000
000000003FFFFFFFFFFFFFFFFF00000003FFFFC0000000000000000000000000000000000000000000000000000000
000000001FFFFFFFFFFFFFFFF800000007FFFF00000000000000000000000000000000000000000000000000000000
0000000007FFFFFFFFFFFFFFE00000000FFFF800000000000000000000000000000000000000000000000000000000
0000000001FFFFFFFFFFFFFF000000003FFFE000000000000000000000000000000000000000000000000000000000
00000000007FFFFFFFFFFFF8000000007FFF0000000000000000000000000000000000000000000000000000000000
00000000001FFFFFFFFFFFC000000001FFF80000000000000000000000000000000000000000000000000000000000
000000000007FFFFFFFFF80000000007FFC00000000000000000000000000000000000000000000000000000000000
000000000001FFFFFFFF80000000000FFE000000000000000000000000000000000000000000000000000000000000
0000000000003FFFFFFF80000000003FE0000000000000000000000000000000000000000000000000000000000000
00000000000007FFFFFF8000000000FFC0000000000000000000000000000000000000000000000000000000000000
00000000000000FFFFFF8000000003FF00000000000000000000000000000000000000000000000000000000000000
000000000000000FFFFF800000000FFC00000000000000000000000000000000000000000000000000000000000000
0000000000000000FFFF800000007FF000000000000000000000000000000000000000000000000000000000000000
000000000000000001FF80000001FFC000000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000FFF0000000000000000000000000000000000000000000000000000000000000000
000000000000000000000000003FFC0000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000003FFE00000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000001FFF800000000000000000000000000000000000000000000000000000000000000000
000000000000000000000001FFFC000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000003FFFE0000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000007FFFE00000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000007FFE000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000007FC0000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:10AM.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
00000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000C00000C0000000000000000000000000000
00000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00001FFE000FF8000000000000000000000000000
00000000000000003FFFFF00001FFFFFFFFFF007FFFFFFFFFFFFF80007FFF001FFE000000000000000000000000000
0000000000000000FFFFFC00001FFFFFFFFE00003FFFFFFFFFFFF80003FFF803FFF000000000000000000000000000
0000000000000001FFFFE000001FFFFFFFF0000007FFFFFFFFFFFC000303FC07E3F800000000000000000000000000
0000000000000007FFFF8000001FFFFFFF80000000FFFFFFFFFFFE000001FC0FC1F800000000000000000000000000
000000000000001FFFFC0000001FFFFFFF000000007FFFFFFFFFFF000000FC0FC0FC00000000000000000000000000
000000000000003FFFF00000001FFFFFFC000000001FFFFFFFFFFF000000FC1F80FC00000000000000000000000000
00000000000000FFFFC00000001FFFFFF0000000000FFFFFFFFFFF800000FC1F807E00000000000000000000000000
00000000000001FFFE000000001FFFFFE00000000003FFFFFFFFFF800001F81F807E00000000000000000000000000
00000000000007FFF8000000001FFFFFC00000000001FFFFFFFFFFC00003F03F807E00000000000000000000000000
0000000000000FFFC0000000001FFFFF800000000000FFFFFFFFFFC0000FE03F007E00000000000000000000000000
0000000000001FFF00000000001FFFFF0000000000007FFFFFFFFFE000FF803F007E00000000000000000000000000
0000000000007FF800000000001FFFFE0000000000003FFFFFFFFFE000FFE03F007E00000000000000000000000000
000000000000FFE000000000001FFFFC0000000000001FFFFFFFFFF000FFF83F007E00000000000000000000000000
000000000001FFF000000000001FFFF80000000000000FFFFFFFFFF00003FC3F007E00000000000000000000000000
000000000003FFF000000000001FFFF000000000000007FFFFFFFFF00000FE3F007E00000000000000000000000000
00000000000FFFF000000000001FFFF000000780000007FFFFFFFFF800007E1F807E00000000000000000000000000
00000000001FFFF800001000001FFFE000003FF0000003FFFFFFFFF800007F1F807E00000000000000000000000000
00000000003FFFF800007000001FFFC000007FFC000001FFFFFFFFF800007F1F807E00000000000000000000000000
00000000007FFFF80003F000001FFFC00001FFFE000001FFFFFFFFF800007F1F80FC00000000000000000000000000
0000000000FFFFF8000FF000001FFF800003FFFF000000FFFFFFFFFC00007E0FC0FC00000000000000000000000000
0000000001FFFFFC007FF000001FFF800003FFFF8000007FFFFFFFFC0000FE0FC1F800000000000000000000000000
0000000003FFFFFC01FFF000001FFF000007FFFFC000007FFFFFFFFC0201FC07E3F800000000000000000000000000
0000000007FFFFFC0FFFF000001FFF00000FFFFFC000003FFFFFFFFC03FFFC03FFF000000000000000000000000000
000000000FFFFFFE3FFFF000001FFE00000FFFFFE000003FFFFFFFFC07FFF001FFE000000000000000000000000000
000000001FFFFFFFFFFFF000001FFE00001FFFFFE000001FFFFFFFFC03FFE000FF8000000000000000000000000000
000000003FFFFFFFFFFFF000001FFC00001FFFFFF000001FFFFFFFFC001E00001C0000000000000000000000000000
000000007FFFFFFFFFFFF000001FFC00003FFFFFF000001FFFFFFFFC00000000000000000000000000000000000000
00000000FFFFFFFFFFFFF000001FF800003FFFFFF800000FFFFFFFFC00000000000000000000000000000000000000
00000001FFFFFFFFFFFFF000001FF800007FFFFFF800000FFFFFFFFC00000000000000000000000000000000000000
00000001FFFFFFFFFFFFF000001FF800007FFFFFF8000007FFFFFFFC00000000000000000000000000000000000000
00000003FFFFFFFFFFFFF000001FF000007FFFFFFC000007FFFFFFFC00000000000000000000000000000000000000
00000007FFFFFFFFFFFFF000001FF000007FFFFFFC000007FFFFFFFC00000000000000000000000000000000000000
0000000FFFFFFFFFFFFFF000001FF00000FFFFFFFC000007FFFFFFFC00000000000000000000000000000000000000
0000001FFFFFFFFFFFFFF000001FE00000FFFFFFFC000003FFFFFFF800000000000000000000000000000000000000
0000001FFFFFFFFFFFFFF000001FE00000FFFFFFFE000003FFFFFFF800000000000000000000000000000000000000
0000003FFFFFFFFFFFFFF000001FE00000FFFFFFFE000003FFFFFFF800000000000000000000000000000000000000
0000007FFFFFFFFFFFFFF000001FE00001FFFFFFFE000001FFFFFFF800000000000000000000000000000000000000
0000007FFFFFFFFFFFFFF000001FC00001FFFFFFFE000001FFFFFFF80000000000000000000030F800000000000000
000000FFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001FFFFFFF00000000000000000000070F800000000000000
000001FFFFFFFFFFFFFFF000001FC00001FFFFFFFF000001FFFFFFF00003F000FF00007F8000F0F800000000000000
000001FFFFFFFFFFFFFFF000001FC00001FFFFFFFF000001FFFFFFF00007F000FF00007F8000E0F800000000000000
000003FFFFFFFFFFFFFFF000001F800001FFFFFFFF000000FFFFFFE00007F000FF8000FF8000E0F800000000000000
000003FFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFE00007F800FF8000FF8001E0F800000000000000
000007FFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFE0000FF800FFC001FF8001C0F800000000000000
000007FFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFC0000FFC00FFC001FF8003C0F800000000000000
00000FFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFFC0001F7C00FFE003FF800380F800000000000000
00000FFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFF80001E7C00FBE003DF800380F8FF000000000000
00001FFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFFFF80003E7E00FBE007DF800700FBFF800000000000
00001FFFFFFFFFFFFFFFF000001F800003FFFFFFFF0000007FFFFF00003E3E00F9F0079F800700FFFFC00000000000
00001FFFFFFFFFFFFFFFF000001F000003FFFFFFFF0000007FFFFF00007C3F00F9F00F9F800F00FF1FE00000000000
00003FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFE00007C3F00F9F80F1F800E00FC07E00000000000
00003FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFE0000781F00F8F81F1F801E00FC07E00000000000
00003FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFC0000F81F80F8FC1E1F801C00F803E00000000000
00007FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFFC0000F81F80F87C3E1F801C00F803E00000000000
00007FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFF80001FFFFC0F87E3C1F803800F803E00000000000
00007FFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFF00001FFFFC0F83E3C1F803800F803E00000000000
0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFF00003FFFFE0F83E781F807800F803E00000000000
0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFE00003FFFFE0F81F781F807000F803E00000000000
0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFC00007C007E0F81FF01F80F000F803E00000000000
0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFFC00007C007F0F81FF01F80E000F803E00000000000
0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFF800007C003F0F80FE01F80E000F803E00000000000
0000FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFF00000F8003F8F80FE01F81E000F803E00000000000
0001FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF8000007FFE00000F8003F8F807C01F81C000F803E00000000000
0001FFFFFFFFFFFFFFFFF000001F000003FFFFFFFF0000007FFC00001F0001F8F807C01F83C000F803E00000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFFC00001F0001FCF803801F838000F803E00000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFF8000000000000000000000380000000000000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFF0000000000000000000000700000000000000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFE0000000000000000000000700000000000000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FFC0000000000000000000000F00000000000000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FF80000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFF000001F800003FFFFFFFF000000FF00000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFF000001F800001FFFFFFFF000000FE00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFF000001F800001FFFFFFFF000000FC00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFF000001F800000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001F000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001F000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001F000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFF000001FC00001FFFFFFFE000001E000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFF000001FE00000FFFFFFFE000003E000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFF000001FE00000FFFFFFFE000003E000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFF000001FE00000FFFFFFFC000003E000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFF000001FE00000FFFFFFFC000003E000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFF000001FF00000FFFFFFFC000007C000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFF000001FF000007FFFFFFC000007C000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFF000001FF000007FFFFFF8000007C000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFF000001FF800007FFFFFF800000FC000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFF000001FF800003FFFFFF800000F8000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFF000001FF800003FFFFFF800000F8000000000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFF000001FFC00003FFFFFF000001F8000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFF000001FFC00001FFFFFF000001F0000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFF000001FFE00001FFFFFE000003F0000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFFF000001FFE00000FFFFFE000003E0000000000000000000000000000000000000000000000
0000007FFFFFFFFFFFFFF000001FFF00000FFFFFC000007E0000000000000000000000000000000000000000000000
0000003FFFFFFFFFFFFFF000001FFF000007FFFFC000007E0000000000000000000000000000000000000000000000
0000001FFFFFFFFFFFFFF000001FFF800007FFFF800000FC0000000000000000000000000000000000000000000000
0000000FFFFFFFFFFFFFF000001FFF800003FFFF000000FC0000000000000000000000000000000000000000000000
00000007FFFFFFFFFFFFF000001FFFC00001FFFE000001F80000000000000000000000000000000000000000000000
00000003FFFFFFFFFFFFF000001FFFC00000FFFC000001F80000000000000000000000000000000000000000000000
00000001FFFFFFFFFFFFF000001FFFE000007FF8000003F00000000000000000000000000000000000000000000000
000000007FFFFFFFFFFFF000001FFFF000001FE0000007F00000000000000000000000000000000000000000000000
000000003FFFFFFFFFFFF000001FFFF000000000000007E00000000000000000000000000000000000000000000000
000000001FFFFFFFFFFFF000001FFFF80000000000000FC00000000000000000000000000000000000000000000000
0000000007FFFFFFFFFFF000001FFFFC0000000000001FC00000000000000000000000000000000000000000000000
0000000001FFFFFFFFFFF000001FFFFE0000000000003F800000000000000000000000000000000000000000000000
00000000007FFFFFFFFFF000001FFFFF0000000000007F000000000000000000000000000000000000000000000000
00000000001FFFFFFFFFF000001FFFFF800000000000FE000000000000000000000000000000000000000000000000
000000000007FFFFFFFFF000001FFFFFC00000000001FE000000000000000000000000000000000000000000000000
000000000001FFFFFFFFF000001FFFFFE00000000003FC000000000000000000000000000000000000000000000000
0000000000003FFFFFFFF000001FFFFFE00000000007F8000000000000000000000000000000000000000000000000
00000000000007FFFFFFF000001FFFFF00000000001FF0000000000000000000000000000000000000000000000000
00000000000000FFFFFFF000001FFFE000000000003FC0000000000000000000000000000000000000000000000000
000000000000000FFFFFF000001FFE000000000000FF80000000000000000000000000000000000000000000000000
0000000000000000FFFFF000001F80000000000003FF00000000000000000000000000000000000000000000000000
000000000000000001FFFF00003E0000001800000FFC00000000000000000000000000000000000000000000000000
000000000000000000003FFFFFFE0000000700007FF800000000000000000000000000000000000000000000000000
00000000000000000000007FFFFE00000001FFFFFFE000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000003FFFFF0000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000007FFF80000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:SATURDAY.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000007FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFFC000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000
0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000000
000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000000
00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000
00000000000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000
0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000
000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000
0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
000000000000000003FFFFFFFFFFFFCFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
00000000000000000FFFFFFFFFFF000003FFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
00000000000000003FFFFFFFFFE00000003FFFFFFFFFFFFFFFFFF80000000000000001F00000000000000000000000
0000000000000000FFFFFFFFFF0000000003FFFFFFFFFFFFFFFFFC0000000000000001F80000000000000000000000
0000000000000001FFFFFFFFF800000000007FFFFFFFFFFFFFE0FE0000000000000001F80000000000000000000000
0000000000000007FFFFFFFFE000000000001FFFFFFFFFFFFFC0FE0000000000000001F80000000000000000000000
000000000000001FFFFFFFFF80000000000007FFFFFFFFFFFFC0FF0000000000000001F80000000000000000000000
000000000000003FFFFFFFFE00000000000001FFFFFFFFFFFFC0FF8000000000000001F80000000000000000000000
00000000000000FFFFFFFFFC00000000000000FFFFFFFFFFFFC0FF8000000000000001F80000000000000000000000
00000000000001FFFFFFFFF0000000000000003FFFFFFC01FE0007C000000000000001F80000000000000000000000
00000000000007FFFFFFFFE0000000000000001FFFFFF0007E0007C000000000000001F80000000000000000000000
0000000000000FFFFFFFFFC0000000000000001FFFFFE0003E0007E0F807C07C7C07F9F803FF00F801F00000000000
0000000000001FFFFFFFFF80000000000000003FFFFFE1F03FC0FFE0F807C07CFC1FFDF80FFFC0F801F00000000000
0000000000007FFFFFFFFF00000000000000003FFFFFF7F81FC0FFF0F807C07FFC3FFFF80FFFE0FC03E00000000000
000000000000FFFFFFFFFE00000000000000007FFFFFFFF81FC0FFF0F807C07FF87E07F80E07E07C03E00000000000
000000000001FFFFFFFFFC0000000000000000FFFFFFFFC01FC0FFF8F807C07F087E03F80003F07E07C00000000000
000000000003FFFFFFFFFC0000000000000001FFFFFFFC001FC0FFF8F807C07E00FC03F80003F07E07C00000000000
00000000000FFFFFFFFFF800000001FFF00001FFFFFFF0081FC0FFF8F807C07E00FC01F8003FF03E07800000000000
00000000001FFFFFFFFFF00000000FFFFF0003FFFFFFE0781FC0FFF8F807C07E00F801F801FFF03F0F800000000000
00000000003FFFFFFFFFF00000003FFFFFC007FFFFFFC0F81FC0FFFCF807C07C00F801F807F3F01F0F000000000000
00000000007FFFFFFFFFE00000007FFFFFF80FFFFFFF81F81FC0FFFCF807C07C00F801F80FC3F01F9F000000000000
0000000000FFFFFFFFFFE0000000FFFFFFFE0FFFFFFF81F81FC0FFFCF807C07C00F801F81F03F00F9E000000000000
0000000001FFFFFFFFFFE0000001FFFFFFFF1FFFFFFF81F01FC0FFFCF807C07C00FC01F83F03F00F9E000000000000
0000000003FFFFFFFFFFC0000003FFFFFFFFFFFFFFFF81F01FC0FFFCF807C07C00FC01F83E03F007FC000000000000
0000000007FFFFFFFFFFC0000007FFFFFFFFFFFFFFFF80C01FC07FFCFC0FC07C00FC03F83E07F007FC000000000000
000000000FFFFFFFFFFFC0000007FFFFFFFFFFFFFFFFC0001FE007FEFC0FC07C007E07F83F0FF003F8000000000000
000000001FFFFFFFFFFFC0000007FFFFFFFFFFFFFFFFE0081FE003FEFF3FC07C007F0FF83F9FF003F8000000000000
000000003FFFFFFFFFFF80000007FFFFFFFFFFFFFFFFF03C0FF007FE7FFFC07C003FFFF81FFFF003F0000000000000
000000007FFFFFFFFFFF8000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE3FF7C07C001FFDF80FF3F001F0000000000000
00000000FFFFFFFFFFFF8000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE1FC7C07C0007F1F007C1F001E0000000000000
00000001FFFFFFFFFFFF80000007FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000003E0000000000000
00000003FFFFFFFFFFFF80000007FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000003C0000000000000
00000003FFFFFFFFFFFF80000007FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000007C0000000000000
00000007FFFFFFFFFFFFC0000003FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000F80000000000000
0000000FFFFFFFFFFFFFC0000003FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000F80000000000000
0000001FFFFFFFFFFFFFC0000001FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000003F00000000000000
0000001FFFFFFFFFFFFFC0000001FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000001FE00000000000000
0000003FFFFFFFFFFFFFC0000000FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000001FC00000000000000
0000007FFFFFFFFFFFFFE00000007FFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000001F000000000000000
0000007FFFFFFFFFFFFFE00000003FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
000000FFFFFFFFFFFFFFE00000001FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
000001FFFFFFFFFFFFFFF00000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
000001FFFFFFFFFFFFFFF000000003FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFF800000001FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFFC00000000FFFFFFFFFFFFFFFFFFFFFFFFF000000000000001F00E00000000000000000000
000007FFFFFFFFFFFFFFFC000000007FFFFFFFFFFFFFFFFFFFFFFFE000000000000001F01F00000000000000000000
000007FFFFFFFFFFFFFFFE000000001FFFFFFFFFFFFFFFFFFFFFFFE000000000000001F03F80000000000000000000
00000FFFFFFFFFFFFFFFFF000000000FFFFFFFFFFFFFFFFFFFFFFFC000000000000001F03F80000000000000000000
00000FFFFFFFFFFFFFFFFF8000000003FFFFFFFFFFFFFFFFFFFFFFC000000000000001F01F00000000000000000000
00001FFFFFFFFFFFFFFFFF8000000001FFFFFFFFFFFFFFFFFFFFFF8000000000000001F00F00000000000000000000
00001FFFFFFFFFFFFFFFFFC000000000FFFFFFFFFFFFFF07FFFFE18000000000000001F00000000000000000000000
00003FFFFFFFFFFFFFFFFFE0000000003FFFFFFFFFFFF800FF83000000000000000001F00000000000000000000000
00003FFFFFFFFFFFFFFFFFF8000000001FFFFFFFFFFFE0007F800000000000F80003E1F00000000000000000000000
00003FFFFFFFFFFFFFFFFFFC000000000FFFFFFFFFFFE0403F800000000007FF000FFDF01F00000000000000000000
00007FFFFFFFFFFFFFFFFFFE0000000003FFFFFFFFFFF3F01F80F807C0001FFF803FFFF01F00000000000000000000
00007FFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFFFFFF81F81FC0FC0403F0FC03F0FF01F00000000000000000000
00007FFFFFFFFFFFFFFFFFFF8000000000FFFFFFFFFFFFF01F81FC0E00403E07C07E07F01F00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFE0000000003FFFFFFFFFFF001F81F80C00607C03E0FC03F01F00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFFF8001F81F00C00607C03E0FC03F01F00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFF8000000000FFFFFFFFFF0181F81F00C0060FC03E0F801F01F00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFE0000000003FFFFFFFFC0F81F81E00C0060FFFFE1F801F01F00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFC1F81F81C00C0060FFFFE1F801F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF8000000000FFFFFFFF81F81F81C00C0060FC0001F801F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFE0000000007FFFFFFF81F81F81800C0060FC0001F801F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFF0000000003FFFFFFF81F01F81000C0060FC0000F801F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFC000000001FFFFFFF81E01F81000C00607E0000FC03F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFE000000000FFFFFFFC0001F81000C00607E0000FC03F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFF8000000007FFFFFFC0001F81000C00603F80C07E07F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFC000000003FFFFFFE0180F81000C00601FFFC07F9FF01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFF000000001FFFFFFF87F1FE3001C00E00FFFE03FFDF01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFF800000000FFFFFFFFFFFFFF00FC07E007FF800FF9F01F00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFFE00000000FFFFFFFFFFFFC00000000000780003C0000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFFF000000007FFFFFFFFFFF80000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFFF800000003FFFFFFFFFFF00000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFFFE00000001FFFFFFFFFFE00000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFFFF00000001FFFFFFFFFFC00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFF80000000FFFFFFFFFF800000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000FFFFFFFFFF000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFE00000007FFFFFFFFC000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFF00000007FFFFFFFF8000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFF00000003FFFFFFFF0000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFF80000003FFFFFFFE0000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000003FFFFFFFC0000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000001FFFFFFF00000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFFFFFFFFFFFFFE0000001FFFFFFE00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFFFFFFFFFFFFFE0000001FFFFFFC00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFFF000000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFFE000000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFF8000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFF0000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFFC0000000000000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFF80000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFFE00000000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFF800000000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFF000000000000000000000000000000000000000000000000000
0000007FFFFFFFFFFFFFFFFFFFFFFFFFF0000001FFC000000000000000000000000000000000000000000000000000
0000003FFFFFFFFFFFFFFFFFFFFFFFFFE0000001FF0000000000000000000000000000000000000000000000000000
0000001FFFFFFFFFFFFFFFFFFFFFFFFFE0000001FC0000000000000000000000000000000000000000000000000000
0000000FFFFFFFFFFFFFF9FFFFFFFFFFE0000003FC0000000000000000000000000000000000000000000000000000
00000007FFFFFFFFFFFFF0FFFFFFFFFFC0000003FC0000000000000000000000000000000000000000000000000000
00000001FFFFFFFFFFFFF03FFFFFFFFF80000007F80000000000000000000000000000000000000000000000000000
00000000FFFFFFFFFFFFE00FFFFFFFFF00000007F80000000000000000000000000000000000000000000000000000
000000007FFFFFFFFFFFC003FFFFFFFE00000007F80000000000000000000000000000000000000000000000000000
000000001FFFFFFFFFFFC000FFFFFFFC0000000FF00000000000000000000000000000000000000000000000000000
000000000FFFFFFFFFFF80003FFFFFF00000001FF00000000000000000000000000000000000000000000000000000
0000000003FFFFFFFFFF000007FFFFC00000001FF00000000000000000000000000000000000000000000000000000
0000000000FFFFFFFFFF000000FFFE000000003FE00000000000000000000000000000000000000000000000000000
00000000003FFFFFFFFE0000000000000000007FE00000000000000000000000000000000000000000000000000000
00000000000FFFFFFFFC000000000000000000FFC00000000000000000000000000000000000000000000000000000
000000000003FFFFFFF8000000000000000000FF800000000000000000000000000000000000000000000000000000
000000000000FFFFFFF8000000000000000001FF000000000000000000000000000000000000000000000000000000
0000000000001FFFFFF0000000000000000003FF000000000000000000000000000000000000000000000000000000
00000000000003FFFFF800000000000000000FFE000000000000000000000000000000000000000000000000000000
000000000000003FFFFE00000000000000001FFC000000000000000000000000000000000000000000000000000000
0000000000000003FFFF00000000000000003FF8000000000000000000000000000000000000000000000000000000
00000000000000001FFFC000000000000000FFF0000000000000000000000000000000000000000000000000000000
0000000000000000001FF000000000000001FFE0000000000000000000000000000000000000000000000000000000
000000000000000000000000000000000007FF80000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000001FFF00000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000007FFE00000000000000000000000000000000000000000000000000000000
00000000000000000000001C0000000003FFF800000000000000000000000000000000000000000000000000000000
000000000000000000000007800000003FFFE000000000000000000000000000000000000000000000000000000000
000000000000000000000000FE000003FFFF8000000000000000000000000000000000000000000000000000000000
0000000000000000000000001FFFFFFFFFFC0000000000000000000000000000000000000000000000000000000000
00000000000000000000000003FFFFFFFFE00000000000000000000000000000000000000000000000000000000000
000000000000000000000000003FFFFFFF000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFC0000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:DANGER.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
00000000000003FFFFFF800FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
00000000000003FFFFFFF83FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
00000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
00000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
00000000000003E0000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
00000000000003E00000007FFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
00000000000003E00000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
00000000000003E000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
00000000000003E000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
00000000000003E0000000007FFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
00000000000003E0000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
00000000000003E0000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
00000000000003E0000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
00000000000003E003FFE00007FFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
00000000000003E003FFFC0003FFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000
00000000000003E003FFFF0001FFFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
00000000000003E003FFFF8001FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
00000000000003E003FFFFC000FFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
00000000000003E003FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
00000000000003E003FFFFF0007FFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
00000000000007E003FFFFF0007FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
0000000000000FE003FFFFF8003FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
0000000000001FE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000003C000000000000000000000
0000000000007FE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFE0007F800000000003C000000000000000000000
000000000000FFE003FFFFFC001FFFFFFFFFFFFFFFFFFFFFFFFFFFF001FFC00000000003C000000000000000000000
000000000001FFE003FFFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFF007E0800000000003C000000000000000000000
000000000003FFE003FFFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFF00F80000000000003C000000000000000000000
00000000000FFFE003FFFFFE001FC3FFE3FF1FFF1FFE7F0FFFFFF8F80F00001E003C0073C0E0000000000000000000
00000000001FFFE003FFFFFE001F00F800FC007C07C43C03E3E1E0381E00007F80FF01FFC3F8000000000000000000
00000000003FFFE003FFFFFE000F187800786078E3C03861E3E1C3781E0001F3C1E783CFC790000000000000000000
00000000007FFFE003FFFFFF000FFC787870F071F1C1F0F0E3E1C7F81E0001E1E3C3C783C780000000000000000000
0000000000FFFFE003FFFFFF000FF038F871F871F1C3E1F8E3E1C3FC1E0003C0E381C783C780000000000000000000
0000000001FFFFE003FFFFFF000F8038F871F86001C7E1F863E1E0FC1E01E3C0E781E703C3E0000000000000000000
0000000003FFFFE003FFFFFF000E1C38F861F86001C7E1F863E1F07C1E01E3C0F781E703C1F0000000000000000000
0000000007FFFFE003FFFFFF000E3C38F871F861FFC7E1F8E3E1F83C0F01E3C0E781E703C0F8000000000000000000
000000000FFFFFE003FFFFFF000C3C38F870F871FFC7F1F0E1E1FE3C0F81E3C1E381C783C038000000000000000000
000000001FFFFFE003FFFFFF000C3838F870F070FFC7F0F0E1C1FE3C07C1E1E1E3C3C787C038000000000000000000
000000003FFFFFE003FFFFFF000E0038F878207801C7F861E001CC3C03FFE0F3C1E783EFC678000000000000000000
000000007FFFFFE003FFFFFF000E0438F87C087C01C7FC03F001C07C00FFE07F80FF01FBC7F0000000000000000000
00000000FFFFFFE003FFFFFF000FFFFFFFFFF87FFFFFFFFFFFFFFFFC001C000C001800600080000000000000000000
00000001FFFFFFE003FFFFFF001FFFFFFFFFF8FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000001FFFFFFE003FFFFFE001FFFFFFFFFF0FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000003FFFFFFE003FFFFFE001FFFFFFFFBE0FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000007FFFFFFE003FFFFFE001FFFFFFFF001FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000000FFFFFFFE003FFFFFE001FFFFFFFFC07FFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000001FFFFFFFE003FFFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000001FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000003FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000007FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000007FFFFFFFE003FFFFFC003FFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
000000FFFFFFFFE003FFFFF8007FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000001FFFFFFFFE003FFFFF8007FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000001FFFFFFFFE003FFFFF000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000003FFFFFFFFE003FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
000003FFFFFFFFE003FFFFE001FFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
000007FFFFFFFFE003FFFFC001FFFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
000007FFFFFFFFE003FFFF8003FFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
00000FFFFFFFFFE003FFFE0003FFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
00000FFFFFFFFFE003FFF80007FFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
00001FFFFFFFFFE003FFE0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
00001FFFFFFFFFE0000000001FFFFFFFC001FFFFFFFFFFC7FFFFFF0000007000000000000000E00000000000000000
00001FFFFFFFFFE0000000003FFFFFFFC001FFFFFFFFFF87FFFFFF00000071E0000000000000F00000000000000000
00003FFFFFFFFFE0000000007FFFFFFF8001FFFFFFFFFF87FFFFFE00000071E0000000000000F00000000000000000
00003FFFFFFFFFE000000000FFFFFFFF8001FFFFFFFFFF87FFFFFE00000070E0000000000000F00000000000000000
00003FFFFFFFFFE000000000FFFFFFFF8001FFFFFFFFFF87FFFFFC0000007000000000000000F00000000000000000
00007FFFFFFFFFE000000000FFFFFFFF0001FFC7FFDFE7873FF9FC01800C7000700300300018F018001800C0000000
00007FFFFFFFFFE0000000007FFFFFFF0001FF00F00701800FC038FFE07FF1E1FC1FC0FE007FF0FF0FFF03FF000000
00007FFFFFFFFFE0000000007FFFFFFE0001FE10F00C018007C410FFF0FBF1E3CC3CE1E400FBF1EF8FFF07DF000000
0000FFFFFFFFFFE0000000007FFFFFFE0001FFF870783F83C3FF10F0F0E0F1E3C07071C001E1F0038F878F0F000000
0000FFFFFFFFFFFFFFFF80003FFFFFFE0001FFF070F87F87C3FC18F071E0F1E3C0F071E001C0F00F8F078E07000000
0000FFFFFFFFFFFFFFFF80003FFFFFFC0001FF8070F8FF87C3E018F071E071E1F0FFF1F001C0F07F8F079E07000000
0000FFFFFFFFFFFFFFFF80003FFFFFFC0001FE1C70F8FF87C38318F071E071E0F8FFF0FC03C0F1E38F079E07000000
0000FFFFFFFFFFFFFFFF80001FFFFFF80001FC3870F8FF87C38F18F071E071E07CF0003E03C0F1C38F079E07000000
0000FFFFFFFFFFFFFFFF80001FFFFFF80001FC7870F87F87C30F18F071E0F1E01C70001E01E0F3C38F078E07000000
0001FFFFFFFFFFFFFFFF80000FFFFFF80001FC3870F83F87C30E18F070F0F1E01C78000E01E1F3C78F078F0F0E0000
0001FFFFFFFFFFFFFFFF80000FFFFFF00001FC0070FC0187C38018F070FBF1E33C3EF39E00F3F1FF8F07879F0F0000
0001FFFFFFFFFFFFFFFF80000FFFFFF01001FE0470FE0187C38008F0707FF1E3F81FF3FC007EF1FBCF0787F70F0000
0001FFFFFFFFFFFFFFFF802007FFFFE01001FF1FFFFFC7FFFFE73800001C0000E007807000180060000000C7060000
0001FFFFFFFFFFFFFFFF802007FFFFE01001FFFFFFFFFFFFFFFE380000000000000000000000000000000007000000
0001FFFFFFFFFFFFFFFF802007FFFFE03001FFFFFFFFFFFFFFE000000000000000000000000000000000000F000000
0001FFFFFFFFFFFFFFFF803003FFFFC03001FFFFFFFFFFFFFFC000000000000000000000000000000000041E000000
0001FFFFFFFFFFFFFFFF803003FFFFC03001FFFFFFFFFFFFFF80000000000000000000000000000000000FFE000000
0001FFFFFFFFFFFFFFFF803003FFFFC07001FFFFFFFFFFFFFF000000000000000000000000000000000007F8000000
0001FFFFFFFFFFFFFFFF803801FFFF807001FFFFFFFFFFFFFE00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF803801FFFF807001FFFFFFFFFFFFFC00000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF803801FFFF00F001FFFFFFFFFFFFF800000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF803C00FFFF00F001FFFFFFFFFFFFF000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF803C00FFFF00F001FFFFFFFFFFFFE000000000000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFF803C00FFFE01F001FFFFFFFFFFFFC000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFF803E007FFE01F001FFFFFFFFFFFF0000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFF803E007FFC01F001FFFFFFFFFFFE0000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFF803E007FFC03F001FFFFFFFFFFFC0000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFF803F003FFC03F001FFFFFFFFFFF80000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFF803F003FF803F001FFFFFFFFFFE00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFF803F003FF807F001FFFFFFFFFFC00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFF803F801FF807F001FFFFFFFFFF800000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFF803F801FF00FF001FFFFFFFFFE000000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFF803F801FF00FF001FFFFFFFFFC000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFF803FC00FE00FF001FFFFFFFFF0000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFF803FC00FE01FF001FFFFFFFFE0000000000000000000000000000000000000000000000000
000003FFFFFFFFFFFFFF803FC00FE01FF001FFFFFFFF80000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFF803FE007C01FF001FFFFFFFF00000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFF803FE007C03FF001FFFFFFFC00000000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFF803FE007C03FF001FFFFFFF000000000000000000000000000000000000000000000000000
0000007FFFFFFFFFFFFF803FF003807FF001FFFFFFE000000000000000000000000000000000000000000000000000
0000003FFFFFFFFFFFFF803FF003807FF001FFFFFF8000000000000000000000000000000000000000000000000000
0000001FFFFFFFFFFFFF803FF003807FF001FFFFFE0000000000000000000000000000000000000000000000000000
0000000FFFFFFFFFFFFF803FF80100FFF001FFFFF80000000000000000000000000000000000000000000000000000
00000007FFFFFFFFFFFF803FF80100FFF001FFFFE00000000000000000000000000000000000000000000000000000
00000003FFFFFFFFFFFF803FF80000FFF001FFFF800000000000000000000000000000000000000000000000000000
00000001FFFFFFFFFFFF803FFC0001FFF001FFFE000000000000000000000000000000000000000000000000000000
000000007FFFFFFFFFFF803FFC0001FFF001FFF8000000000000000000000000000000000000000000000000000000
000000003FFFFFFFFFFF803FFE0003FFF001FFC0000000000000000000000000000000000000000000000000000000
000000001FFFFFFFFFFF803FFE0003FFF001FF00000000000000000000000000000000000000000000000000000000
0000000007FFFFFFFFFF803FFE0003FFF001F800000000000000000000000000000000000000000000000000000000
0000000001FFFFFFFFFF803FFF0007FFF001F000000000000000000000000000000000000000000000000000000000
00000000007FFFFFFFFF803FFF0007FFF001F000000000000000000000000000000000000000000000000000000000
00000000001FFFFFFFFF803FFF0007FFF001F000000000000000000000000000000000000000000000000000000000
000000000007FFFFFFFF803FFF800FFFF001F000000000000000000000000000000000000000000000000000000000
000000000001FFFFFFFF803FFF800FFFF001F000000000000000000000000000000000000000000000000000000000
0000000000003FFFFFFF803FFF801FFFE001F000000000000000000000000000000000000000000000000000000000
00000000000007FFFFFF803FFFC01FFF0001F000000000000000000000000000000000000000000000000000000000
00000000000000FFFFFF803FFFC01FE00001F000000000000000000000000000000000000000000000000000000000
000000000000000FFFFF803FFFE03F000001F000000000000000000000000000000000000000000000000000000000
0000000000000000FFFF803FFFE03F000001F000000000000000000000000000000000000000000000000000000000
000000000000000001FF807FFFC07F000001F000000000000000000000000000000000000000000000000000000000
000000000000000000003FFE0001FE0000FFF000000000000000000000000000000000000000000000000000000000
0000000000000000000007FC0001FE0000FFF000000000000000000000000000000000000000000000000000000000
0000000000000000000007FC0001FC0000FFF000000000000000000000000000000000000000000000000000000000
0000000000000000000007FC0000FC00007FF000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:HEAVY.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
0000000000007FFE0000003FFF0FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
0000000000007FFE0000003FFF7FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
0000000000007FFE0000003FFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
0000000000007FFE0000003FFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
0000000000007C000000003E000FFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
0000000000007C000000003E000FFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
0000000000007C000000003E000FFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
0000000000007C00000001FE000FFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
0000000000007C0000000FFE000FFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
0000000000007C0000003FFE000FFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
0000000000007C000000FFFE000FFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
0000000000007C000003FFFE000FFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
0000000000007C00000FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
0000000000007C00003FFFFE000FFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
0000000000007C0000FFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
0000000000007C0003FFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
0000000000007C000FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF803C000000000000000000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFDFFF803E00001E0000007C0000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFC1FF8003F00001F0000007C0000000000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFE0FF8003F00003F0000007C0000100000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFE0FF8007E00001F0000007C0000F00000000000000000
0000000000007C001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFE0FF0007E00001E0000007C0001F00000000000000000
000000000000FC0000000000000FFFFFFFFFFFFFFFFFFFFFFE0FF0107E0000000000007C0001F00000000000000000
000000000001FC0000000000000FFFFFFFFFFFFFFFFFFFFFFF07F0107E0000000000007C0001F00000000000000000
000000000003FC0000000000000FFFE07FF01FE3FC79FF1FFF07E000FC07E01E00FC787C7E07FF0000000000000000
00000000000FFC0000000000000FFF803FC00783FC00FF0FFF07E008FC1FF81F01FEF87DFF07FF8000000000000000
00000000001FFC0000000000000FFE001F800383FC20FE0FFF87E308FC3FFC1F03FFF87FFF87FF8000000000000000
00000000003FFC0000000000000FFE0F0FCF83C1F8707E1FFF83C300F87C3C1F07C3F87F8FC1F00000000000000000
00000000007FFC0000000000000FFC1F07FFC1C1F8707E1FFF83C301F8F81E1F0F81F87E07C1F00000000000000000
0000000000FFFC0000000000000FFC3F87FF81E0F0707C3FFF83C381F8F81E1F0F80F87E07C1F00000000000000000
0000000001FFFC0000000000000FF83F87FC01E0F0F83C3FFFC38781F9F01E1F1F00F87C07C1F00000000000000000
0000000003FFFC001FFFFFFE000FF80007E001F0F0F8387FFFC18781F1FFFE1F1F00F87C07C1F00000000000000000
0000000007FFFC001FFFFFFE000FF80007C0C1F061FC387FFFC187C3F1FFFE1F1F00F87C07C1F00000000000000000
000000000FFFFC001FFFFFFE000FF83FFF83C1F061FC187FFFE18FC3F1F8001F1F00F87C07C1F00000000000000000
000000001FFFFC001FFFFFFE000FF83FFF07C1F863FE10FFFFE10FC3E1F0001F1F00F87C07C1F00000000000000000
000000003FFFFC001FFFFFFE000FF83FFF07C1F803FE10FFFFE00FC3E0F8001F1F00F87C07C1F00000000000000000
000000007FFFFC001FFFFFFE000FFC1FFF0F81FC07FE01FFFFE01FE3E0F8001F0F81F87C07C1F00000000000000000
00000000FFFFFC001FFFFFFE000FFC0FFF0781FC07FF01FFFFF01FE3E0FC001F0F81F87C07C1F00000000000000000
00000001FFFFFC001FFFFFFE000FFE078F0201FE07FF03FFFFF01FE3C07E1C1F07C3F87C07C0F80000000000000000
00000001FFFFFC001FFFFFFE000FFF00078001FE0FFF83FFFFF01FF3C03FFE1F07FFF87C07C0FF8000000000000000
00000003FFFFFC001FFFFFFE000FFF800F80C1FE0FFF87FFFFF83FF3C01FFC1F03FEF87C07C07F8000000000000000
00000007FFFFFC001FFFFFFE000FFFE07FE1E1FF1FFF87FFFFF83FFB8007F01E00F8F83C03C03F0000000000000000
0000000FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFF0FFFFFFFFFFC000000000000F8000000000000000000000000
0000001FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFF0FFFFFFFFFF8000000000000F8000000000000000000000000
0000001FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFE0FFFFFFFFFF8000000000001F0000000000000000000000000
0000003FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFE1FFFFFFFFFF8000000000001F0000000000000000000000000
0000007FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFF83FFFFFFFFFF8000000000607E0000000000000000000000000
0000007FFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFC03FFFFFFFFFF8000000000FFFC0000000000000000000000000
000000FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFC07FFFFFFFFFF0000000000FFF80000000000000000000000000
000001FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFC1FFFFFFFFFFF00000000001FE00000000000000000000000000
000001FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000003FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
000003FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
000007FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000
000007FFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
00000FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000
00000FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
00001FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000
00001FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
00001FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
00003FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
00003FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
00003FFFFFFFFC001FFFFFFE000FFFFFFFFFFFFFFFFC7FFFFFFFFCF000000000000000001C00000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC3FFFFFFFFDF000000000000000003E00000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0FFFFFFFF9F000000000000000003E00000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF07FFFFFFF1F000000000000000003E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC3FFFFFFF1F000000000000000003E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFE00000000000007FFFFFFF7FFFFFFE1F000000000000000003E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFE00000000000007FFFFFFFFFFFFFFC1F000000000000000003E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFE00000000000007FFFFFFFFFFFFFFC1F000000000000000003E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFE00000000000007FE1C7F81FFC0FF81F003F00780783C703F3E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFE00000000000007FE183E007F003F01F01FFC07C0F87DF8FFBE00000000000000000000
0001FFFFFFFFFFFFFFFFFFFE00000000000007FE103C003F007E01F03FFE07C0F87FF9FFFE00000000000000000000
0001FFFFFFFFFFFFFFFFFFFE00000000000007FE00783C3E0FFC01F07C1F07C0F87FF1F0FE00000000000000000000
0001FFFFFFFFFFFFFFFFFFFE00000000000007FE07707E1E0FFC01F07C0F87C0F87F13E07E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE0007FFFFFFE0FF07E1E0FF801F0F80F87C0F87E03C07E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE0FF07E1E07F001F0F80787C0F87E07C03E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FE0001F01E001F0F807C7C0F87C07C03E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FE0001F80C001F0F807C7C0F87C07C03E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FE07FFFC00001F0F807C7C0F87C07C03E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF0FFFFF00001F0F807C7C0F87C07C03E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF07FFFF82001F0F80F87C0F87C07C03E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF07FFFF82001F0F80F87C0F87C03E07E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF83FFFF83001F07C0F87E1F87C03E07E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FF80F3E703001F07E1F03F3F87C03F0FE00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FFC001C006001F03FFE03FFF87C01FFFE00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFE1FFE003E00E001F00FFC01FEF87C00FFBE00000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFC0FF83C0000003F000F80000003E0000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFFE7F80000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00003FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFE00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
00001FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFF800000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
00000FFFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFFC000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFF0000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFF80000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFF00000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFFC00000000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFF000000000000000000000000000000000000000000000000000
0000007FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFFE000000000000000000000000000000000000000000000000000
0000003FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000001FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFFE0000000000000000000000000000000000000000000000000000
0000000FFFFFFFFFFFFFFFFFFFFFE000FFFFFFFFF80000000000000000000000000000000000000000000000000000
00000007FFFFFFFFFFFFFFFFFFFFE000FFFFFFFFE00000000000000000000000000000000000000000000000000000
00000003FFFFFFFFFFFFFFFFFFFFE000FFFFFFFF800000000000000000000000000000000000000000000000000000
00000001FFFFFFFFFFFFFFFFFFFFE000FFFFFFFE000000000000000000000000000000000000000000000000000000
000000007FFFFFFFFFFFFFFFFFFFE000FFFFFFF8000000000000000000000000000000000000000000000000000000
000000003FFFFFFFFFFFFFFFFFFFE000FFFFFFC0000000000000000000000000000000000000000000000000000000
000000001FFFFFFFFFFFFFFFFFFFE000FFFFFF00000000000000000000000000000000000000000000000000000000
0000000007FFFFFFFFFFFFFFFFFFE000FFFFF800000000000000000000000000000000000000000000000000000000
0000000001FFFFFFFFFFFFFFFFFFE000FFFFE000000000000000000000000000000000000000000000000000000000
00000000007FFFFFFFFFFFFFFFFFE000FFFF0000000000000000000000000000000000000000000000000000000000
00000000001FFFFFFFFFFFFFFFFFE000FFF80000000000000000000000000000000000000000000000000000000000
000000000007FFFFFFFFFFFFFFFFE000FFC00000000000000000000000000000000000000000000000000000000000
000000000001FFFFFFFFFFFFFFFFE000FE000000000000000000000000000000000000000000000000000000000000
0000000000003FFFFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
00000000000007FFFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
00000000000000FFFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
000000000000000FFFFFFFFFFFFFE000F8000000000000000000000000000000000000000000000000000000000000
0000000000000000FFFFFFFFFFFF8000F8000000000000000000000000000000000000000000000000000000000000
000000000000000001FFFFFFFFC00000F8000000000000000000000000000000000000000000000000000000000000
000000000000000000003FFC00000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000F8000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
000000000000000000000000000001FFF8000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:HOLD.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
000000000000000000000001C0007FFFFF87FFC3FFFE0FFFE0000000000380003C0000000000000000000000000000
00000000000000000000000FC0007FFFFF87FFC3FFFC0FFFF80000000007C0003C0000000000000000000000000000
00000000000000000000003FC0007FFFFF87FFC3FFF87FFFFE0000000007C0003C0000000000000000000000000000
00000000000000000E0001FFC0007FFFFF87FFC3FFF87FFFFF800000000380003C0000000000000000000000000000
00000000000000000E000FFFC0007FFFFF87FFC3FFF87FFFFFC00000000000003C0000000000000000000000000000
00000000000000000E003FFFC0007FFFFF87FFC3FFF87FFFFFF00000000000003C0000000000000000000000000000
00000000000000000E00FFFFC0007FE01F87E043FFE00F80FE30000F7F0780FE3C38003C0E1EFE0000000000000000
00000000000000000E03FFFFC0007FC00F87C003FFE00E003E00800FFF8783FE3C78003C0E1FFF0000000000000000
00000000000000000E0FFFFFC0007F8787878783FFF87C3E1E01800FC7C787C03CF0003C0E1F0F0000000000000000
00000000000000000E3FFFFFC0007F0FC3870FC3FFF87C3E1E1F800F83C787803DE0003C0E1E078000000000000000
00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E1FC00F03E78F003FC0003C0E1E078000000000000000
00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E1FE00F01E78F003FC0003C0E1E078000000000000000
00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E3FF00F01E78F003FC0003C0E1E078000000000000000
00000000000000000FFFFFFFC0007F0FC3870FC3FFF8787F0E3FF80F01E78F003DE0003C0E1E078000000000000000
00000000000000000FFFFFFFC0007F0FC3870FC3FFF87C3F0E3FF80F03C78F803DF0003C1E1E078000000000000000
00000000000000000FFFFFFFC0007F87C3870783FFF87C3E1E3FFC0F83C787803CF8001E1E1F0F8000000000000000
00000000000000000FFFFFFFC0007F8387878303FFF87E1C3E3FFE0FC78783E63C7C001FFE1F9F0000000000000000
00000000000000000FFFFFFFC0007FC00F87C003FFF87F007E3FFF0FFF0781FF3C3C001FFE1FFE0000000000000000
00000000000000000FFFFFFFC0007FF03F87E0C3FFF87F80FE3FFF0F3E0380FE3C180007CE1EF80000000000000000
00000000000000000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFF8F0000000000000000001E000000000000000000
00000000000000000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFF8F0000000000000000001E000000000000000000
00000000000000000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFCF0000000000000000001E000000000000000000
0000000000000C000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFCF0000000000000000001E000000000000000000
0000000000001C000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFEF0000000000000000001E000000000000000000
0000000000007C000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFEF0000000000000000001E000000000000000000
000000000000FC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000000000001FC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
000000000003FC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000
00000000000FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
00000000001FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
00000000003FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
00000000007FFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000000000FFFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000000001FFFC000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000000003FFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000000007FFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
000000000FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
000000001FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
000000003FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
000000007FFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000000FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000001FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000001FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000003FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
00000007FFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000000FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000
0000001FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000001FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000003FFFFFFC000FFFFFFFC0007FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000
0000007FFFFFFC000FFFFFFFC0000000007FFFFFFFFFFFFFFFFFFFF870000000000000000000000000000000000000
0000007FFFFFFC000FFFFFFFC0000000000FFFFFFFFFFFFFFFFFFFF878000000000000000000000000000000000000
000000FFFFFFFC000FFFFFFFC00000000001FFFFFFFFFE1FFFFFFFF078000000000000000000000000000000000000
000001FFFFFFFC000FFFFFFFC000000000007FFFFFFFFE1FFFFFFFF070000000000000000000000000000000000000
000001FFFFFFFC000FFFFFFFC000000000003FFFFFFFFE1FFFFFFFF000000000000000000000000000000000000000
000003FFFFFFFC000FFFFFFFC000000000000FFFFFF1FC1FF87FFE200003000007000E000000030000000000000000
000003FFFFFFFC000FFFFFFFC000000000000FFFFF807803E01F000078F78003FFC07FC1E070F78000000000000000
000007FFFFFFFC000FFFFFFFC0000000000007FFFF0C3803C30F000078FF8003FFE0FBE1E070FF8000000000000000
000007FFFFFFFC000FFFFFFFC0000000000003FFFE1E1E1F8787078478FF0003E1E1E0F1E070FF0000000000000000
00000FFFFFFFFC000FFFFFFFC00001FFE00001FFFE1F1E1F0F870F8478F80003C0F1E0F1E070F00000000000000000
00000FFFFFFFFC000FFFFFFFC00001FFF80001FFFC001E1F00070F8678F00003C0F3C079E070F00000000000000000
00001FFFFFFFFC000FFFFFFFC00001FFFE0001FFFC001E1F00070F8678F00003C0F3C079E070F00000000000000000
00001FFFFFFFFC000FFFFFFFC00001FFFF0000FFFC1FFE1F07FF0F0678F00003C0F3C079E070F00000000000000000
00001FFFFFFFFC000FFFFFFFC00001FFFF0000FFFC1FFE1F0FFF0F0678F00003C0F3C079E070F00000000000000000
00003FFFFFFFFC000FFFFFFFC00001FFFF8000FFFE1FFE1F07FF0E0678F00003C0F1E0F1F0F0F00000000000000000
00003FFFFFFFFC000FFFFFFFC00001FFFF8000FFFE0FFE1F83FF0E0678F00003E1E1E0F0F0F0F00000000000000000
00003FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFF001E0BC00F0C0678F00003F3E0F1E0FFF0F00000000000000000
00007FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFF801F01E00F0C0678F00003FFC07FC07FF0F00000000000000000
00007FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFFE0FF87F83FF81E00000003CF001F003C00000000000000000000
00007FFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFFFFFFFFFFFFF81E00000003C00000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FFFFC000FFFFFFFFFFFFFFF00000000003C00000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF8000FFFFFFFFFFFFFFE00000000003C00000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF8000FFFFFFFFFFFFFFC00000000003C00000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF8001FFFFFFFFFFFFFFC00000000003C00000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FFFF0001FFFFFFFFFFFFFF800000000003800000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FFFE0001FFFFFFFFFFFFFF000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0001FFFE0003FFFFFFFFFFFFFE000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0001FFF80003FFFFFFFFFFFFFC000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0001FFF00007FFFFFFFFFFFFFC000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0001FFC0000FFFFFFFFFFFFFF8000000000000000000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF00000000001FFFFFFFFFFFFFF0000000000C3C380000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF00000000003FFFFFFFFFFFFFE0000000001E3C780000000000000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF00000000007FFFFFFFFFFFFFC0000000003E3C780000100200000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0000000000FFFFFFFFFFFFFF80000000001E3C780000F01E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0000000001FFFFFFFFFFFFFF0000000000003C780000F01E00000000000000000000
0001FFFFFFFFFFFFFFFFFFFFFF0000000007FFFFFFFFFFFFFE0000000000003C780000F01E00000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0000000007FFFFFFFFFFFFFC3F9E0F01F81E3C780FC1FF7FE0FE0000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0000000007FFFFFFFFFFFFF8FF9E0F07FE1E3C783FF1FF7FE3FF0000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0000000003FFFFFFFFFFFFF1F11E0F0F0E1E3C787870F01E07878000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FF0003FFFFFFFFFFFFE3E01E0F0E0F1E3C787078F01E07838000000000000000
0000FFFFFFFFFFFFFFFFFFFFFF0001FF0001FFFFFFFFFFFFC3C01E0F1E0F1E3C78F078F01E07838000000000000000
00007FFFFFFFFFFFFFFFFFFFFF0001FF8000FFFFFFFFFFFF03C01E0F1FFF1E3C78FFF8F01E0FFF8000000000000000
00007FFFFFFFFFFFFFFFFFFFFF0001FF8000FFFFFFFFFFFE03C01E0F1FFF1E3C78FFF8F01E0FFF8000000000000000
00007FFFFFFFFFFFFFFFFFFFFF0001FFC0007FFFFFFFFFFC03C01E0F1E001E3C78F000F01E0F000000000000000000
00003FFFFFFFFFFFFFFFFFFFFF0001FFC0007FFFFFFFFFF803C01E0F1E001E3C78F000F01E07800000000000000000
00003FFFFFFFFFFFFFFFFFFFFF0001FFE0003FFFFFFFFFE003E01F0F0F001E3C787800F01E07800000000000000000
00001FFFFFFFFFFFFFFFFFFFFF0001FFE0001FFFFFFFFFC001F18F9F0F861E3C787C30781F03E18000000000000000
00001FFFFFFFFFFFFFFFFFFFFF0001FFF0001FFFFFFFFF8000FF8FFF07FF1E3C783FF87F0FE1FF8000000000000000
00000FFFFFFFFFFFFFFFFFFFFF0001FFF0000FFFFFFFFE00003F87E701FC1E3C380FE03F07E0FF0000000000000000
00000FFFFFFFFFFFFFFFFFFFFF0001FFF8000FFFFFFFFC000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFF0001FFF80007FFFFFFF0000000000000000000000000000000000000000000000000
000007FFFFFFFFFFFFFFFFFFFF0001FFFC0003FFFFFFE0000000000000000000000000000000000000000000000000
000003FFFFFFFFFFFFFFFFFFFF0001FFFE0003FFFFFF80000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFF0001FFFE0001FFFFFF00000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFF0001FFFF0000FFFFFC00000000000000000000000000000000000000000000000000
000000FFFFFFFFFFFFFFFFFFFF0001FFFF0000FFFFF000000000000000000000000000000000000000000000000000
0000007FFFFFFFFFFFFFFFFFFF0001FFFF80007FFFE000000000000000000000000000000000000000000000000000
0000003FFFFFFFFFFFFFFFFFFF0001FFFF80007FFF8000000000000000000000000000000000000000000000000000
0000001FFFFFFFFFFFFFFFFFFF0001FFFFC0003FFE0000000000000000000000000000000000000000000000000000
0000000FFFFFFFFFFFFFFFFFFF0001FFFFC0001FF80000000000000000000000000000000000000000000000000000
00000007FFFFFFFFFFFFFFFFFF0001FFFFE0001FE00000000000000000000000000000000000000000000000000000
00000003FFFFFFFFFFFFFFFFFF0001FFFFE0000F800000000000000000000000000000000000000000000000000000
00000001FFFFFFFFFFFFFFFFFF0001FFFFF0000E000000000000000000000000000000000000000000000000000000
000000007FFFFFFFFFFFFFFFFF0001FFFFF00004000000000000000000000000000000000000000000000000000000
000000003FFFFFFFFFFFFFFFFF0001FFFFF8007E000000000000000000000000000000000000000000000000000000
000000001FFFFFFFFFFFFFFFFFFFFFFFFFF81FFF000000000000000000000000000000000000000000000000000000
0000000007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000000000000000
0000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000000000000000
00000000007FFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000000000000000000
00000000001FFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000000000000000
000000000007FFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000000000000000
000000000001FFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000
0000000000003FFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000
00000000000007FFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000000000000000
00000000000000FFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000000
000000000000000FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000000
0000000000000000FFFFFFFFFFFF800000000000000000000000000000000000000000000000000000000000000000
000000000000000001FFFFFFFFC0000000000000000000000000000000000000000000000000000000000000000000
000000000000000000003FFC0000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
~DGR:OSNR.GRF,08225,047,
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000003FFFFF800000000000000000000000000000000000000000000000000000
00000000000000000000000000000000FFFFFFFFFF8000000000000000000000000000000000000000000000000000
0000000000000000000000000000003FFFFFFFFFFFFE00000000000000000000000000000000000000000000000000
000000000000000000000000000007FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000
0000000000000000000000000000FFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000
000000000000000000000000000FFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000
000000000000000000000000007FFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000
00000000000000000000000007FFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000
0000000000000000000000003FFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000000
000000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000
00000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000
00000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000000
0000000000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000
000000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000000
000000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000
00000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8000000000000000000000000000000000000000000
00000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000
0000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF000000000000000000000000000000000000000000
0000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000
000000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000
000000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE00000000000000000000000000000000000000000
00000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000
00000000000000003FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
0000000000000000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000
0000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC0000000000000000000000000000000000000000
0000000000000007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000
000000000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
000000000000000003FFFFFFFFFFFFF001FFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000
0000000000000000003FFFFFFFFFFF00003FFFFF003FFFFFFFFF0000003FFFFFFC0000000000000000000000000000
00000000000000000007FFFFFFFFFC000007FFFF001FFFFFFFFF0000007FFFFFFFC000000000000000000000000000
00000000000000000001FFFFFFFFF0000001FFFF000FFFFFFFFF0000007FFFFFFFF000000000000000000000000000
000000000000000000007FFFFFFFC0000000FFFF0007FFFFFFFF0000007FFFFFFFFC00000000000000000000000000
000000000000000000003FFFFFFF800000007FFF0003FFFFFFFF003E007FFFFFFFFF00000000000000000000000000
000000000000000000000FFFFFFF000000007FFF0001FFFFFFFF003E007FFFFFFFFF80000000000000000000000000
0000000000000000000007FFFFFE000000007FFF0001FFFFFFFF003E007FFFFFFFFFC0000000000000000000000000
0000000000000000000003FFFFFC00000000FFFF0000FFFFFFFF003E007FFFFFFFFFE0000000000000000000000000
0000000000000000000001FFFFFC0001FC01FFFF00007FFFFFFF003E007FFFFFFFFFE0000000000000000000000000
000000000000003FFC0000FFFFF80007FF81FFFF00003FFFFFFF003E007FFE007FFFF0000000000000000000000000
00000000000001FFFF00007FFFF8000FFFE3FFFF00001FFFFFFF003E007FFE000FFFF0000000000000000000000000
00000000000003FFFFC0003FFFF8001FFFFFFFFF00000FFFFFFF003E007FFE0007FFF8000000000000000000000000
0000000000000FFFFFE0001FFFF0003FFFFFFFFF00000FFFFFFF003E007FFE0003FFF8000000000000000000000000
0000000000001FFFFFF0001FFFF0003FFFFFFFFF000007FFFFFF003E007FFE0001FFF8000000000000000000000000
0000000000003FFFFFF8000FFFF0003FFFFFFFFF000003FFFFFF003E007FFE0001FFF8000000000000000000000000
0000000000003FFFFFFC000FFFF0003FFFFFFFFF000001FFFFFF003E007FFE0000FFF8000000000000000000000000
0000000000007FFFFFFC0007FFF0003FFFFFFFFF000000FFFFFF003E007FFE0000FFF8000000000000000000000000
000000000000FFFFFFFE0007FFF0001FFFFFFFFF0000007FFFFF003E007FFE0000FFFC000000000000000000000000
000000000000FFFFFFFF0003FFF0001FFFFFFFFF0000007FFFFF003E007FFE0000FFF8000000000000000000000000
000000000001FFFFFFFF0003FFF8000FFFFFFFFF0010003FFFFF003E007FFE0000FFF8000000000000000000000000
000000000001FFFFFFFF0001FFF80007FFFFFFFF0010001FFFFF003E007FFE0000FFF8000000000000000000000000
000000000001FFFFFFFF8001FFF80003FFFFFFFF0018000FFFFF003E007FFE0000FFF8000000000000000000000000
000000010003FFFFFFFF8001FFFC0001FFFFFFFF001C0007FFFF003E007FFE0000FFF8000000000000000000000000
000000010003FFFFFFFF8000FFFC0000FFFFFFFF001E0007FFFF003E007FFE0001FFF8000000000000000000000000
000000030003FFFFFFFFC000FFFE00007FFFFFFF001E0003FFFF003E007FFE0001FFF0000000000000000000000000
000000060003FFFFFFFFC000FFFF00001FFFFFFF001F0001FFFF003E007FFE0003FFF0000000000000000000000000
0000000E0003FFFFFFFFC000FFFF80000FFFFFFF001F8000FFFF003E007FFE0007FFF0000000000000000000000000
0000001E0007FFFFFFFFC000FFFFC00007FFFFFF001FC0007FFF003E007FFE0007FFE0000000000000000000000000
0000001E0007FFFFFFFFC000FFFFE00003FFFFFF001FC0003FFF003E007FFE001FFFE0000000000000000000000000
0000003E0007FFFFFFFFC0007FFFF00000FFFFFF001FE0003FFF003E007FFE007FFFC0000000000000000000000000
0000007E0007FFFFFFFFC0007FFFF800007FFFFF001FF0001FFF003E007FFE07FFFF80000000000000000000000000
0000007E0007FFFFFFFFC0007FFFFC00003FFFFF001FF8000FFF003E007FFFFFFFFF00000000000000000000000000
000000FE0007FFFFFFFFC0007FFFFE00001FFFFF001FF80007FF003E007FFFFFFFFE00000000000000000000000000
000001FE0007FFFFFFFFC0007FFFFF80000FFFFF001FFC0007FF003E007FFFFFFFFC00000000000000000000000000
000001FE0007FFFFFFFFC0007FFFFFC00007FFFF001FFE0003FF003E007FFFFFFFF800000000000000000000000000
000003FE0007FFFFFFFFC000FFFFFFF00003FFFF001FFF0001FF003E007FFFFFFFF000000000000000000000000000
000003FE0007FFFFFFFFC000FFFFFFF80001FFFF001FFF8000FF003E007FFFFFFFE000000000000000000000000000
000007FE0007FFFFFFFFC000FFFFFFFC0000FFFF001FFF80007F003E007FFFFFFFE000000000000000000000000000
000007FE0003FFFFFFFFC000FFFFFFFF00007FFF001FFFC0007F003E007FFFFFFFF000000000000000000000000000
00000FFF0003FFFFFFFFC000FFFFFFFF80007FFF001FFFE0003F003E007FFE03FFF000000000000000000000000000
00000FFF0003FFFFFFFFC000FFFFFFFFC0003FFF001FFFF0001F003E007FFE01FFF800000000000000000000000000
00001FFF0003FFFFFFFF8000FFFFFFFFE0003FFF001FFFF8000F003E007FFE00FFF800000000000000000000000000
00001FFF0003FFFFFFFF8001FFFFFFFFF0001FFF001FFFF8000F003E007FFE00FFFC00000000000000000000000000
00001FFF0001FFFFFFFF8001FFFFFFFFF0001FFF001FFFFC0007003E007FFE007FFE00000000000000000000000000
00003FFF8001FFFFFFFF0001FFFFFFFFF8001FFF001FFFFE0003003E007FFE007FFE00000000000000000000000000
00003FFF8001FFFFFFFF0003FFFFFFFFF8001FFF001FFFFF0001003E007FFE003FFF00000000000000000000000000
00003FFF8000FFFFFFFF0003FFFFFFFFFC000FFF001FFFFF8000003E007FFE003FFF00000000000000000000000000
00007FFFC000FFFFFFFE0003FFFFFFFFFC000FFF001FFFFFC000003E007FFE001FFF80000000000000000000000000
00007FFFC0007FFFFFFE0007FFFFFFFFFC000FFF001FFFFFC000003E007FFE001FFF80000000000000000000000000
00007FFFE0003FFFFFFC0007FFFFFFFFFC000FFF001FFFFFE000003E007FFE000FFFC0000000000000000000000000
0000FFFFE0003FFFFFF8000FFFFFFFFFFC000FFF001FFFFFF000003E007FFE000FFFC0000000000000000000000000
0000FFFFF0001FFFFFF8000FFFFFFFFFFC001FFF001FFFFFF800003E007FFE000FFFE0000000000000000000000000
0000FFFFF8000FFFFFF0001FFFFFFFFFF8001FFF001FFFFFFC00003E007FFE0007FFF0000000000000000000000000
0000FFFFF80007FFFFE0003FFFFCFFFFF8001FFF001FFFFFFC00003E007FFE0007FFF0000000000000000000000000
0000FFFFFC0003FFFF80003FFFF87FFFF0001FFF001FFFFFFE00003E007FFE0003FFF8000000000000000000000000
0000FFFFFE0000FFFE00007FFFF01FFFE0003FFF001FFFFFFF00003E007FFE0003FFF8000000000000000000000000
0001FFFFFF00001FF80000FFFFF007FF80003FFF001FFFFFFF80003E007FFE0001FFFC000000000000000000000000
0001FFFFFF800000000001FFFFE0007C00007FFF001FFFFFFFC0003E007FFE0001FFFC000000000000000000000000
0001FFFFFFC00000000003FFFFC000000000FFFF001FFFFFFFE0003E007FFE0000FFFE000000000000000000000000
0001FFFFFFE00000000007FFFFC000000001FFFF001FFFFFFFF0003E007FFE0000FFFE000000000000000000000000
0001FFFFFFF0000000001FFFFFC000000003FFFF001FFFFFFFF0003E007FFE00007FFF000000000000000000000000
0001FFFFFFF8000000003FFFFFE000000007FFFF001FFFFFFFE0003E007FFE00007FFF800000000000000000000000
0001FFFFFFFE00000000FFFFFFF80000000FFFFF001FFFFFFFC0003E007FFE00003FFF800000000000000000000000
0001FFFFFFFF80000001FFFFFFFE0000003FFFFF001FFFFFFF80003E007FFE00003FFFC00000000000000000000000
0001FFFFFFFFE000000FFFFFFFFF800000FFFFFF001FFFFFFF00003E007FFE00001FFF000000000000000000000000
0001FFFFFFFFFE00007FFFFFFFFFF00007FFFFFF803FFFFFFE00003E003FFC00001FC0000000000000000000000000
0000FFFFFFFFFFF01FFFFFFFFFFFFFC0FFFFFFFFFFFFFFFFFC003FFE00000000000800000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF8001FFE00000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000FFE00000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFE00007FC00000000000000000000000000000000000000
0000FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC000000000000000000000000000000000000000000000
00007FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000
00007FFFE3FFFFCFFFFFFFFFFFFFFFF9FFFFFFFFFFFFFFFE018000000C0300000009800000C0480000000000000000
00007FFFCBFFFFCFFFFFFFFFFFFFFFF9FFFFFFFFFFFFFFFC0180080008000000000900000000498000000000000000
00003FFFCFCE9E4E75F9D9D3AE77F3C9FFFFFFFFFFFFFFF803C41C3028C302418A090C4160C3C9C622500000000000
00003FFFC7244C8931F4C4898C932491FFFFFFFFFFFFFFE0024CCCC9E98D8332CE083679B366CD8D32780000000000
00001FFFF304E9C837F84C9C99934099FFFFFFFFFFFFFFC0026CC8CD898D8331C80836711B6C4D9DB2600000000000
00001FFFF93CE9C9F7F64C9CB9D84799FFFFFFFFFFFFFF8007ECC88D88CC0336C80830311B0C4D9832600000000000
00000FFFF93CECC9F7E44C99B998E799FFFFFFFFFFFFFE00042CC8CD886C0336C80830599B0CCD8832600000000000
00000FFFC384EC0C37F04183BC3CE0C1FFFFFFFFFFFFFC000C37CE7989C783E7C8081ECDF1E7C8EF3E600000000000
000007FFFFFFFFFFFFFFCF9FFFFFFFFFFFFFFFFFFFFFF0000000000000000300000000010000000000000000000000
000007FFFFFFFFFFFFFFCF9FFFFFFFFFFFFFFFFFFFFFE0000000000000000300000000010000000000000000000000
000003FFFFFFFFFFFFFFDF9FFFFFFFFFFFFFFFFFFFFF80000000000000000200000000010000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000
000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000000
000000FFFCFFFFFFFFFFFFFFFFFFFFFFFE7FFFDFFFF000000000001800000000000000000000000180000000000000
0000007FFEFFFFFE7FFFFFFFFE7FFFFFFF7FFFDFFFE000000000000000000800000000000000000000000000000000
0000003FC4C1838426421F070C3E31C1BB611C1FFF800000000001D9F3E39E89EE07C79F83DE3EC99CF00000000000
0000001F9CC899E66644CF32667C64993366699FFE0000000000031B3320C88999066CD9833266CDB1900000000000
0000000FCC9C9986664C0F32727CC099336E09DFF80000000000019B1233C8899F066CD8833FC6CD99F00000000000
00000007E49C9926664CFF32767CE799336E79DFE0000000000180DB1236C88998066CD8833046CD8D800000000000
00000003E4C89926644E7F33267CE799936E689F80000000000000DB3236CCD998066CD883386EDD8D800000000000
00000001CEE0B99730CF1F3B8F3EF1C18B6F0C5E0000000000000188F2224E6907040308820E366918700000000000
000000007FFDFFFFFFFFFFFFFFFFFFF9FFFFFFF8000000000000000030000000000000000000060000000000000000
000000003FC1FFFFFFFFFFFFFFFFFFF9FFFFFFC00000000000000001E0000000000000000000060000000000000000
000000001FFFFFFFFFFFFFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000000000
0000000007FFFFFFFFFFFFFFFFFFFFFFFFFFF800000000000000000000000000000000000000000000000000000000
0000000001FFFFFFFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000
00000000007FFFFFFFFFFFFFFFFFFFFFFFFF0000000000000000000000000000000000000000000000000000000000
00000000001FFFFFFFFFFFFFFFFFFFFFFFF80000000000000000000000000000000000000000000000000000000000
000000000007FFFFFFFFFFFFFFFFFFFFFFC00000000000000000000000000000000000000000000000000000000000
000000000001FFFFFFFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000
0000000000003FFFFFFFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000
00000000000007FFFFFFFFFFFFFFFFFF00000000000000000000000000000000000000000000000000000000000000
00000000000000FFFFFFFFFFFFFFFFE000000000000000000000000000000000000000000000000000000000000000
000000000000000FFFFFFFFFFFFFFE0000000000000000000000000000000000000000000000000000000000000000
0000000000000000FFFFFFFFFFFF800000000000000000000000000000000000000000000000000000000000000000
000000000000000001FFFFFFFFC0000000000000000000000000000000000000000000000000000000000000000000
000000000000000000003FFC0000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</ZPLCode>
         </GetZPLInitializationImagesResult>
      </GetZPLInitializationImagesResponse>
   </soap:Body>
</soap:Envelope>


Shipment Verification

Shipment Verification Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Verifies that each package is being shipped.

Some clients scan packages as they are loaded and require the ability to confirm packages before they are closed out and shipped.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:ShipmentVerification>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:PackageTrackingNumbers>
                      <pur:string>TST000006569</pur:string>
                      <pur:string>TST000006577</pur:string>
                      <pur:string>TST000006585</pur:string>
                  </pur:PackageTrackingNumbers>
              </pur:request>
          </pur:ShipmentVerification>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:ShipmentVerification>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:PackageTrackingNumbers>
                    <pur:string>TST000006569</pur:string>
                    <pur:string>TST000006577</pur:string>
                    <pur:string>TST000006585</pur:string>
                </pur:PackageTrackingNumbers>
            </pur:request>
        </pur:ShipmentVerification>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <ShipmentVerificationResponse xmlns="http://PurolatorServices.com/">
           <ShipmentVerificationResult>
              <Status>0</Status>
           </ShipmentVerificationResult>
        </ShipmentVerificationResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <ShipmentVerificationResponse xmlns="http://PurolatorServices.com/">
         <ShipmentVerificationResult>
            <Status>0</Status>
         </ShipmentVerificationResult>
      </ShipmentVerificationResponse>
   </soap:Body>
</soap:Envelope>


Void Order

Void Order Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Voids a list of orders.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:VoidOrders>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:OrderNumbers>
                      <pur:string>Void Order-002</pur:string>
                  </pur:OrderNumbers>
              </pur:request>
          </pur:VoidOrders>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:VoidOrders>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:OrderNumbers>
                    <pur:string>Void Order-002</pur:string>
                </pur:OrderNumbers>
            </pur:request>
        </pur:VoidOrders>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <VoidOrdersResponse xmlns="http://PurolatorServices.com/">
           <VoidOrdersResult>
              <Status>0</Status>
           </VoidOrdersResult>
        </VoidOrdersResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <VoidOrdersResponse xmlns="http://PurolatorServices.com/">
         <VoidOrdersResult>
            <Status>0</Status>
         </VoidOrdersResult>
      </VoidOrdersResponse>
   </soap:Body>
</soap:Envelope>


Void Packages

Void Packages Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Voids a list of packages.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:VoidPackages>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:PackageTrackingNumbers>
                      <pur:string>TST000006601</pur:string>
                  </pur:PackageTrackingNumbers>
              </pur:request>
          </pur:VoidPackages>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:VoidPackages>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:PackageTrackingNumbers>
                    <pur:string>TST000006601</pur:string>
                </pur:PackageTrackingNumbers>
            </pur:request>
        </pur:VoidPackages>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <VoidPackagesResponse xmlns="http://PurolatorServices.com/">
           <VoidPackagesResult>
              <Status>0</Status>
           </VoidPackagesResult>
        </VoidPackagesResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <VoidPackagesResponse xmlns="http://PurolatorServices.com/">
         <VoidPackagesResult>
            <Status>0</Status>
         </VoidPackagesResult>
      </VoidPackagesResponse>
   </soap:Body>
</soap:Envelope>


Closeout

Closeout Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Closes out a series of packages.

A closeout notifies the system that packages are being shipped.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
      <soap:Header/>
      <soap:Body>
          <pur:Closeout>
              <pur:request>
                  <pur:Credentials>
                      <pur:UserName>TestUser</pur:UserName>
                      <pur:Password>5VJrtqTa</pur:Password>
                      <pur:ClientID>0000000</pur:ClientID>
                  </pur:Credentials>
                  <pur:ShipDate>2012-08-09T00:00:00</pur:ShipDate>
                  <pur:ParsNumber/>
                  <pur:SkidCount>1</pur:SkidCount>
                  <pur:PackIDType>PIN</pur:PackIDType>
                  <pur:PackageIDs>
                      <pur:string>TST000006569</pur:string>
                      <pur:string>TST000006577</pur:string>
                      <pur:string>TST000006585</pur:string>
                  </pur:PackageIDs>
              </pur:request>
          </pur:Closeout>
      </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
    <soap:Header/>
    <soap:Body>
        <pur:Closeout>
            <pur:request>
                <pur:Credentials>
                    <pur:UserName>TestUser</pur:UserName>
                    <pur:Password>5VJrtqTa</pur:Password>
                    <pur:ClientID>0000000</pur:ClientID>
                </pur:Credentials>
                <pur:ShipDate>2012-08-09T00:00:00</pur:ShipDate>
                <pur:ParsNumber/>
                <pur:SkidCount>1</pur:SkidCount>
                <pur:PackIDType>PIN</pur:PackIDType>
                <pur:PackageIDs>
                    <pur:string>TST000006569</pur:string>
                    <pur:string>TST000006577</pur:string>
                    <pur:string>TST000006585</pur:string>
                </pur:PackageIDs>
            </pur:request>
        </pur:Closeout>
    </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <CloseoutResponse xmlns="http://PurolatorServices.com/">
           <CloseoutResult>
              <Status>0</Status>
              <Packages>
                 <CloseoutPackage>
                    <TrackingNumber>TST000006569</TrackingNumber>
                    <Rate>1.6468</Rate>
                 </CloseoutPackage>
                 <CloseoutPackage>
                    <TrackingNumber>TST000006577</TrackingNumber>
                    <Rate>2.9732</Rate>
                 </CloseoutPackage>
                 <CloseoutPackage>
                    <TrackingNumber>TST000006585</TrackingNumber>
                    <Rate>0.1686</Rate>
                 </CloseoutPackage>
              </Packages>
           </CloseoutResult>
        </CloseoutResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <CloseoutResponse xmlns="http://PurolatorServices.com/">
         <CloseoutResult>
            <Status>0</Status>
            <Packages>
               <CloseoutPackage>
                  <TrackingNumber>TST000006569</TrackingNumber>
                  <Rate>1.6468</Rate>
               </CloseoutPackage>
               <CloseoutPackage>
                  <TrackingNumber>TST000006577</TrackingNumber>
                  <Rate>2.9732</Rate>
               </CloseoutPackage>
               <CloseoutPackage>
                  <TrackingNumber>TST000006585</TrackingNumber>
                  <Rate>0.1686</Rate>
               </CloseoutPackage>
            </Packages>
         </CloseoutResult>
      </CloseoutResponse>
   </soap:Body>
</soap:Envelope>


Closeout With LTL

Closeout With LTL Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Closes out a series of packages and LTL Pro Numbers.

A closeout notifies the system that packages are being shipped.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:CloseoutWithLTL>
           <pur:request>
              <pur:Credentials>
                 <pur:UserName>TestUser</pur:UserName>
                 <pur:Password>5VJrtqTa</pur:Password>
                 <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:ShipDate>2012-08-14T00:00:00</pur:ShipDate>
              <pur:ParsNumber/>
              <pur:SkidCount>1</pur:SkidCount>
              <pur:PackIDType>PackageID</pur:PackIDType>
              <pur:PackageIDs>
                 <pur:string>Pkg-0045</pur:string>
              </pur:PackageIDs>
              <pur:LTLNumberType>ProNumber</pur:LTLNumberType>
              <pur:LTLNumbers>
                 <pur:string>000000059</pur:string>
              </pur:LTLNumbers>
           </pur:request>
        </pur:CloseoutWithLTL>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:CloseoutWithLTL>
         <pur:request>
            <pur:Credentials>
               <pur:UserName>TestUser</pur:UserName>
               <pur:Password>5VJrtqTa</pur:Password>
               <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:ShipDate>2012-08-14T00:00:00</pur:ShipDate>
            <pur:ParsNumber/>
            <pur:SkidCount>1</pur:SkidCount>
            <pur:PackIDType>PackageID</pur:PackIDType>
            <pur:PackageIDs>
               <pur:string>Pkg-0045</pur:string>
            </pur:PackageIDs>
            <pur:LTLNumberType>ProNumber</pur:LTLNumberType>
            <pur:LTLNumbers>
               <pur:string>000000059</pur:string>
            </pur:LTLNumbers>
         </pur:request>
      </pur:CloseoutWithLTL>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <CloseoutWithLTLResponse xmlns="http://PurolatorServices.com/">
           <CloseoutWithLTLResult>
              <Status>0</Status>
              <Packages>
                 <CloseoutPackage>
                    <TrackingNumber>TST000006619</TrackingNumber>
                    <Rate>75.2200</Rate>
                 </CloseoutPackage>
              </Packages>
              <Pallets>
                 <LTLPalletResponse>
                    <PalletNumber>1</PalletNumber>
                    <TrackingNumber>000000059</TrackingNumber>
                    <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO125,580^BY3^B3N,N,200,N,N^FD000000059^FS^FO0,810^A0N,33,43^FB800,,,C^FDPRO NUMBER: 000000059^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
                 </LTLPalletResponse>
                 <LTLPalletResponse>
                    <PalletNumber>1</PalletNumber>
                    <TrackingNumber>67</TrackingNumber>
                    <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD2 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO0,590^A0N,33,43^FDPRO NUMBER: 000000059^FS^FO210,650^BY4^BCN,200,N,N,N,N^FD67^FS^FO0,885^A0N,33,43^FB800,,,C^FDPIN NUMBER: 67^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
                 </LTLPalletResponse>
              </Pallets>
           </CloseoutWithLTLResult>
        </CloseoutWithLTLResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <CloseoutWithLTLResponse xmlns="http://PurolatorServices.com/">
         <CloseoutWithLTLResult>
            <Status>0</Status>
            <Packages>
               <CloseoutPackage>
                  <TrackingNumber>TST000006619</TrackingNumber>
                  <Rate>75.2200</Rate>
               </CloseoutPackage>
            </Packages>
            <Pallets>
               <LTLPalletResponse>
                  <PalletNumber>1</PalletNumber>
                  <TrackingNumber>000000059</TrackingNumber>
                  <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD1 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO125,580^BY3^B3N,N,200,N,N^FD000000059^FS^FO0,810^A0N,33,43^FB800,,,C^FDPRO NUMBER: 000000059^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
               </LTLPalletResponse>
               <LTLPalletResponse>
                  <PalletNumber>1</PalletNumber>
                  <TrackingNumber>67</TrackingNumber>
                  <ZPLCode>^XA^PR5,5^LH25,0^PW800^LL1200^FO5,10^XGR:PCLLOGO.GRF,1,1^FS^FO25,30^A0N,22,30^FB750,,,R^FDwww.purolatorinternational.com^FS^FO25,60^A0N,22,30^FB750,,,R^FDNIR# R-500035-2^FS^FO8,88^GB18,120,23^FS^FO12,102^A0B,20,23^FR^FDFROM/DE^FS^FO43,85^A0N,22,23^FDSimple Earth Hops^FS^FO43,108^A0N,22,23^FD210 S Lindsey Street^FS^FO43,131^A0N,22,23^FDDodgeville, WI   53533^FS^FO8,218^GB18,80,23^FS^FO12,232^A0B,20,23^FR^FDTO/A^FS^FO43,215^A0N,26,27^FDRed Duck Beer^FS^FO43,247^A0N,26,27^FD101 Sample Street^FS^FO43,279^A0N,26,27^FDSuite 202^FS^FO41,311^A0N,32,33^FDScarborough, ON   M1M1M1^FS^FO34,503^GB102,26,26^FS^FO30,507^A0N,25,27^FB102,,,C^FR^FDDATE^FS^FO0,537^A0N,25,29^FB162,,,C^FD9 Aug 2012^FS^FO334,503^GB131,26,26^FS^FO336,507^A0N,25,27^FB131,,,C^FR^FDSKID^FS^FO305,537^A0N,25,29^FB191,,,C^FD2 of/de 2^FS^FO569,503^GB225,26,26^FS^FO569,507^A0N,25,27^FB225,,,C^FR^FDWEIGHT/POIDS^FS^FO569,537^A0N,25,29^FB225,,,C^FD30.00 lb^FS^FO0,590^A0N,33,43^FDPRO NUMBER: 000000059^FS^FO210,650^BY4^BCN,200,N,N,N,N^FD67^FS^FO0,885^A0N,33,43^FB800,,,C^FDPIN NUMBER: 67^FS^FO400,310^A0N,48,48^FDTest Label^FS^FO400,350^A0N,48,48^FDDo Not Ship^FS^XZ</ZPLCode>
               </LTLPalletResponse>
            </Pallets>
         </CloseoutWithLTLResult>
      </CloseoutWithLTLResponse>
   </soap:Body>
</soap:Envelope>


Closeout Update Weight

Closeout Update Weight Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Closes out a series of packages and updates their weights.

A closeout notifies the system that packages are being shipped.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:CloseoutUpdateWeight>
           <pur:request>
              <pur:Credentials>
                 <pur:UserName>TestUser</pur:UserName>
                 <pur:Password>5VJrtqTa</pur:Password>
                 <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:ShipDate>2012-02-05T00:00:00</pur:ShipDate>
              <pur:ParsNumber/>
              <pur:SkidCount>1</pur:SkidCount>
              <pur:PackIDType>PIN</pur:PackIDType>
              <pur:PackageWeights>
                 <pur:PackageIDWeight>
                    <pur:PackageID>TST000000075</pur:PackageID>
                    <pur:WeightUOM>L</pur:WeightUOM>
                    <pur:Weight>2.25</pur:Weight>
                 </pur:PackageIDWeight>
                 <pur:PackageIDWeight>
                    <pur:PackageID>TST000000083</pur:PackageID>
                    <pur:WeightUOM>L</pur:WeightUOM>
                    <pur:Weight>7.33</pur:Weight>
                 </pur:PackageIDWeight>
                 <pur:PackageIDWeight>
                    <pur:PackageID>TST000000091</pur:PackageID>
                    <pur:WeightUOM>L</pur:WeightUOM>
                    <pur:Weight>5.89</pur:Weight>
                 </pur:PackageIDWeight>
              </pur:PackageWeights>
           </pur:request>
        </pur:CloseoutUpdateWeight>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:CloseoutUpdateWeight>
         <pur:request>
            <pur:Credentials>
               <pur:UserName>TestUser</pur:UserName>
               <pur:Password>5VJrtqTa</pur:Password>
               <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:ShipDate>2012-02-05T00:00:00</pur:ShipDate>
            <pur:ParsNumber/>
            <pur:SkidCount>1</pur:SkidCount>
            <pur:PackIDType>PIN</pur:PackIDType>
            <pur:PackageWeights>
               <pur:PackageIDWeight>
                  <pur:PackageID>TST000000075</pur:PackageID>
                  <pur:WeightUOM>L</pur:WeightUOM>
                  <pur:Weight>2.25</pur:Weight>
               </pur:PackageIDWeight>
               <pur:PackageIDWeight>
                  <pur:PackageID>TST000000083</pur:PackageID>
                  <pur:WeightUOM>L</pur:WeightUOM>
                  <pur:Weight>7.33</pur:Weight>
               </pur:PackageIDWeight>
               <pur:PackageIDWeight>
                  <pur:PackageID>TST000000091</pur:PackageID>
                  <pur:WeightUOM>L</pur:WeightUOM>
                  <pur:Weight>5.89</pur:Weight>
               </pur:PackageIDWeight>
            </pur:PackageWeights>
         </pur:request>
      </pur:CloseoutUpdateWeight>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <CloseoutUpdateWeightResponse xmlns="http://PurolatorServices.com/">
           <CloseoutUpdateWeightResult>
              <Status>2</Status>
              <Messages>
                 <ResponseMessage>
                    <Number>88</Number>
                    <Severity>2</Severity>
                    <Message>The following packages do not exist or are not available for closeout: TST000000075,TST000000083,TST000000091.</Message>
                 </ResponseMessage>
              </Messages>
           </CloseoutUpdateWeightResult>
        </CloseoutUpdateWeightResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <CloseoutUpdateWeightResponse xmlns="http://PurolatorServices.com/">
         <CloseoutUpdateWeightResult>
            <Status>2</Status>
            <Messages>
               <ResponseMessage>
                  <Number>88</Number>
                  <Severity>2</Severity>
                  <Message>The following packages do not exist or are not available for closeout: TST000000075,TST000000083,TST000000091.</Message>
               </ResponseMessage>
            </Messages>
         </CloseoutUpdateWeightResult>
      </CloseoutUpdateWeightResponse>
   </soap:Body>
</soap:Envelope>


Add Consolidated LTL Shipment

Add Consolidated LTL Shipment Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Complete processing of a series of packages and updates their weights.

A closeout notifies the system that packages are being shipped.

Sample Request
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
     <soap:Header/>
     <soap:Body>
        <pur:AddConsolidatedLTLShipment>
           <pur:request>
              <pur:Credentials>
                  <pur:UserName>TestUser</pur:UserName>
                  <pur:Password>5VJrtqTa</pur:Password>
                  <pur:ClientID>0000000</pur:ClientID>
              </pur:Credentials>
              <pur:ProNumber>1813-13815</pur:ProNumber>
              <pur:LTLShipmentNumber>Test-0002</pur:LTLShipmentNumber>
              <pur:ShipDate>2012-02-05T00:00:00</pur:ShipDate>
              <pur:ShipToAddress>
                  <pur:Name></pur:Name>
                  <pur:Company>Red Duck Beer</pur:Company>
                  <pur:Add1>101 Sample Street</pur:Add1>
                  <pur:Add2>Suite 202</pur:Add2>
                  <pur:City>Scarborough</pur:City>
                  <pur:StateProv>ON</pur:StateProv>
                  <pur:PostalCode>M1M1M1</pur:PostalCode>
                  <pur:Country>CA</pur:Country>
                  <pur:Phone></pur:Phone>
                  <pur:Email>SampleAddress@Example.com</pur:Email>
              </pur:ShipToAddress>
              <pur:GrossWeight>48.92</pur:GrossWeight>
              <pur:OrderNumbers>
                 <pur:string>Test-0001</pur:string>
              </pur:OrderNumbers>
              <pur:Pallets>
                 <pur:LTLPalletRequest>
                    <pur:PalletNumber>1</pur:PalletNumber>
                 </pur:LTLPalletRequest>
              </pur:Pallets>
           </pur:request>
        </pur:AddConsolidatedLTLShipment>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:pur="http://PurolatorServices.com/">
   <soap:Header/>
   <soap:Body>
      <pur:AddConsolidatedLTLShipment>
         <pur:request>
            <pur:Credentials>
                <pur:UserName>TestUser</pur:UserName>
                <pur:Password>5VJrtqTa</pur:Password>
                <pur:ClientID>0000000</pur:ClientID>
            </pur:Credentials>
            <pur:ProNumber>1813-13815</pur:ProNumber>
            <pur:LTLShipmentNumber>Test-0002</pur:LTLShipmentNumber>
            <pur:ShipDate>2012-02-05T00:00:00</pur:ShipDate>
            <pur:ShipToAddress>
                <pur:Name></pur:Name>
                <pur:Company>Red Duck Beer</pur:Company>
                <pur:Add1>101 Sample Street</pur:Add1>
                <pur:Add2>Suite 202</pur:Add2>
                <pur:City>Scarborough</pur:City>
                <pur:StateProv>ON</pur:StateProv>
                <pur:PostalCode>M1M1M1</pur:PostalCode>
                <pur:Country>CA</pur:Country>
                <pur:Phone></pur:Phone>
                <pur:Email>SampleAddress@Example.com</pur:Email>
            </pur:ShipToAddress>
            <pur:GrossWeight>48.92</pur:GrossWeight>
            <pur:OrderNumbers>
               <pur:string>Test-0001</pur:string>
            </pur:OrderNumbers>
            <pur:Pallets>
               <pur:LTLPalletRequest>
                  <pur:PalletNumber>1</pur:PalletNumber>
               </pur:LTLPalletRequest>
            </pur:Pallets>
         </pur:request>
      </pur:AddConsolidatedLTLShipment>
   </soap:Body>
</soap:Envelope>
Sample Response
XML
View Colorized Copy to Clipboard Print
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
     <soap:Body>
        <AddConsolidatedLTLShipmentResponse xmlns="http://PurolatorServices.com/">
           <AddConsolidatedLTLShipmentResult>
              <Status>0</Status>
           </AddConsolidatedLTLShipmentResult>
        </AddConsolidatedLTLShipmentResponse>
     </soap:Body>
  </soap:Envelope>
<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <AddConsolidatedLTLShipmentResponse xmlns="http://PurolatorServices.com/">
         <AddConsolidatedLTLShipmentResult>
            <Status>0</Status>
         </AddConsolidatedLTLShipmentResult>
      </AddConsolidatedLTLShipmentResponse>
   </soap:Body>
</soap:Envelope>


Return Codes

Return Codes Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

This page lists the error codes which might be returned by a web service response.

Messages Sorted By Return Code
Return Code | Type | Message * | Explanation | Add Order | Add LTL Order | Get Rates | Update Order | Add Package | Add Item | Get Label | Closeout | Closeout Update Weight | Closeout With LTL | Add Consolidated LTL Shipment | Void Packages | Void Orders | Get ZPL Initialization Images | Get Order Status | Shipment Verification
1 | Error | The credentials didn't match or were not provided. | The UserName and/or Password and/or ClientID was incorrect. | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x
2 | Error | The service code isn't valid. | The valid text for the each Service is: "9AM", "1030AM", "Saturday", "OSNR", "HFP", "NotifyConsignee", "DangerousLQ", "Dangerous500KG", & "DangerousRegulated" | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
3 | Error | The specified Ship Method isn't valid. | Either the destination Postal Code is not serviced by Purolator, or the Ship Method text is not one of the following: "Air, "Ground", "PuroLetter", "PuroPak", "PuroPost", "Fastest", or "LTL" | x | x | x |  | x |  |  |  |  | x | x |  |  |  |  |
4 | Error | The specified Country isn't valid. | Either the two digit ISO 3166 Country Code or the full country name is accepted. See the Country Names tab. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
5 | Error | The specified Currency isn't valid. USD and CAD supported. | The only accepted currency codes USD and CAD. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
6 | Error | The specified PIN wasn't found in the database. | The pin number was not found. |  |  |  |  |  |  |  |  |  |  |  | x |  |  |  |
8 | Error | The supported label types are ZPL, ZPLIMAGES, and IMAGE. | The valid Label types are: "ZPL", "ZPLIMAGES", "IMAGE", and "NONE". | x |  |  |  | x |  | x |  |  |  |  |  |  |  |  |
9 | Error | The supported billing types are PREPAID, COLLECT, and 3RDPARTY. | The valid Billing Options are: "Prepaid", "Collect", and "3rdParty". | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 | Error | Invalid Purolator account number. | The specified Purolator account number does not have the correct format. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
10 | Error | Invalid Purolator account number. | This account does not have access to the package with the matching Pin or PackageID. |  |  |  |  |  |  | x |  |  |  |  |  |  |  |  |
11 | Error | Invalid Order number. | No shipment with specified Order Number was found. |  |  |  |  |  |  |  |  |  |  |  |  | x |  | x |
12 | Warning | Invalid Contract number. | The contract number was not provided or was blank. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
13 | Error | Invalid Province for the postal code. | The specified Postal Code is not valid for the specified province. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
14 | Error | Only packages that are Ready for Pickup or Verified can be voided | The customer may only void a package/order until it is picked up by Purolator. |  |  |  |  |  |  |  |  |  |  |  | x | x |  |  |
15 | Error | 9 AM service is unavailable for this location. | 9:00 am service is unavailable for LTL shipments. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
16 | Error | 10:30 AM service is unavailable for this location. | 10:30 am service is unavailable for LTL shipments. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
17 | Error | Saturday service is unavailable for this location. | Saturday service is unavailable for LTL shipments. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
18 | Error | Only one time/date service may be selected. | More than one of the following mutually exclusive time services was specified: 9AM, 1030AM, SATURDAY | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
20 | Error | Only one Dangerous Goods service may be selected. | More than one of the following mutually exclusive dangerous goods services was specified: DANGEROUSLQ, DANGEROUS500KG, DANGEROUSREGULATED | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
21 | Error | Dangerous Goods cannot be selected with Saturday service. | Dangerous Goods cannot be selected with Saturday service. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
22 | Error | Dangerous Goods cannot be shipped to beyond points. | Dangerous Goods cannot be shipped to beyond points. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
23 | Error | Dangerous Goods Limited Quantities and Dangerous Goods 500 KG Exemption packages are limited to 66 lbs. | Dangerous Goods Limited Quantities and Dangerous Goods 500 KG Exemption packages are limited to 66 lbs. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
24 | Error | Dangerous Goods Limited Quantities and Dangerous Goods 500 KG Exemption shipments must be shipped ground. | Dangerous Goods Limited Quantities and Dangerous Goods 500 KG Exemption shipments must be shipped ground. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
25 | Error | Dangerous Goods Fully Regulated shipments are limited to 1000KG (2204 lbs). | Dangerous Goods Fully Regulated shipments are limited to 1000KG (2204 pounds). | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
26 | Error | 9:00am, 10:30am and Saturday shipments must be shipped via the fastest ship method | For 9:00am, 10:30am, and Saturday services, Ground may not be selected if Air is faster and visa versa. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
27 | Error | 9:00am, 10:30am and Saturday shipments must be shipped to a location with one day delivery | The specified destination does not offer 9:00am, 10:30am, or Saturday services. |  |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
28 | Error | Dangerous Goods cannot be shipped to points serviced by ferries. | Dangerous Goods cannot be shipped to points serviced by ferries. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
29 | Error | Hold For Pickup and No Signature Required may not be selected together. | Hold For Pickup and No Signature Required may not be selected together. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
30 | Error | Order number is required. | The Order Number for the shipment is a required field. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
31 | Error | Ship Date is required. | The Ship Date is a required field. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
32 | Error | Either PackageID or PIN is required. | Get Label requires either the package's Pin or its PackageID. |  |  |  |  |  |  | x |  |  |  |  |  |  |  |  |
33 | Error | Valid PackageID or PIN is required. | No package with the specified Pin or PackageID was found. |  |  |  |  |  |  | x |  |  |  |  |  |  |  |  |
34 | Error | Existing Order number is required. | The Order Number specified in the request could not be found. |  |  |  | x | x | x |  |  |  |  | x |  |  |  |  |
35 | Error | LTL shipments must be end of day. | LTL shipments cannot be marked for 9AM, 1030AM, or SATURDAY delivery. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
36 | Error | Each order number must be unique. | An Order Number cannot be used on more than one shipment within the same Account. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
37 | Error | Dangerous Goods may not be shipped to US or international destinations. | Dangerous Goods may not be shipped to US or international destinations. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
38 | Error | Shipments to the US are limited to 551 lbs. | A shipment to the United States cannot weigh more than 551 pounds. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
39 | Error | This account is not authorized to ship to US destinations. | This account is not authorized to ship to US destinations. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
40 | Error | The Consignee's name is required. | The name of the consignee is required when Hold For Pickup is selected. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
41 | Error | The destination address requires a postal code. | The destination address requires a street address. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
42 | Error | The Consignee's postal code is required. | The destination address requires a postal code. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
43 | Error | The Consignee's phone number is required. | A valid phone number is required if Hold For Pickup is selected. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
44 | Error | The Consignee's city is required. | Consignee's City is required. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
45 | Error | The Consignee's province is required. | Consignee's Province is required. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
46 | Warning | The Consignee's email is required for shipments with advanced notification. | Consignee's Email is required for shipments with advanced notification. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
47 | Warning | The Consignee's email is required for shipments with advanced notification. | If provided, the consignee's Email should be properly formatted. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
49 | Error | Consignee's postal code must be properly formatted. | Consignee's postal code must be properly formatted. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
50 | Error | The Sender's name or company is required. | Sender's name or Company is required. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
51 | Error | The Sender's street address is required. | Sender's address requires a street address. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
52 | Error | The Sender's postal code is required. | Sender's address requires a postal code. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
54 | Error | The Sender's city is required. | Sender's city is required. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
55 | Error | The Sender's state or province is required. | Sender's state or province is required. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
56 | Error | The Sender's postal / zip code must be properly formatted. | Sender's postal or zip code must be properly formatted. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
58 | Error | Declared Value insurance is not available for LTL Shipments. | Declared Value insurance is not available for LTL Shipments. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
59 | Error | At least one Item is required for customs. | Item information is required for Customs if Purolator is handling customs for a Canadian bound shipment or if the shipment is a US bound shipment. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
60 | Error | A valid SKU is required. | The item's SKU is required. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
61 | Error | Customs description for items is required. | A short description of each item is required by customs. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
62 | Error | Billing Account is required. | The Billing Account is required for COLLECT and 3RDPARTY billing types. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
63 | Error | Item values must be greater than $1 CAD. | Item values must be greater than $1 CAD. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
64 | Error | Item Quantity is required. | Item quantity is required. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
65 | Error | The date is too old to be used. | The Ship Date must be the day the request is submitted, or later. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
66 | Error | The maximum declared value is $5,000. | Declared value for a shipment must be between $0 and $5,000 USD, inclusive. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
67 | Error | This package is too heavy. | A package may not weigh more than 150 pounds. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
68 | Error | This package is too heavy for a time/date service shipment or to a beyond point. | A package weighing more than 70 pounds cannot be shipped using a time/date service or shipped to a beyond point. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
69 | Error | The package is too long. | An Air package cannot have a length larger than 96 inches/144 centimeters. A Ground package cannot have a length larger than 120 inches/300 centimeters. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
70 | Error | The package is too large. | An Air package cannot have a dimension product (length + 2*(height + width)) larger than 144 inches/370 centimeters. A Ground package cannot have a dimension product larger than 216 inches/550 centimeters. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
71 | Error | There are no packages to close out. | There are no packages to close out. |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |
72 | Warning | There are no packages to rate. | Packages with the correct weight and dimensions are required to rate a shipment accurately. |  |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
73 | Error | There are no packages. | There are no packages. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
75 | Error | Each package must have a positive weight. | Packages with a zero weight can be entered, but the weight must be corrected before the shipment can be shipped. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
76 | Error | Each package must have a package number. | The Package Number was not provided for at least one package. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
77 | Error | Each package is required to have all three dimensions set to at least 1 inch. | If the package dimensions are specified all must be larger than 0. | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
78 | Error | Declared Currency must be CAD or USD. |  |  | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
79 | Error | Customers using Purolator for Customs Clearance must include a list of packages to closeout. | Customers using Purolator for Customs Clearance must include a list of packages to closeout. |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |
80 | Error | The PackageID must be unique. | Two non-void packages in the same Purolator Account cannot have the same Package Number. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
81 | Error | Air service is not available to this postal code. | Air was specified, but Air service is not available to this postal code. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
82 | Error | Ground service is not available to this postal code. | Ground was specified, but Ground service is not available to this postal code. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
86 | Error | Sum of Items total values is too large for PASS clearance. | The total value for all Items listed cannot exceede $1600 CAD. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
87 | Error | Web services Closeout PackIDType must be Pin or PackageID. | Web services Closeout PackIDType must be 'Pin' or 'PackageID'. |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |
88 | Error | The following packages do not exist or are not available for closeout: | The following packages do not exist or are not available for closeout. |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |
89 | Error | Southbound shipments must originate in Canada. | Southbound shipments must originate in Canada. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
93 | Error | Return shipments must be sent from a Canadian address. | Return shipments must be sent from a Canadian address. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
94 | Error | Return shipments must be sent to a Canadian address. | Return shipments must be sent to a Canadian address. | x |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
95 | Error | Return shipments may not be Puro Letter or Puro Pak. | Return shipments cannot be PuroLetters or PuroPaks. | x |  | x |  |  |  |  |  |  |  |  |  |  |  |  |
96 | Error | Return shipments may not be LTL. | Return shipments cannot be LTL shipments. | x |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
97 | Error | Return shipments may not be Collect or third party. | Return shipments cannot be Collect or Third Party shipments. | x |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
99 | Error | The Ship To Country is required and must be a two digit ISO 3166 Country Code (US - United States, CA - Canada). | The Ship To Country is required and must be a two digit ISO 3166 Country Code (US - United States, CA - Canada). | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
101 | Error | The origin is invalid. | The Postal Code in the from address is not a valid Canadian Postal Code. (Spaces, dashes, and capitalization differences are ignored.) | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
102 | Error | The destination is invalid. | The destination Postal Code/ZIP Code is not valid. (Spaces, dashes, and capitalization differences are ignored.) | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
103 | Error | Purolator doesn't service this origin. | The Postal Code in the from address may be valid, but it is not serviced by Purolator. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
104 | Error | Purolator doesn't service this destination. | The destination Postal Code may be valid, but it is not serviced by Purolator. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
105 | Error | Invalid sort code. | Purolator does not ship to this destination. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
106 | Error | Invalid transit code. | Purolator does not ship to this destination. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
199 | Error | Unexpected error occurred when trying to make service calculations. | An unexpected internal problem occurred when attempting to determine which services to the destination address are available. | x | x | x |  | x |  |  |  |  |  |  |  |  |  |  |
201 | Error | The update type is not supported. |  |  |  |  | x |  |  |  |  |  |  |  |  |  |  |  |
202 | Error | Web services Closeout PalletIDType must be TrackNo or PalletID. |  |  |  |  |  |  |  |  |  |  | x |  |  |  |  |  |
203 | Error | The PARS number must be unique |  |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |
205 | Error | Each package is required to have minimum dimensions of {0}. |  | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
206 | Error | Dangerous Goods are prohibited for this ship method. |  | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
207 | Error | This service type does not support Third Party or Collect billing. |  | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
208 | Error | This product may not have more than {0} package(s). |  | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
209 | Error | This product must have at least {0} packages. |  | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
210 | Error | This product requires a shipment of at least {0} lbs. |  | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
211 | Error | This product has a maximum shipment weight of {0} lbs. |  | x |  | x |  | x |  |  |  |  |  |  |  |  |  |  |
1000 | Error | Name or Company is required. |  | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1001 | Error | Name is too long. | Name cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1002 | Error | Company is too long. | Company cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1051 | Error | Address 1 is too long. | Address 1 cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1052 | Error | Address 2 is too long. | Address 2 cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1053 | Error | Address 3 is too long. | Address 3 cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1055 | Error | Purolator cannot ship to post office boxes. |  | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1101 | Error | Postal Code is too long. | Postal Code cannot be longer than 10 characters. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
1151 | Error | City is too long. | City cannot be longer than 30 characters. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
1201 | Error | Province/State must be a two character abbreviation. | Province/State cannot be longer than 2 characters. | x | x | x |  |  |  |  |  |  |  |  |  |  |  |  |
1261 | Error | Email is too long. | Email cannot be longer than 40 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1301 | Error | Phone is too long. | Phone cannot be longer than 20 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
1402 | Error | All packages must have a weight greater than 0. |  |  |  |  |  |  |  |  |  | x |  |  |  |  |  |  |
2002 | Error | Orders must be LTL ship type. |  |  |  |  |  |  |  |  |  |  |  | x |  |  |  |  |
2003 | Error | All orders in an LTL shipment must have the same consignee address. |  |  |  |  |  |  |  |  |  |  |  | x |  |  |  |  |
2004 | Error | ProNumbers for LTL Shipments must be unique. |  |  |  |  |  |  |  |  |  |  |  | x |  |  |  |  |
9011 | Error | Order Number is too long. | The shipment's Order Number cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
9012 | Error | Currency is too long. | The Currency Code cannot be longer than 3 characters. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
9015 | Error | Reference is too long. | The Reference field cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
9016 | Error | Reference2/Note is too long. | The Reference2/Note field cannot be longer than 50 characters. | x | x |  |  |  |  |  |  |  |  |  |  |  |  |  |
9017 | Error | PO Number is too long. | The PO Number field cannot be longer than 50 characters. | x | x |  | x |  |  |  |  |  |  |  |  |  |  |  |
9020 | Error | Package Number is too long. | The package's Package Number cannot be longer than 50 characters. | x |  |  |  | x |  |  |  |  |  |  |  |  |  |  |
9025 | Error | SKU is too long. | The package's SKU cannot be longer than 25 characters. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
9026 | Error | Description is too long. | The package's Description cannot be longer than 50 characters. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
9027 | Error | HSCode is too long. | The package's HSCode cannot be longer than 20 characters. | x | x |  |  |  | x |  |  |  |  |  |  |  |  |  |
9999 | Error | Unhandled Exception | The web service encountered an unexpected problem and was unable to process the request properly. | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x

* The error message may contain additional information, for example specifying which package Pin in a shipment is invalid.


API Reference

API Reference Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Purolator Webservice allows clients to create labels and ship packages through a web service interface.

The service exposes five methods:

GetRates(OrderRequest) | Get availability and estimated rate without creating the order.
AddOrder(OrderRequest) | Get availability and estimated rate and creating an order in the Purolator system.
AddPackage(AddPackageRequest) | Adds packages to an existing order.
AddItem(AddItemRequest) | Add customs item records to an existing order.
Closeout(CloseoutRequest) | Complete processing of orders.
ShipmentVerification(PackageListRequest) | Verify packages as part of some clients multi-step shipment process.
VoidPackages(PackageListRequest) | Void a list of previosly created packages.

The location of the WSDL file on our test server is: http://support.pclusa.com/PurolatorOLS/WebServices/ShippingServices.asmx?WSDL.

Once you are ready to go into production, you can change the url to: http://www.purolatorshipping.com/WebServices/ShippingServices.asmx

Please keep in mind that any test packages created in production will be billed as if they were real and shipped unless you check with us in advance.

Namespaces
Namespace | Description
Purolator.Webservice | Defines available webservice calls.
Purolator.Webservice.Objects | Defines objects supporting Purolator Webservice calls.


Purolator.Webservice Namespace

Purolator.Webservice Namespace Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Defines available webservice calls.
Classes
 | Class | Description
Public class | CredentialSummary |
Public class | FtpNotification | Summary description for FtpNotification
Public class | LogWebService |
Public class | ShippingServices | Summary description for ShippingServices


CredentialSummary Class

CredentialSummary Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.CredentialSummary"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice CredentialSummary

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CredentialSummary
public class CredentialSummary
Public Class CredentialSummary
Public Class CredentialSummary
public ref class CredentialSummary
public ref class CredentialSummary
See Also
CredentialSummary Members
Purolator.Webservice Namespace


CredentialSummary Members

CredentialSummary Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CredentialSummary type exposes the following members.
Constructors
 | Name | Description
Public method | CredentialSummary |
Back to Top
Properties
 | Name | Description
Public property | sa |
Public property | user |
Back to Top
See Also
CredentialSummary Class
Purolator.Webservice Namespace


CredentialSummary Constructor

CredentialSummary Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.CredentialSummary.#ctor"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialSummary()
public CredentialSummary()
Public Sub New
Public Sub New
public:
CredentialSummary()
public:
CredentialSummary()
See Also
CredentialSummary Class
CredentialSummary Members
Purolator.Webservice Namespace


CredentialSummary Properties

CredentialSummary Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CredentialSummary type exposes the following members.
Properties
 | Name | Description
Public property | sa |
Public property | user |
Back to Top
See Also
CredentialSummary Class
Purolator.Webservice Namespace


sa Property

CredentialSummary sa Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.CredentialSummary.sa"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShipperAccount sa { get; set; }
public ShipperAccount sa { get; set; }
Public Property sa As ShipperAccount
    Get
    Set
Public Property sa As ShipperAccount
    Get
    Set
public:
property ShipperAccount^ sa {
    ShipperAccount^ get ();
    void set (ShipperAccount^ value);
}
public:
property ShipperAccount^ sa {
    ShipperAccount^ get ();
    void set (ShipperAccount^ value);
}
See Also
CredentialSummary Class
CredentialSummary Members
Purolator.Webservice Namespace


user Property

CredentialSummary user Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.CredentialSummary.user"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UserInfo user { get; set; }
public UserInfo user { get; set; }
Public Property user As UserInfo
    Get
    Set
Public Property user As UserInfo
    Get
    Set
public:
property UserInfo^ user {
    UserInfo^ get ();
    void set (UserInfo^ value);
}
public:
property UserInfo^ user {
    UserInfo^ get ();
    void set (UserInfo^ value);
}
See Also
CredentialSummary Class
CredentialSummary Members
Purolator.Webservice Namespace


FtpNotification Class

FtpNotification Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Summary description for FtpNotification
Inheritance Hierarchy
Online System Object
Online System.ComponentModel MarshalByValueComponent
Online System.Web.Services WebService
Purolator.Webservice FtpNotification

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class FtpNotification : WebService
public class FtpNotification : WebService
Public Class FtpNotification _
    Inherits WebService
Public Class FtpNotification _
    Inherits WebService
public ref class FtpNotification : public WebService
public ref class FtpNotification : public WebService
See Also
FtpNotification Members
Purolator.Webservice Namespace


FtpNotification Members

FtpNotification Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The FtpNotification type exposes the following members.
Constructors
 | Name | Description
Public method | FtpNotification |
Back to Top
Methods
 | Name | Description
Public method | FtpNotify | Notifies OLS that a file is available for parsing on an ftp site.
Back to Top
See Also
FtpNotification Class
Purolator.Webservice Namespace


FtpNotification Constructor

FtpNotification Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.FtpNotification.#ctor"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FtpNotification()
public FtpNotification()
Public Sub New
Public Sub New
public:
FtpNotification()
public:
FtpNotification()
See Also
FtpNotification Class
FtpNotification Members
Purolator.Webservice Namespace


FtpNotification Methods

FtpNotification Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The FtpNotification type exposes the following members.
Methods
 | Name | Description
Public method | FtpNotify | Notifies OLS that a file is available for parsing on an ftp site.
Back to Top
See Also
FtpNotification Class
Purolator.Webservice Namespace


FtpNotify Method

FtpNotification FtpNotify Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Notifies OLS that a file is available for parsing on an ftp site.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool FtpNotify(
    string clientID,
    string url,
    string userName,
    string password
)
public bool FtpNotify(
    string clientID,
    string url,
    string userName,
    string password
)
Public Function FtpNotify ( _
    clientID As String, _
    url As String, _
    userName As String, _
    password As String _
) As Boolean
Public Function FtpNotify ( _
    clientID As String, _
    url As String, _
    userName As String, _
    password As String _
) As Boolean
public:
bool FtpNotify(
    String^ clientID,
    String^ url,
    String^ userName,
    String^ password
)
public:
bool FtpNotify(
    String^ clientID,
    String^ url,
    String^ userName,
    String^ password
)
Parameters
clientID
Type:   Online System String
The clientID of the file. The clientID must match the clientID in the file.
url
Type:   Online System String
The ftp location of file. If a username and password are embedded in the url,
            they will override the username and password provided in this call.
userName
Type:   Online System String
The username required for logging into the website. An embedded username in the ftp url will overide this value.
password
Type:   Online System String
The password required for logging into the website. An embedded password in the ftp url will overide this value.
Return Value

            True or false, depending on whether the call succeeded.
            Success is defined as adding the url to the database, not actually reading and parsing the file.

See Also
FtpNotification Class
FtpNotification Members
Purolator.Webservice Namespace


LogWebService Class

LogWebService Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.LogWebService"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice LogWebService

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class LogWebService
public static class LogWebService
Public NotInheritable Class LogWebService
Public NotInheritable Class LogWebService
public ref class LogWebService abstract sealed
public ref class LogWebService abstract sealed
See Also
LogWebService Members
Purolator.Webservice Namespace


LogWebService Members

LogWebService Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LogWebService type exposes the following members.
Methods
Name | Description
LogWebServiceCall |
Back to Top
Properties
Name | Description
LogCalls |
Back to Top
See Also
LogWebService Class
Purolator.Webservice Namespace


LogWebService Methods

LogWebService Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LogWebService type exposes the following members.
Methods
Name | Description
LogWebServiceCall |
Back to Top
See Also
LogWebService Class
Purolator.Webservice Namespace


LogWebServiceCall Method

LogWebService LogWebServiceCall Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.LogWebService.LogWebServiceCall(Purolator.Webservice.Objects.CredentialInfo,System.String,System.Object,System.String)"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void LogWebServiceCall(
    CredentialInfo credentials,
    string orderNumber,
    Object response,
    string suffix
)
public static void LogWebServiceCall(
    CredentialInfo credentials,
    string orderNumber,
    Object response,
    string suffix
)
Public Shared Sub LogWebServiceCall ( _
    credentials As CredentialInfo, _
    orderNumber As String, _
    response As Object, _
    suffix As String _
)
Public Shared Sub LogWebServiceCall ( _
    credentials As CredentialInfo, _
    orderNumber As String, _
    response As Object, _
    suffix As String _
)
public:
static void LogWebServiceCall(
    CredentialInfo^ credentials,
    String^ orderNumber,
    Object^ response,
    String^ suffix
)
public:
static void LogWebServiceCall(
    CredentialInfo^ credentials,
    String^ orderNumber,
    Object^ response,
    String^ suffix
)
Parameters
credentials
Type: Purolator.Webservice.Objects CredentialInfo
[Missing <param name="credentials"/> documentation for "M:Purolator.Webservice.LogWebService.LogWebServiceCall(Purolator.Webservice.Objects.CredentialInfo,System.String,System.Object,System.String)"]
orderNumber
Type:   Online System String
[Missing <param name="orderNumber"/> documentation for "M:Purolator.Webservice.LogWebService.LogWebServiceCall(Purolator.Webservice.Objects.CredentialInfo,System.String,System.Object,System.String)"]
response
Type:   Online System Object
[Missing <param name="response"/> documentation for "M:Purolator.Webservice.LogWebService.LogWebServiceCall(Purolator.Webservice.Objects.CredentialInfo,System.String,System.Object,System.String)"]
suffix
Type:   Online System String
[Missing <param name="suffix"/> documentation for "M:Purolator.Webservice.LogWebService.LogWebServiceCall(Purolator.Webservice.Objects.CredentialInfo,System.String,System.Object,System.String)"]
See Also
LogWebService Class
LogWebService Members
Purolator.Webservice Namespace


LogWebService Properties

LogWebService Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LogWebService type exposes the following members.
Properties
Name | Description
LogCalls |
Back to Top
See Also
LogWebService Class
Purolator.Webservice Namespace


LogCalls Property

LogWebService LogCalls Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.LogWebService.LogCalls"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool LogCalls { get; }
public static bool LogCalls { get; }
Public Shared ReadOnly Property LogCalls As Boolean
    Get
Public Shared ReadOnly Property LogCalls As Boolean
    Get
public:
static property bool LogCalls {
    bool get ();
}
public:
static property bool LogCalls {
    bool get ();
}
See Also
LogWebService Class
LogWebService Members
Purolator.Webservice Namespace


ShippingServices Class

ShippingServices Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Summary description for ShippingServices
Inheritance Hierarchy
Online System Object
Online System.ComponentModel MarshalByValueComponent
Online System.Web.Services WebService
Purolator.Webservice ShippingServices

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ShippingServices : WebService
public class ShippingServices : WebService
Public Class ShippingServices _
    Inherits WebService
Public Class ShippingServices _
    Inherits WebService
public ref class ShippingServices : public WebService
public ref class ShippingServices : public WebService
See Also
ShippingServices Members
Purolator.Webservice Namespace


ShippingServices Members

ShippingServices Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ShippingServices type exposes the following members.
Constructors
 | Name | Description
Public method | ShippingServices |
Back to Top
Methods
 | Name | Description
Public method | AddConsolidatedLTLShipment | Complete processing of a series of packages and updates their weights.
Public method | AddItem | Adds customs items to an existing order.
Public method | AddLTLOrder | Adds an LTL order that will be included in a single LTL Shipment.
Public method | AddOrder | Gets the service availability, estimated rate, pin numbers, and labels for each package; enters the order in the Purolator system.
Public method | AddPackage | Adds packages to an existing order.
Public method | Closeout | Complete processing of a series of packages.
Public method | CloseoutUpdateWeight | Complete processing of a series of packages and updates their weights.
Public method | CloseoutWithLTL | Complete processing of a series of packages and LTL Pro Numbers.
Public method | GetLabel | Gets a Package label either as ZPL code or as a Base64 encoded image.
Public method | GetOrderStatus | Gets an OrderResponse for the specified order.
Public method | GetRates | Gets the service availability and estimated rates without creating the order.
Public method | GetZPLInitializationImages | Gets ZPL code to load Purolator specific images into a ZPL printer.
Public method | ShipmentVerification | Verifies that each package is being shipped as part of some clients multi-step shipment process.
Public method | UpdateOrder | Updates values in existing orders.
Public method | VoidOrders | Voids a list of orders.
Public method | VoidPackages | Voids a list of packages.
Back to Top
See Also
ShippingServices Class
Purolator.Webservice Namespace


ShippingServices Constructor

ShippingServices Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.ShippingServices.#ctor"]

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShippingServices()
public ShippingServices()
Public Sub New
Public Sub New
public:
ShippingServices()
public:
ShippingServices()
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


ShippingServices Methods

ShippingServices Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ShippingServices type exposes the following members.
Methods
 | Name | Description
Public method | AddConsolidatedLTLShipment | Complete processing of a series of packages and updates their weights.
Public method | AddItem | Adds customs items to an existing order.
Public method | AddLTLOrder | Adds an LTL order that will be included in a single LTL Shipment.
Public method | AddOrder | Gets the service availability, estimated rate, pin numbers, and labels for each package; enters the order in the Purolator system.
Public method | AddPackage | Adds packages to an existing order.
Public method | Closeout | Complete processing of a series of packages.
Public method | CloseoutUpdateWeight | Complete processing of a series of packages and updates their weights.
Public method | CloseoutWithLTL | Complete processing of a series of packages and LTL Pro Numbers.
Public method | GetLabel | Gets a Package label either as ZPL code or as a Base64 encoded image.
Public method | GetOrderStatus | Gets an OrderResponse for the specified order.
Public method | GetRates | Gets the service availability and estimated rates without creating the order.
Public method | GetZPLInitializationImages | Gets ZPL code to load Purolator specific images into a ZPL printer.
Public method | ShipmentVerification | Verifies that each package is being shipped as part of some clients multi-step shipment process.
Public method | UpdateOrder | Updates values in existing orders.
Public method | VoidOrders | Voids a list of orders.
Public method | VoidPackages | Voids a list of packages.
Back to Top
See Also
ShippingServices Class
Purolator.Webservice Namespace


AddConsolidatedLTLShipment Method

ShippingServices AddConsolidatedLTLShipment Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Complete processing of a series of packages and updates their weights.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLShipmentResponse AddConsolidatedLTLShipment(
    LTLShipmentRequest request
)
public LTLShipmentResponse AddConsolidatedLTLShipment(
    LTLShipmentRequest request
)
Public Function AddConsolidatedLTLShipment ( _
    request As LTLShipmentRequest _
) As LTLShipmentResponse
Public Function AddConsolidatedLTLShipment ( _
    request As LTLShipmentRequest _
) As LTLShipmentResponse
public:
LTLShipmentResponse^ AddConsolidatedLTLShipment(
    LTLShipmentRequest^ request
)
public:
LTLShipmentResponse^ AddConsolidatedLTLShipment(
    LTLShipmentRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects LTLShipmentRequest
A LTLShipmentRequest.
Return Value
A LTLShipmentResponse
Remarks

            A closeout notifies the system that packages are being shipped.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


AddItem Method

ShippingServices AddItem Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds customs items to an existing order.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddItemResponse AddItem(
    AddItemRequest request
)
public AddItemResponse AddItem(
    AddItemRequest request
)
Public Function AddItem ( _
    request As AddItemRequest _
) As AddItemResponse
Public Function AddItem ( _
    request As AddItemRequest _
) As AddItemResponse
public:
AddItemResponse^ AddItem(
    AddItemRequest^ request
)
public:
AddItemResponse^ AddItem(
    AddItemRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects AddItemRequest
An AddItemRequest.
Return Value
An AddItemResponse
Remarks
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


AddLTLOrder Method

ShippingServices AddLTLOrder Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds an LTL order that will be included in a single LTL Shipment.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLOrderResponse AddLTLOrder(
    LTLOrderRequest request
)
public LTLOrderResponse AddLTLOrder(
    LTLOrderRequest request
)
Public Function AddLTLOrder ( _
    request As LTLOrderRequest _
) As LTLOrderResponse
Public Function AddLTLOrder ( _
    request As LTLOrderRequest _
) As LTLOrderResponse
public:
LTLOrderResponse^ AddLTLOrder(
    LTLOrderRequest^ request
)
public:
LTLOrderResponse^ AddLTLOrder(
    LTLOrderRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects LTLOrderRequest
An LTLOrderRequest.
Return Value
An LTLOrderResponse
Remarks
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


AddOrder Method

ShippingServices AddOrder Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets the service availability, estimated rate, pin numbers, and labels for each package; enters the order in the Purolator system.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderResponse AddOrder(
    OrderRequest request
)
public OrderResponse AddOrder(
    OrderRequest request
)
Public Function AddOrder ( _
    request As OrderRequest _
) As OrderResponse
Public Function AddOrder ( _
    request As OrderRequest _
) As OrderResponse
public:
OrderResponse^ AddOrder(
    OrderRequest^ request
)
public:
OrderResponse^ AddOrder(
    OrderRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects OrderRequest
An OrderRequest.
Return Value
An OrderResponse
Remarks

            AddOrder determines if the specified service is avaialble for the order and returns
            an estimated rate and a pin number and label for each package. AddOrder enters
            the order into the system for shipping.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


AddPackage Method

ShippingServices AddPackage Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds packages to an existing order.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddPackageResponse AddPackage(
    AddPackageRequest request
)
public AddPackageResponse AddPackage(
    AddPackageRequest request
)
Public Function AddPackage ( _
    request As AddPackageRequest _
) As AddPackageResponse
Public Function AddPackage ( _
    request As AddPackageRequest _
) As AddPackageResponse
public:
AddPackageResponse^ AddPackage(
    AddPackageRequest^ request
)
public:
AddPackageResponse^ AddPackage(
    AddPackageRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects AddPackageRequest
An AddPackageRequest.
Return Value
An AddPackageResponse
Remarks
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


Closeout Method

ShippingServices Closeout Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Complete processing of a series of packages.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutResponse Closeout(
    CloseoutRequest request
)
public CloseoutResponse Closeout(
    CloseoutRequest request
)
Public Function Closeout ( _
    request As CloseoutRequest _
) As CloseoutResponse
Public Function Closeout ( _
    request As CloseoutRequest _
) As CloseoutResponse
public:
CloseoutResponse^ Closeout(
    CloseoutRequest^ request
)
public:
CloseoutResponse^ Closeout(
    CloseoutRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects CloseoutRequest
A CloseoutRequest.
Return Value
A CloseoutResponse
Remarks

            A closeout notifies the system that packages are being shipped.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


CloseoutUpdateWeight Method

ShippingServices CloseoutUpdateWeight Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Complete processing of a series of packages and updates their weights.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutResponse CloseoutUpdateWeight(
    CloseoutWithWeightRequest request
)
public CloseoutResponse CloseoutUpdateWeight(
    CloseoutWithWeightRequest request
)
Public Function CloseoutUpdateWeight ( _
    request As CloseoutWithWeightRequest _
) As CloseoutResponse
Public Function CloseoutUpdateWeight ( _
    request As CloseoutWithWeightRequest _
) As CloseoutResponse
public:
CloseoutResponse^ CloseoutUpdateWeight(
    CloseoutWithWeightRequest^ request
)
public:
CloseoutResponse^ CloseoutUpdateWeight(
    CloseoutWithWeightRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects CloseoutWithWeightRequest
A CloseoutWithWeightRequest.
Return Value
A CloseoutResponse
Remarks

            A closeout notifies the system that packages are being shipped.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


CloseoutWithLTL Method

ShippingServices CloseoutWithLTL Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Complete processing of a series of packages and LTL Pro Numbers.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutResponseLTL CloseoutWithLTL(
    CloseoutRequestLTL request
)
public CloseoutResponseLTL CloseoutWithLTL(
    CloseoutRequestLTL request
)
Public Function CloseoutWithLTL ( _
    request As CloseoutRequestLTL _
) As CloseoutResponseLTL
Public Function CloseoutWithLTL ( _
    request As CloseoutRequestLTL _
) As CloseoutResponseLTL
public:
CloseoutResponseLTL^ CloseoutWithLTL(
    CloseoutRequestLTL^ request
)
public:
CloseoutResponseLTL^ CloseoutWithLTL(
    CloseoutRequestLTL^ request
)
Parameters
request
Type: Purolator.Webservice.Objects CloseoutRequestLTL
A CloseoutRequest.
Return Value
A CloseoutResponse
Remarks

            A closeout notifies the system that packages are being shipped.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


GetLabel Method

ShippingServices GetLabel Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets a Package label either as ZPL code or as a Base64 encoded image.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LabelResponse GetLabel(
    LabelRequest request
)
public LabelResponse GetLabel(
    LabelRequest request
)
Public Function GetLabel ( _
    request As LabelRequest _
) As LabelResponse
Public Function GetLabel ( _
    request As LabelRequest _
) As LabelResponse
public:
LabelResponse^ GetLabel(
    LabelRequest^ request
)
public:
LabelResponse^ GetLabel(
    LabelRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects LabelRequest
A LabelRequest.
Return Value
A LabelResponse.
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


GetOrderStatus Method

ShippingServices GetOrderStatus Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets an OrderResponse for the specified order.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderResponse GetOrderStatus(
    CredentialInfo credentials,
    string orderNumber
)
public OrderResponse GetOrderStatus(
    CredentialInfo credentials,
    string orderNumber
)
Public Function GetOrderStatus ( _
    credentials As CredentialInfo, _
    orderNumber As String _
) As OrderResponse
Public Function GetOrderStatus ( _
    credentials As CredentialInfo, _
    orderNumber As String _
) As OrderResponse
public:
OrderResponse^ GetOrderStatus(
    CredentialInfo^ credentials,
    String^ orderNumber
)
public:
OrderResponse^ GetOrderStatus(
    CredentialInfo^ credentials,
    String^ orderNumber
)
Parameters
credentials
Type: Purolator.Webservice.Objects CredentialInfo
Login credentials for validation.
orderNumber
Type:   Online System String
The order number of the order.
Return Value
An OrderResponse.
Remarks

            Finds the order with the specified order number and returns an OrderResponse.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


GetRates Method

ShippingServices GetRates Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets the service availability and estimated rates without creating the order.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderResponse GetRates(
    OrderRequest request
)
public OrderResponse GetRates(
    OrderRequest request
)
Public Function GetRates ( _
    request As OrderRequest _
) As OrderResponse
Public Function GetRates ( _
    request As OrderRequest _
) As OrderResponse
public:
OrderResponse^ GetRates(
    OrderRequest^ request
)
public:
OrderResponse^ GetRates(
    OrderRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects OrderRequest
An .
Return Value
An
Remarks

            GetRates returns a list of  that include estimated delivery
            time and estimated rate for air and ground ship methods. If the ShipMethod is set
            to PuroLetter or PuroPak, and estimated rate will also be included for the requested service.
            GetRates does not enter the order into the system for shipping.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace
Purolator.Webservice.Objects Rate
Purolator.Webservice.Objects OrderRequest
Purolator.Webservice.Objects OrderResponse


GetZPLInitializationImages Method

ShippingServices GetZPLInitializationImages Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets ZPL code to load Purolator specific images into a ZPL printer.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ZPLInitializationResponse GetZPLInitializationImages(
    CredentialInfo request
)
public ZPLInitializationResponse GetZPLInitializationImages(
    CredentialInfo request
)
Public Function GetZPLInitializationImages ( _
    request As CredentialInfo _
) As ZPLInitializationResponse
Public Function GetZPLInitializationImages ( _
    request As CredentialInfo _
) As ZPLInitializationResponse
public:
ZPLInitializationResponse^ GetZPLInitializationImages(
    CredentialInfo^ request
)
public:
ZPLInitializationResponse^ GetZPLInitializationImages(
    CredentialInfo^ request
)
Parameters
request
Type: Purolator.Webservice.Objects CredentialInfo
[Missing <param name="request"/> documentation for "M:Purolator.Webservice.ShippingServices.GetZPLInitializationImages(Purolator.Webservice.Objects.CredentialInfo)"]
Return Value
An ZPLInitializationResponse
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


ShipmentVerification Method

ShippingServices ShipmentVerification Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Verifies that each package is being shipped as part of some clients multi-step shipment process.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageListResponse ShipmentVerification(
    PackageListRequest request
)
public PackageListResponse ShipmentVerification(
    PackageListRequest request
)
Public Function ShipmentVerification ( _
    request As PackageListRequest _
) As PackageListResponse
Public Function ShipmentVerification ( _
    request As PackageListRequest _
) As PackageListResponse
public:
PackageListResponse^ ShipmentVerification(
    PackageListRequest^ request
)
public:
PackageListResponse^ ShipmentVerification(
    PackageListRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects PackageListRequest
A PackageListRequest.
Return Value
A PackageListResponse
Remarks

            Some clients scan packages as they are loaded and require the ability to confirm packages before they are closed out and shipped.

See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


UpdateOrder Method

ShippingServices UpdateOrder Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Updates values in existing orders.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdateOrderResponse UpdateOrder(
    UpdateOrderRequest request
)
public UpdateOrderResponse UpdateOrder(
    UpdateOrderRequest request
)
Public Function UpdateOrder ( _
    request As UpdateOrderRequest _
) As UpdateOrderResponse
Public Function UpdateOrder ( _
    request As UpdateOrderRequest _
) As UpdateOrderResponse
public:
UpdateOrderResponse^ UpdateOrder(
    UpdateOrderRequest^ request
)
public:
UpdateOrderResponse^ UpdateOrder(
    UpdateOrderRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects UpdateOrderRequest
An UpdateOrderRequest.
Return Value
An UpdateOrderResponse
Remarks
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


VoidOrders Method

ShippingServices VoidOrders Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Voids a list of orders.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderListResponse VoidOrders(
    OrderListRequest request
)
public OrderListResponse VoidOrders(
    OrderListRequest request
)
Public Function VoidOrders ( _
    request As OrderListRequest _
) As OrderListResponse
Public Function VoidOrders ( _
    request As OrderListRequest _
) As OrderListResponse
public:
OrderListResponse^ VoidOrders(
    OrderListRequest^ request
)
public:
OrderListResponse^ VoidOrders(
    OrderListRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects OrderListRequest
A OrderListRequest.
Return Value
A OrderListResponse
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


VoidPackages Method

ShippingServices VoidPackages Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Voids a list of packages.

Namespace: Purolator.Webservice
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageListResponse VoidPackages(
    PackageListRequest request
)
public PackageListResponse VoidPackages(
    PackageListRequest request
)
Public Function VoidPackages ( _
    request As PackageListRequest _
) As PackageListResponse
Public Function VoidPackages ( _
    request As PackageListRequest _
) As PackageListResponse
public:
PackageListResponse^ VoidPackages(
    PackageListRequest^ request
)
public:
PackageListResponse^ VoidPackages(
    PackageListRequest^ request
)
Parameters
request
Type: Purolator.Webservice.Objects PackageListRequest
A PackageListRequest.
Return Value
A PackageListResponse
See Also
ShippingServices Class
ShippingServices Members
Purolator.Webservice Namespace


Purolator.Webservice.Objects Namespace

Purolator.Webservice.Objects Namespace Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Defines objects supporting Purolator Webservice calls.
Classes
 | Class | Description
Public class | AddItemRequest | Request for AddItem(AddItemRequest)
Public class | AddItemResponse | Response for AddItem(AddItemRequest)
Public class | AddPackageRequest | Request for AddPackage(AddPackageRequest)
Public class | AddPackageResponse | Response for AddPackage(AddPackageRequest)
Public class | Address | Canadian Address
Public class | CloseoutDocument | A document returned by Closeout(CloseoutRequest)
Public class | CloseoutPackage | Package information returned by Closeout(CloseoutRequest)
Public class | CloseoutRequest | Request for Closeout(CloseoutRequest)
Public class | CloseoutRequestLTL | Request for CloseoutWithLTL(CloseoutRequestLTL)
Public class | CloseoutResponse | Response for Closeout(CloseoutRequest)
Public class | CloseoutResponseLTL | Response for CloseoutWithLTL(CloseoutRequestLTL)
Public class | CloseoutWithWeightRequest | Request for CloseoutUpdateWeight(CloseoutWithWeightRequest)
Public class | CredentialInfo | Login credentials for validation.
Public class | CustomsItemResponse |
Public class | IDResponse |
Public class | InductionPointLookupListItem |
Public class | InductionPointLookupListResponse |
Public class | LabelRequest | Request for GetLabel(LabelRequest).
Public class | LabelResponse | Response for GetLabel(LabelRequest).
Public class | LTLOrderRequest | Adds an LTL order and LTL shipment.
Public class | LTLOrderResponse |
Public class | LTLPalletRequest | A Pallet included in an LTLShipmentRequest
Public class | LTLPalletResponse | A Pallet included in an LTLShipmentResponse
Public class | LTLShipmentRequest | Request for AddConsolidatedLTLShipment(LTLShipmentRequest)
Public class | LTLShipmentResponse |
Public class | OrderListRequest | The request for VoidOrders(OrderListRequest)
Public class | OrderListResponse | The response returned by a CloseoutRequest.
Public class | OrderRequest | Request for GetRates(OrderRequest) and AddOrder(OrderRequest)
Public class | OrderResponse | Response for GetRates(OrderRequest) and AddOrder(OrderRequest)
Public class | PackageIDWeight | Request for CloseoutWithWeightRequest
Public class | PackageListRequest | The request for ShipmentVerification(PackageListRequest), VoidPackages(PackageListRequest), and [!:Purolator.Webservice.ShippingServices.SetLabelPrintTime]
Public class | PackageListResponse | The response returned by a CloseoutRequest.
Public class | Rate | A single Rate returned in OrderResponse
Public class | RateRequest | Request for [!:ShippingServices.RateRequest]
Public class | RequestItem | An item contained in an order for customs purposes.
Public class | RequestPackage | Describes a package
Public class | ResponseBase | Base class for responses
Public class | ResponseMessage | The status and messages returned by each web service call.
Public class | ResponsePackage | Returned Package Data.
Public class | ShipmentItemResponse |
Public class | ShipperAccountServiceTypeLinkResponse | A link indicating whether a shipping type is available to a Shipper Account
Public class | UpdateOrderInfo | Order for UpdateOrderRequest
Public class | UpdateOrderRequest | Request for UpdateOrder(UpdateOrderRequest)
Public class | UpdateOrderResponse | Response for UpdateOrder(UpdateOrderRequest)
Public class | ZPLInitializationRequest | Request for GetZPLInitializationImages(CredentialInfo)
Public class | ZPLInitializationResponse | Response for Closeout(CloseoutRequest)
Enumerations
 | Enumeration | Description
Public enumeration | CloseoutResponse CloseoutReportTypes | Report types to be returned in the closeout.
Public enumeration | ResponseMessage SeverityEnum | The severity of each message and the response status.


AddItemRequest Class

AddItemRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for AddItem(AddItemRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects AddItemRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AddItemRequest
public class AddItemRequest
Public Class AddItemRequest
Public Class AddItemRequest
public ref class AddItemRequest
public ref class AddItemRequest
See Also
AddItemRequest Members
Purolator.Webservice.Objects Namespace


AddItemRequest Members

AddItemRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddItemRequest type exposes the following members.
Constructors
 | Name | Description
Public method | AddItemRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | Items | The items to add to the order.
Public property | OrderNumber | Unique order number. The order number must be for an existing order.
Back to Top
See Also
AddItemRequest Class


AddItemRequest Constructor

AddItemRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.AddItemRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddItemRequest()
public AddItemRequest()
Public Sub New
Public Sub New
public:
AddItemRequest()
public:
AddItemRequest()
See Also
AddItemRequest Class
AddItemRequest Members


AddItemRequest Properties

AddItemRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddItemRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | Items | The items to add to the order.
Public property | OrderNumber | Unique order number. The order number must be for an existing order.
Back to Top
See Also
AddItemRequest Class


Credentials Property

AddItemRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
AddItemRequest Class
AddItemRequest Members


Items Property

AddItemRequest Items Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The items to add to the order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RequestItem> Items { get; set; }
public List<RequestItem> Items { get; set; }
Public Property Items As List(Of RequestItem)
    Get
    Set
Public Property Items As List(Of RequestItem)
    Get
    Set
public:
property List<RequestItem^>^ Items {
    List<RequestItem^>^ get ();
    void set (List<RequestItem^>^ value);
}
public:
property List<RequestItem^>^ Items {
    List<RequestItem^>^ get ();
    void set (List<RequestItem^>^ value);
}
See Also
AddItemRequest Class
AddItemRequest Members


OrderNumber Property

AddItemRequest OrderNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Unique order number. The order number must be for an existing order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrderNumber { get; set; }
public string OrderNumber { get; set; }
Public Property OrderNumber As String
    Get
    Set
Public Property OrderNumber As String
    Get
    Set
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
See Also
AddItemRequest Class
AddItemRequest Members


AddItemResponse Class

AddItemResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for AddItem(AddItemRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects AddItemResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AddItemResponse : ResponseBase
public class AddItemResponse : ResponseBase
Public Class AddItemResponse _
    Inherits ResponseBase
Public Class AddItemResponse _
    Inherits ResponseBase
public ref class AddItemResponse : public ResponseBase
public ref class AddItemResponse : public ResponseBase
See Also
AddItemResponse Members


AddItemResponse Members

AddItemResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddItemResponse type exposes the following members.
Constructors
 | Name | Description
Public method | AddItemResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
AddItemResponse Class


AddItemResponse Constructor

AddItemResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.AddItemResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddItemResponse()
public AddItemResponse()
Public Sub New
Public Sub New
public:
AddItemResponse()
public:
AddItemResponse()
See Also
AddItemResponse Class
AddItemResponse Members


AddItemResponse Properties

AddItemResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddItemResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
AddItemResponse Class


Request Property

AddItemResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddItemRequest Request { get; set; }
public AddItemRequest Request { get; set; }
Public Property Request As AddItemRequest
    Get
    Set
Public Property Request As AddItemRequest
    Get
    Set
public:
property AddItemRequest^ Request {
    AddItemRequest^ get ();
    void set (AddItemRequest^ value);
}
public:
property AddItemRequest^ Request {
    AddItemRequest^ get ();
    void set (AddItemRequest^ value);
}
See Also
AddItemResponse Class
AddItemResponse Members


AddPackageRequest Class

AddPackageRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for AddPackage(AddPackageRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects AddPackageRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AddPackageRequest
public class AddPackageRequest
Public Class AddPackageRequest
Public Class AddPackageRequest
public ref class AddPackageRequest
public ref class AddPackageRequest
See Also
AddPackageRequest Members


AddPackageRequest Members

AddPackageRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddPackageRequest type exposes the following members.
Constructors
 | Name | Description
Public method | AddPackageRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | LabelType | The type of label returned (None, ZPL, ZPLIMAGES, Image)
Public property | OrderNumber | Unique order number. The order number must be for an existing order.
Public property | Packages | The packages to add to the order.
Back to Top
See Also
AddPackageRequest Class


AddPackageRequest Constructor

AddPackageRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.AddPackageRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddPackageRequest()
public AddPackageRequest()
Public Sub New
Public Sub New
public:
AddPackageRequest()
public:
AddPackageRequest()
See Also
AddPackageRequest Class
AddPackageRequest Members


AddPackageRequest Properties

AddPackageRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddPackageRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | LabelType | The type of label returned (None, ZPL, ZPLIMAGES, Image)
Public property | OrderNumber | Unique order number. The order number must be for an existing order.
Public property | Packages | The packages to add to the order.
Back to Top
See Also
AddPackageRequest Class


Credentials Property

AddPackageRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
AddPackageRequest Class
AddPackageRequest Members


LabelType Property

AddPackageRequest LabelType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The type of label returned (None, ZPL, ZPLIMAGES, Image)

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LabelType { get; set; }
public string LabelType { get; set; }
Public Property LabelType As String
    Get
    Set
Public Property LabelType As String
    Get
    Set
public:
property String^ LabelType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LabelType {
    String^ get ();
    void set (String^ value);
}
Remarks
AddPackage(AddPackageRequest) can return a label in ZPL format or as an image.  ZPLIMAGES returns ZPL code for the image labels in addition to code for the rest of the label.

See Also
AddPackageRequest Class
AddPackageRequest Members


OrderNumber Property

AddPackageRequest OrderNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Unique order number. The order number must be for an existing order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrderNumber { get; set; }
public string OrderNumber { get; set; }
Public Property OrderNumber As String
    Get
    Set
Public Property OrderNumber As String
    Get
    Set
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
See Also
AddPackageRequest Class
AddPackageRequest Members


Packages Property

AddPackageRequest Packages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The packages to add to the order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RequestPackage> Packages { get; set; }
public List<RequestPackage> Packages { get; set; }
Public Property Packages As List(Of RequestPackage)
    Get
    Set
Public Property Packages As List(Of RequestPackage)
    Get
    Set
public:
property List<RequestPackage^>^ Packages {
    List<RequestPackage^>^ get ();
    void set (List<RequestPackage^>^ value);
}
public:
property List<RequestPackage^>^ Packages {
    List<RequestPackage^>^ get ();
    void set (List<RequestPackage^>^ value);
}
See Also
AddPackageRequest Class
AddPackageRequest Members


AddPackageResponse Class

AddPackageResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for AddPackage(AddPackageRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects AddPackageResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class AddPackageResponse : ResponseBase
public class AddPackageResponse : ResponseBase
Public Class AddPackageResponse _
    Inherits ResponseBase
Public Class AddPackageResponse _
    Inherits ResponseBase
public ref class AddPackageResponse : public ResponseBase
public ref class AddPackageResponse : public ResponseBase
See Also
AddPackageResponse Members


AddPackageResponse Members

AddPackageResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddPackageResponse type exposes the following members.
Constructors
 | Name | Description
Public method | AddPackageResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | List of calculated Package data, including existing packages.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | TotalShipping | The updated total estimated cost to ship this order.
Back to Top
See Also
AddPackageResponse Class


AddPackageResponse Constructor

AddPackageResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.AddPackageResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddPackageResponse()
public AddPackageResponse()
Public Sub New
Public Sub New
public:
AddPackageResponse()
public:
AddPackageResponse()
See Also
AddPackageResponse Class
AddPackageResponse Members


AddPackageResponse Properties

AddPackageResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The AddPackageResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | List of calculated Package data, including existing packages.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | TotalShipping | The updated total estimated cost to ship this order.
Back to Top
See Also
AddPackageResponse Class


Packages Property

AddPackageResponse Packages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

List of calculated Package data, including existing packages.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<ResponsePackage> Packages { get; set; }
public List<ResponsePackage> Packages { get; set; }
Public Property Packages As List(Of ResponsePackage)
    Get
    Set
Public Property Packages As List(Of ResponsePackage)
    Get
    Set
public:
property List<ResponsePackage^>^ Packages {
    List<ResponsePackage^>^ get ();
    void set (List<ResponsePackage^>^ value);
}
public:
property List<ResponsePackage^>^ Packages {
    List<ResponsePackage^>^ get ();
    void set (List<ResponsePackage^>^ value);
}
See Also
AddPackageResponse Class
AddPackageResponse Members


Request Property

AddPackageResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AddPackageRequest Request { get; set; }
public AddPackageRequest Request { get; set; }
Public Property Request As AddPackageRequest
    Get
    Set
Public Property Request As AddPackageRequest
    Get
    Set
public:
property AddPackageRequest^ Request {
    AddPackageRequest^ get ();
    void set (AddPackageRequest^ value);
}
public:
property AddPackageRequest^ Request {
    AddPackageRequest^ get ();
    void set (AddPackageRequest^ value);
}
See Also
AddPackageResponse Class
AddPackageResponse Members


TotalShipping Property

AddPackageResponse TotalShipping Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The updated total estimated cost to ship this order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal TotalShipping { get; set; }
public decimal TotalShipping { get; set; }
Public Property TotalShipping As Decimal
    Get
    Set
Public Property TotalShipping As Decimal
    Get
    Set
public:
property Decimal TotalShipping {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal TotalShipping {
    Decimal get ();
    void set (Decimal value);
}
See Also
AddPackageResponse Class
AddPackageResponse Members


Address Class

Address Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Canadian Address
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects Address

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Address
public class Address
Public Class Address
Public Class Address
public ref class Address
public ref class Address
See Also
Address Members


Address Members

Address Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Address type exposes the following members.
Constructors
 | Name | Description
Public method | Address |
Back to Top
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetValidationAddress |
Public method | IsEmpty | Determines if all the address fields are null or empty.
 | IsNullOrEmpty | Determines if the address is null or all the address fields are null or empty.
Back to Top
Properties
 | Name | Description
Public property | Add1 | Address line 1 is required.
Public property | Add2 | Address line 2 is optional.
Public property | City | The city.
Public property | Company | Company
Public property | Country | The ISO 3166 two character country code. ('CA' - Canada, 'US' - United States)
Public property | Email | The notification email address.
Public property | Name | Name
Public property | Phone | The phone number.
Public property | PostalCode | The postal code.
Public property | StateProv | The two letter province designation.
Back to Top
See Also
Address Class


Address Constructor

Address Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.Address.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address()
public Address()
Public Sub New
Public Sub New
public:
Address()
public:
Address()
See Also
Address Class
Address Members


Address Methods

Address Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Address type exposes the following members.
Methods
 | Name | Description
Public method | Equals | (Overrides Online Object Equals(Object).)
Public method | GetHashCode | (Overrides Online Object GetHashCode .)
Public method | GetValidationAddress |
Public method | IsEmpty | Determines if all the address fields are null or empty.
 | IsNullOrEmpty | Determines if the address is null or all the address fields are null or empty.
Back to Top
See Also
Address Class


Equals Method

Address Equals Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.Address.Equals(System.Object)"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj
Type:   Online System Object
[Missing <param name="obj"/> documentation for "M:Purolator.Webservice.Objects.Address.Equals(System.Object)"]
Return Value
[Missing <returns> documentation for "M:Purolator.Webservice.Objects.Address.Equals(System.Object)"]
See Also
Address Class
Address Members


GetHashCode Method

Address GetHashCode Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.Address.GetHashCode"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
Return Value
[Missing <returns> documentation for "M:Purolator.Webservice.Objects.Address.GetHashCode"]
See Also
Address Class
Address Members


GetValidationAddress Method

Address GetValidationAddress Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.Address.GetValidationAddress"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ValidationAddress GetValidationAddress()
public ValidationAddress GetValidationAddress()
Public Function GetValidationAddress As ValidationAddress
Public Function GetValidationAddress As ValidationAddress
public:
ValidationAddress^ GetValidationAddress()
public:
ValidationAddress^ GetValidationAddress()
Return Value
[Missing <returns> documentation for "M:Purolator.Webservice.Objects.Address.GetValidationAddress"]
See Also
Address Class
Address Members


IsEmpty Method

Address IsEmpty Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Determines if all the address fields are null or empty.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsEmpty()
public bool IsEmpty()
Public Function IsEmpty As Boolean
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
public:
bool IsEmpty()
Return Value
True if all strings are empty or null
See Also
Address Class
Address Members


IsNullOrEmpty Method

Address IsNullOrEmpty Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Determines if the address is null or all the address fields are null or empty.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNullOrEmpty(
    Address address
)
public static bool IsNullOrEmpty(
    Address address
)
Public Shared Function IsNullOrEmpty ( _
    address As Address _
) As Boolean
Public Shared Function IsNullOrEmpty ( _
    address As Address _
) As Boolean
public:
static bool IsNullOrEmpty(
    Address^ address
)
public:
static bool IsNullOrEmpty(
    Address^ address
)
Parameters
address
Type: Purolator.Webservice.Objects Address
[Missing <param name="address"/> documentation for "M:Purolator.Webservice.Objects.Address.IsNullOrEmpty(Purolator.Webservice.Objects.Address)"]
Return Value
True is address is empty or all strings are empty or null
See Also
Address Class
Address Members


Address Properties

Address Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Address type exposes the following members.
Properties
 | Name | Description
Public property | Add1 | Address line 1 is required.
Public property | Add2 | Address line 2 is optional.
Public property | City | The city.
Public property | Company | Company
Public property | Country | The ISO 3166 two character country code. ('CA' - Canada, 'US' - United States)
Public property | Email | The notification email address.
Public property | Name | Name
Public property | Phone | The phone number.
Public property | PostalCode | The postal code.
Public property | StateProv | The two letter province designation.
Back to Top
See Also
Address Class


Add1 Property

Address Add1 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Address line 1 is required.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Add1 { get; set; }
public string Add1 { get; set; }
Public Property Add1 As String
    Get
    Set
Public Property Add1 As String
    Get
    Set
public:
property String^ Add1 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Add1 {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


Add2 Property

Address Add2 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Address line 2 is optional.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Add2 { get; set; }
public string Add2 { get; set; }
Public Property Add2 As String
    Get
    Set
Public Property Add2 As String
    Get
    Set
public:
property String^ Add2 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Add2 {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


City Property

Address City Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The city.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string City { get; set; }
public string City { get; set; }
Public Property City As String
    Get
    Set
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


Company Property

Address Company Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Company

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Company { get; set; }
public string Company { get; set; }
Public Property Company As String
    Get
    Set
Public Property Company As String
    Get
    Set
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Company {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


Country Property

Address Country Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ISO 3166 two character country code. ('CA' - Canada, 'US' - United States)

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Country { get; set; }
public string Country { get; set; }
Public Property Country As String
    Get
    Set
Public Property Country As String
    Get
    Set
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


Email Property

Address Email Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The notification email address.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Email { get; set; }
public string Email { get; set; }
Public Property Email As String
    Get
    Set
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
Remarks

            The notification email address is required only if notification will be sent once the package is shipped.

See Also
Address Class
Address Members


Name Property

Address Name Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Name

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Name { get; set; }
public string Name { get; set; }
Public Property Name As String
    Get
    Set
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


Phone Property

Address Phone Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The phone number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Phone { get; set; }
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


PostalCode Property

Address PostalCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The postal code.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostalCode { get; set; }
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


StateProv Property

Address StateProv Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The two letter province designation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string StateProv { get; set; }
public string StateProv { get; set; }
Public Property StateProv As String
    Get
    Set
Public Property StateProv As String
    Get
    Set
public:
property String^ StateProv {
    String^ get ();
    void set (String^ value);
}
public:
property String^ StateProv {
    String^ get ();
    void set (String^ value);
}
See Also
Address Class
Address Members


CloseoutDocument Class

CloseoutDocument Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A document returned by Closeout(CloseoutRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CloseoutDocument

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutDocument
public class CloseoutDocument
Public Class CloseoutDocument
Public Class CloseoutDocument
public ref class CloseoutDocument
public ref class CloseoutDocument
See Also
CloseoutDocument Members


CloseoutDocument Members

CloseoutDocument Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutDocument type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutDocument |
Back to Top
Properties
 | Name | Description
Public property | Data | The document data.
Public property | DocumentType | Indicates what type of document and in what format
Back to Top
See Also
CloseoutDocument Class


CloseoutDocument Constructor

CloseoutDocument Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.CloseoutDocument.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutDocument()
public CloseoutDocument()
Public Sub New
Public Sub New
public:
CloseoutDocument()
public:
CloseoutDocument()
See Also
CloseoutDocument Class
CloseoutDocument Members


CloseoutDocument Properties

CloseoutDocument Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutDocument type exposes the following members.
Properties
 | Name | Description
Public property | Data | The document data.
Public property | DocumentType | Indicates what type of document and in what format
Back to Top
See Also
CloseoutDocument Class


Data Property

CloseoutDocument Data Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The document data.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Data { get; set; }
public string Data { get; set; }
Public Property Data As String
    Get
    Set
Public Property Data As String
    Get
    Set
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}
See Also
CloseoutDocument Class
CloseoutDocument Members


DocumentType Property

CloseoutDocument DocumentType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Indicates what type of document and in what format

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DocumentType { get; set; }
public int DocumentType { get; set; }
Public Property DocumentType As Integer
    Get
    Set
Public Property DocumentType As Integer
    Get
    Set
public:
property int DocumentType {
    int get ();
    void set (int value);
}
public:
property int DocumentType {
    int get ();
    void set (int value);
}
See Also
CloseoutDocument Class
CloseoutDocument Members


CloseoutPackage Class

CloseoutPackage Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Package information returned by Closeout(CloseoutRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CloseoutPackage

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutPackage
public class CloseoutPackage
Public Class CloseoutPackage
Public Class CloseoutPackage
public ref class CloseoutPackage
public ref class CloseoutPackage
See Also
CloseoutPackage Members


CloseoutPackage Members

CloseoutPackage Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutPackage type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutPackage |
Back to Top
Properties
 | Name | Description
Public property | Rate | The estimated rate to ship this package
Public property | TrackingNumber | A package tracking number
Back to Top
See Also
CloseoutPackage Class


CloseoutPackage Constructor

CloseoutPackage Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.CloseoutPackage.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutPackage()
public CloseoutPackage()
Public Sub New
Public Sub New
public:
CloseoutPackage()
public:
CloseoutPackage()
See Also
CloseoutPackage Class
CloseoutPackage Members


CloseoutPackage Properties

CloseoutPackage Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutPackage type exposes the following members.
Properties
 | Name | Description
Public property | Rate | The estimated rate to ship this package
Public property | TrackingNumber | A package tracking number
Back to Top
See Also
CloseoutPackage Class


Rate Property

CloseoutPackage Rate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The estimated rate to ship this package

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal Rate { get; set; }
public decimal Rate { get; set; }
Public Property Rate As Decimal
    Get
    Set
Public Property Rate As Decimal
    Get
    Set
public:
property Decimal Rate {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal Rate {
    Decimal get ();
    void set (Decimal value);
}
See Also
CloseoutPackage Class
CloseoutPackage Members


TrackingNumber Property

CloseoutPackage TrackingNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A package tracking number

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TrackingNumber { get; set; }
public string TrackingNumber { get; set; }
Public Property TrackingNumber As String
    Get
    Set
Public Property TrackingNumber As String
    Get
    Set
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
See Also
CloseoutPackage Class
CloseoutPackage Members


CloseoutRequest Class

CloseoutRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for Closeout(CloseoutRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CloseoutRequest
Purolator.Webservice.Objects CloseoutRequestLTL

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutRequest
public class CloseoutRequest
Public Class CloseoutRequest
Public Class CloseoutRequest
public ref class CloseoutRequest
public ref class CloseoutRequest
See Also
CloseoutRequest Members


CloseoutRequest Members

CloseoutRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutRequest type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutRequest | Initializes a new instance of the CloseoutRequest class.
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | PackageIDs | A list of Courier (not LTL) packages to closeout.
Public property | PackIDType | Package Identifier Type (Pin, PackageID)
Public property | ParsNumber | Pre-Arrival Review System (PARS) number.
Public property | ShipDate | Date the shipment leaves the facility.
Public property | SkidCount | Number of skids in the closeout.
Back to Top
See Also
CloseoutRequest Class


CloseoutRequest Constructor

CloseoutRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CloseoutRequest class.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutRequest()
public CloseoutRequest()
Public Sub New
Public Sub New
public:
CloseoutRequest()
public:
CloseoutRequest()
Remarks

            Customers using Purolator for Customs Clearance must include PackageIDs to be closed out.

See Also
CloseoutRequest Class
CloseoutRequest Members


CloseoutRequest Properties

CloseoutRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | PackageIDs | A list of Courier (not LTL) packages to closeout.
Public property | PackIDType | Package Identifier Type (Pin, PackageID)
Public property | ParsNumber | Pre-Arrival Review System (PARS) number.
Public property | ShipDate | Date the shipment leaves the facility.
Public property | SkidCount | Number of skids in the closeout.
Back to Top
See Also
CloseoutRequest Class


Credentials Property

CloseoutRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
CloseoutRequest Class
CloseoutRequest Members


PackageIDs Property

CloseoutRequest PackageIDs Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of Courier (not LTL) packages to closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> PackageIDs { get; set; }
public List<string> PackageIDs { get; set; }
Public Property PackageIDs As List(Of String)
    Get
    Set
Public Property PackageIDs As List(Of String)
    Get
    Set
public:
property List<String^>^ PackageIDs {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ PackageIDs {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

            For customers using Purolator for Customs Clearance, the list must be filled.
            For customers not using Purolator for customs, this field is optional. If the filed contains package ids, only those packages will be included in the closeout. If the list is empty, all open, valid packages will be included in the closeout.

See Also
CloseoutRequest Class
CloseoutRequest Members


PackIDType Property

CloseoutRequest PackIDType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Package Identifier Type (Pin, PackageID)

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PackIDType { get; set; }
public string PackIDType { get; set; }
Public Property PackIDType As String
    Get
    Set
Public Property PackIDType As String
    Get
    Set
public:
property String^ PackIDType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PackIDType {
    String^ get ();
    void set (String^ value);
}
Remarks

            The following package ID types are available.

Pin | The Purolator Pin used for package tracking.
PackageID | The customer supplied package number.
See Also
CloseoutRequest Class
CloseoutRequest Members


ParsNumber Property

CloseoutRequest ParsNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Pre-Arrival Review System (PARS) number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ParsNumber { get; set; }
public string ParsNumber { get; set; }
Public Property ParsNumber As String
    Get
    Set
Public Property ParsNumber As String
    Get
    Set
public:
property String^ ParsNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ParsNumber {
    String^ get ();
    void set (String^ value);
}
See Also
CloseoutRequest Class
CloseoutRequest Members


ShipDate Property

CloseoutRequest ShipDate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Date the shipment leaves the facility.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ShipDate { get; set; }
public DateTime ShipDate { get; set; }
Public Property ShipDate As DateTime
    Get
    Set
Public Property ShipDate As DateTime
    Get
    Set
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
Field Value
The ship date.
See Also
CloseoutRequest Class
CloseoutRequest Members


SkidCount Property

CloseoutRequest SkidCount Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Number of skids in the closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SkidCount { get; set; }
public int SkidCount { get; set; }
Public Property SkidCount As Integer
    Get
    Set
Public Property SkidCount As Integer
    Get
    Set
public:
property int SkidCount {
    int get ();
    void set (int value);
}
public:
property int SkidCount {
    int get ();
    void set (int value);
}
See Also
CloseoutRequest Class
CloseoutRequest Members


CloseoutRequestLTL Class

CloseoutRequestLTL Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for CloseoutWithLTL(CloseoutRequestLTL)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CloseoutRequest
Purolator.Webservice.Objects CloseoutRequestLTL

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutRequestLTL : CloseoutRequest
public class CloseoutRequestLTL : CloseoutRequest
Public Class CloseoutRequestLTL _
    Inherits CloseoutRequest
Public Class CloseoutRequestLTL _
    Inherits CloseoutRequest
public ref class CloseoutRequestLTL : public CloseoutRequest
public ref class CloseoutRequestLTL : public CloseoutRequest
See Also
CloseoutRequestLTL Members


CloseoutRequestLTL Members

CloseoutRequestLTL Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutRequestLTL type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutRequestLTL | Initializes a new instance of the CloseoutRequestLTL class.
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation. (Inherited from CloseoutRequest.)
Public property | LTLNumbers | A list of consolidated LTL Shipments to closeout.
Public property | LTLNumberType | LTL Number Identifier Type (ProNumber, LTLNumber)
Public property | PackageIDs | A list of Courier (not LTL) packages to closeout. (Inherited from CloseoutRequest.)
Public property | PackIDType | Package Identifier Type (Pin, PackageID) (Inherited from CloseoutRequest.)
Public property | ParsNumber | Pre-Arrival Review System (PARS) number. (Inherited from CloseoutRequest.)
Public property | ShipDate | Date the shipment leaves the facility. (Inherited from CloseoutRequest.)
Public property | SkidCount | Number of skids in the closeout. (Inherited from CloseoutRequest.)
Back to Top
See Also
CloseoutRequestLTL Class


CloseoutRequestLTL Constructor

CloseoutRequestLTL Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CloseoutRequestLTL class.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutRequestLTL()
public CloseoutRequestLTL()
Public Sub New
Public Sub New
public:
CloseoutRequestLTL()
public:
CloseoutRequestLTL()
Remarks

            Customers using Purolator for Customs Clearance must include PackageIDs and LTLNumbers to be closed out.

See Also
CloseoutRequestLTL Class
CloseoutRequestLTL Members


CloseoutRequestLTL Properties

CloseoutRequestLTL Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutRequestLTL type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation. (Inherited from CloseoutRequest.)
Public property | LTLNumbers | A list of consolidated LTL Shipments to closeout.
Public property | LTLNumberType | LTL Number Identifier Type (ProNumber, LTLNumber)
Public property | PackageIDs | A list of Courier (not LTL) packages to closeout. (Inherited from CloseoutRequest.)
Public property | PackIDType | Package Identifier Type (Pin, PackageID) (Inherited from CloseoutRequest.)
Public property | ParsNumber | Pre-Arrival Review System (PARS) number. (Inherited from CloseoutRequest.)
Public property | ShipDate | Date the shipment leaves the facility. (Inherited from CloseoutRequest.)
Public property | SkidCount | Number of skids in the closeout. (Inherited from CloseoutRequest.)
Back to Top
See Also
CloseoutRequestLTL Class


LTLNumbers Property

CloseoutRequestLTL LTLNumbers Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of consolidated LTL Shipments to closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> LTLNumbers { get; set; }
public List<string> LTLNumbers { get; set; }
Public Property LTLNumbers As List(Of String)
    Get
    Set
Public Property LTLNumbers As List(Of String)
    Get
    Set
public:
property List<String^>^ LTLNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ LTLNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
See Also
CloseoutRequestLTL Class
CloseoutRequestLTL Members


LTLNumberType Property

CloseoutRequestLTL LTLNumberType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

LTL Number Identifier Type (ProNumber, LTLNumber)

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LTLNumberType { get; set; }
public string LTLNumberType { get; set; }
Public Property LTLNumberType As String
    Get
    Set
Public Property LTLNumberType As String
    Get
    Set
public:
property String^ LTLNumberType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LTLNumberType {
    String^ get ();
    void set (String^ value);
}
Remarks

            The following LTL Number types are available.

ProNumber | The Pro number of the LTL Shipment.
LTLNumber | The customer supplied LTL Shipment number.
See Also
CloseoutRequestLTL Class
CloseoutRequestLTL Members


CloseoutResponse Class

CloseoutResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for Closeout(CloseoutRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects CloseoutResponse
Purolator.Webservice.Objects CloseoutResponseLTL

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutResponse : ResponseBase
public class CloseoutResponse : ResponseBase
Public Class CloseoutResponse _
    Inherits ResponseBase
Public Class CloseoutResponse _
    Inherits ResponseBase
public ref class CloseoutResponse : public ResponseBase
public ref class CloseoutResponse : public ResponseBase
See Also
CloseoutResponse Members


CloseoutResponse Members

CloseoutResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutResponse type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutResponse |
Back to Top
Properties
 | Name | Description
Public property | Documents | The documents returned by the closeout.
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | The list of package tracking numbers along with an estimated rate for each.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
CloseoutResponse Class


CloseoutResponse Constructor

CloseoutResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.CloseoutResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutResponse()
public CloseoutResponse()
Public Sub New
Public Sub New
public:
CloseoutResponse()
public:
CloseoutResponse()
See Also
CloseoutResponse Class
CloseoutResponse Members


CloseoutResponse Properties

CloseoutResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutResponse type exposes the following members.
Properties
 | Name | Description
Public property | Documents | The documents returned by the closeout.
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | The list of package tracking numbers along with an estimated rate for each.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
CloseoutResponse Class


Documents Property

CloseoutResponse Documents Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The documents returned by the closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<CloseoutDocument> Documents { get; set; }
public List<CloseoutDocument> Documents { get; set; }
Public Property Documents As List(Of CloseoutDocument)
    Get
    Set
Public Property Documents As List(Of CloseoutDocument)
    Get
    Set
public:
property List<CloseoutDocument^>^ Documents {
    List<CloseoutDocument^>^ get ();
    void set (List<CloseoutDocument^>^ value);
}
public:
property List<CloseoutDocument^>^ Documents {
    List<CloseoutDocument^>^ get ();
    void set (List<CloseoutDocument^>^ value);
}
Remarks

            Depending on the customer needs, the closeout may return customs or manifest documents.

See Also
CloseoutResponse Class
CloseoutResponse Members


Packages Property

CloseoutResponse Packages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The list of package tracking numbers along with an estimated rate for each.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<CloseoutPackage> Packages { get; set; }
public List<CloseoutPackage> Packages { get; set; }
Public Property Packages As List(Of CloseoutPackage)
    Get
    Set
Public Property Packages As List(Of CloseoutPackage)
    Get
    Set
public:
property List<CloseoutPackage^>^ Packages {
    List<CloseoutPackage^>^ get ();
    void set (List<CloseoutPackage^>^ value);
}
public:
property List<CloseoutPackage^>^ Packages {
    List<CloseoutPackage^>^ get ();
    void set (List<CloseoutPackage^>^ value);
}
See Also
CloseoutResponse Class
CloseoutResponse Members


Request Property

CloseoutResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutRequest Request { get; set; }
public CloseoutRequest Request { get; set; }
Public Property Request As CloseoutRequest
    Get
    Set
Public Property Request As CloseoutRequest
    Get
    Set
public:
property CloseoutRequest^ Request {
    CloseoutRequest^ get ();
    void set (CloseoutRequest^ value);
}
public:
property CloseoutRequest^ Request {
    CloseoutRequest^ get ();
    void set (CloseoutRequest^ value);
}
See Also
CloseoutResponse Class
CloseoutResponse Members


CloseoutResponse.CloseoutReportTypes Enumeration

CloseoutResponse CloseoutReportTypes Enumeration Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Report types to be returned in the closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CloseoutReportTypes
public enum CloseoutReportTypes
Public Enumeration CloseoutReportTypes
Public Enumeration CloseoutReportTypes
public enum class CloseoutReportTypes
public enum class CloseoutReportTypes
Members
Member name | Value | Description
DetailedManifest | 1 | A Detailied Manifest of all packages in the closeout.
SummaryManifest | 2 | A Summary of all packages in the closeout.
See Also


CloseoutResponseLTL Class

CloseoutResponseLTL Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for CloseoutWithLTL(CloseoutRequestLTL)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects CloseoutResponse
Purolator.Webservice.Objects CloseoutResponseLTL

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutResponseLTL : CloseoutResponse
public class CloseoutResponseLTL : CloseoutResponse
Public Class CloseoutResponseLTL _
    Inherits CloseoutResponse
Public Class CloseoutResponseLTL _
    Inherits CloseoutResponse
public ref class CloseoutResponseLTL : public CloseoutResponse
public ref class CloseoutResponseLTL : public CloseoutResponse
See Also
CloseoutResponseLTL Members


CloseoutResponseLTL Members

CloseoutResponseLTL Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutResponseLTL type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutResponseLTL |
Back to Top
Properties
 | Name | Description
Public property | Documents | The documents returned by the closeout. (Inherited from CloseoutResponse.)
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | The list of package tracking numbers along with an estimated rate for each. (Inherited from CloseoutResponse.)
Public property | Pallets | The list of pallets included in the closeout.
Public property | Request | The original request. (Inherited from CloseoutResponse.)
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
CloseoutResponseLTL Class


CloseoutResponseLTL Constructor

CloseoutResponseLTL Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.CloseoutResponseLTL.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutResponseLTL()
public CloseoutResponseLTL()
Public Sub New
Public Sub New
public:
CloseoutResponseLTL()
public:
CloseoutResponseLTL()
See Also
CloseoutResponseLTL Class
CloseoutResponseLTL Members


CloseoutResponseLTL Properties

CloseoutResponseLTL Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutResponseLTL type exposes the following members.
Properties
 | Name | Description
Public property | Documents | The documents returned by the closeout. (Inherited from CloseoutResponse.)
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | The list of package tracking numbers along with an estimated rate for each. (Inherited from CloseoutResponse.)
Public property | Pallets | The list of pallets included in the closeout.
Public property | Request | The original request. (Inherited from CloseoutResponse.)
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
CloseoutResponseLTL Class


Pallets Property

CloseoutResponseLTL Pallets Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The list of pallets included in the closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<LTLPalletResponse> Pallets { get; set; }
public List<LTLPalletResponse> Pallets { get; set; }
Public Property Pallets As List(Of LTLPalletResponse)
    Get
    Set
Public Property Pallets As List(Of LTLPalletResponse)
    Get
    Set
public:
property List<LTLPalletResponse^>^ Pallets {
    List<LTLPalletResponse^>^ get ();
    void set (List<LTLPalletResponse^>^ value);
}
public:
property List<LTLPalletResponse^>^ Pallets {
    List<LTLPalletResponse^>^ get ();
    void set (List<LTLPalletResponse^>^ value);
}
See Also
CloseoutResponseLTL Class
CloseoutResponseLTL Members


CloseoutWithWeightRequest Class

CloseoutWithWeightRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for CloseoutUpdateWeight(CloseoutWithWeightRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CloseoutWithWeightRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CloseoutWithWeightRequest
public class CloseoutWithWeightRequest
Public Class CloseoutWithWeightRequest
Public Class CloseoutWithWeightRequest
public ref class CloseoutWithWeightRequest
public ref class CloseoutWithWeightRequest
See Also
CloseoutWithWeightRequest Members


CloseoutWithWeightRequest Members

CloseoutWithWeightRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutWithWeightRequest type exposes the following members.
Constructors
 | Name | Description
Public method | CloseoutWithWeightRequest | Initializes a new instance of the CloseoutWithWeightRequest class.
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | PackageWeights | A list of packages to closeout and update weights.
Public property | PackIDType | Package Identifier Type
Public property | ParsNumber | Pre-Arrival Review System (PARS) number.
Public property | ShipDate | Date the shipment leaves the facility.
Public property | SkidCount | Number of skids in the closeout.
Back to Top
See Also
CloseoutWithWeightRequest Class


CloseoutWithWeightRequest Constructor

CloseoutWithWeightRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the CloseoutWithWeightRequest class.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutWithWeightRequest()
public CloseoutWithWeightRequest()
Public Sub New
Public Sub New
public:
CloseoutWithWeightRequest()
public:
CloseoutWithWeightRequest()
Remarks

            Customers using Purolator for Customs Clearance must include PackageWeights to be closed out.

See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


CloseoutWithWeightRequest Properties

CloseoutWithWeightRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CloseoutWithWeightRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | PackageWeights | A list of packages to closeout and update weights.
Public property | PackIDType | Package Identifier Type
Public property | ParsNumber | Pre-Arrival Review System (PARS) number.
Public property | ShipDate | Date the shipment leaves the facility.
Public property | SkidCount | Number of skids in the closeout.
Back to Top
See Also
CloseoutWithWeightRequest Class


Credentials Property

CloseoutWithWeightRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


PackageWeights Property

CloseoutWithWeightRequest PackageWeights Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of packages to closeout and update weights.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<PackageIDWeight> PackageWeights { get; set; }
public List<PackageIDWeight> PackageWeights { get; set; }
Public Property PackageWeights As List(Of PackageIDWeight)
    Get
    Set
Public Property PackageWeights As List(Of PackageIDWeight)
    Get
    Set
public:
property List<PackageIDWeight^>^ PackageWeights {
    List<PackageIDWeight^>^ get ();
    void set (List<PackageIDWeight^>^ value);
}
public:
property List<PackageIDWeight^>^ PackageWeights {
    List<PackageIDWeight^>^ get ();
    void set (List<PackageIDWeight^>^ value);
}
Remarks

            For customers using Purolator for Customs Clearance, the list must be filled.
            For customers not using Purolator for customs, this field is optional. If the filed contains package ids, only those packages will be included in the closeout. If the list is empty, all open, valid packages will be included in the closeout.

See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


PackIDType Property

CloseoutWithWeightRequest PackIDType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Package Identifier Type

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PackIDType { get; set; }
public string PackIDType { get; set; }
Public Property PackIDType As String
    Get
    Set
Public Property PackIDType As String
    Get
    Set
public:
property String^ PackIDType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PackIDType {
    String^ get ();
    void set (String^ value);
}
Remarks

            The following package ID types are available.

Pin | The Purolator Pin used for package tracking.
PackageID | The customer supplied package number.
See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


ParsNumber Property

CloseoutWithWeightRequest ParsNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Pre-Arrival Review System (PARS) number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ParsNumber { get; set; }
public string ParsNumber { get; set; }
Public Property ParsNumber As String
    Get
    Set
Public Property ParsNumber As String
    Get
    Set
public:
property String^ ParsNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ParsNumber {
    String^ get ();
    void set (String^ value);
}
See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


ShipDate Property

CloseoutWithWeightRequest ShipDate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Date the shipment leaves the facility.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ShipDate { get; set; }
public DateTime ShipDate { get; set; }
Public Property ShipDate As DateTime
    Get
    Set
Public Property ShipDate As DateTime
    Get
    Set
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
Field Value
The ship date.
See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


SkidCount Property

CloseoutWithWeightRequest SkidCount Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Number of skids in the closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SkidCount { get; set; }
public int SkidCount { get; set; }
Public Property SkidCount As Integer
    Get
    Set
Public Property SkidCount As Integer
    Get
    Set
public:
property int SkidCount {
    int get ();
    void set (int value);
}
public:
property int SkidCount {
    int get ();
    void set (int value);
}
See Also
CloseoutWithWeightRequest Class
CloseoutWithWeightRequest Members


CredentialInfo Class

CredentialInfo Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CredentialInfo

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CredentialInfo
public class CredentialInfo
Public Class CredentialInfo
Public Class CredentialInfo
public ref class CredentialInfo
public ref class CredentialInfo
See Also
CredentialInfo Members


CredentialInfo Members

CredentialInfo Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CredentialInfo type exposes the following members.
Constructors
 | Name | Description
Public method | CredentialInfo |
Back to Top
Properties
 | Name | Description
Public property | ClientID | Unique ClientID.
Public property | Password | Login password.
Public property | UserName | Login username.
Back to Top
See Also
CredentialInfo Class


CredentialInfo Constructor

CredentialInfo Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.CredentialInfo.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo()
public CredentialInfo()
Public Sub New
Public Sub New
public:
CredentialInfo()
public:
CredentialInfo()
See Also
CredentialInfo Class
CredentialInfo Members


CredentialInfo Properties

CredentialInfo Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CredentialInfo type exposes the following members.
Properties
 | Name | Description
Public property | ClientID | Unique ClientID.
Public property | Password | Login password.
Public property | UserName | Login username.
Back to Top
See Also
CredentialInfo Class


ClientID Property

CredentialInfo ClientID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Unique ClientID.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ClientID { get; set; }
public string ClientID { get; set; }
Public Property ClientID As String
    Get
    Set
Public Property ClientID As String
    Get
    Set
public:
property String^ ClientID {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ClientID {
    String^ get ();
    void set (String^ value);
}
See Also
CredentialInfo Class
CredentialInfo Members


Password Property

CredentialInfo Password Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login password.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Password { get; set; }
public string Password { get; set; }
Public Property Password As String
    Get
    Set
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
See Also
CredentialInfo Class
CredentialInfo Members


UserName Property

CredentialInfo UserName Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login username.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UserName { get; set; }
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
See Also
CredentialInfo Class
CredentialInfo Members


CustomsItemResponse Class

CustomsItemResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.CustomsItemResponse"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects CustomsItemResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class CustomsItemResponse
public class CustomsItemResponse
Public Class CustomsItemResponse
Public Class CustomsItemResponse
public ref class CustomsItemResponse
public ref class CustomsItemResponse
See Also
CustomsItemResponse Members


CustomsItemResponse Members

CustomsItemResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CustomsItemResponse type exposes the following members.
Constructors
 | Name | Description
Public method | CustomsItemResponse |
Back to Top
Properties
 | Name | Description
Public property | AccountID |
Public property | CustomsItemID |
Public property | Description |
Public property | HSCode |
Public property | SKU |
Public property | Updated |
Back to Top
See Also
CustomsItemResponse Class


CustomsItemResponse Constructor

CustomsItemResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.CustomsItemResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CustomsItemResponse()
public CustomsItemResponse()
Public Sub New
Public Sub New
public:
CustomsItemResponse()
public:
CustomsItemResponse()
See Also
CustomsItemResponse Class
CustomsItemResponse Members


CustomsItemResponse Properties

CustomsItemResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The CustomsItemResponse type exposes the following members.
Properties
 | Name | Description
Public property | AccountID |
Public property | CustomsItemID |
Public property | Description |
Public property | HSCode |
Public property | SKU |
Public property | Updated |
Back to Top
See Also
CustomsItemResponse Class


AccountID Property

CustomsItemResponse AccountID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.CustomsItemResponse.AccountID"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AccountID { get; set; }
public int AccountID { get; set; }
Public Property AccountID As Integer
    Get
    Set
Public Property AccountID As Integer
    Get
    Set
public:
property int AccountID {
    int get ();
    void set (int value);
}
public:
property int AccountID {
    int get ();
    void set (int value);
}
See Also
CustomsItemResponse Class
CustomsItemResponse Members


CustomsItemID Property

CustomsItemResponse CustomsItemID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.CustomsItemResponse.CustomsItemID"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int CustomsItemID { get; set; }
public int CustomsItemID { get; set; }
Public Property CustomsItemID As Integer
    Get
    Set
Public Property CustomsItemID As Integer
    Get
    Set
public:
property int CustomsItemID {
    int get ();
    void set (int value);
}
public:
property int CustomsItemID {
    int get ();
    void set (int value);
}
See Also
CustomsItemResponse Class
CustomsItemResponse Members


Description Property

CustomsItemResponse Description Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.CustomsItemResponse.Description"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
Public Property Description As String
    Get
    Set
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
See Also
CustomsItemResponse Class
CustomsItemResponse Members


HSCode Property

CustomsItemResponse HSCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.CustomsItemResponse.HSCode"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HSCode { get; set; }
public string HSCode { get; set; }
Public Property HSCode As String
    Get
    Set
Public Property HSCode As String
    Get
    Set
public:
property String^ HSCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HSCode {
    String^ get ();
    void set (String^ value);
}
See Also
CustomsItemResponse Class
CustomsItemResponse Members


SKU Property

CustomsItemResponse SKU Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.CustomsItemResponse.SKU"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SKU { get; set; }
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}
See Also
CustomsItemResponse Class
CustomsItemResponse Members


Updated Property

CustomsItemResponse Updated Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.CustomsItemResponse.Updated"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Updated { get; set; }
public DateTime Updated { get; set; }
Public Property Updated As DateTime
    Get
    Set
Public Property Updated As DateTime
    Get
    Set
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}
See Also
CustomsItemResponse Class
CustomsItemResponse Members


IDResponse Class

IDResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.IDResponse"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects IDResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IDResponse : ResponseBase
public class IDResponse : ResponseBase
Public Class IDResponse _
    Inherits ResponseBase
Public Class IDResponse _
    Inherits ResponseBase
public ref class IDResponse : public ResponseBase
public ref class IDResponse : public ResponseBase
See Also
IDResponse Members


IDResponse Members

IDResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The IDResponse type exposes the following members.
Constructors
 | Name | Description
Public method | IDResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | ReturnID | The ID of the added item.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
IDResponse Class


IDResponse Constructor

IDResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.IDResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IDResponse()
public IDResponse()
Public Sub New
Public Sub New
public:
IDResponse()
public:
IDResponse()
See Also
IDResponse Class
IDResponse Members


IDResponse Properties

IDResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The IDResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | ReturnID | The ID of the added item.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
IDResponse Class


ReturnID Property

IDResponse ReturnID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ID of the added item.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ReturnID { get; set; }
public int ReturnID { get; set; }
Public Property ReturnID As Integer
    Get
    Set
Public Property ReturnID As Integer
    Get
    Set
public:
property int ReturnID {
    int get ();
    void set (int value);
}
public:
property int ReturnID {
    int get ();
    void set (int value);
}
See Also
IDResponse Class
IDResponse Members


InductionPointLookupListItem Class

InductionPointLookupListItem Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.InductionPointLookupListItem"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects InductionPointLookupListItem

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InductionPointLookupListItem
public class InductionPointLookupListItem
Public Class InductionPointLookupListItem
Public Class InductionPointLookupListItem
public ref class InductionPointLookupListItem
public ref class InductionPointLookupListItem
See Also
InductionPointLookupListItem Members


InductionPointLookupListItem Members

InductionPointLookupListItem Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The InductionPointLookupListItem type exposes the following members.
Constructors
 | Name | Description
Public method | InductionPointLookupListItem |
Back to Top
Properties
 | Name | Description
Public property | Address1 |
Public property | Address2 |
Public property | City |
Public property | Code |
Public property | Description |
Public property | InductionPointID |
Public property | PostalCode |
Public property | Province |
Back to Top
See Also
InductionPointLookupListItem Class


InductionPointLookupListItem Constructor

InductionPointLookupListItem Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.InductionPointLookupListItem.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InductionPointLookupListItem()
public InductionPointLookupListItem()
Public Sub New
Public Sub New
public:
InductionPointLookupListItem()
public:
InductionPointLookupListItem()
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


InductionPointLookupListItem Properties

InductionPointLookupListItem Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The InductionPointLookupListItem type exposes the following members.
Properties
 | Name | Description
Public property | Address1 |
Public property | Address2 |
Public property | City |
Public property | Code |
Public property | Description |
Public property | InductionPointID |
Public property | PostalCode |
Public property | Province |
Back to Top
See Also
InductionPointLookupListItem Class


Address1 Property

InductionPointLookupListItem Address1 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.Address1"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Address1 { get; set; }
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


Address2 Property

InductionPointLookupListItem Address2 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.Address2"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Address2 { get; set; }
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


City Property

InductionPointLookupListItem City Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.City"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string City { get; set; }
public string City { get; set; }
Public Property City As String
    Get
    Set
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


Code Property

InductionPointLookupListItem Code Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.Code"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; set; }
public string Code { get; set; }
Public Property Code As String
    Get
    Set
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


Description Property

InductionPointLookupListItem Description Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.Description"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
Public Property Description As String
    Get
    Set
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


InductionPointID Property

InductionPointLookupListItem InductionPointID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.InductionPointID"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int InductionPointID { get; set; }
public int InductionPointID { get; set; }
Public Property InductionPointID As Integer
    Get
    Set
Public Property InductionPointID As Integer
    Get
    Set
public:
property int InductionPointID {
    int get ();
    void set (int value);
}
public:
property int InductionPointID {
    int get ();
    void set (int value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


PostalCode Property

InductionPointLookupListItem PostalCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.PostalCode"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PostalCode { get; set; }
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


Province Property

InductionPointLookupListItem Province Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListItem.Province"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Province { get; set; }
public string Province { get; set; }
Public Property Province As String
    Get
    Set
Public Property Province As String
    Get
    Set
public:
property String^ Province {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Province {
    String^ get ();
    void set (String^ value);
}
See Also
InductionPointLookupListItem Class
InductionPointLookupListItem Members


InductionPointLookupListResponse Class

InductionPointLookupListResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.InductionPointLookupListResponse"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects InductionPointLookupListResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InductionPointLookupListResponse : ResponseBase
public class InductionPointLookupListResponse : ResponseBase
Public Class InductionPointLookupListResponse _
    Inherits ResponseBase
Public Class InductionPointLookupListResponse _
    Inherits ResponseBase
public ref class InductionPointLookupListResponse : public ResponseBase
public ref class InductionPointLookupListResponse : public ResponseBase
See Also
InductionPointLookupListResponse Members


InductionPointLookupListResponse Members

InductionPointLookupListResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The InductionPointLookupListResponse type exposes the following members.
Constructors
 | Name | Description
Public method | InductionPointLookupListResponse |
Back to Top
Properties
 | Name | Description
Public property | InductionPoints |
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
InductionPointLookupListResponse Class


InductionPointLookupListResponse Constructor

InductionPointLookupListResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.InductionPointLookupListResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InductionPointLookupListResponse()
public InductionPointLookupListResponse()
Public Sub New
Public Sub New
public:
InductionPointLookupListResponse()
public:
InductionPointLookupListResponse()
See Also
InductionPointLookupListResponse Class
InductionPointLookupListResponse Members


InductionPointLookupListResponse Properties

InductionPointLookupListResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The InductionPointLookupListResponse type exposes the following members.
Properties
 | Name | Description
Public property | InductionPoints |
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
InductionPointLookupListResponse Class


InductionPoints Property

InductionPointLookupListResponse InductionPoints Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "P:Purolator.Webservice.Objects.InductionPointLookupListResponse.InductionPoints"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<InductionPointLookupListItem> InductionPoints { get; set; }
public List<InductionPointLookupListItem> InductionPoints { get; set; }
Public Property InductionPoints As List(Of InductionPointLookupListItem)
    Get
    Set
Public Property InductionPoints As List(Of InductionPointLookupListItem)
    Get
    Set
public:
property List<InductionPointLookupListItem^>^ InductionPoints {
    List<InductionPointLookupListItem^>^ get ();
    void set (List<InductionPointLookupListItem^>^ value);
}
public:
property List<InductionPointLookupListItem^>^ InductionPoints {
    List<InductionPointLookupListItem^>^ get ();
    void set (List<InductionPointLookupListItem^>^ value);
}
See Also
InductionPointLookupListResponse Class
InductionPointLookupListResponse Members


LabelRequest Class

LabelRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for GetLabel(LabelRequest).
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects LabelRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LabelRequest
public class LabelRequest
Public Class LabelRequest
Public Class LabelRequest
public ref class LabelRequest
public ref class LabelRequest
See Also
LabelRequest Members


LabelRequest Members

LabelRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LabelRequest type exposes the following members.
Constructors
 | Name | Description
Public method | LabelRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | LabelType | The type of label returned (None, ZPL, Image)
Public property | OrderNumber | Specifies the order the package belongs to.
Public property | PackageID | The customer provided ID of the package to retrieve a label for.
Public property | TrackingNumber | The TrackingNumber/PIN of the package to retrieve a label for.
Back to Top
See Also
LabelRequest Class


LabelRequest Constructor

LabelRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LabelRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LabelRequest()
public LabelRequest()
Public Sub New
Public Sub New
public:
LabelRequest()
public:
LabelRequest()
See Also
LabelRequest Class
LabelRequest Members


LabelRequest Properties

LabelRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LabelRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | LabelType | The type of label returned (None, ZPL, Image)
Public property | OrderNumber | Specifies the order the package belongs to.
Public property | PackageID | The customer provided ID of the package to retrieve a label for.
Public property | TrackingNumber | The TrackingNumber/PIN of the package to retrieve a label for.
Back to Top
See Also
LabelRequest Class


Credentials Property

LabelRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
LabelRequest Class
LabelRequest Members


LabelType Property

LabelRequest LabelType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The type of label returned (None, ZPL, Image)

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LabelType { get; set; }
public string LabelType { get; set; }
Public Property LabelType As String
    Get
    Set
Public Property LabelType As String
    Get
    Set
public:
property String^ LabelType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LabelType {
    String^ get ();
    void set (String^ value);
}
See Also
LabelRequest Class
LabelRequest Members


OrderNumber Property

LabelRequest OrderNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Specifies the order the package belongs to.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrderNumber { get; set; }
public string OrderNumber { get; set; }
Public Property OrderNumber As String
    Get
    Set
Public Property OrderNumber As String
    Get
    Set
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LabelRequest Class
LabelRequest Members


PackageID Property

LabelRequest PackageID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The customer provided ID of the package to retrieve a label for.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PackageID { get; set; }
public string PackageID { get; set; }
Public Property PackageID As String
    Get
    Set
Public Property PackageID As String
    Get
    Set
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
See Also
LabelRequest Class
LabelRequest Members


TrackingNumber Property

LabelRequest TrackingNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The TrackingNumber/PIN of the package to retrieve a label for.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TrackingNumber { get; set; }
public string TrackingNumber { get; set; }
Public Property TrackingNumber As String
    Get
    Set
Public Property TrackingNumber As String
    Get
    Set
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LabelRequest Class
LabelRequest Members


LabelResponse Class

LabelResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for GetLabel(LabelRequest).
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects LabelResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LabelResponse : ResponseBase
public class LabelResponse : ResponseBase
Public Class LabelResponse _
    Inherits ResponseBase
Public Class LabelResponse _
    Inherits ResponseBase
public ref class LabelResponse : public ResponseBase
public ref class LabelResponse : public ResponseBase
See Also
LabelResponse Members


LabelResponse Members

LabelResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LabelResponse type exposes the following members.
Constructors
 | Name | Description
Public method | LabelResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Package | The specified package, if found.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
LabelResponse Class


LabelResponse Constructor

LabelResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LabelResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LabelResponse()
public LabelResponse()
Public Sub New
Public Sub New
public:
LabelResponse()
public:
LabelResponse()
See Also
LabelResponse Class
LabelResponse Members


LabelResponse Properties

LabelResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LabelResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Package | The specified package, if found.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
LabelResponse Class


Package Property

LabelResponse Package Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The specified package, if found.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponsePackage Package { get; set; }
public ResponsePackage Package { get; set; }
Public Property Package As ResponsePackage
    Get
    Set
Public Property Package As ResponsePackage
    Get
    Set
public:
property ResponsePackage^ Package {
    ResponsePackage^ get ();
    void set (ResponsePackage^ value);
}
public:
property ResponsePackage^ Package {
    ResponsePackage^ get ();
    void set (ResponsePackage^ value);
}
See Also
LabelResponse Class
LabelResponse Members


Request Property

LabelResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LabelRequest Request { get; set; }
public LabelRequest Request { get; set; }
Public Property Request As LabelRequest
    Get
    Set
Public Property Request As LabelRequest
    Get
    Set
public:
property LabelRequest^ Request {
    LabelRequest^ get ();
    void set (LabelRequest^ value);
}
public:
property LabelRequest^ Request {
    LabelRequest^ get ();
    void set (LabelRequest^ value);
}
See Also
LabelResponse Class
LabelResponse Members


LTLOrderRequest Class

LTLOrderRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Adds an LTL order and LTL shipment.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects OrderRequest
Purolator.Webservice.Objects LTLOrderRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LTLOrderRequest : OrderRequest
public class LTLOrderRequest : OrderRequest
Public Class LTLOrderRequest _
    Inherits OrderRequest
Public Class LTLOrderRequest _
    Inherits OrderRequest
public ref class LTLOrderRequest : public OrderRequest
public ref class LTLOrderRequest : public OrderRequest
Remarks

            If an LTL shipment exists with the exact same return and consignee address, the order will be
            added to the existing LTL Shipment. If no matching LTL shipment exists, a new LTL Shipment will be created.

See Also
LTLOrderRequest Members


LTLOrderRequest Members

LTLOrderRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLOrderRequest type exposes the following members.
Constructors
 | Name | Description
Public method | LTLOrderRequest | Initializes a new instance of the OrderRequest class.
Back to Top
Properties
 | Name | Description
Public property | BillingAccount | A valid Purolator account number is required for all collect and 3rd party orders. (Inherited from OrderRequest.)
Public property | BillingOption | Billing Option (Prepaid, Collect, 3rdParty). (Inherited from OrderRequest.)
Public property | Credentials | Login credentials for validation. (Inherited from OrderRequest.)
Public property | Currency | The currency used for DeclaredValue (USD or CAD). (Inherited from OrderRequest.)
Public property | DeclaredValue | A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment. (Inherited from OrderRequest.)
Public property | GrossWeight | Gross Weight of entire LTL Shipment
Public property | Items | The customs items in the order. (Inherited from OrderRequest.)
Public property | LabelType | The type of label returned (None, ZPL, ZPLIMAGES, Image) (Inherited from OrderRequest.)
Public property | OrderNumber | Unique order number. Each order must have a unique order number that identifies it. (Inherited from OrderRequest.)
Public property | Packages | The packages in the order. (Inherited from OrderRequest.)
Public property | Pallets | A list of pallets included in the Order.
Public property | Ref1 | Customer reference number. (Inherited from OrderRequest.)
Public property | Ref2 | Customer reference number. (Inherited from OrderRequest.)
Public property | ShipDate | The date the order will ship. (Inherited from OrderRequest.)
Public property | ShipFromAddress | The return address on the shipping label (Inherited from OrderRequest.)
Public property | ShipMethod | Ship method. (Inherited from OrderRequest.)
Public property | ShipToAddress | The address to which the order is being shipped. (Inherited from OrderRequest.)
Public property | SpecialServices | Special Services (Inherited from OrderRequest.)
Back to Top
See Also
LTLOrderRequest Class


LTLOrderRequest Constructor

LTLOrderRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the OrderRequest class.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLOrderRequest()
public LTLOrderRequest()
Public Sub New
Public Sub New
public:
LTLOrderRequest()
public:
LTLOrderRequest()
See Also
LTLOrderRequest Class
LTLOrderRequest Members


LTLOrderRequest Properties

LTLOrderRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLOrderRequest type exposes the following members.
Properties
 | Name | Description
Public property | BillingAccount | A valid Purolator account number is required for all collect and 3rd party orders. (Inherited from OrderRequest.)
Public property | BillingOption | Billing Option (Prepaid, Collect, 3rdParty). (Inherited from OrderRequest.)
Public property | Credentials | Login credentials for validation. (Inherited from OrderRequest.)
Public property | Currency | The currency used for DeclaredValue (USD or CAD). (Inherited from OrderRequest.)
Public property | DeclaredValue | A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment. (Inherited from OrderRequest.)
Public property | GrossWeight | Gross Weight of entire LTL Shipment
Public property | Items | The customs items in the order. (Inherited from OrderRequest.)
Public property | LabelType | The type of label returned (None, ZPL, ZPLIMAGES, Image) (Inherited from OrderRequest.)
Public property | OrderNumber | Unique order number. Each order must have a unique order number that identifies it. (Inherited from OrderRequest.)
Public property | Packages | The packages in the order. (Inherited from OrderRequest.)
Public property | Pallets | A list of pallets included in the Order.
Public property | Ref1 | Customer reference number. (Inherited from OrderRequest.)
Public property | Ref2 | Customer reference number. (Inherited from OrderRequest.)
Public property | ShipDate | The date the order will ship. (Inherited from OrderRequest.)
Public property | ShipFromAddress | The return address on the shipping label (Inherited from OrderRequest.)
Public property | ShipMethod | Ship method. (Inherited from OrderRequest.)
Public property | ShipToAddress | The address to which the order is being shipped. (Inherited from OrderRequest.)
Public property | SpecialServices | Special Services (Inherited from OrderRequest.)
Back to Top
See Also
LTLOrderRequest Class


GrossWeight Property

LTLOrderRequest GrossWeight Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gross Weight of entire LTL Shipment

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal GrossWeight { get; set; }
public decimal GrossWeight { get; set; }
Public Property GrossWeight As Decimal
    Get
    Set
Public Property GrossWeight As Decimal
    Get
    Set
public:
property Decimal GrossWeight {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal GrossWeight {
    Decimal get ();
    void set (Decimal value);
}
Remarks

            If a matching LTL shipment exists, the GrossWeight will be added to the existing LTL shipment.

See Also
LTLOrderRequest Class
LTLOrderRequest Members


Pallets Property

LTLOrderRequest Pallets Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of pallets included in the Order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<LTLPalletRequest> Pallets { get; set; }
public List<LTLPalletRequest> Pallets { get; set; }
Public Property Pallets As List(Of LTLPalletRequest)
    Get
    Set
Public Property Pallets As List(Of LTLPalletRequest)
    Get
    Set
public:
property List<LTLPalletRequest^>^ Pallets {
    List<LTLPalletRequest^>^ get ();
    void set (List<LTLPalletRequest^>^ value);
}
public:
property List<LTLPalletRequest^>^ Pallets {
    List<LTLPalletRequest^>^ get ();
    void set (List<LTLPalletRequest^>^ value);
}
Remarks

            If a matching LTL shipment exists, the Pallets will be added to the existing LTL shipment.

See Also
LTLOrderRequest Class
LTLOrderRequest Members


LTLOrderResponse Class

LTLOrderResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.LTLOrderResponse"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects OrderResponse
Purolator.Webservice.Objects LTLOrderResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LTLOrderResponse : OrderResponse
public class LTLOrderResponse : OrderResponse
Public Class LTLOrderResponse _
    Inherits OrderResponse
Public Class LTLOrderResponse _
    Inherits OrderResponse
public ref class LTLOrderResponse : public OrderResponse
public ref class LTLOrderResponse : public OrderResponse
See Also
LTLOrderResponse Members


LTLOrderResponse Members

LTLOrderResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLOrderResponse type exposes the following members.
Constructors
 | Name | Description
Public method | LTLOrderResponse |
Back to Top
Methods
 | Name | Description
Public method | GetOrCreateLTLShipment |
Public method | GetValidationShipment | (Inherited from OrderResponse.)
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | List of calculated Package data. (Inherited from OrderResponse.)
Public property | Pallets | A list of pallets included in the Order.
Public property | ProNumber | Pro number identifying the LTL Shipment.
Public property | Rates | Rates for all available Ship Methods (Inherited from OrderResponse.)
Public property | Request | The original request. (Inherited from OrderResponse.)
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | TotalShipping | The total estimated cost to ship this order by the indicated ShipMethod. (Inherited from OrderResponse.)
Back to Top
See Also
LTLOrderResponse Class


LTLOrderResponse Constructor

LTLOrderResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LTLOrderResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLOrderResponse()
public LTLOrderResponse()
Public Sub New
Public Sub New
public:
LTLOrderResponse()
public:
LTLOrderResponse()
See Also
LTLOrderResponse Class
LTLOrderResponse Members


LTLOrderResponse Methods

LTLOrderResponse Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLOrderResponse type exposes the following members.
Methods
 | Name | Description
Public method | GetOrCreateLTLShipment |
Public method | GetValidationShipment | (Inherited from OrderResponse.)
Back to Top
See Also
LTLOrderResponse Class


GetOrCreateLTLShipment Method

LTLOrderResponse GetOrCreateLTLShipment Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LTLOrderResponse.GetOrCreateLTLShipment(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLOrderRequest)"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int GetOrCreateLTLShipment(
    ShipperAccount sa,
    LTLOrderRequest request
)
public int GetOrCreateLTLShipment(
    ShipperAccount sa,
    LTLOrderRequest request
)
Public Function GetOrCreateLTLShipment ( _
    sa As ShipperAccount, _
    request As LTLOrderRequest _
) As Integer
Public Function GetOrCreateLTLShipment ( _
    sa As ShipperAccount, _
    request As LTLOrderRequest _
) As Integer
public:
int GetOrCreateLTLShipment(
    ShipperAccount^ sa,
    LTLOrderRequest^ request
)
public:
int GetOrCreateLTLShipment(
    ShipperAccount^ sa,
    LTLOrderRequest^ request
)
Parameters
sa
Type: ShipperAccount
[Missing <param name="sa"/> documentation for "M:Purolator.Webservice.Objects.LTLOrderResponse.GetOrCreateLTLShipment(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLOrderRequest)"]
request
Type: Purolator.Webservice.Objects LTLOrderRequest
[Missing <param name="request"/> documentation for "M:Purolator.Webservice.Objects.LTLOrderResponse.GetOrCreateLTLShipment(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLOrderRequest)"]
Return Value
[Missing <returns> documentation for "M:Purolator.Webservice.Objects.LTLOrderResponse.GetOrCreateLTLShipment(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLOrderRequest)"]
See Also
LTLOrderResponse Class
LTLOrderResponse Members


LTLOrderResponse Properties

LTLOrderResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLOrderResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | List of calculated Package data. (Inherited from OrderResponse.)
Public property | Pallets | A list of pallets included in the Order.
Public property | ProNumber | Pro number identifying the LTL Shipment.
Public property | Rates | Rates for all available Ship Methods (Inherited from OrderResponse.)
Public property | Request | The original request. (Inherited from OrderResponse.)
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | TotalShipping | The total estimated cost to ship this order by the indicated ShipMethod. (Inherited from OrderResponse.)
Back to Top
See Also
LTLOrderResponse Class


Pallets Property

LTLOrderResponse Pallets Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of pallets included in the Order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<LTLPalletResponse> Pallets { get; set; }
public List<LTLPalletResponse> Pallets { get; set; }
Public Property Pallets As List(Of LTLPalletResponse)
    Get
    Set
Public Property Pallets As List(Of LTLPalletResponse)
    Get
    Set
public:
property List<LTLPalletResponse^>^ Pallets {
    List<LTLPalletResponse^>^ get ();
    void set (List<LTLPalletResponse^>^ value);
}
public:
property List<LTLPalletResponse^>^ Pallets {
    List<LTLPalletResponse^>^ get ();
    void set (List<LTLPalletResponse^>^ value);
}
Remarks

            If a matching LTL shipment exists, the Pallets will be added to the existing LTL shipment.

See Also
LTLOrderResponse Class
LTLOrderResponse Members


ProNumber Property

LTLOrderResponse ProNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Pro number identifying the LTL Shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProNumber { get; set; }
public string ProNumber { get; set; }
Public Property ProNumber As String
    Get
    Set
Public Property ProNumber As String
    Get
    Set
public:
property String^ ProNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ProNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLOrderResponse Class
LTLOrderResponse Members


LTLPalletRequest Class

LTLPalletRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A Pallet included in an LTLShipmentRequest
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects LTLPalletRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LTLPalletRequest
public class LTLPalletRequest
Public Class LTLPalletRequest
Public Class LTLPalletRequest
public ref class LTLPalletRequest
public ref class LTLPalletRequest
See Also
LTLPalletRequest Members


LTLPalletRequest Members

LTLPalletRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLPalletRequest type exposes the following members.
Constructors
 | Name | Description
Public method | LTLPalletRequest |
Back to Top
Properties
 | Name | Description
Public property | PalletNumber | Optional Customer number defining the Pallet.
Back to Top
See Also
LTLPalletRequest Class


LTLPalletRequest Constructor

LTLPalletRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LTLPalletRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLPalletRequest()
public LTLPalletRequest()
Public Sub New
Public Sub New
public:
LTLPalletRequest()
public:
LTLPalletRequest()
See Also
LTLPalletRequest Class
LTLPalletRequest Members


LTLPalletRequest Properties

LTLPalletRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLPalletRequest type exposes the following members.
Properties
 | Name | Description
Public property | PalletNumber | Optional Customer number defining the Pallet.
Back to Top
See Also
LTLPalletRequest Class


PalletNumber Property

LTLPalletRequest PalletNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Optional Customer number defining the Pallet.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PalletNumber { get; set; }
public string PalletNumber { get; set; }
Public Property PalletNumber As String
    Get
    Set
Public Property PalletNumber As String
    Get
    Set
public:
property String^ PalletNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PalletNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLPalletRequest Class
LTLPalletRequest Members


LTLPalletResponse Class

LTLPalletResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A Pallet included in an LTLShipmentResponse
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects LTLPalletResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LTLPalletResponse
public class LTLPalletResponse
Public Class LTLPalletResponse
Public Class LTLPalletResponse
public ref class LTLPalletResponse
public ref class LTLPalletResponse
See Also
LTLPalletResponse Members


LTLPalletResponse Members

LTLPalletResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLPalletResponse type exposes the following members.
Constructors
 | Name | Description
Public method | LTLPalletResponse |
Back to Top
Properties
 | Name | Description
Public property | LabelImage | Label bitmap for laser printers. The bitmap is only generated if LabelType is set to Image.
Public property | PalletNumber | Optional Customer number defining the Pallet.
Public property | TrackingNumber | Tracking number identifying the Pallet.
Public property | ZPLCode | Label ZPL code for Zebra printers. The ZPL code is only generated if LabelType is set to ZPL.
Back to Top
See Also
LTLPalletResponse Class


LTLPalletResponse Constructor

LTLPalletResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LTLPalletResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLPalletResponse()
public LTLPalletResponse()
Public Sub New
Public Sub New
public:
LTLPalletResponse()
public:
LTLPalletResponse()
See Also
LTLPalletResponse Class
LTLPalletResponse Members


LTLPalletResponse Properties

LTLPalletResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLPalletResponse type exposes the following members.
Properties
 | Name | Description
Public property | LabelImage | Label bitmap for laser printers. The bitmap is only generated if LabelType is set to Image.
Public property | PalletNumber | Optional Customer number defining the Pallet.
Public property | TrackingNumber | Tracking number identifying the Pallet.
Public property | ZPLCode | Label ZPL code for Zebra printers. The ZPL code is only generated if LabelType is set to ZPL.
Back to Top
See Also
LTLPalletResponse Class


LabelImage Property

LTLPalletResponse LabelImage Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Label bitmap for laser printers. The bitmap is only generated if LabelType is set to Image.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LabelImage { get; set; }
public string LabelImage { get; set; }
Public Property LabelImage As String
    Get
    Set
Public Property LabelImage As String
    Get
    Set
public:
property String^ LabelImage {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LabelImage {
    String^ get ();
    void set (String^ value);
}
Remarks

            Bitmap labels are png files encoded using Base64 encoding. To decode the image, you can use the following code in Microsoft .NET

Examples

            byte[] byteArray = Convert.FromBase64String(package.LabelImage);
            MemoryStream ms = new MemoryStream(byteArray);
            Bitmap bm = new Bitmap(ms);

See Also
LTLPalletResponse Class
LTLPalletResponse Members


PalletNumber Property

LTLPalletResponse PalletNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Optional Customer number defining the Pallet.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PalletNumber { get; set; }
public string PalletNumber { get; set; }
Public Property PalletNumber As String
    Get
    Set
Public Property PalletNumber As String
    Get
    Set
public:
property String^ PalletNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PalletNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLPalletResponse Class
LTLPalletResponse Members


TrackingNumber Property

LTLPalletResponse TrackingNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Tracking number identifying the Pallet.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TrackingNumber { get; set; }
public string TrackingNumber { get; set; }
Public Property TrackingNumber As String
    Get
    Set
Public Property TrackingNumber As String
    Get
    Set
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLPalletResponse Class
LTLPalletResponse Members


ZPLCode Property

LTLPalletResponse ZPLCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Label ZPL code for Zebra printers. The ZPL code is only generated if LabelType is set to ZPL.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ZPLCode { get; set; }
public string ZPLCode { get; set; }
Public Property ZPLCode As String
    Get
    Set
Public Property ZPLCode As String
    Get
    Set
public:
property String^ ZPLCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ZPLCode {
    String^ get ();
    void set (String^ value);
}
See Also
LTLPalletResponse Class
LTLPalletResponse Members


LTLShipmentRequest Class

LTLShipmentRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for AddConsolidatedLTLShipment(LTLShipmentRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects LTLShipmentRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LTLShipmentRequest
public class LTLShipmentRequest
Public Class LTLShipmentRequest
Public Class LTLShipmentRequest
public ref class LTLShipmentRequest
public ref class LTLShipmentRequest
See Also
LTLShipmentRequest Members


LTLShipmentRequest Members

LTLShipmentRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLShipmentRequest type exposes the following members.
Constructors
 | Name | Description
Public method | LTLShipmentRequest | Initializes a new instance of the LTLShipmentRequest class.
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | GrossWeight | The Gross Weight of the entire LTL Shipment
Public property | LTLShipmentNumber | Optional Customer number defining the LTL Shipment.
Public property | OrderNumbers | A list of order numbers included in the LTL Shipment
Public property | Pallets | A list of pallets included in the LTL Shipment
Public property | ProNumber | ProNumber defining the LTL Shipment.
Public property | ShipDate | The date the LTL Shipment will ship.
Public property | ShipToAddress | The address to which the order is being shipped.
Back to Top
See Also
LTLShipmentRequest Class


LTLShipmentRequest Constructor

LTLShipmentRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the LTLShipmentRequest class.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLShipmentRequest()
public LTLShipmentRequest()
Public Sub New
Public Sub New
public:
LTLShipmentRequest()
public:
LTLShipmentRequest()
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


LTLShipmentRequest Properties

LTLShipmentRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLShipmentRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | GrossWeight | The Gross Weight of the entire LTL Shipment
Public property | LTLShipmentNumber | Optional Customer number defining the LTL Shipment.
Public property | OrderNumbers | A list of order numbers included in the LTL Shipment
Public property | Pallets | A list of pallets included in the LTL Shipment
Public property | ProNumber | ProNumber defining the LTL Shipment.
Public property | ShipDate | The date the LTL Shipment will ship.
Public property | ShipToAddress | The address to which the order is being shipped.
Back to Top
See Also
LTLShipmentRequest Class


Credentials Property

LTLShipmentRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


GrossWeight Property

LTLShipmentRequest GrossWeight Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Gross Weight of the entire LTL Shipment

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal GrossWeight { get; set; }
public decimal GrossWeight { get; set; }
Public Property GrossWeight As Decimal
    Get
    Set
Public Property GrossWeight As Decimal
    Get
    Set
public:
property Decimal GrossWeight {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal GrossWeight {
    Decimal get ();
    void set (Decimal value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


LTLShipmentNumber Property

LTLShipmentRequest LTLShipmentNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Optional Customer number defining the LTL Shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LTLShipmentNumber { get; set; }
public string LTLShipmentNumber { get; set; }
Public Property LTLShipmentNumber As String
    Get
    Set
Public Property LTLShipmentNumber As String
    Get
    Set
public:
property String^ LTLShipmentNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LTLShipmentNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


OrderNumbers Property

LTLShipmentRequest OrderNumbers Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of order numbers included in the LTL Shipment

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> OrderNumbers { get; set; }
public List<string> OrderNumbers { get; set; }
Public Property OrderNumbers As List(Of String)
    Get
    Set
Public Property OrderNumbers As List(Of String)
    Get
    Set
public:
property List<String^>^ OrderNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ OrderNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


Pallets Property

LTLShipmentRequest Pallets Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of pallets included in the LTL Shipment

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<LTLPalletRequest> Pallets { get; set; }
public List<LTLPalletRequest> Pallets { get; set; }
Public Property Pallets As List(Of LTLPalletRequest)
    Get
    Set
Public Property Pallets As List(Of LTLPalletRequest)
    Get
    Set
public:
property List<LTLPalletRequest^>^ Pallets {
    List<LTLPalletRequest^>^ get ();
    void set (List<LTLPalletRequest^>^ value);
}
public:
property List<LTLPalletRequest^>^ Pallets {
    List<LTLPalletRequest^>^ get ();
    void set (List<LTLPalletRequest^>^ value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


ProNumber Property

LTLShipmentRequest ProNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

ProNumber defining the LTL Shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProNumber { get; set; }
public string ProNumber { get; set; }
Public Property ProNumber As String
    Get
    Set
Public Property ProNumber As String
    Get
    Set
public:
property String^ ProNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ProNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


ShipDate Property

LTLShipmentRequest ShipDate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The date the LTL Shipment will ship.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ShipDate { get; set; }
public DateTime ShipDate { get; set; }
Public Property ShipDate As DateTime
    Get
    Set
Public Property ShipDate As DateTime
    Get
    Set
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


ShipToAddress Property

LTLShipmentRequest ShipToAddress Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The address to which the order is being shipped.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address ShipToAddress { get; set; }
public Address ShipToAddress { get; set; }
Public Property ShipToAddress As Address
    Get
    Set
Public Property ShipToAddress As Address
    Get
    Set
public:
property Address^ ShipToAddress {
    Address^ get ();
    void set (Address^ value);
}
public:
property Address^ ShipToAddress {
    Address^ get ();
    void set (Address^ value);
}
See Also
LTLShipmentRequest Class
LTLShipmentRequest Members


LTLShipmentResponse Class

LTLShipmentResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.LTLShipmentResponse"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects LTLShipmentResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class LTLShipmentResponse : ResponseBase
public class LTLShipmentResponse : ResponseBase
Public Class LTLShipmentResponse _
    Inherits ResponseBase
Public Class LTLShipmentResponse _
    Inherits ResponseBase
public ref class LTLShipmentResponse : public ResponseBase
public ref class LTLShipmentResponse : public ResponseBase
See Also
LTLShipmentResponse Members


LTLShipmentResponse Members

LTLShipmentResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLShipmentResponse type exposes the following members.
Constructors
 | Name | Description
Public method | LTLShipmentResponse |
Back to Top
Methods
 | Name | Description
Public method | SetFromRequest |
Back to Top
Properties
 | Name | Description
Public property | LTLShipmentNumber | Optional Customer number defining the LTL Shipment.
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | ProNumber | ProNumber defining the LTL Shipment.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
LTLShipmentResponse Class


LTLShipmentResponse Constructor

LTLShipmentResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LTLShipmentResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLShipmentResponse()
public LTLShipmentResponse()
Public Sub New
Public Sub New
public:
LTLShipmentResponse()
public:
LTLShipmentResponse()
See Also
LTLShipmentResponse Class
LTLShipmentResponse Members


LTLShipmentResponse Methods

LTLShipmentResponse Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLShipmentResponse type exposes the following members.
Methods
 | Name | Description
Public method | SetFromRequest |
Back to Top
See Also
LTLShipmentResponse Class


SetFromRequest Method

LTLShipmentResponse SetFromRequest Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.LTLShipmentResponse.SetFromRequest(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLShipmentRequest)"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetFromRequest(
    ShipperAccount sa,
    LTLShipmentRequest request
)
public void SetFromRequest(
    ShipperAccount sa,
    LTLShipmentRequest request
)
Public Sub SetFromRequest ( _
    sa As ShipperAccount, _
    request As LTLShipmentRequest _
)
Public Sub SetFromRequest ( _
    sa As ShipperAccount, _
    request As LTLShipmentRequest _
)
public:
void SetFromRequest(
    ShipperAccount^ sa,
    LTLShipmentRequest^ request
)
public:
void SetFromRequest(
    ShipperAccount^ sa,
    LTLShipmentRequest^ request
)
Parameters
sa
Type: ShipperAccount
[Missing <param name="sa"/> documentation for "M:Purolator.Webservice.Objects.LTLShipmentResponse.SetFromRequest(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLShipmentRequest)"]
request
Type: Purolator.Webservice.Objects LTLShipmentRequest
[Missing <param name="request"/> documentation for "M:Purolator.Webservice.Objects.LTLShipmentResponse.SetFromRequest(WorldPak.Library.ShipperAccount,Purolator.Webservice.Objects.LTLShipmentRequest)"]
See Also
LTLShipmentResponse Class
LTLShipmentResponse Members


LTLShipmentResponse Properties

LTLShipmentResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The LTLShipmentResponse type exposes the following members.
Properties
 | Name | Description
Public property | LTLShipmentNumber | Optional Customer number defining the LTL Shipment.
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | ProNumber | ProNumber defining the LTL Shipment.
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
LTLShipmentResponse Class


LTLShipmentNumber Property

LTLShipmentResponse LTLShipmentNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Optional Customer number defining the LTL Shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LTLShipmentNumber { get; set; }
public string LTLShipmentNumber { get; set; }
Public Property LTLShipmentNumber As String
    Get
    Set
Public Property LTLShipmentNumber As String
    Get
    Set
public:
property String^ LTLShipmentNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LTLShipmentNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLShipmentResponse Class
LTLShipmentResponse Members


ProNumber Property

LTLShipmentResponse ProNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

ProNumber defining the LTL Shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ProNumber { get; set; }
public string ProNumber { get; set; }
Public Property ProNumber As String
    Get
    Set
Public Property ProNumber As String
    Get
    Set
public:
property String^ ProNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ProNumber {
    String^ get ();
    void set (String^ value);
}
See Also
LTLShipmentResponse Class
LTLShipmentResponse Members


Request Property

LTLShipmentResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LTLShipmentRequest Request { get; set; }
public LTLShipmentRequest Request { get; set; }
Public Property Request As LTLShipmentRequest
    Get
    Set
Public Property Request As LTLShipmentRequest
    Get
    Set
public:
property LTLShipmentRequest^ Request {
    LTLShipmentRequest^ get ();
    void set (LTLShipmentRequest^ value);
}
public:
property LTLShipmentRequest^ Request {
    LTLShipmentRequest^ get ();
    void set (LTLShipmentRequest^ value);
}
See Also
LTLShipmentResponse Class
LTLShipmentResponse Members


OrderListRequest Class

OrderListRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The request for VoidOrders(OrderListRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects OrderListRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OrderListRequest
public class OrderListRequest
Public Class OrderListRequest
Public Class OrderListRequest
public ref class OrderListRequest
public ref class OrderListRequest
See Also
OrderListRequest Members


OrderListRequest Members

OrderListRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderListRequest type exposes the following members.
Constructors
 | Name | Description
Public method | OrderListRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | OrderNumbers | List of order numbers for operation.
Back to Top
See Also
OrderListRequest Class


OrderListRequest Constructor

OrderListRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.OrderListRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderListRequest()
public OrderListRequest()
Public Sub New
Public Sub New
public:
OrderListRequest()
public:
OrderListRequest()
See Also
OrderListRequest Class
OrderListRequest Members


OrderListRequest Properties

OrderListRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderListRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | OrderNumbers | List of order numbers for operation.
Back to Top
See Also
OrderListRequest Class


Credentials Property

OrderListRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
OrderListRequest Class
OrderListRequest Members


OrderNumbers Property

OrderListRequest OrderNumbers Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

List of order numbers for operation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> OrderNumbers { get; set; }
public List<string> OrderNumbers { get; set; }
Public Property OrderNumbers As List(Of String)
    Get
    Set
Public Property OrderNumbers As List(Of String)
    Get
    Set
public:
property List<String^>^ OrderNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ OrderNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
See Also
OrderListRequest Class
OrderListRequest Members


OrderListResponse Class

OrderListResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The response returned by a CloseoutRequest.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects OrderListResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OrderListResponse : ResponseBase
public class OrderListResponse : ResponseBase
Public Class OrderListResponse _
    Inherits ResponseBase
Public Class OrderListResponse _
    Inherits ResponseBase
public ref class OrderListResponse : public ResponseBase
public ref class OrderListResponse : public ResponseBase
See Also
OrderListResponse Members


OrderListResponse Members

OrderListResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderListResponse type exposes the following members.
Constructors
 | Name | Description
Public method | OrderListResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
OrderListResponse Class


OrderListResponse Constructor

OrderListResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.OrderListResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderListResponse()
public OrderListResponse()
Public Sub New
Public Sub New
public:
OrderListResponse()
public:
OrderListResponse()
See Also
OrderListResponse Class
OrderListResponse Members


OrderListResponse Properties

OrderListResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderListResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
OrderListResponse Class


Request Property

OrderListResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderListRequest Request { get; set; }
public OrderListRequest Request { get; set; }
Public Property Request As OrderListRequest
    Get
    Set
Public Property Request As OrderListRequest
    Get
    Set
public:
property OrderListRequest^ Request {
    OrderListRequest^ get ();
    void set (OrderListRequest^ value);
}
public:
property OrderListRequest^ Request {
    OrderListRequest^ get ();
    void set (OrderListRequest^ value);
}
See Also
OrderListResponse Class
OrderListResponse Members


OrderRequest Class

OrderRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for GetRates(OrderRequest) and AddOrder(OrderRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects OrderRequest
Purolator.Webservice.Objects LTLOrderRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OrderRequest
public class OrderRequest
Public Class OrderRequest
Public Class OrderRequest
public ref class OrderRequest
public ref class OrderRequest
See Also
OrderRequest Members


OrderRequest Members

OrderRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderRequest type exposes the following members.
Properties
 | Name | Description
Public property | BillingAccount | A valid Purolator account number is required for all collect and 3rd party orders.
Public property | BillingOption | Billing Option (Prepaid, Collect, 3rdParty).
Public property | Credentials | Login credentials for validation.
Public property | Currency | The currency used for DeclaredValue (USD or CAD).
Public property | DeclaredValue | A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment.
Public property | Items | The customs items in the order.
Public property | LabelType | The type of label returned (None, ZPL, ZPLIMAGES, Image)
Public property | OrderNumber | Unique order number. Each order must have a unique order number that identifies it.
Public property | Packages | The packages in the order.
Public property | Ref1 | Customer reference number.
Public property | Ref2 | Customer reference number.
Public property | ShipDate | The date the order will ship.
Public property | ShipFromAddress | The return address on the shipping label
Public property | ShipMethod | Ship method.
Public property | ShipToAddress | The address to which the order is being shipped.
Public property | SpecialServices | Special Services
Back to Top
See Also
OrderRequest Class


OrderRequest Properties

OrderRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderRequest type exposes the following members.
Properties
 | Name | Description
Public property | BillingAccount | A valid Purolator account number is required for all collect and 3rd party orders.
Public property | BillingOption | Billing Option (Prepaid, Collect, 3rdParty).
Public property | Credentials | Login credentials for validation.
Public property | Currency | The currency used for DeclaredValue (USD or CAD).
Public property | DeclaredValue | A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment.
Public property | Items | The customs items in the order.
Public property | LabelType | The type of label returned (None, ZPL, ZPLIMAGES, Image)
Public property | OrderNumber | Unique order number. Each order must have a unique order number that identifies it.
Public property | Packages | The packages in the order.
Public property | Ref1 | Customer reference number.
Public property | Ref2 | Customer reference number.
Public property | ShipDate | The date the order will ship.
Public property | ShipFromAddress | The return address on the shipping label
Public property | ShipMethod | Ship method.
Public property | ShipToAddress | The address to which the order is being shipped.
Public property | SpecialServices | Special Services
Back to Top
See Also
OrderRequest Class


BillingAccount Property

OrderRequest BillingAccount Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A valid Purolator account number is required for all collect and 3rd party orders.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BillingAccount { get; set; }
public string BillingAccount { get; set; }
Public Property BillingAccount As String
    Get
    Set
Public Property BillingAccount As String
    Get
    Set
public:
property String^ BillingAccount {
    String^ get ();
    void set (String^ value);
}
public:
property String^ BillingAccount {
    String^ get ();
    void set (String^ value);
}
See Also
OrderRequest Class
OrderRequest Members


BillingOption Property

OrderRequest BillingOption Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Billing Option (Prepaid, Collect, 3rdParty).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BillingOption { get; set; }
public string BillingOption { get; set; }
Public Property BillingOption As String
    Get
    Set
Public Property BillingOption As String
    Get
    Set
public:
property String^ BillingOption {
    String^ get ();
    void set (String^ value);
}
public:
property String^ BillingOption {
    String^ get ();
    void set (String^ value);
}
See Also
OrderRequest Class
OrderRequest Members


Credentials Property

OrderRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
OrderRequest Class
OrderRequest Members


Currency Property

OrderRequest Currency Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The currency used for DeclaredValue (USD or CAD).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Currency { get; set; }
public string Currency { get; set; }
Public Property Currency As String
    Get
    Set
Public Property Currency As String
    Get
    Set
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
See Also
OrderRequest Class
OrderRequest Members


DeclaredValue Property

OrderRequest DeclaredValue Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal DeclaredValue { get; set; }
public decimal DeclaredValue { get; set; }
Public Property DeclaredValue As Decimal
    Get
    Set
Public Property DeclaredValue As Decimal
    Get
    Set
public:
property Decimal DeclaredValue {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal DeclaredValue {
    Decimal get ();
    void set (Decimal value);
}
See Also
OrderRequest Class
OrderRequest Members


Items Property

OrderRequest Items Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The customs items in the order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RequestItem> Items { get; set; }
public List<RequestItem> Items { get; set; }
Public Property Items As List(Of RequestItem)
    Get
    Set
Public Property Items As List(Of RequestItem)
    Get
    Set
public:
property List<RequestItem^>^ Items {
    List<RequestItem^>^ get ();
    void set (List<RequestItem^>^ value);
}
public:
property List<RequestItem^>^ Items {
    List<RequestItem^>^ get ();
    void set (List<RequestItem^>^ value);
}
See Also
OrderRequest Class
OrderRequest Members


LabelType Property

OrderRequest LabelType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The type of label returned (None, ZPL, ZPLIMAGES, Image)

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LabelType { get; set; }
public string LabelType { get; set; }
Public Property LabelType As String
    Get
    Set
Public Property LabelType As String
    Get
    Set
public:
property String^ LabelType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LabelType {
    String^ get ();
    void set (String^ value);
}
Remarks
AddOrder(OrderRequest) can return a label in ZPL format or as an image.  ZPLIMAGES returns ZPL code for the image labels in addition to code for the rest of the label.

See Also
OrderRequest Class
OrderRequest Members


OrderNumber Property

OrderRequest OrderNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Unique order number. Each order must have a unique order number that identifies it.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrderNumber { get; set; }
public string OrderNumber { get; set; }
Public Property OrderNumber As String
    Get
    Set
Public Property OrderNumber As String
    Get
    Set
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
See Also
OrderRequest Class
OrderRequest Members


Packages Property

OrderRequest Packages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The packages in the order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RequestPackage> Packages { get; set; }
public List<RequestPackage> Packages { get; set; }
Public Property Packages As List(Of RequestPackage)
    Get
    Set
Public Property Packages As List(Of RequestPackage)
    Get
    Set
public:
property List<RequestPackage^>^ Packages {
    List<RequestPackage^>^ get ();
    void set (List<RequestPackage^>^ value);
}
public:
property List<RequestPackage^>^ Packages {
    List<RequestPackage^>^ get ();
    void set (List<RequestPackage^>^ value);
}
See Also
OrderRequest Class
OrderRequest Members


Ref1 Property

OrderRequest Ref1 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Customer reference number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Ref1 { get; set; }
public string Ref1 { get; set; }
Public Property Ref1 As String
    Get
    Set
Public Property Ref1 As String
    Get
    Set
public:
property String^ Ref1 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Ref1 {
    String^ get ();
    void set (String^ value);
}
See Also
OrderRequest Class
OrderRequest Members


Ref2 Property

OrderRequest Ref2 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Customer reference number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Ref2 { get; set; }
public string Ref2 { get; set; }
Public Property Ref2 As String
    Get
    Set
Public Property Ref2 As String
    Get
    Set
public:
property String^ Ref2 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Ref2 {
    String^ get ();
    void set (String^ value);
}
See Also
OrderRequest Class
OrderRequest Members


ShipDate Property

OrderRequest ShipDate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The date the order will ship.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ShipDate { get; set; }
public DateTime ShipDate { get; set; }
Public Property ShipDate As DateTime
    Get
    Set
Public Property ShipDate As DateTime
    Get
    Set
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
See Also
OrderRequest Class
OrderRequest Members


ShipFromAddress Property

OrderRequest ShipFromAddress Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The return address on the shipping label

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address ShipFromAddress { get; set; }
public Address ShipFromAddress { get; set; }
Public Property ShipFromAddress As Address
    Get
    Set
Public Property ShipFromAddress As Address
    Get
    Set
public:
property Address^ ShipFromAddress {
    Address^ get ();
    void set (Address^ value);
}
public:
property Address^ ShipFromAddress {
    Address^ get ();
    void set (Address^ value);
}
Remarks

            The return address prints on the shipping label and controls what happens to undeliverable packages.
            If a Canadian address is used for the return address, any undeliverable packages will be returned to the return address.
            If a US address is used for the return address, the package will be returned to Purolator International’s Martin Grove facility in Etobicoke Ontario. The following text will also be printed on the label “UNDELIVERABLE RETURN TO PCL LOGISTICS”

See Also
OrderRequest Class
OrderRequest Members


ShipMethod Property

OrderRequest ShipMethod Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Ship method.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ShipMethod { get; set; }
public string ShipMethod { get; set; }
Public Property ShipMethod As String
    Get
    Set
Public Property ShipMethod As String
    Get
    Set
public:
property String^ ShipMethod {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ShipMethod {
    String^ get ();
    void set (String^ value);
}
Remarks

            The following ship methods are available.

Air | Any shipment designated by the customer to travel within Purolator’s air system. Air packages will arrive on the next business day for many locations, but some locations will take more than one day. Air service is not available between most point where packages can be delivered in one day via Ground service.
Ground | Any shipment designated by the customer to travel within Purolator’s ground system. Overnight ground service is available within approximately a 500 mile (800km) radius of most Canadian induction points.
PuroLetter | An attention grabbing, protective cardboard, legal sized envelope for shipping documents. PuroLetter travels via the fastest mode available to the destination. PuroLetters are available as single piece shipments only, and are priced per piece.
PuroPak | A convenient, easy to use, sealable bag that is tear free and water-resistant. PuroPak travels via the fastest mode available to the destination. PuroPaks are available as single piece shipments only, and are priced per piece.
Fastest | Any shipment designated by the customer to travel via Purolator’s fastest method. Any shipment that can be delivered via ground service in one business day will travel within Purolator's ground system. All other packages will travel within Purolator's air system.
XpressPost | A Canada Post delivery method that guarantees delivery to most locations within 2 days.
CanadaPostExpedited | A cost-effective, ground delivery service for documents and parcels within Canada.
PuroPost | Unique Economical eCommerce Shipping Solution.
LTL | Any LTL shipment. Note that a Purolator LTL shipment must be setup separately from Purolator accounts.
See Also
OrderRequest Class
OrderRequest Members


ShipToAddress Property

OrderRequest ShipToAddress Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The address to which the order is being shipped.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address ShipToAddress { get; set; }
public Address ShipToAddress { get; set; }
Public Property ShipToAddress As Address
    Get
    Set
Public Property ShipToAddress As Address
    Get
    Set
public:
property Address^ ShipToAddress {
    Address^ get ();
    void set (Address^ value);
}
public:
property Address^ ShipToAddress {
    Address^ get ();
    void set (Address^ value);
}
See Also
OrderRequest Class
OrderRequest Members


SpecialServices Property

OrderRequest SpecialServices Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Special Services

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> SpecialServices { get; set; }
public List<string> SpecialServices { get; set; }
Public Property SpecialServices As List(Of String)
    Get
    Set
Public Property SpecialServices As List(Of String)
    Get
    Set
public:
property List<String^>^ SpecialServices {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ SpecialServices {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

            The following special services are available.

9AM | Guaranteed delivery before 9:00 AM next business day.
1030AM | Guaranteed delivery before 10:30 AM next business day.
Saturday | Guaranteed delivery before Noon Saturday (Friday pick up) or delivery before Noon Monday (Saturday pick up).
OSNR | OSNR is an option whereby the Shipper gives Purolator authorization to deliver without obtaining a delivery signature.
SignatureRequired | SignatureRequired requires a signature even if the shipper default is to not require a signature.
HFP | Hold for Pickup (HFP) is a service whereby the package is held at the destination Purolator terminal or Retail Centre rather than being delivered directly to the Receiver.
NotifyConsignee | The consignee will be notified by email that their packages has shipped.
DangerousLQ | Dangerous Goods, Limited Quantities (DangerousLQ) will consist of packages that are restricted in quantity and that will be offered for transport without benefit of documentation or hazard labels. DangerousLQ packages are only acceptable for ground shipment.
Dangerous500KG | Dangerous Goods, 500 KG Exception (Dangerous500KG) eliminates the need for conventional dangerous goods documentation and is acceptable for ground shipment only. There is a physical weight restriction of 66lbs. for the 500KG Exemption category.
DangerousRegulated | Dangerous Goods, Fully Regulated (DangerousRegulated) require full documentation, but can be shipped by Air or Ground.

            Only one time and day special service (9AM, 1030AM and Saturday) may be selected per order. Only one dangerous goods service (DangerousLQ, Dangerous500KG and DangerousRegulated) may be selected per order.

See Also
OrderRequest Class
OrderRequest Members


OrderResponse Class

OrderResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for GetRates(OrderRequest) and AddOrder(OrderRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects OrderResponse
Purolator.Webservice.Objects LTLOrderResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class OrderResponse : ResponseBase
public class OrderResponse : ResponseBase
Public Class OrderResponse _
    Inherits ResponseBase
Public Class OrderResponse _
    Inherits ResponseBase
public ref class OrderResponse : public ResponseBase
public ref class OrderResponse : public ResponseBase
See Also
OrderResponse Members


OrderResponse Members

OrderResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderResponse type exposes the following members.
Constructors
 | Name | Description
Public method | OrderResponse |
Back to Top
Methods
 | Name | Description
Public method | GetValidationShipment |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | List of calculated Package data.
Public property | Rates | Rates for all available Ship Methods
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | TotalShipping | The total estimated cost to ship this order by the indicated ShipMethod.
Back to Top
See Also
OrderResponse Class


OrderResponse Constructor

OrderResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.OrderResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderResponse()
public OrderResponse()
Public Sub New
Public Sub New
public:
OrderResponse()
public:
OrderResponse()
See Also
OrderResponse Class
OrderResponse Members


OrderResponse Methods

OrderResponse Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderResponse type exposes the following members.
Methods
 | Name | Description
Public method | GetValidationShipment |
Back to Top
See Also
OrderResponse Class


GetValidationShipment Method

OrderResponse GetValidationShipment Method Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.OrderResponse.GetValidationShipment(Purolator.Webservice.Objects.OrderRequest,WorldPak.Library.ShipperAccount,WorldPak.Library.Shipment,System.Boolean)"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ValidationShipment GetValidationShipment(
    OrderRequest request,
    ShipperAccount shipperAccount,
    Shipment shipment = null,
    bool updatingPackages = false
)
public ValidationShipment GetValidationShipment(
    OrderRequest request,
    ShipperAccount shipperAccount,
    Shipment shipment = null,
    bool updatingPackages = false
)
Public Function GetValidationShipment ( _
    request As OrderRequest, _
    shipperAccount As ShipperAccount, _
    Optional shipment As Shipment = Nothing, _
    Optional updatingPackages As Boolean = False _
) As ValidationShipment
Public Function GetValidationShipment ( _
    request As OrderRequest, _
    shipperAccount As ShipperAccount, _
    Optional shipment As Shipment = Nothing, _
    Optional updatingPackages As Boolean = False _
) As ValidationShipment
public:
ValidationShipment^ GetValidationShipment(
    OrderRequest^ request,
    ShipperAccount^ shipperAccount,
    Shipment^ shipment = nullptr,
    bool updatingPackages = false
)
public:
ValidationShipment^ GetValidationShipment(
    OrderRequest^ request,
    ShipperAccount^ shipperAccount,
    Shipment^ shipment = nullptr,
    bool updatingPackages = false
)
Parameters
request
Type: Purolator.Webservice.Objects OrderRequest
[Missing <param name="request"/> documentation for "M:Purolator.Webservice.Objects.OrderResponse.GetValidationShipment(Purolator.Webservice.Objects.OrderRequest,WorldPak.Library.ShipperAccount,WorldPak.Library.Shipment,System.Boolean)"]
shipperAccount
Type: ShipperAccount
[Missing <param name="shipperAccount"/> documentation for "M:Purolator.Webservice.Objects.OrderResponse.GetValidationShipment(Purolator.Webservice.Objects.OrderRequest,WorldPak.Library.ShipperAccount,WorldPak.Library.Shipment,System.Boolean)"]
shipment (Optional)
Type: Shipment
[Missing <param name="shipment"/> documentation for "M:Purolator.Webservice.Objects.OrderResponse.GetValidationShipment(Purolator.Webservice.Objects.OrderRequest,WorldPak.Library.ShipperAccount,WorldPak.Library.Shipment,System.Boolean)"]
updatingPackages (Optional)
Type:   Online System Boolean
[Missing <param name="updatingPackages"/> documentation for "M:Purolator.Webservice.Objects.OrderResponse.GetValidationShipment(Purolator.Webservice.Objects.OrderRequest,WorldPak.Library.ShipperAccount,WorldPak.Library.Shipment,System.Boolean)"]
Return Value
[Missing <returns> documentation for "M:Purolator.Webservice.Objects.OrderResponse.GetValidationShipment(Purolator.Webservice.Objects.OrderRequest,WorldPak.Library.ShipperAccount,WorldPak.Library.Shipment,System.Boolean)"]
See Also
OrderResponse Class
OrderResponse Members


OrderResponse Properties

OrderResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The OrderResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Packages | List of calculated Package data.
Public property | Rates | Rates for all available Ship Methods
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | TotalShipping | The total estimated cost to ship this order by the indicated ShipMethod.
Back to Top
See Also
OrderResponse Class


Packages Property

OrderResponse Packages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

List of calculated Package data.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<ResponsePackage> Packages { get; set; }
public List<ResponsePackage> Packages { get; set; }
Public Property Packages As List(Of ResponsePackage)
    Get
    Set
Public Property Packages As List(Of ResponsePackage)
    Get
    Set
public:
property List<ResponsePackage^>^ Packages {
    List<ResponsePackage^>^ get ();
    void set (List<ResponsePackage^>^ value);
}
public:
property List<ResponsePackage^>^ Packages {
    List<ResponsePackage^>^ get ();
    void set (List<ResponsePackage^>^ value);
}
See Also
OrderResponse Class
OrderResponse Members


Rates Property

OrderResponse Rates Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Rates for all available Ship Methods

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<Rate> Rates { get; set; }
public List<Rate> Rates { get; set; }
Public Property Rates As List(Of Rate)
    Get
    Set
Public Property Rates As List(Of Rate)
    Get
    Set
public:
property List<Rate^>^ Rates {
    List<Rate^>^ get ();
    void set (List<Rate^>^ value);
}
public:
property List<Rate^>^ Rates {
    List<Rate^>^ get ();
    void set (List<Rate^>^ value);
}
See Also
OrderResponse Class
OrderResponse Members


Request Property

OrderResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OrderRequest Request { get; set; }
public OrderRequest Request { get; set; }
Public Property Request As OrderRequest
    Get
    Set
Public Property Request As OrderRequest
    Get
    Set
public:
property OrderRequest^ Request {
    OrderRequest^ get ();
    void set (OrderRequest^ value);
}
public:
property OrderRequest^ Request {
    OrderRequest^ get ();
    void set (OrderRequest^ value);
}
See Also
OrderResponse Class
OrderResponse Members


TotalShipping Property

OrderResponse TotalShipping Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The total estimated cost to ship this order by the indicated ShipMethod.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal TotalShipping { get; set; }
public decimal TotalShipping { get; set; }
Public Property TotalShipping As Decimal
    Get
    Set
Public Property TotalShipping As Decimal
    Get
    Set
public:
property Decimal TotalShipping {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal TotalShipping {
    Decimal get ();
    void set (Decimal value);
}
See Also
OrderResponse Class
OrderResponse Members


PackageIDWeight Class

PackageIDWeight Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for CloseoutWithWeightRequest
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects PackageIDWeight

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PackageIDWeight
public class PackageIDWeight
Public Class PackageIDWeight
Public Class PackageIDWeight
public ref class PackageIDWeight
public ref class PackageIDWeight
See Also
PackageIDWeight Members


PackageIDWeight Members

PackageIDWeight Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The PackageIDWeight type exposes the following members.
Constructors
 | Name | Description
Public method | PackageIDWeight |
Back to Top
Properties
 | Name | Description
Public property | PackageID | A package to closeout.
Public property | Weight | The weight of this package.
Public property | WeightUOM | The weight Unit of Measure (KG or LB).
Back to Top
See Also
PackageIDWeight Class


PackageIDWeight Constructor

PackageIDWeight Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.PackageIDWeight.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageIDWeight()
public PackageIDWeight()
Public Sub New
Public Sub New
public:
PackageIDWeight()
public:
PackageIDWeight()
See Also
PackageIDWeight Class
PackageIDWeight Members


PackageIDWeight Properties

PackageIDWeight Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The PackageIDWeight type exposes the following members.
Properties
 | Name | Description
Public property | PackageID | A package to closeout.
Public property | Weight | The weight of this package.
Public property | WeightUOM | The weight Unit of Measure (KG or LB).
Back to Top
See Also
PackageIDWeight Class


PackageID Property

PackageIDWeight PackageID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A package to closeout.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PackageID { get; set; }
public string PackageID { get; set; }
Public Property PackageID As String
    Get
    Set
Public Property PackageID As String
    Get
    Set
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
See Also
PackageIDWeight Class
PackageIDWeight Members


Weight Property

PackageIDWeight Weight Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The weight of this package.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal Weight { get; set; }
public decimal Weight { get; set; }
Public Property Weight As Decimal
    Get
    Set
Public Property Weight As Decimal
    Get
    Set
public:
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
See Also
PackageIDWeight Class
PackageIDWeight Members


WeightUOM Property

PackageIDWeight WeightUOM Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The weight Unit of Measure (KG or LB).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string WeightUOM { get; set; }
public string WeightUOM { get; set; }
Public Property WeightUOM As String
    Get
    Set
Public Property WeightUOM As String
    Get
    Set
public:
property String^ WeightUOM {
    String^ get ();
    void set (String^ value);
}
public:
property String^ WeightUOM {
    String^ get ();
    void set (String^ value);
}
See Also
PackageIDWeight Class
PackageIDWeight Members


PackageListRequest Class

PackageListRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The request for ShipmentVerification(PackageListRequest), VoidPackages(PackageListRequest), and [!:Purolator.Webservice.ShippingServices.SetLabelPrintTime]
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects PackageListRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PackageListRequest
public class PackageListRequest
Public Class PackageListRequest
Public Class PackageListRequest
public ref class PackageListRequest
public ref class PackageListRequest
See Also
PackageListRequest Members


PackageListRequest Members

PackageListRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The PackageListRequest type exposes the following members.
Constructors
 | Name | Description
Public method | PackageListRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | PackageTrackingNumbers | List of tracking numbers for operation.
Back to Top
See Also
PackageListRequest Class


PackageListRequest Constructor

PackageListRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.PackageListRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageListRequest()
public PackageListRequest()
Public Sub New
Public Sub New
public:
PackageListRequest()
public:
PackageListRequest()
See Also
PackageListRequest Class
PackageListRequest Members


PackageListRequest Properties

PackageListRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The PackageListRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | PackageTrackingNumbers | List of tracking numbers for operation.
Back to Top
See Also
PackageListRequest Class


Credentials Property

PackageListRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
PackageListRequest Class
PackageListRequest Members


PackageTrackingNumbers Property

PackageListRequest PackageTrackingNumbers Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

List of tracking numbers for operation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> PackageTrackingNumbers { get; set; }
public List<string> PackageTrackingNumbers { get; set; }
Public Property PackageTrackingNumbers As List(Of String)
    Get
    Set
Public Property PackageTrackingNumbers As List(Of String)
    Get
    Set
public:
property List<String^>^ PackageTrackingNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ PackageTrackingNumbers {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
See Also
PackageListRequest Class
PackageListRequest Members


PackageListResponse Class

PackageListResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The response returned by a CloseoutRequest.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects PackageListResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PackageListResponse : ResponseBase
public class PackageListResponse : ResponseBase
Public Class PackageListResponse _
    Inherits ResponseBase
Public Class PackageListResponse _
    Inherits ResponseBase
public ref class PackageListResponse : public ResponseBase
public ref class PackageListResponse : public ResponseBase
See Also
PackageListResponse Members


PackageListResponse Members

PackageListResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The PackageListResponse type exposes the following members.
Constructors
 | Name | Description
Public method | PackageListResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
PackageListResponse Class


PackageListResponse Constructor

PackageListResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.PackageListResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageListResponse()
public PackageListResponse()
Public Sub New
Public Sub New
public:
PackageListResponse()
public:
PackageListResponse()
See Also
PackageListResponse Class
PackageListResponse Members


PackageListResponse Properties

PackageListResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The PackageListResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
PackageListResponse Class


Request Property

PackageListResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PackageListRequest Request { get; set; }
public PackageListRequest Request { get; set; }
Public Property Request As PackageListRequest
    Get
    Set
Public Property Request As PackageListRequest
    Get
    Set
public:
property PackageListRequest^ Request {
    PackageListRequest^ get ();
    void set (PackageListRequest^ value);
}
public:
property PackageListRequest^ Request {
    PackageListRequest^ get ();
    void set (PackageListRequest^ value);
}
See Also
PackageListResponse Class
PackageListResponse Members


Rate Class

Rate Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A single Rate returned in OrderResponse
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects Rate

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Rate
public class Rate
Public Class Rate
Public Class Rate
public ref class Rate
public ref class Rate
See Also
Rate Members


Rate Members

Rate Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Rate type exposes the following members.
Constructors
 | Name | Description
Public method | Rate |
Back to Top
Properties
 | Name | Description
Public property | EstimatedDeliveryDate | The estimated number of days to deliver this shipment
Public property | EstimatedRate | The estimated rate for this shipment
Public property | ShipMethod | Ship method.
Back to Top
See Also
Rate Class


Rate Constructor

Rate Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.Rate.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rate()
public Rate()
Public Sub New
Public Sub New
public:
Rate()
public:
Rate()
See Also
Rate Class
Rate Members


Rate Properties

Rate Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Rate type exposes the following members.
Properties
 | Name | Description
Public property | EstimatedDeliveryDate | The estimated number of days to deliver this shipment
Public property | EstimatedRate | The estimated rate for this shipment
Public property | ShipMethod | Ship method.
Back to Top
See Also
Rate Class


EstimatedDeliveryDate Property

Rate EstimatedDeliveryDate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The estimated number of days to deliver this shipment

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime EstimatedDeliveryDate { get; set; }
public DateTime EstimatedDeliveryDate { get; set; }
Public Property EstimatedDeliveryDate As DateTime
    Get
    Set
Public Property EstimatedDeliveryDate As DateTime
    Get
    Set
public:
property DateTime EstimatedDeliveryDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime EstimatedDeliveryDate {
    DateTime get ();
    void set (DateTime value);
}
See Also
Rate Class
Rate Members


EstimatedRate Property

Rate EstimatedRate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The estimated rate for this shipment

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal EstimatedRate { get; set; }
public decimal EstimatedRate { get; set; }
Public Property EstimatedRate As Decimal
    Get
    Set
Public Property EstimatedRate As Decimal
    Get
    Set
public:
property Decimal EstimatedRate {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal EstimatedRate {
    Decimal get ();
    void set (Decimal value);
}
See Also
Rate Class
Rate Members


ShipMethod Property

Rate ShipMethod Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Ship method.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ShipMethod { get; set; }
public string ShipMethod { get; set; }
Public Property ShipMethod As String
    Get
    Set
Public Property ShipMethod As String
    Get
    Set
public:
property String^ ShipMethod {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ShipMethod {
    String^ get ();
    void set (String^ value);
}
See Also
Rate Class
Rate Members


RateRequest Class

RateRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for [!:ShippingServices.RateRequest]
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects RateRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RateRequest
public class RateRequest
Public Class RateRequest
Public Class RateRequest
public ref class RateRequest
public ref class RateRequest
See Also
RateRequest Members


RateRequest Members

RateRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The RateRequest type exposes the following members.
Constructors
 | Name | Description
Public method | RateRequest | Initializes a new instance of the RateRequest class.
Back to Top
Properties
 | Name | Description
Public property | BillingAccount | A valid Purolator account number is required for all collect and 3rd party orders.
Public property | BillingOption | Billing Option (Prepaid, Collect, 3rdParty).
Public property | Credentials | Login credentials for validation.
Public property | Currency | The currency used for DeclaredValue (USD or CAD).
Public property | DeclaredValue | A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment.
Public property | OrderNumber | Unique order number. Each order must have a unique order number that identifies it.
Public property | Packages | The packages in the order.
Public property | Ref1 | Customer reference number.
Public property | Ref2 | Customer reference number.
Public property | ShipDate | The date the order will ship.
Public property | ShipFromAddress | The return address on the shipping label
Public property | ShipMethod | Ship method.
Public property | ShipToAddress | The address to which the order is being shipped.
Public property | SpecialServices | Special Services
Back to Top
See Also
RateRequest Class


RateRequest Constructor

RateRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RateRequest class.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RateRequest()
public RateRequest()
Public Sub New
Public Sub New
public:
RateRequest()
public:
RateRequest()
See Also
RateRequest Class
RateRequest Members


RateRequest Properties

RateRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The RateRequest type exposes the following members.
Properties
 | Name | Description
Public property | BillingAccount | A valid Purolator account number is required for all collect and 3rd party orders.
Public property | BillingOption | Billing Option (Prepaid, Collect, 3rdParty).
Public property | Credentials | Login credentials for validation.
Public property | Currency | The currency used for DeclaredValue (USD or CAD).
Public property | DeclaredValue | A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment.
Public property | OrderNumber | Unique order number. Each order must have a unique order number that identifies it.
Public property | Packages | The packages in the order.
Public property | Ref1 | Customer reference number.
Public property | Ref2 | Customer reference number.
Public property | ShipDate | The date the order will ship.
Public property | ShipFromAddress | The return address on the shipping label
Public property | ShipMethod | Ship method.
Public property | ShipToAddress | The address to which the order is being shipped.
Public property | SpecialServices | Special Services
Back to Top
See Also
RateRequest Class


BillingAccount Property

RateRequest BillingAccount Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A valid Purolator account number is required for all collect and 3rd party orders.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BillingAccount { get; set; }
public string BillingAccount { get; set; }
Public Property BillingAccount As String
    Get
    Set
Public Property BillingAccount As String
    Get
    Set
public:
property String^ BillingAccount {
    String^ get ();
    void set (String^ value);
}
public:
property String^ BillingAccount {
    String^ get ();
    void set (String^ value);
}
See Also
RateRequest Class
RateRequest Members


BillingOption Property

RateRequest BillingOption Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Billing Option (Prepaid, Collect, 3rdParty).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BillingOption { get; set; }
public string BillingOption { get; set; }
Public Property BillingOption As String
    Get
    Set
Public Property BillingOption As String
    Get
    Set
public:
property String^ BillingOption {
    String^ get ();
    void set (String^ value);
}
public:
property String^ BillingOption {
    String^ get ();
    void set (String^ value);
}
See Also
RateRequest Class
RateRequest Members


Credentials Property

RateRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
RateRequest Class
RateRequest Members


Currency Property

RateRequest Currency Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The currency used for DeclaredValue (USD or CAD).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Currency { get; set; }
public string Currency { get; set; }
Public Property Currency As String
    Get
    Set
Public Property Currency As String
    Get
    Set
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
See Also
RateRequest Class
RateRequest Members


DeclaredValue Property

RateRequest DeclaredValue Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A value declared for insurance that is in excess of the base value amount. The maximum allowable declared value for insurance is $5000.00 per shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal DeclaredValue { get; set; }
public decimal DeclaredValue { get; set; }
Public Property DeclaredValue As Decimal
    Get
    Set
Public Property DeclaredValue As Decimal
    Get
    Set
public:
property Decimal DeclaredValue {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal DeclaredValue {
    Decimal get ();
    void set (Decimal value);
}
See Also
RateRequest Class
RateRequest Members


OrderNumber Property

RateRequest OrderNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Unique order number. Each order must have a unique order number that identifies it.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrderNumber { get; set; }
public string OrderNumber { get; set; }
Public Property OrderNumber As String
    Get
    Set
Public Property OrderNumber As String
    Get
    Set
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
See Also
RateRequest Class
RateRequest Members


Packages Property

RateRequest Packages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The packages in the order.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<RequestPackage> Packages { get; set; }
public List<RequestPackage> Packages { get; set; }
Public Property Packages As List(Of RequestPackage)
    Get
    Set
Public Property Packages As List(Of RequestPackage)
    Get
    Set
public:
property List<RequestPackage^>^ Packages {
    List<RequestPackage^>^ get ();
    void set (List<RequestPackage^>^ value);
}
public:
property List<RequestPackage^>^ Packages {
    List<RequestPackage^>^ get ();
    void set (List<RequestPackage^>^ value);
}
See Also
RateRequest Class
RateRequest Members


Ref1 Property

RateRequest Ref1 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Customer reference number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Ref1 { get; set; }
public string Ref1 { get; set; }
Public Property Ref1 As String
    Get
    Set
Public Property Ref1 As String
    Get
    Set
public:
property String^ Ref1 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Ref1 {
    String^ get ();
    void set (String^ value);
}
See Also
RateRequest Class
RateRequest Members


Ref2 Property

RateRequest Ref2 Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Customer reference number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Ref2 { get; set; }
public string Ref2 { get; set; }
Public Property Ref2 As String
    Get
    Set
Public Property Ref2 As String
    Get
    Set
public:
property String^ Ref2 {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Ref2 {
    String^ get ();
    void set (String^ value);
}
See Also
RateRequest Class
RateRequest Members


ShipDate Property

RateRequest ShipDate Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The date the order will ship.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime ShipDate { get; set; }
public DateTime ShipDate { get; set; }
Public Property ShipDate As DateTime
    Get
    Set
Public Property ShipDate As DateTime
    Get
    Set
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
See Also
RateRequest Class
RateRequest Members


ShipFromAddress Property

RateRequest ShipFromAddress Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The return address on the shipping label

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address ShipFromAddress { get; set; }
public Address ShipFromAddress { get; set; }
Public Property ShipFromAddress As Address
    Get
    Set
Public Property ShipFromAddress As Address
    Get
    Set
public:
property Address^ ShipFromAddress {
    Address^ get ();
    void set (Address^ value);
}
public:
property Address^ ShipFromAddress {
    Address^ get ();
    void set (Address^ value);
}
Remarks

            The return address prints on the shipping label and controls what happens to undeliverable packages.
            If a Canadian address is used for the return address, any undeliverable packages will be returned to the return address.
            If a US address is used for the return address, the package will be returned to Purolator International’s Martin Grove facility in Etobicoke Ontario. The following text will also be printed on the label “UNDELIVERABLE RETURN TO PCL LOGISTICS”

See Also
RateRequest Class
RateRequest Members


ShipMethod Property

RateRequest ShipMethod Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Ship method.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ShipMethod { get; set; }
public string ShipMethod { get; set; }
Public Property ShipMethod As String
    Get
    Set
Public Property ShipMethod As String
    Get
    Set
public:
property String^ ShipMethod {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ShipMethod {
    String^ get ();
    void set (String^ value);
}
Remarks

            The following ship methods are available.

Air | Any shipment designated by the customer to travel within Purolator’s air system. Air packages will arrive on the next business day for many locations, but some locations will take more than one day. Air service is not available between most point where packages can be delivered in one day via Ground service.
Ground | Any shipment designated by the customer to travel within Purolator’s ground system. Overnight ground service is available within approximately a 500 mile (800km) radius of most Canadian induction points.
PuroLetter | An attention grabbing, protective cardboard, legal sized envelope for shipping documents. PuroLetter travels via the fastest mode available to the destination. PuroLetters are available as single piece shipments only, and are priced per piece.
PuroPak | A convenient, easy to use, sealable bag that is tear free and water-resistant. PuroPak travels via the fastest mode available to the destination. PuroPaks are available as single piece shipments only, and are priced per piece.
Fastest | Any shipment designated by the customer to travel via Purolator’s fastest method. Any shipment that can be delivered via ground service in one business day will travel within Purolator's ground system. All other packages will travel within Purolator's air system.
See Also
RateRequest Class
RateRequest Members


ShipToAddress Property

RateRequest ShipToAddress Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The address to which the order is being shipped.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Address ShipToAddress { get; set; }
public Address ShipToAddress { get; set; }
Public Property ShipToAddress As Address
    Get
    Set
Public Property ShipToAddress As Address
    Get
    Set
public:
property Address^ ShipToAddress {
    Address^ get ();
    void set (Address^ value);
}
public:
property Address^ ShipToAddress {
    Address^ get ();
    void set (Address^ value);
}
See Also
RateRequest Class
RateRequest Members


SpecialServices Property

RateRequest SpecialServices Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Special Services

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> SpecialServices { get; set; }
public List<string> SpecialServices { get; set; }
Public Property SpecialServices As List(Of String)
    Get
    Set
Public Property SpecialServices As List(Of String)
    Get
    Set
public:
property List<String^>^ SpecialServices {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
public:
property List<String^>^ SpecialServices {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

            The following special services are available.

9AM | Guaranteed delivery before 9:00 AM next business day.
1030AM | Guaranteed delivery before 10:30 AM next business day.
Saturday | Guaranteed delivery before Noon Saturday (Friday pick up) or delivery before Noon Monday (Saturday pick up).
OSNR | OSNR is an option whereby the Shipper gives Purolator authorization to deliver without obtaining a delivery signature.
SignatureRequired | SignatureRequired requires a signature even if the shipper default is to not require a signature.
HFP | Hold for Pickup (HFP) is a service whereby the package is held at the destination Purolator terminal or Retail Centre rather than being delivered directly to the Receiver.
NotifyConsignee | The consignee will be notified by email that their packages has shipped.
DangerousLQ | Dangerous Goods, Limited Quantities (DangerousLQ) will consist of packages that are restricted in quantity and that will be offered for transport without benefit of documentation or hazard labels. DangerousLQ packages are only acceptable for ground shipment.
Dangerous500KG | Dangerous Goods, 500 KG Exception (Dangerous500KG) eliminates the need for conventional dangerous goods documentation and is acceptable for ground shipment only. There is a physical weight restriction of 66lbs. for the 500KG Exemption category.
DangerousRegulated | Dangerous Goods, Fully Regulated (DangerousRegulated) require full documentation, but can be shipped by Air or Ground.

            Only one time and day special service (9AM, 1030AM and Saturday) may be selected per order. Only one dangerous goods service (DangerousLQ, Dangerous500KG and DangerousRegulated) may be selected per order.

See Also
RateRequest Class
RateRequest Members


RequestItem Class

RequestItem Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

An item contained in an order for customs purposes.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects RequestItem

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RequestItem
public class RequestItem
Public Class RequestItem
Public Class RequestItem
public ref class RequestItem
public ref class RequestItem
See Also
RequestItem Members


RequestItem Members

RequestItem Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The RequestItem type exposes the following members.
Constructors
 | Name | Description
Public method | RequestItem |
Back to Top
Properties
 | Name | Description
Public property | CountryOfOrigin | The country of origin of this SKU.
Public property | Currency | The currency used for TotalValue (USD or CAD).
Public property | CustomsDesc | The customs description.
Public property | ExtendedDesc | The extended description.
Public property | FDAFood | Is the item FDA Food.
Public property | HSCode | The Harmonized System Code (HS Code).
Public property | NAFTAEligible | Is the item eligible for NAFTA.
Public property | Quantity | Gets or sets the quantity.
Public property | SKU | The SKU (stock keeping unit).
Public property | Textile | Is the item a Textile.
Public property | TotalValue | The total value of all the items.
Back to Top
See Also
RequestItem Class


RequestItem Constructor

RequestItem Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.RequestItem.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestItem()
public RequestItem()
Public Sub New
Public Sub New
public:
RequestItem()
public:
RequestItem()
See Also
RequestItem Class
RequestItem Members


RequestItem Properties

RequestItem Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The RequestItem type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfOrigin | The country of origin of this SKU.
Public property | Currency | The currency used for TotalValue (USD or CAD).
Public property | CustomsDesc | The customs description.
Public property | ExtendedDesc | The extended description.
Public property | FDAFood | Is the item FDA Food.
Public property | HSCode | The Harmonized System Code (HS Code).
Public property | NAFTAEligible | Is the item eligible for NAFTA.
Public property | Quantity | Gets or sets the quantity.
Public property | SKU | The SKU (stock keeping unit).
Public property | Textile | Is the item a Textile.
Public property | TotalValue | The total value of all the items.
Back to Top
See Also
RequestItem Class


CountryOfOrigin Property

RequestItem CountryOfOrigin Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The country of origin of this SKU.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfOrigin { get; set; }
public string CountryOfOrigin { get; set; }
Public Property CountryOfOrigin As String
    Get
    Set
Public Property CountryOfOrigin As String
    Get
    Set
public:
property String^ CountryOfOrigin {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CountryOfOrigin {
    String^ get ();
    void set (String^ value);
}
See Also
RequestItem Class
RequestItem Members


Currency Property

RequestItem Currency Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The currency used for TotalValue (USD or CAD).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Currency { get; set; }
public string Currency { get; set; }
Public Property Currency As String
    Get
    Set
Public Property Currency As String
    Get
    Set
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
See Also
RequestItem Class
RequestItem Members


CustomsDesc Property

RequestItem CustomsDesc Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The customs description.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CustomsDesc { get; set; }
public string CustomsDesc { get; set; }
Public Property CustomsDesc As String
    Get
    Set
Public Property CustomsDesc As String
    Get
    Set
public:
property String^ CustomsDesc {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CustomsDesc {
    String^ get ();
    void set (String^ value);
}
See Also
RequestItem Class
RequestItem Members


ExtendedDesc Property

RequestItem ExtendedDesc Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The extended description.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ExtendedDesc { get; set; }
public string ExtendedDesc { get; set; }
Public Property ExtendedDesc As String
    Get
    Set
Public Property ExtendedDesc As String
    Get
    Set
public:
property String^ ExtendedDesc {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ExtendedDesc {
    String^ get ();
    void set (String^ value);
}
See Also
RequestItem Class
RequestItem Members


FDAFood Property

RequestItem FDAFood Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Is the item FDA Food.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool FDAFood { get; set; }
public bool FDAFood { get; set; }
Public Property FDAFood As Boolean
    Get
    Set
Public Property FDAFood As Boolean
    Get
    Set
public:
property bool FDAFood {
    bool get ();
    void set (bool value);
}
public:
property bool FDAFood {
    bool get ();
    void set (bool value);
}
See Also
RequestItem Class
RequestItem Members


HSCode Property

RequestItem HSCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Harmonized System Code (HS Code).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HSCode { get; set; }
public string HSCode { get; set; }
Public Property HSCode As String
    Get
    Set
Public Property HSCode As String
    Get
    Set
public:
property String^ HSCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HSCode {
    String^ get ();
    void set (String^ value);
}
See Also
RequestItem Class
RequestItem Members


NAFTAEligible Property

RequestItem NAFTAEligible Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Is the item eligible for NAFTA.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NAFTAEligible { get; set; }
public bool NAFTAEligible { get; set; }
Public Property NAFTAEligible As Boolean
    Get
    Set
Public Property NAFTAEligible As Boolean
    Get
    Set
public:
property bool NAFTAEligible {
    bool get ();
    void set (bool value);
}
public:
property bool NAFTAEligible {
    bool get ();
    void set (bool value);
}
See Also
RequestItem Class
RequestItem Members


Quantity Property

RequestItem Quantity Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Gets or sets the quantity.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Quantity { get; set; }
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}
public:
property int Quantity {
    int get ();
    void set (int value);
}
See Also
RequestItem Class
RequestItem Members


SKU Property

RequestItem SKU Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The SKU (stock keeping unit).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SKU { get; set; }
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}
See Also
RequestItem Class
RequestItem Members


Textile Property

RequestItem Textile Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Is the item a Textile.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Textile { get; set; }
public bool Textile { get; set; }
Public Property Textile As Boolean
    Get
    Set
Public Property Textile As Boolean
    Get
    Set
public:
property bool Textile {
    bool get ();
    void set (bool value);
}
public:
property bool Textile {
    bool get ();
    void set (bool value);
}
See Also
RequestItem Class
RequestItem Members


TotalValue Property

RequestItem TotalValue Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The total value of all the items.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal TotalValue { get; set; }
public decimal TotalValue { get; set; }
Public Property TotalValue As Decimal
    Get
    Set
Public Property TotalValue As Decimal
    Get
    Set
public:
property Decimal TotalValue {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal TotalValue {
    Decimal get ();
    void set (Decimal value);
}
See Also
RequestItem Class
RequestItem Members


RequestPackage Class

RequestPackage Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Describes a package
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects RequestPackage

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class RequestPackage
public class RequestPackage
Public Class RequestPackage
Public Class RequestPackage
public ref class RequestPackage
public ref class RequestPackage
See Also
RequestPackage Members


RequestPackage Members

RequestPackage Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The RequestPackage type exposes the following members.
Constructors
 | Name | Description
Public method | RequestPackage |
Back to Top
Properties
 | Name | Description
Public property | DimensionUOM | The dimension Unit of Measure (CM or IN).
Public property | DimH | The height of the package.
Public property | DimL | The length of the package.
Public property | DimW | The width of the package.
Public property | PackageID | The unique package Number.
Public property | Weight | The weight of this package.
Public property | WeightUOM | The weight Unit of Measure (KG or LB).
Back to Top
See Also
RequestPackage Class


RequestPackage Constructor

RequestPackage Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.RequestPackage.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RequestPackage()
public RequestPackage()
Public Sub New
Public Sub New
public:
RequestPackage()
public:
RequestPackage()
See Also
RequestPackage Class
RequestPackage Members


RequestPackage Properties

RequestPackage Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The RequestPackage type exposes the following members.
Properties
 | Name | Description
Public property | DimensionUOM | The dimension Unit of Measure (CM or IN).
Public property | DimH | The height of the package.
Public property | DimL | The length of the package.
Public property | DimW | The width of the package.
Public property | PackageID | The unique package Number.
Public property | Weight | The weight of this package.
Public property | WeightUOM | The weight Unit of Measure (KG or LB).
Back to Top
See Also
RequestPackage Class


DimensionUOM Property

RequestPackage DimensionUOM Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The dimension Unit of Measure (CM or IN).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DimensionUOM { get; set; }
public string DimensionUOM { get; set; }
Public Property DimensionUOM As String
    Get
    Set
Public Property DimensionUOM As String
    Get
    Set
public:
property String^ DimensionUOM {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DimensionUOM {
    String^ get ();
    void set (String^ value);
}
See Also
RequestPackage Class
RequestPackage Members


DimH Property

RequestPackage DimH Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The height of the package.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal DimH { get; set; }
public decimal DimH { get; set; }
Public Property DimH As Decimal
    Get
    Set
Public Property DimH As Decimal
    Get
    Set
public:
property Decimal DimH {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal DimH {
    Decimal get ();
    void set (Decimal value);
}
See Also
RequestPackage Class
RequestPackage Members


DimL Property

RequestPackage DimL Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The length of the package.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal DimL { get; set; }
public decimal DimL { get; set; }
Public Property DimL As Decimal
    Get
    Set
Public Property DimL As Decimal
    Get
    Set
public:
property Decimal DimL {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal DimL {
    Decimal get ();
    void set (Decimal value);
}
Remarks

            The lenghth of a package is always its longest dimension.

See Also
RequestPackage Class
RequestPackage Members


DimW Property

RequestPackage DimW Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The width of the package.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal DimW { get; set; }
public decimal DimW { get; set; }
Public Property DimW As Decimal
    Get
    Set
Public Property DimW As Decimal
    Get
    Set
public:
property Decimal DimW {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal DimW {
    Decimal get ();
    void set (Decimal value);
}
See Also
RequestPackage Class
RequestPackage Members


PackageID Property

RequestPackage PackageID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The unique package Number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PackageID { get; set; }
public string PackageID { get; set; }
Public Property PackageID As String
    Get
    Set
Public Property PackageID As String
    Get
    Set
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
Remarks

            The package ID is not required, but can be used to associate ResponsePackages with RequestPackages.

See Also
RequestPackage Class
RequestPackage Members


Weight Property

RequestPackage Weight Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The weight of this package.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal Weight { get; set; }
public decimal Weight { get; set; }
Public Property Weight As Decimal
    Get
    Set
Public Property Weight As Decimal
    Get
    Set
public:
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
See Also
RequestPackage Class
RequestPackage Members


WeightUOM Property

RequestPackage WeightUOM Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The weight Unit of Measure (KG or LB).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string WeightUOM { get; set; }
public string WeightUOM { get; set; }
Public Property WeightUOM As String
    Get
    Set
Public Property WeightUOM As String
    Get
    Set
public:
property String^ WeightUOM {
    String^ get ();
    void set (String^ value);
}
public:
property String^ WeightUOM {
    String^ get ();
    void set (String^ value);
}
See Also
RequestPackage Class
RequestPackage Members


ResponseBase Class

ResponseBase Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Base class for responses
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects AddItemResponse
Purolator.Webservice.Objects AddPackageResponse
Purolator.Webservice.Objects CloseoutResponse
Purolator.Webservice.Objects IDResponse
Purolator.Webservice.Objects InductionPointLookupListResponse
Purolator.Webservice.Objects LabelResponse
Purolator.Webservice.Objects LTLShipmentResponse
Purolator.Webservice.Objects OrderListResponse
Purolator.Webservice.Objects OrderResponse
Purolator.Webservice.Objects PackageListResponse
Purolator.Webservice.Objects UpdateOrderResponse
Purolator.Webservice.Objects ZPLInitializationResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResponseBase
public class ResponseBase
Public Class ResponseBase
Public Class ResponseBase
public ref class ResponseBase
public ref class ResponseBase
See Also
ResponseBase Members


ResponseBase Members

ResponseBase Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ResponseBase type exposes the following members.
Constructors
 | Name | Description
Public method | ResponseBase |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure).
Back to Top
See Also
ResponseBase Class


ResponseBase Constructor

ResponseBase Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ResponseBase.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseBase()
public ResponseBase()
Public Sub New
Public Sub New
public:
ResponseBase()
public:
ResponseBase()
See Also
ResponseBase Class
ResponseBase Members


ResponseBase Properties

ResponseBase Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ResponseBase type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure).
Back to Top
See Also
ResponseBase Class


Messages Property

ResponseBase Messages Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Error, Warning or Informational messages.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<ResponseMessage> Messages { get; set; }
public List<ResponseMessage> Messages { get; set; }
Public Property Messages As List(Of ResponseMessage)
    Get
    Set
Public Property Messages As List(Of ResponseMessage)
    Get
    Set
public:
property List<ResponseMessage^>^ Messages {
    List<ResponseMessage^>^ get ();
    void set (List<ResponseMessage^>^ value);
}
public:
property List<ResponseMessage^>^ Messages {
    List<ResponseMessage^>^ get ();
    void set (List<ResponseMessage^>^ value);
}
See Also
ResponseBase Class
ResponseBase Members


Status Property

ResponseBase Status Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure).

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Status { get; set; }
public int Status { get; set; }
Public Property Status As Integer
    Get
    Set
Public Property Status As Integer
    Get
    Set
public:
property int Status {
    int get ();
    void set (int value);
}
public:
property int Status {
    int get ();
    void set (int value);
}
See Also
ResponseBase Class
ResponseBase Members


ResponseMessage Class

ResponseMessage Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The status and messages returned by each web service call.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseMessage

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResponseMessage
public class ResponseMessage
Public Class ResponseMessage
Public Class ResponseMessage
public ref class ResponseMessage
public ref class ResponseMessage
See Also
ResponseMessage Members


ResponseMessage Members

ResponseMessage Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ResponseMessage type exposes the following members.
Constructors
 | Name | Description
Public method | ResponseMessage |
Back to Top
Properties
 | Name | Description
Public property | Message | The text of the message.
Public property | Number | The error code.
Public property | Severity | The severity of the message ResponseMessage SeverityEnum.
Back to Top
See Also
ResponseMessage Class


ResponseMessage Constructor

ResponseMessage Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ResponseMessage.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponseMessage()
public ResponseMessage()
Public Sub New
Public Sub New
public:
ResponseMessage()
public:
ResponseMessage()
See Also
ResponseMessage Class
ResponseMessage Members


ResponseMessage Properties

ResponseMessage Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ResponseMessage type exposes the following members.
Properties
 | Name | Description
Public property | Message | The text of the message.
Public property | Number | The error code.
Public property | Severity | The severity of the message ResponseMessage SeverityEnum.
Back to Top
See Also
ResponseMessage Class


Message Property

ResponseMessage Message Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The text of the message.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Message { get; set; }
public string Message { get; set; }
Public Property Message As String
    Get
    Set
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
See Also
ResponseMessage Class
ResponseMessage Members


Number Property

ResponseMessage Number Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The error code.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Number { get; set; }
public int Number { get; set; }
Public Property Number As Integer
    Get
    Set
Public Property Number As Integer
    Get
    Set
public:
property int Number {
    int get ();
    void set (int value);
}
public:
property int Number {
    int get ();
    void set (int value);
}
See Also
ResponseMessage Class
ResponseMessage Members


Severity Property

ResponseMessage Severity Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The severity of the message ResponseMessage SeverityEnum.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Severity { get; set; }
public int Severity { get; set; }
Public Property Severity As Integer
    Get
    Set
Public Property Severity As Integer
    Get
    Set
public:
property int Severity {
    int get ();
    void set (int value);
}
public:
property int Severity {
    int get ();
    void set (int value);
}
See Also
ResponseMessage Class
ResponseMessage Members


ResponseMessage.SeverityEnum Enumeration

ResponseMessage SeverityEnum Enumeration Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The severity of each message and the response status.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum SeverityEnum
public enum SeverityEnum
Public Enumeration SeverityEnum
Public Enumeration SeverityEnum
public enum class SeverityEnum
public enum class SeverityEnum
Members
Member name | Value | Description
Success | 0 | The call was successful without any warnings or error messages.
Message | 0 | Information Message.
Warning | 1 | The call was successful, but with warnings.
Error | 2 | The call failed.


ResponsePackage Class

ResponsePackage Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Returned Package Data.
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponsePackage

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ResponsePackage
public class ResponsePackage
Public Class ResponsePackage
Public Class ResponsePackage
public ref class ResponsePackage
public ref class ResponsePackage
See Also
ResponsePackage Members


ResponsePackage Members

ResponsePackage Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ResponsePackage type exposes the following members.
Constructors
 | Name | Description
Public method | ResponsePackage |
Back to Top
Properties
 | Name | Description
Public property | AirportCode | Purolator airport code.
Public property | BarCode | Bar code.
Public property | LabelImage | Label bitmap for laser printers. The bitmap is only generated if LabelType is set to Image.
Public property | PackageID | Unique ID.
Public property | ShippingCharge | The estimated shipping charge.
Public property | TrackingNumber | The tracking number.
Public property | Unicode | Purolator unicode.
Public property | ZPLCode | Label ZPL code for Zebra printers. The ZPL code is only generated if LabelType is set to ZPL.
Back to Top
See Also
ResponsePackage Class


ResponsePackage Constructor

ResponsePackage Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ResponsePackage.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ResponsePackage()
public ResponsePackage()
Public Sub New
Public Sub New
public:
ResponsePackage()
public:
ResponsePackage()
See Also
ResponsePackage Class
ResponsePackage Members


ResponsePackage Properties

ResponsePackage Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ResponsePackage type exposes the following members.
Properties
 | Name | Description
Public property | AirportCode | Purolator airport code.
Public property | BarCode | Bar code.
Public property | LabelImage | Label bitmap for laser printers. The bitmap is only generated if LabelType is set to Image.
Public property | PackageID | Unique ID.
Public property | ShippingCharge | The estimated shipping charge.
Public property | TrackingNumber | The tracking number.
Public property | Unicode | Purolator unicode.
Public property | ZPLCode | Label ZPL code for Zebra printers. The ZPL code is only generated if LabelType is set to ZPL.
Back to Top
See Also
ResponsePackage Class


AirportCode Property

ResponsePackage AirportCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Purolator airport code.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AirportCode { get; set; }
public string AirportCode { get; set; }
Public Property AirportCode As String
    Get
    Set
Public Property AirportCode As String
    Get
    Set
public:
property String^ AirportCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AirportCode {
    String^ get ();
    void set (String^ value);
}
See Also
ResponsePackage Class
ResponsePackage Members


BarCode Property

ResponsePackage BarCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Bar code.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string BarCode { get; set; }
public string BarCode { get; set; }
Public Property BarCode As String
    Get
    Set
Public Property BarCode As String
    Get
    Set
public:
property String^ BarCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ BarCode {
    String^ get ();
    void set (String^ value);
}
See Also
ResponsePackage Class
ResponsePackage Members


LabelImage Property

ResponsePackage LabelImage Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Label bitmap for laser printers. The bitmap is only generated if LabelType is set to Image.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string LabelImage { get; set; }
public string LabelImage { get; set; }
Public Property LabelImage As String
    Get
    Set
Public Property LabelImage As String
    Get
    Set
public:
property String^ LabelImage {
    String^ get ();
    void set (String^ value);
}
public:
property String^ LabelImage {
    String^ get ();
    void set (String^ value);
}
Remarks

            Bitmap labels are png files encoded using Base64 encoding. To decode the image, you can use the following code in Microsoft .NET

Examples

            byte[] byteArray = Convert.FromBase64String(package.LabelImage);
            MemoryStream ms = new MemoryStream(byteArray);
            Bitmap bm = new Bitmap(ms);

See Also
ResponsePackage Class
ResponsePackage Members


PackageID Property

ResponsePackage PackageID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Unique ID.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string PackageID { get; set; }
public string PackageID { get; set; }
Public Property PackageID As String
    Get
    Set
Public Property PackageID As String
    Get
    Set
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
public:
property String^ PackageID {
    String^ get ();
    void set (String^ value);
}
See Also
ResponsePackage Class
ResponsePackage Members


ShippingCharge Property

ResponsePackage ShippingCharge Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The estimated shipping charge.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal ShippingCharge { get; set; }
public decimal ShippingCharge { get; set; }
Public Property ShippingCharge As Decimal
    Get
    Set
Public Property ShippingCharge As Decimal
    Get
    Set
public:
property Decimal ShippingCharge {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal ShippingCharge {
    Decimal get ();
    void set (Decimal value);
}
See Also
ResponsePackage Class
ResponsePackage Members


TrackingNumber Property

ResponsePackage TrackingNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The tracking number.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TrackingNumber { get; set; }
public string TrackingNumber { get; set; }
Public Property TrackingNumber As String
    Get
    Set
Public Property TrackingNumber As String
    Get
    Set
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
See Also
ResponsePackage Class
ResponsePackage Members


Unicode Property

ResponsePackage Unicode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Purolator unicode.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Unicode { get; set; }
public string Unicode { get; set; }
Public Property Unicode As String
    Get
    Set
Public Property Unicode As String
    Get
    Set
public:
property String^ Unicode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Unicode {
    String^ get ();
    void set (String^ value);
}
See Also
ResponsePackage Class
ResponsePackage Members


ZPLCode Property

ResponsePackage ZPLCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Label ZPL code for Zebra printers. The ZPL code is only generated if LabelType is set to ZPL.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ZPLCode { get; set; }
public string ZPLCode { get; set; }
Public Property ZPLCode As String
    Get
    Set
Public Property ZPLCode As String
    Get
    Set
public:
property String^ ZPLCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ZPLCode {
    String^ get ();
    void set (String^ value);
}
See Also
ResponsePackage Class
ResponsePackage Members


ShipmentItemResponse Class

ShipmentItemResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:Purolator.Webservice.Objects.ShipmentItemResponse"]

Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ShipmentItemResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ShipmentItemResponse
public class ShipmentItemResponse
Public Class ShipmentItemResponse
Public Class ShipmentItemResponse
public ref class ShipmentItemResponse
public ref class ShipmentItemResponse
See Also
ShipmentItemResponse Members


ShipmentItemResponse Members

ShipmentItemResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ShipmentItemResponse type exposes the following members.
Constructors
 | Name | Description
Public method | ShipmentItemResponse |
Back to Top
Properties
 | Name | Description
Public property | CountryOfOrigin | The Country of Origin of the item.
Public property | CustomsCurrency | The Currency for the value.
Public property | CustomsValue | The value of the items.
Public property | Description | The Description of the item.
Public property | FDAFood | Is the item FDA Food.
Public property | HSCode | The HSCode of the item.
Public property | NAFTAEligible | Is the item eligible for NAFTA.
Public property | Quantity | The number of items.
Public property | ShipmentID | The ID of the shipment.
Public property | ShipmentItemID | The ID of the shipment item.
Public property | SKU | The SKU of the item.
Public property | Textile | Is the item a Textile.
Public property | Updated | The Currency for the value.
Back to Top
See Also
ShipmentItemResponse Class


ShipmentItemResponse Constructor

ShipmentItemResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ShipmentItemResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShipmentItemResponse()
public ShipmentItemResponse()
Public Sub New
Public Sub New
public:
ShipmentItemResponse()
public:
ShipmentItemResponse()
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


ShipmentItemResponse Properties

ShipmentItemResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ShipmentItemResponse type exposes the following members.
Properties
 | Name | Description
Public property | CountryOfOrigin | The Country of Origin of the item.
Public property | CustomsCurrency | The Currency for the value.
Public property | CustomsValue | The value of the items.
Public property | Description | The Description of the item.
Public property | FDAFood | Is the item FDA Food.
Public property | HSCode | The HSCode of the item.
Public property | NAFTAEligible | Is the item eligible for NAFTA.
Public property | Quantity | The number of items.
Public property | ShipmentID | The ID of the shipment.
Public property | ShipmentItemID | The ID of the shipment item.
Public property | SKU | The SKU of the item.
Public property | Textile | Is the item a Textile.
Public property | Updated | The Currency for the value.
Back to Top
See Also
ShipmentItemResponse Class


CountryOfOrigin Property

ShipmentItemResponse CountryOfOrigin Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Country of Origin of the item.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CountryOfOrigin { get; set; }
public string CountryOfOrigin { get; set; }
Public Property CountryOfOrigin As String
    Get
    Set
Public Property CountryOfOrigin As String
    Get
    Set
public:
property String^ CountryOfOrigin {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CountryOfOrigin {
    String^ get ();
    void set (String^ value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


CustomsCurrency Property

ShipmentItemResponse CustomsCurrency Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Currency for the value.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CustomsCurrency { get; set; }
public string CustomsCurrency { get; set; }
Public Property CustomsCurrency As String
    Get
    Set
Public Property CustomsCurrency As String
    Get
    Set
public:
property String^ CustomsCurrency {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CustomsCurrency {
    String^ get ();
    void set (String^ value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


CustomsValue Property

ShipmentItemResponse CustomsValue Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The value of the items.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public decimal CustomsValue { get; set; }
public decimal CustomsValue { get; set; }
Public Property CustomsValue As Decimal
    Get
    Set
Public Property CustomsValue As Decimal
    Get
    Set
public:
property Decimal CustomsValue {
    Decimal get ();
    void set (Decimal value);
}
public:
property Decimal CustomsValue {
    Decimal get ();
    void set (Decimal value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


Description Property

ShipmentItemResponse Description Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Description of the item.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Description { get; set; }
public string Description { get; set; }
Public Property Description As String
    Get
    Set
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


FDAFood Property

ShipmentItemResponse FDAFood Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Is the item FDA Food.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool FDAFood { get; set; }
public bool FDAFood { get; set; }
Public Property FDAFood As Boolean
    Get
    Set
Public Property FDAFood As Boolean
    Get
    Set
public:
property bool FDAFood {
    bool get ();
    void set (bool value);
}
public:
property bool FDAFood {
    bool get ();
    void set (bool value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


HSCode Property

ShipmentItemResponse HSCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The HSCode of the item.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HSCode { get; set; }
public string HSCode { get; set; }
Public Property HSCode As String
    Get
    Set
Public Property HSCode As String
    Get
    Set
public:
property String^ HSCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HSCode {
    String^ get ();
    void set (String^ value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


NAFTAEligible Property

ShipmentItemResponse NAFTAEligible Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Is the item eligible for NAFTA.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool NAFTAEligible { get; set; }
public bool NAFTAEligible { get; set; }
Public Property NAFTAEligible As Boolean
    Get
    Set
Public Property NAFTAEligible As Boolean
    Get
    Set
public:
property bool NAFTAEligible {
    bool get ();
    void set (bool value);
}
public:
property bool NAFTAEligible {
    bool get ();
    void set (bool value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


Quantity Property

ShipmentItemResponse Quantity Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The number of items.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Quantity { get; set; }
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}
public:
property int Quantity {
    int get ();
    void set (int value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


ShipmentID Property

ShipmentItemResponse ShipmentID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ID of the shipment.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ShipmentID { get; set; }
public int ShipmentID { get; set; }
Public Property ShipmentID As Integer
    Get
    Set
Public Property ShipmentID As Integer
    Get
    Set
public:
property int ShipmentID {
    int get ();
    void set (int value);
}
public:
property int ShipmentID {
    int get ();
    void set (int value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


ShipmentItemID Property

ShipmentItemResponse ShipmentItemID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ID of the shipment item.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ShipmentItemID { get; set; }
public int ShipmentItemID { get; set; }
Public Property ShipmentItemID As Integer
    Get
    Set
Public Property ShipmentItemID As Integer
    Get
    Set
public:
property int ShipmentItemID {
    int get ();
    void set (int value);
}
public:
property int ShipmentItemID {
    int get ();
    void set (int value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


SKU Property

ShipmentItemResponse SKU Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The SKU of the item.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SKU { get; set; }
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


Textile Property

ShipmentItemResponse Textile Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Is the item a Textile.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Textile { get; set; }
public bool Textile { get; set; }
Public Property Textile As Boolean
    Get
    Set
Public Property Textile As Boolean
    Get
    Set
public:
property bool Textile {
    bool get ();
    void set (bool value);
}
public:
property bool Textile {
    bool get ();
    void set (bool value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


Updated Property

ShipmentItemResponse Updated Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The Currency for the value.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DateTime Updated { get; set; }
public DateTime Updated { get; set; }
Public Property Updated As DateTime
    Get
    Set
Public Property Updated As DateTime
    Get
    Set
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}
See Also
ShipmentItemResponse Class
ShipmentItemResponse Members


ShipperAccountServiceTypeLinkResponse Class

ShipperAccountServiceTypeLinkResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A link indicating whether a shipping type is available to a Shipper Account
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ShipperAccountServiceTypeLinkResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ShipperAccountServiceTypeLinkResponse
public class ShipperAccountServiceTypeLinkResponse
Public Class ShipperAccountServiceTypeLinkResponse
Public Class ShipperAccountServiceTypeLinkResponse
public ref class ShipperAccountServiceTypeLinkResponse
public ref class ShipperAccountServiceTypeLinkResponse
See Also
ShipperAccountServiceTypeLinkResponse Members


ShipperAccountServiceTypeLinkResponse Members

ShipperAccountServiceTypeLinkResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ShipperAccountServiceTypeLinkResponse type exposes the following members.
Constructors
 | Name | Description
Public method | ShipperAccountServiceTypeLinkResponse |
Back to Top
Properties
 | Name | Description
Public property | Allow | True is this shipping type is available to this Shipper Account
Public property | ServiceTypeID | The ID of the Service Type
Public property | ShipperAccountID | The ID of the Shipper Account
Back to Top
See Also
ShipperAccountServiceTypeLinkResponse Class


ShipperAccountServiceTypeLinkResponse Constructor

ShipperAccountServiceTypeLinkResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ShipperAccountServiceTypeLinkResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ShipperAccountServiceTypeLinkResponse()
public ShipperAccountServiceTypeLinkResponse()
Public Sub New
Public Sub New
public:
ShipperAccountServiceTypeLinkResponse()
public:
ShipperAccountServiceTypeLinkResponse()
See Also
ShipperAccountServiceTypeLinkResponse Class
ShipperAccountServiceTypeLinkResponse Members


ShipperAccountServiceTypeLinkResponse Properties

ShipperAccountServiceTypeLinkResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ShipperAccountServiceTypeLinkResponse type exposes the following members.
Properties
 | Name | Description
Public property | Allow | True is this shipping type is available to this Shipper Account
Public property | ServiceTypeID | The ID of the Service Type
Public property | ShipperAccountID | The ID of the Shipper Account
Back to Top
See Also
ShipperAccountServiceTypeLinkResponse Class


Allow Property

ShipperAccountServiceTypeLinkResponse Allow Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

True is this shipping type is available to this Shipper Account

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Allow { get; set; }
public bool Allow { get; set; }
Public Property Allow As Boolean
    Get
    Set
Public Property Allow As Boolean
    Get
    Set
public:
property bool Allow {
    bool get ();
    void set (bool value);
}
public:
property bool Allow {
    bool get ();
    void set (bool value);
}
See Also
ShipperAccountServiceTypeLinkResponse Class
ShipperAccountServiceTypeLinkResponse Members


ServiceTypeID Property

ShipperAccountServiceTypeLinkResponse ServiceTypeID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ID of the Service Type

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ServiceTypeID { get; set; }
public int ServiceTypeID { get; set; }
Public Property ServiceTypeID As Integer
    Get
    Set
Public Property ServiceTypeID As Integer
    Get
    Set
public:
property int ServiceTypeID {
    int get ();
    void set (int value);
}
public:
property int ServiceTypeID {
    int get ();
    void set (int value);
}
See Also
ShipperAccountServiceTypeLinkResponse Class
ShipperAccountServiceTypeLinkResponse Members


ShipperAccountID Property

ShipperAccountServiceTypeLinkResponse ShipperAccountID Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ID of the Shipper Account

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ShipperAccountID { get; set; }
public int ShipperAccountID { get; set; }
Public Property ShipperAccountID As Integer
    Get
    Set
Public Property ShipperAccountID As Integer
    Get
    Set
public:
property int ShipperAccountID {
    int get ();
    void set (int value);
}
public:
property int ShipperAccountID {
    int get ();
    void set (int value);
}
See Also
ShipperAccountServiceTypeLinkResponse Class
ShipperAccountServiceTypeLinkResponse Members


UpdateOrderInfo Class

UpdateOrderInfo Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Order for UpdateOrderRequest
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects UpdateOrderInfo

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class UpdateOrderInfo
public class UpdateOrderInfo
Public Class UpdateOrderInfo
Public Class UpdateOrderInfo
public ref class UpdateOrderInfo
public ref class UpdateOrderInfo
See Also
UpdateOrderInfo Members


UpdateOrderInfo Members

UpdateOrderInfo Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The UpdateOrderInfo type exposes the following members.
Constructors
 | Name | Description
Public method | UpdateOrderInfo |
Back to Top
Properties
 | Name | Description
Public property | OrderNumber | order numbers for update.
Public property | UpdateType | Type of Update
Public property | UpdateValue | Value of Update
Back to Top
See Also
UpdateOrderInfo Class


UpdateOrderInfo Constructor

UpdateOrderInfo Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.UpdateOrderInfo.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdateOrderInfo()
public UpdateOrderInfo()
Public Sub New
Public Sub New
public:
UpdateOrderInfo()
public:
UpdateOrderInfo()
See Also
UpdateOrderInfo Class
UpdateOrderInfo Members


UpdateOrderInfo Properties

UpdateOrderInfo Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The UpdateOrderInfo type exposes the following members.
Properties
 | Name | Description
Public property | OrderNumber | order numbers for update.
Public property | UpdateType | Type of Update
Public property | UpdateValue | Value of Update
Back to Top
See Also
UpdateOrderInfo Class


OrderNumber Property

UpdateOrderInfo OrderNumber Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

order numbers for update.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OrderNumber { get; set; }
public string OrderNumber { get; set; }
Public Property OrderNumber As String
    Get
    Set
Public Property OrderNumber As String
    Get
    Set
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
See Also
UpdateOrderInfo Class
UpdateOrderInfo Members


UpdateType Property

UpdateOrderInfo UpdateType Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Type of Update

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UpdateType { get; set; }
public string UpdateType { get; set; }
Public Property UpdateType As String
    Get
    Set
Public Property UpdateType As String
    Get
    Set
public:
property String^ UpdateType {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UpdateType {
    String^ get ();
    void set (String^ value);
}
Remarks

            The following Update Types are available.

PONumber Update the Purchase Order Number for the order.
See Also
UpdateOrderInfo Class
UpdateOrderInfo Members


UpdateValue Property

UpdateOrderInfo UpdateValue Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Value of Update

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string UpdateValue { get; set; }
public string UpdateValue { get; set; }
Public Property UpdateValue As String
    Get
    Set
Public Property UpdateValue As String
    Get
    Set
public:
property String^ UpdateValue {
    String^ get ();
    void set (String^ value);
}
public:
property String^ UpdateValue {
    String^ get ();
    void set (String^ value);
}
See Also
UpdateOrderInfo Class
UpdateOrderInfo Members


UpdateOrderRequest Class

UpdateOrderRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for UpdateOrder(UpdateOrderRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects UpdateOrderRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class UpdateOrderRequest
public class UpdateOrderRequest
Public Class UpdateOrderRequest
Public Class UpdateOrderRequest
public ref class UpdateOrderRequest
public ref class UpdateOrderRequest
See Also
UpdateOrderRequest Members


UpdateOrderRequest Members

UpdateOrderRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The UpdateOrderRequest type exposes the following members.
Constructors
 | Name | Description
Public method | UpdateOrderRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | UpdateOrders | A list of orders, update types and values to use for updating orders.
Back to Top
See Also
UpdateOrderRequest Class


UpdateOrderRequest Constructor

UpdateOrderRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.UpdateOrderRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdateOrderRequest()
public UpdateOrderRequest()
Public Sub New
Public Sub New
public:
UpdateOrderRequest()
public:
UpdateOrderRequest()
See Also
UpdateOrderRequest Class
UpdateOrderRequest Members


UpdateOrderRequest Properties

UpdateOrderRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The UpdateOrderRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Public property | UpdateOrders | A list of orders, update types and values to use for updating orders.
Back to Top
See Also
UpdateOrderRequest Class


Credentials Property

UpdateOrderRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
UpdateOrderRequest Class
UpdateOrderRequest Members


UpdateOrders Property

UpdateOrderRequest UpdateOrders Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

A list of orders, update types and values to use for updating orders.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<UpdateOrderInfo> UpdateOrders { get; set; }
public List<UpdateOrderInfo> UpdateOrders { get; set; }
Public Property UpdateOrders As List(Of UpdateOrderInfo)
    Get
    Set
Public Property UpdateOrders As List(Of UpdateOrderInfo)
    Get
    Set
public:
property List<UpdateOrderInfo^>^ UpdateOrders {
    List<UpdateOrderInfo^>^ get ();
    void set (List<UpdateOrderInfo^>^ value);
}
public:
property List<UpdateOrderInfo^>^ UpdateOrders {
    List<UpdateOrderInfo^>^ get ();
    void set (List<UpdateOrderInfo^>^ value);
}
See Also
UpdateOrderRequest Class
UpdateOrderRequest Members


UpdateOrderResponse Class

UpdateOrderResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for UpdateOrder(UpdateOrderRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects UpdateOrderResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class UpdateOrderResponse : ResponseBase
public class UpdateOrderResponse : ResponseBase
Public Class UpdateOrderResponse _
    Inherits ResponseBase
Public Class UpdateOrderResponse _
    Inherits ResponseBase
public ref class UpdateOrderResponse : public ResponseBase
public ref class UpdateOrderResponse : public ResponseBase
See Also
UpdateOrderResponse Members


UpdateOrderResponse Members

UpdateOrderResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The UpdateOrderResponse type exposes the following members.
Constructors
 | Name | Description
Public method | UpdateOrderResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
UpdateOrderResponse Class


UpdateOrderResponse Constructor

UpdateOrderResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.UpdateOrderResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdateOrderResponse()
public UpdateOrderResponse()
Public Sub New
Public Sub New
public:
UpdateOrderResponse()
public:
UpdateOrderResponse()
See Also
UpdateOrderResponse Class
UpdateOrderResponse Members


UpdateOrderResponse Properties

UpdateOrderResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The UpdateOrderResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Back to Top
See Also
UpdateOrderResponse Class


Request Property

UpdateOrderResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpdateOrderRequest Request { get; set; }
public UpdateOrderRequest Request { get; set; }
Public Property Request As UpdateOrderRequest
    Get
    Set
Public Property Request As UpdateOrderRequest
    Get
    Set
public:
property UpdateOrderRequest^ Request {
    UpdateOrderRequest^ get ();
    void set (UpdateOrderRequest^ value);
}
public:
property UpdateOrderRequest^ Request {
    UpdateOrderRequest^ get ();
    void set (UpdateOrderRequest^ value);
}
See Also
UpdateOrderResponse Class
UpdateOrderResponse Members


ZPLInitializationRequest Class

ZPLInitializationRequest Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Request for GetZPLInitializationImages(CredentialInfo)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ZPLInitializationRequest

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ZPLInitializationRequest
public class ZPLInitializationRequest
Public Class ZPLInitializationRequest
Public Class ZPLInitializationRequest
public ref class ZPLInitializationRequest
public ref class ZPLInitializationRequest
See Also
ZPLInitializationRequest Members


ZPLInitializationRequest Members

ZPLInitializationRequest Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ZPLInitializationRequest type exposes the following members.
Constructors
 | Name | Description
Public method | ZPLInitializationRequest |
Back to Top
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Back to Top
See Also
ZPLInitializationRequest Class


ZPLInitializationRequest Constructor

ZPLInitializationRequest Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ZPLInitializationRequest.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ZPLInitializationRequest()
public ZPLInitializationRequest()
Public Sub New
Public Sub New
public:
ZPLInitializationRequest()
public:
ZPLInitializationRequest()
See Also
ZPLInitializationRequest Class
ZPLInitializationRequest Members


ZPLInitializationRequest Properties

ZPLInitializationRequest Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ZPLInitializationRequest type exposes the following members.
Properties
 | Name | Description
Public property | Credentials | Login credentials for validation.
Back to Top
See Also
ZPLInitializationRequest Class


Credentials Property

ZPLInitializationRequest Credentials Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Login credentials for validation.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CredentialInfo Credentials { get; set; }
public CredentialInfo Credentials { get; set; }
Public Property Credentials As CredentialInfo
    Get
    Set
Public Property Credentials As CredentialInfo
    Get
    Set
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
public:
property CredentialInfo^ Credentials {
    CredentialInfo^ get ();
    void set (CredentialInfo^ value);
}
See Also
ZPLInitializationRequest Class
ZPLInitializationRequest Members


ZPLInitializationResponse Class

ZPLInitializationResponse Class Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Response for Closeout(CloseoutRequest)
Inheritance Hierarchy
Online System Object
Purolator.Webservice.Objects ResponseBase
Purolator.Webservice.Objects ZPLInitializationResponse

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ZPLInitializationResponse : ResponseBase
public class ZPLInitializationResponse : ResponseBase
Public Class ZPLInitializationResponse _
    Inherits ResponseBase
Public Class ZPLInitializationResponse _
    Inherits ResponseBase
public ref class ZPLInitializationResponse : public ResponseBase
public ref class ZPLInitializationResponse : public ResponseBase
See Also
ZPLInitializationResponse Members


ZPLInitializationResponse Members

ZPLInitializationResponse Members Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ZPLInitializationResponse type exposes the following members.
Constructors
 | Name | Description
Public method | ZPLInitializationResponse |
Back to Top
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | ZPLCode | The ZPL initialization string.
Back to Top
See Also
ZPLInitializationResponse Class


ZPLInitializationResponse Constructor

ZPLInitializationResponse Constructor Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:Purolator.Webservice.Objects.ZPLInitializationResponse.#ctor"]

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ZPLInitializationResponse()
public ZPLInitializationResponse()
Public Sub New
Public Sub New
public:
ZPLInitializationResponse()
public:
ZPLInitializationResponse()
See Also
ZPLInitializationResponse Class
ZPLInitializationResponse Members


ZPLInitializationResponse Properties

ZPLInitializationResponse Properties Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ZPLInitializationResponse type exposes the following members.
Properties
 | Name | Description
Public property | Messages | Error, Warning or Informational messages. (Inherited from ResponseBase.)
Public property | Request | The original request.
Public property | Status | The status of the request (0 - Success, 1 - Success with warnings, 2 - Failure). (Inherited from ResponseBase.)
Public property | ZPLCode | The ZPL initialization string.
Back to Top
See Also
ZPLInitializationResponse Class


Request Property

ZPLInitializationResponse Request Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The original request.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CloseoutRequest Request { get; set; }
public CloseoutRequest Request { get; set; }
Public Property Request As CloseoutRequest
    Get
    Set
Public Property Request As CloseoutRequest
    Get
    Set
public:
property CloseoutRequest^ Request {
    CloseoutRequest^ get ();
    void set (CloseoutRequest^ value);
}
public:
property CloseoutRequest^ Request {
    CloseoutRequest^ get ();
    void set (CloseoutRequest^ value);
}
See Also
ZPLInitializationResponse Class
ZPLInitializationResponse Members


ZPLCode Property

ZPLInitializationResponse ZPLCode Property Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The ZPL initialization string.

Namespace: Purolator.Webservice.Objects
Assembly: Purolator.Webservice (in Purolator.Webservice.dll) Version: 2.1.0.8029 (2.1.0.8029)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ZPLCode { get; set; }
public string ZPLCode { get; set; }
Public Property ZPLCode As String
    Get
    Set
Public Property ZPLCode As String
    Get
    Set
public:
property String^ ZPLCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ZPLCode {
    String^ get ();
    void set (String^ value);
}
See Also
ZPLInitializationResponse Class
ZPLInitializationResponse Members


Web Service Objects

Web Service Objects Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

The following table entries represent the objects for interacting with the web service.

Requests
Name | Description
AddItemRequest | Request for AddItem(AddItemRequest)
AddPackageRequest | Request for AddPackage(AddPackageRequest)
CloseoutRequest | Request for Closeout(CloseoutRequest)
CloseoutRequestLTL | Request for CloseoutWithLTL(CloseoutRequestLTL)
CloseoutWithWeightRequest | Request for CloseoutUpdateWeight(CloseoutWithWeightRequest)
LabelRequest | Request for GetLabel(LabelRequest).
LTLOrderRequest | Adds an LTL order and LTL shipment.
LTLPalletRequest | A Pallet included in an LTLShipmentRequest
LTLShipmentRequest | Request for AddConsolidatedLTLShipment(LTLShipmentRequest)
OrderListRequest | The request for VoidOrders(OrderListRequest)
OrderRequest | Request for GetRates(OrderRequest) and AddOrder(OrderRequest)
PackageListRequest | The request for ShipmentVerification(PackageListRequest), and VoidPackages(PackageListRequest)
UpdateOrderRequest | Request for UpdateOrder(UpdateOrderRequest)
ZPLInitializationRequest | Request for GetZPLInitializationImages(CredentialInfo)
RateRequest | Request for [!:ShippingServices.RateRequest]
UpdateOrderInfo | Order for UpdateOrderRequest
Responses
Name | Description
AddItemResponse | Response for AddItem(AddItemRequest)
AddPackageResponse | Response for AddPackage(AddPackageRequest)
CloseoutResponse | Response for Closeout(CloseoutRequest)
CloseoutResponseLTL | Response for CloseoutWithLTL(CloseoutRequestLTL)
CustomsItemResponse |
InductionPointLookupListResponse |
LabelResponse | Response for GetLabel(LabelRequest).
LTLOrderResponse |
LTLPalletResponse | A Pallet included in an LTLShipmentResponse
LTLShipmentResponse |
OrderListResponse | The response returned by a CloseoutRequest.
OrderResponse | Response for GetRates(OrderRequest) and AddOrder(OrderRequest)
PackageListResponse | The response returned by a CloseoutRequest.
RateResponse | Response for GetRates(OrderRequest) and AddOrder(OrderRequest)
ResponseBase | Base class for responses
ShipmentItemResponse |
ShipperAccountServiceTypeLinkResponse | A link indicating whether a shipping type is available to a Shipper Account
UpdateOrderResponse | Response for UpdateOrder(UpdateOrderRequest)
ZPLInitializationResponse | Response for Closeout(CloseoutWithLTL(CloseoutRequestLTL))
Data Objects
Name | Description
Address | Canadian Address
CloseoutDocument | A document returned by Closeout(CloseoutRequest)
CloseoutPackage | Package information returned by Closeout(CloseoutRequest)
CredentialInfo | Login credentials for validation.
IDResponse |
InductionPointLookupListItem |
PackageIDWeight | Request for CloseoutWithWeightRequest
Rate | A single Rate returned in OrderResponse
RequestItem | An item contained in an order for customs purposes.
RequestPackage | Describes a package
ResponseMessage | The status and messages returned by each web service call.
ResponsePackage | Returned Package Data.


More Information

More Information Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

This page is a placeholder for links to more detailed information. It should probably be hidden in the final release.

Optional section title

ZPL page.

Optional section title

Soap UI page.


Web Service Methods

Web Service Methods Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

intro

Courier Specific Methods
Name | Description
GetRates(OrderRequest) | Gets the service availability and estimated rates.
AddOrder(OrderRequest) | Gets the service availability, estimated rate, pin numbers, and labels for each package; enters the order in the Purolator system.
LTL Specific Methods
Name | Description
AddLTLOrder(LTLOrderRequest) | Adds an LTL order that will be included in a single LTL Shipment.
AddConsolidatedLTLShipment(LTLShipmentRequest) | Complete processing of a series of packages and updates their weights.
CloseoutWithLTL(CloseoutRequestLTL) | Complete processing of a series of packages and LTL Pro Numbers.
Common Methods
Name | Description
GetZPLInitializationImages(CredentialInfo) | Gets ZPL code to load Purolator specific images into a ZPL printer. See ZPL info
AddPackage(AddPackageRequest) | Adds packages to an existing order.
AddItem(AddItemRequest) | Adds customs items to an existing order.
GetLabel(LabelRequest) | Gets a Package label either as ZPL code or as a Base64 encoded image.
UpdateOrder(UpdateOrderRequest) | Updates values in existing orders.
GetOrderStatus(CredentialInfo, String) | Gets an OrderResponse for the specified order.
ShipmentVerification(PackageListRequest) | Verifies that each package is being shipped as part of some clients multi-step shipment process.
VoidOrders(OrderListRequest) | Voids a list of orders.
VoidPackages(PackageListRequest) | Voids a list of packages.
Closeout(CloseoutRequest) | Complete processing of a series of packages.
CloseoutUpdateWeight(CloseoutWithWeightRequest) | Complete processing of a series of packages and updates their weights.


soapUI

soapUI Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

soapUI is an open source web service testing tool.

It can be useful in creating test Requests before customer software is written/modified to communicate with Purolator Web Services. It can also be useful in troubleshooting problematic requests since it makes it easier to see both the request and the response, and to modify the request.

See Also

Other Resources

Online soapUI
Online soapUI (Wikipedia)


Purolator Web Services

Purolator Web Services Purolator International Web Services Documentation - Confidential
Send Feedback

[This is preliminary documentation and is subject to change.]

Purolator International provides a SOAP Online web service interface for customers who wish to write their own software to interact with Purolator’s Online Shipping System.

Purolator support staff provides an Account with one or more users, and (typically) one Shipper Account to represent each facility the customer will be shipping from.

A customer will typically ship a courier order by:

  1. Create an order with AddOrder.
  2. If the response indicated an error, fix the information and repeat step 1.
  3. Print and apply the label for each package.
  4. Repeat 1. through 3. for all orders.
  5. Closeout all orders which are being shipped.

A customer will typically ship a LTL order by:

  1. Create an order with AddLtlOrder.
  2. If the response indicated an error, fix the information and repeat step 1.
  3. Print and apply the label for each package.
  4. Repeat 1. through 3. for all orders.
  5. Closeout all orders which are being shipped.

Customs documentation may be generated by the closeout process so a closeout should contain the packages which are being shipped on that day.

Order information such as the destination address, ship method, ship date, etc. may be changed before the system generates the first package label; after this the order information cannot be changed but packages and items can still be added before they are closed out.

At any point after an order has been created, but before it has been closed out, an entire order, or one or more packages may be voided using VoidOrders(OrderListRequest)/VoidPackages(PackageListRequest). A voided order or package can be recreated and a non-void order or package may use a "unique" OrderNumber or PackageID which is only used by a voided order or package.

Closing out a collection of orders:

  1. Finalizes them in the OLS database and prevents future modification
  2. Consolidates rates for all orders with the same order information (including the exact destination address, ship method, and other shipping options).
  3. May create required documentation for customs.